15:00:01 <tidwellr_> #startmeeting neutron_l3
15:00:01 <openstack> Meeting started Thu May 26 15:00:01 2016 UTC and is due to finish in 60 minutes. The chair is tidwellr_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:04 <openstack> The meeting name has been set to 'neutron_l3'
15:00:11 <tidwellr_> hi
15:00:14 <yamamoto> hi
15:00:14 <vikram> Hi
15:00:16 <pavel_bondar_> hi
15:00:22 <mlavalle> o/
15:00:29 <tidwellr_> #chair mlavalle carl_baldwin
15:00:30 <openstack> Current chairs: carl_baldwin mlavalle tidwellr_
15:01:04 <tidwellr_> #topic Announcements
15:01:29 <tidwellr_> the agenda can be found here https://etherpad.openstack.org/p/neutron-l3-subteam
15:02:03 <carl_baldwin> One more week to N-1
15:02:27 <carl_baldwin> #link http://releases.openstack.org/newton/schedule.html
15:02:45 <carl_baldwin> If that. It could be sooner.
15:03:11 <mlavalle> it usually is sooner
15:03:37 <tidwellr_> thanks carl_baldwin
15:03:49 <tidwellr_> anything other announcements?
15:04:14 <tidwellr_> if not, let's move on
15:04:24 <carl_baldwin> I wish we could announce the mid-cycle but I haven't seen it become official.
15:04:45 <carl_baldwin> It will be in mid-August and the unofficial word is that it will be in Cork, Ireland.
15:05:37 <carl_baldwin> that's all
15:05:45 <tidwellr_> carl_baldwin: when do we expect plans to firm up on that?
15:05:53 <carl_baldwin> Any time now.
15:06:09 <carl_baldwin> #link https://wiki.openstack.org/wiki/Sprints
15:06:25 <carl_baldwin> Watch there ^
15:06:32 <tidwellr_> thanks for the link
15:07:04 <tidwellr_> #topic Bugs
15:07:26 <tidwellr_> https://bugs.launchpad.net/neutron/+bug/1581918
15:07:27 <openstack> Launchpad bug 1581918 in neutron "Sometimes DHCP agent spawns dnsmasq incorrectly" [High,Fix released] - Assigned to Kevin Benton (kevinbenton)
15:07:36 <tidwellr_> working backwards through the list
15:07:47 <tidwellr_> this one looks new
15:07:56 <carl_baldwin> Fixed
15:07:57 <tidwellr_> and it's been fixed apparently
15:08:05 <tidwellr_> moving on! :)
15:08:43 <mlavalle> lol
15:08:53 <tidwellr_> https://bugs.launchpad.net/neutron/+bug/1564335
15:08:55 <openstack> Launchpad bug 1564335 in neutron " [Pluggable IPAM] delete subnet in ml2 plugin does not comply with pluggable ipam (deletes ip allocations directly from db)" [High,In progress] - Assigned to Pavel Bondar (pasha117)
15:09:28 <tidwellr_> pavel_bondar: do you have any news to share on this one?
15:09:48 <carl_baldwin> Will look again
15:10:09 <pavel_bondar_> hi
15:10:33 <pavel_bondar_> the first part of the patch is on review
15:11:04 <pavel_bondar_> and for the second part looks like we have a solution
15:11:16 <pavel_bondar_> so I will work on implementing it
15:11:24 <carl_baldwin> pavel_bondar_: I haven't seen much activity on the ML
15:11:25 <carl_baldwin> #link http://lists.openstack.org/pipermail/openstack-dev/2016-May/095547.html
15:12:08 <carl_baldwin> It has been a week, I say we pursue the solution we discussed in the thread.
15:12:39 <carl_baldwin> tidwellr_: I think that's it.
15:13:06 <tidwellr_> thanks
15:13:12 <tidwellr_> https://bugs.launchpad.net/neutron/+bug/1543094
15:13:13 <openstack> Launchpad bug 1543094 in neutron "[Pluggable IPAM] DB exceeded retry limit (RetryRequest) on create_router call" [High,In progress] - Assigned to Ryan Tidwell (ryan-tidwell)
15:13:14 <pavel_bondar_> carl_baldwin: I think we can pick solution with hacking 'fixed_ips' unless any other ideas come up
15:13:53 <carl_baldwin> ++
15:14:26 <tidwellr_> sorry, jumped the gun there. anything else on the previous bug?
15:14:38 <pavel_bondar_> no
15:15:10 <tidwellr_> I haven't had much time to look at this one during the week
15:15:20 <tidwellr_> I am stuck on this error #link http://paste.openstack.org/show/505673/
15:16:16 <tidwellr_> I'm not sure what I've changed that causes this, still needs more investigation
15:16:31 <carl_baldwin> tidwellr_: It is strange. I could maybe help look in to it a little bit if you want.
15:16:55 <carl_baldwin> tidwellr_: I looked at it enough to be sure that somehow your patch is causing this or uncovering it.
15:17:13 <tidwellr_> carl_baldwin: that would be awesome, I haven't been able to devote time to it this week
15:17:34 <carl_baldwin> tidwellr_: Okay, I'll plan to look in to it a little bit today between trying to get reviews for routed netwroks.
15:17:51 <tidwellr_> carl_baldwin: I'm convinced there's something about the patch that causes this
15:18:02 <carl_baldwin> agreed
15:18:28 <carl_baldwin> #action carl_baldwin will look in to errors in https://bugs.launchpad.net/neutron/+bug/1543094
15:18:30 <openstack> Launchpad bug 1543094 in neutron "[Pluggable IPAM] DB exceeded retry limit (RetryRequest) on create_router call" [High,In progress] - Assigned to Ryan Tidwell (ryan-tidwell)
15:19:22 <tidwellr_> #topic Routed Networks
15:19:42 <carl_baldwin> Hi
15:20:05 <carl_baldwin> Need reviews for some patches.
15:20:40 <carl_baldwin> https://review.openstack.org/#/c/314815
15:21:02 <carl_baldwin> That is the first IPAM patch. It is now the bottom of the chain since mlavalle 's patch merged!
15:21:30 <mlavalle> thanks for all the help!
15:21:50 <carl_baldwin> There are three IPAM patches. One for segment awareness on port create, one for deferred IP allocation on port update, and one to root out a bug with ML2 that keeps fixed_ips from being returned in the response.
15:22:06 <carl_baldwin> I won't link them all here since they're lined up.
15:22:42 <john-davidge> carl_baldwin: Are there any routed networks areas that could use more implementation help?
15:22:59 <carl_baldwin> john-davidge: Yes, I'm sure there are.
15:23:17 <carl_baldwin> I was discussing with blogan the other day about DHCP. There might be some ways to help there.
15:23:31 <carl_baldwin> john-davidge: Have you seen the etherpad?
15:23:32 <carl_baldwin> #link https://etherpad.openstack.org/p/routed-provider-networks-notes
15:23:55 <john-davidge> carl_baldwin: I hadn't. Thanks, will take a look
15:24:32 <carl_baldwin> We have meetings on Tuesday mornings too.
15:25:12 <mlavalle> john-davidge: blogan mentioned this past Tuesday during the meeting that he could use help with DHCP
15:25:37 <mlavalle> he said the effort is going to be longer than originally expected
15:25:37 <john-davidge> mlavalle: Thanks, will reach out to him
15:25:49 <carl_baldwin> john-davidge: You might want to start by running through some of the setup documented on the etherpad.
15:26:27 <john-davidge> carl_baldwin: Will do, thanks. Missed the meeting this week due to pesky British Summer Time
15:26:44 <carl_baldwin> john-davidge: ack. It'll will be great to have help.
15:27:16 <mlavalle> john-davidge: here's this past Tuesday's log: http://eavesdrop.openstack.org/meetings/neutron_routed_networks/2016/neutron_routed_networks.2016-05-24-15.02.log.txt
15:27:24 <mlavalle> so you can see blogan's comments
15:27:58 <carl_baldwin> I'm thinking it is time to start building some bigger environments. I'm starting to reach out to some folks trying to get some help setting up hardware.
15:28:35 <carl_baldwin> Here are some other patches in flight:
15:28:37 <carl_baldwin> #link https://review.openstack.org/#/c/295173
15:28:49 <carl_baldwin> #link https://review.openstack.org/#/c/315573/
15:29:15 <carl_baldwin> #link https://review.openstack.org/#/c/299591
15:29:29 <carl_baldwin> #link https://review.openstack.org/#/c/321152
15:29:46 <carl_baldwin> #link https://review.openstack.org/#/c/317358
15:30:05 <carl_baldwin> The list goes on ...
15:30:32 <carl_baldwin> I'll get mine rebased as soon as possible. That's all from me.
15:30:40 <carl_baldwin> mlavalle: Anything else?
15:30:50 <mlavalle> nope, good summary
15:31:23 <tidwellr_> awesome work
15:31:44 <carl_baldwin> Great progress here!
15:32:10 <tidwellr_> seems to be moving along fairly quickly
15:32:28 <tidwellr_> john_davidge: those time changes are pesky, bites us here in the states too :)
15:33:03 <tidwellr_> alright, if nothing else let's move on
15:33:20 <tidwellr_> #topic BGP Dynamic Routing
15:33:32 <Na_Zhu> hi
15:33:46 <Na_Zhu> https://review.openstack.org/319558 this patch need review
15:34:30 <Na_Zhu> this patch is for adding policy file in neutron-dynamic-routing
15:34:40 <tidwellr_> Na_Zhu: thanks working on this
15:35:03 <Na_Zhu> tidwellr_: i think you still have comments on this patch
15:35:05 <tidwellr_> Na_Zhu: thanks for working on this, I think it's close
15:35:34 <tidwellr_> we had aimed to have the neutron dynamic-routing repository stood up by N-1, as far as I can tell this is the last hurdle we have
15:35:57 <Na_Zhu> tidwellr_: yes, i also think so
15:36:19 <Na_Zhu> tidwellr: about the cli part, we can release together with osc transition
15:36:33 <tidwellr_> the docs and functional/api/fullstack jobs can continue to be worked on
15:36:51 <tidwellr_> Na_Zhu: ack
15:37:07 <tidwellr_> thanks for working that as well
15:37:20 <Na_Zhu> tidwellr: the cli has dependency on osc plugin, we can not do anything until the python-neutronclient osc plugin is ready
15:37:32 <Na_Zhu> tidwellr_: np
15:37:53 <tidwellr_> we're at the point now where you can stack with neutron-dynamic-routing and have BGP in your devstack environment
15:39:00 <tidwellr_> we're at the point where I think we can start working through RFE's
15:39:27 <tidwellr_> carl_baldwin has some RFE's to bring up at the next driver's meeting
15:39:38 <tidwellr_> so good progress here
15:39:46 <carl_baldwin> That's today.
15:40:17 <Na_Zhu> tidwellr_: i think i can help about the RFEs
15:40:48 <Na_Zhu> tidwellr_: there are several RFEs about neutron-dynamic-routing, we can work together, right?
15:41:38 <tidwellr_> Na_Zhu: yes, we're finally getting around to discussing some RFE's filed by Mickey and Steve, as well as some others
15:42:44 <Na_Zhu> tidwellr_: thanks
15:43:05 <tidwellr_> Na_Zhu: we'll see what gets approved and we'll start working on some things shortly
15:43:13 <tidwellr_> that's all I had
15:43:20 <Na_Zhu> tidwellr: ok, thanks
15:44:10 <tidwellr_> #topic FWaaS
15:44:26 <carl_baldwin> SridarK: ping
15:44:36 <SridarK> Hi
15:44:39 <SridarK> thanks
15:44:39 <tidwellr_> I wanted to leave some time for FWaaS, I saw some activity on the etherpad earlier in the meeting
15:44:57 <SridarK> On the L3 Agent extension to support services:
15:45:10 <SridarK> #link https://review.openstack.org/#/c/315745/
15:45:32 <SridarK> We still need more details, the intent is to see how closely we can follow the L2 Agent extension pattern
15:46:22 <carl_baldwin> SridarK: I will read through this.
15:46:25 <SridarK> if u folks can monitor this and add comments will be most helpful
15:46:29 <SridarK> carl_baldwin: thx
15:46:48 <SridarK> we want to also get more details to capture the workflow
15:47:15 <SridarK> thx
15:47:28 <SridarK> thats all from me, we will continue to iterate
15:47:52 <carl_baldwin> SridarK: Thanks.
15:49:52 <tidwellr_> thanks
15:50:17 <SridarK> tidwellr_: thx for the airtime
15:51:11 <tidwellr_> #topic Open Discussion
15:51:48 <john-davidge> carl_baldwin: I've been out of the loop on the midcycle discussion, how final would you say the location is at this point?
15:52:25 <carl_baldwin> john-davidge: It isn't for me to say. I'd wait for the "tentative" to be removed from the wiki by someone from IBM.
15:53:35 <carl_baldwin> Hopefully, they'll send an announcement to the ML.
15:53:35 <john-davidge> carl_baldwin: Ok, cool. I know we tried to reach out to Armando about hosting in San Antonio but I guess the wheels were already turning
15:55:00 <carl_baldwin> I'm hoping it will be official soon so that we can make travel arrangements.
15:55:08 <tidwellr_> carl_baldwin: international travel is always an issue both ways, I wonder if a handful of meetups would possible
15:55:22 <tidwellr_> just a crazy thought
15:55:39 <tidwellr_> in different locations
15:56:31 <tidwellr_> alright, anything else to discuss?
15:57:21 <tidwellr_> going once....
15:57:31 <carl_baldwin> Not from me
15:57:48 <tidwellr_> going twice....
15:58:04 <tidwellr_> thanks everyone!
15:58:07 <tidwellr_> #endmeeting