14:59:58 <mlavalle> #startmeeting neutron_l3
14:59:59 <openstack> Meeting started Thu Jun  2 14:59:58 2016 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:03 <openstack> The meeting name has been set to 'neutron_l3'
15:00:13 <mlavalle> #chair carl_baldwin
15:00:14 <openstack> Current chairs: carl_baldwin mlavalle
15:00:28 <mlavalle> #chair tidwellr
15:00:30 <openstack> Current chairs: carl_baldwin mlavalle tidwellr
15:00:36 <carl_baldwin> Hi
15:00:39 <yamamoto> hi
15:00:39 <pavel_bondar> hi
15:00:40 <john-davidge> Hi
15:00:41 <haleyb> hi
15:00:44 <mlavalle> Hi everybody
15:00:46 <njohnston> o/
15:00:53 <tidwellr> hi
15:00:57 <johndperkins> hi
15:01:07 <mlavalle> Agenda is here: https://etherpad.openstack.org/p/neutron-l3-subteam
15:01:20 <mlavalle> #topic Annoucements
15:01:53 <mlavalle> Newton-1 is being cut this week, as we speak
15:02:45 <mlavalle> Also the Neutron mid-cycle is confirmed to take place in Cork Ireland, August 17 -19
15:03:27 <mlavalle> Any other annoucements from the team?
15:04:05 <carl_baldwin> Not from me
15:04:17 <mlavalle> Etherpad for the mid-cycle is here:
15:04:24 <mlavalle> #link https://etherpad.openstack.org/p/newton-neutron-midcycle
15:04:43 <mlavalle> ok, let's move on...
15:04:49 <mlavalle> #topic Bugs
15:05:16 <mlavalle> First up is https://bugs.launchpad.net/neutron/+bug/1543094
15:05:16 <openstack> Launchpad bug 1543094 in neutron "[Pluggable IPAM] DB exceeded retry limit (RetryRequest) on create_router call" [High,In progress] - Assigned to Carl Baldwin (carl-baldwin)
15:05:37 <tidwellr> hi
15:06:07 <carl_baldwin> I think this is about ready to merge.
15:06:20 <carl_baldwin> I just wonder if the pluggable side of the changes are getting enough exercise.
15:06:30 <tidwellr> me too
15:06:46 <carl_baldwin> I'm comfortable with the non-pluggable side.
15:07:07 <pavel_bondar> I have rebased migration to pluggable ipam patch on top of that patch to see CI results
15:07:11 <carl_baldwin> tidwellr: BTW, I rolled that call to flush in to your patch the other day.
15:07:26 <carl_baldwin> pavel_bondar: Great.  Any results yet?
15:07:40 <tidwellr> carl_baldwin: thanks, barely treading water this week :)
15:07:47 <pavel_bondar> See two failed jobs, need to investigate deeper
15:07:57 <pavel_bondar> #link https://review.openstack.org/#/c/181023/
15:08:40 <carl_baldwin> pavel_bondar: I can probably help a bit.  I'm pretty familiar with tidwellr 's change by now.
15:09:16 <tidwellr> pavel_bondar: those are odd failures
15:09:56 <pavel_bondar> we can try to do recheck to see if it is a fluctuation or not
15:10:32 <carl_baldwin> pavel_bondar: It will help to recheck it a few times.  With this big a change, it helps to collect more data.
15:10:53 <carl_baldwin> I'd say recheck it any time you notice it is not in the check queue getting checked.
15:11:05 <pavel_bondar> ok :)
15:11:33 <pavel_bondar> rechecking
15:12:07 <carl_baldwin> We're going to get this one soon, I think.
15:12:31 <carl_baldwin> mlavalle: I think that's all for now.
15:12:42 <mlavalle> ok, let's move on...
15:12:51 <mlavalle> Next up is https://bugs.launchpad.net/neutron/+bug/1564335
15:12:51 <openstack> Launchpad bug 1564335 in neutron " [Pluggable IPAM] delete subnet in ml2 plugin does not comply with pluggable ipam (deletes ip allocations directly from db)" [High,In progress] - Assigned to Pavel Bondar (pasha117)
15:13:19 <pavel_bondar> two fixes are in gerrit for that
15:13:37 <pavel_bondar> #link https://review.openstack.org/#/c/300984/ updated it today, fixed some comments
15:14:16 <pavel_bondar> #link https://review.openstack.org/#/c/323345 is a WIP, UTs are pending, uploaded to get agreement about the approach
15:15:01 <pavel_bondar> initial review fix #2 is strongly welcome
15:15:22 <carl_baldwin> Will do
15:15:34 <pavel_bondar> carl_baldwin: thanks
15:15:58 <pavel_bondar> so that is it from my side
15:16:17 <mlavalle> Thanks pavel_bondar for your update and hard work!
15:16:45 <mlavalle> Those are the 2 high priority bugs we have for this week
15:16:58 <mlavalle> Any other bugs that the team wants to discuss here?
15:17:31 <mlavalle> If not, let's move on
15:17:41 <mlavalle> #topic Routed Networks
15:17:58 <carl_baldwin> Hi
15:18:17 <carl_baldwin> Still trying to work through the etherpad items.
15:18:19 <carl_baldwin> #link https://etherpad.openstack.org/p/routed-provider-networks-notes
15:18:36 <carl_baldwin> The Nova spec has a +2 from John.
15:18:42 <mlavalle> Yeap
15:18:51 <carl_baldwin> The next highest priority patch is for IPAM
15:18:55 <mlavalle> We probably need to ping mriedem today to get his
15:19:03 <carl_baldwin> #link https://review.openstack.org/#/c/314815/
15:19:10 <carl_baldwin> ... and the next one ...
15:19:20 <carl_baldwin> #link https://review.openstack.org/#/c/320631
15:20:48 <carl_baldwin> That's about it from me.  I'm starting to work on Nova and deferred IP ports.
15:22:53 <mlavalle> carl_baldwin: so we don't duplicate effort, could you elaborate on the Nova work you are doing?
15:23:24 <carl_baldwin> mlavalle: A simple part.  Just getting Nova to accept a port without an IP until host binding.
15:23:36 <mlavalle> ok, cool
15:23:57 <mlavalle> I just pinged mriedem in the Nova channel to get his review for https://review.openstack.org/#/c/263898
15:23:58 <carl_baldwin> mlavalle: Essentially what I started with that Nova patch a while back.
15:23:59 <carl_baldwin> #link https://review.openstack.org/#/c/299591
15:24:09 <carl_baldwin> mlavalle: Thanks for helping that spec along.
15:24:27 <mlavalle> ok, let's move on...
15:25:17 <mlavalle> #topic BGP Dynamic Routing
15:25:25 <tidwellr> hi
15:26:21 <tidwellr> I think we're ready to start dealing with RFE's and specs since the neutron-dynamic-routing repo is in reasonably good shape
15:27:13 <tidwellr> the last important item is to get test jobs up and running and get enough confidence in the jobs that we can turn them to voting jobs
15:28:38 <steve_ruan> hi Ryan, when the test jobs ready?
15:28:48 <Na_Zhu> tidwellr: what is the plan about RFE?  Mickey and Steve are working on the RFE about BGP EVPN, is there anyone works on other RFEs?
15:29:21 <tidwellr> steve_ruan: we need to get the jobs so they actually run tests
15:29:26 <Na_Zhu> tidwellr: seems like vikram is working on bgp statistics, right
15:30:05 <tidwellr> steve_ruan: we have 2 jobs, but they don't run any tests and I think they are non-voting at the moment
15:30:33 <steve_ruan> tidwellr, thanks
15:30:57 <Na_Zhu> tidwellr: can i take one confirmed RFE?
15:31:39 <tidwellr> Na_Zhu: let's wait until the RFE goes to "accepted"
15:32:13 <Na_Zhu> tidwellr: ok
15:32:19 <mickeys> We submitted a spec for BGP EVPN IP Prefix Advertisement
15:32:20 <tidwellr> Na_Zhu: I think we're still taking RFE's to the neutron drivers team, so that feedback is important
15:32:23 <mickeys> #link https://review.openstack.org/#/c/322654/
15:32:52 <tidwellr> mickeys: thanks for the pointer, I've been meaning to give that a look
15:33:24 <mickeys> tidwellr: We are looking forward to your feedback, and any feedback we can get from others
15:34:11 <tidwellr> #action tidwellr to review EPVN spec
15:35:20 <tidwellr> I didn't have anything else
15:35:37 <tidwellr> mickeys, Na_Zhu, steve_ruan?
15:35:46 <mickeys> Nothing else from me
15:36:03 <steve_ruan> yes, no update
15:36:46 <Na_Zhu> nothing to update
15:37:06 <Na_Zhu> nothing else to update
15:37:10 <mlavalle> tidwellr, mickeys, steve_ruan, Na_Zhu thanks for the update
15:37:23 <mlavalle> #topic FWaaS
15:37:47 <mlavalle> Are there any updates from the FWaaS team?
15:38:28 <SridarK> mlavalle: we have been looking at the agent extensions
15:38:32 <njohnston> I drilled down on how the L2 agent extensions work and how the notification driver works
15:38:48 <njohnston> My hope is to follow that as a common pattern
15:38:53 <SridarK> +1
15:39:29 <njohnston> The L2 agent notification driver is build on top of the 'port_update' and 'network_update' RPCs
15:39:50 <njohnston> so to follow their model I will need to gain more knowledge about what RPCs are in use by the L3 agent
15:40:21 <njohnston> They had tried to implement a separate set of messaging, but they said that experiments with it proved to be a RabbitMQ-buster
15:40:33 <mlavalle> lol
15:40:46 <njohnston> So research is ongoing, but I will add info to https://review.openstack.org/#/c/315745/ as I grok it
15:41:13 <carl_baldwin> njohnston: Thanks, I'll watch that spec.
15:41:47 <njohnston> carl_baldwin: thanks!
15:42:07 <SridarK> just to add - we also got pointed to https://review.openstack.org/#/c/91532/
15:42:32 <SridarK> which had done some earlier work on this area - we hope we can get some more data off that
15:43:09 <njohnston> yes, the author of that one said that it is dead but that we should feel free to plagiarize anything that looks usable.
15:44:35 <mlavalle> SridarK, njohnston: anything else to share with the team?
15:44:43 <njohnston> nope
15:44:45 <SridarK> mlavalle: nothing
15:44:48 <SridarK> thx
15:44:58 <mlavalle> Thanks for your update!
15:45:07 <mlavalle> #topic Open discussion
15:45:23 <mlavalle> I have a topic to share with the team
15:46:05 <mlavalle> A few months ago, armax sent an email to carl_baldwin and me, asking us to cleanup some technical debt we had incurred when initially implementing DNS integration
15:46:29 <mlavalle> Specifically, to clean up calls in the DB core plugin to DNS
15:47:24 <mlavalle> I have been working with one of my team members, Bin yu (yb is his irc nickname) on this:
15:47:32 <mlavalle> #link https://review.openstack.org/#/c/313291
15:48:04 <mlavalle> We have iterated it several times. I think it is very close to be ready for reviews from carl_baldwin and other team members
15:48:24 <carl_baldwin> mlavalle: Thanks for following up on this.
15:48:41 <mlavalle> I will review the last revision today and if I feel comfortable with it, I will ping carl_baldwin and others to get reviews
15:48:56 <mlavalle> don't invest time on it until I let you know
15:48:58 <carl_baldwin> mlavalle: sounds good.
15:49:46 <mlavalle> that's all I have on this topic
15:49:56 <mlavalle> any other topics from the team?
15:51:19 <mlavalle> Thanks for attending today's meeting!
15:51:28 <carl_baldwin> Thanks!
15:51:28 <mlavalle> #endmeeting