15:00:20 <mlavalle> #startmeeting neutron_l3
15:00:22 <openstack> Meeting started Thu Jul 14 15:00:20 2016 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:25 <openstack> The meeting name has been set to 'neutron_l3'
15:00:34 <njohnston> o/
15:00:38 <haleyb> hi
15:00:41 <tidwellr> hi
15:00:43 <mlavalle> #chair tidwellr carl_baldwin
15:00:44 <openstack> Current chairs: carl_baldwin mlavalle tidwellr
15:01:26 <mlavalle> #topic Announcements
15:01:45 <mlavalle> Today's agenda can be found here:
15:01:54 <mlavalle> #link https://etherpad.openstack.org/p/neutron-l3-subteam
15:02:41 <mlavalle> The other announcement is that we are in the process of cutting the Newton-2 milestone
15:03:01 <mlavalle> I don't know exactly where we are in that process, but it's taking place this week
15:03:56 <njohnston> According to dhellman, today is the deadline
15:04:26 <mlavalle> Also a reminder to the team about the Neutron mid-cycle is Cork Ireland. Here's the etherpad:
15:04:37 <mlavalle> #link https://etherpad.openstack.org/p/newton-neutron-midcycle
15:04:46 <mlavalle> njohnston: thanks!
15:05:11 <mlavalle> Any other annoucements from the team?
15:05:52 <carl_baldwin> Can't think of another
15:06:11 <mlavalle> ok, moving on...
15:06:17 <mlavalle> #topic Bugs
15:06:52 <mlavalle> First in the list is https://bugs.launchpad.net/neutron/+bug/1564335
15:06:52 <openstack> Launchpad bug 1564335 in neutron " [Pluggable IPAM] delete subnet in ml2 plugin does not comply with pluggable ipam (deletes ip allocations directly from db)" [High,In progress] - Assigned to Pavel Bondar (pasha117)
15:07:18 <mlavalle> any updates pavel_bondar?
15:07:28 <pavel_bondar> hi
15:07:42 <pavel_bondar> I have uploaded new version with addressed comments
15:07:52 <pavel_bondar> #link https://review.openstack.org/#/c/323345/
15:08:15 <pavel_bondar> it has some jenkins failures, but I believe it is just fluctuations
15:08:21 <pavel_bondar> so rechecking it
15:08:40 <pavel_bondar> reviews are welcome
15:09:29 <pavel_bondar> and that is probably it for that bug
15:09:48 <mlavalle> pavel_bondar: thanks for the update and your hard work
15:09:48 <carl_baldwin> Thanks, pavel_bondar
15:10:11 <mlavalle> Next up is https://bugs.launchpad.net/neutron/+bug/1596075
15:10:11 <openstack> Launchpad bug 1596075 in neutron "Neutron confused about overlapping subnet creation" [High,In progress] - Assigned to Kevin Benton (kevinbenton)
15:10:45 <mlavalle> For this one kevinbenton has been exchanging patchsets and information with the reporter
15:11:30 <mlavalle> Progress has been made but hasn't arrived to the final solution yet
15:11:39 <mlavalle> any other comments from the team?
15:12:06 <carl_baldwin> I was reading through comments yesterday.  At least it sheds some light on the problem.
15:12:56 <mlavalle> ok, moving on...
15:13:26 <mlavalle> https://bugs.launchpad.net/neutron/+bug/1599329
15:13:26 <openstack> Launchpad bug 1599329 in neutron "Potential regression on handing over DHCP addresses to VMs" [High,Confirmed] - Assigned to Kevin Benton (kevinbenton)
15:14:09 <mlavalle> This is also assigned to kevinbenton. It was confirmed by armax
15:14:18 <mlavalle> Not much more in the bug yet
15:14:28 <mlavalle> any comments?
15:15:14 <carl_baldwin> Without digging in, it could be anything.
15:15:40 <mlavalle> ok, moving on
15:16:15 <mlavalle> Last one this week is https://bugs.launchpad.net/neutron/+bug/1600530
15:16:15 <openstack> Launchpad bug 1600530 in neutron "Part 2 of engine DB facade breaks metadata agent" [High,In progress] - Assigned to Henry Gessau (gessau)
15:17:09 <mlavalle> HenryG and Ann are working on it. Ann already submitted a partial fix
15:17:23 <HenryG> Er ...
15:17:36 <HenryG> It was reverted and a new fix posted
15:18:04 <HenryG> Or am I confused?
15:18:23 <mlavalle> HenryG: well, the patchset merged by Ann seems to be a partial fix
15:18:59 <HenryG> Oh, right
15:19:10 <HenryG> It's a temporary fix.
15:19:22 <mlavalle> and actually Ann's comments point in that direction
15:19:46 <HenryG> The real fix went into oslo.db
15:19:58 <HenryG> We'll pick that up when the requirement lands
15:20:46 <mlavalle> HenryG: thanks for the update. Do you have the url of that fix?
15:20:58 <HenryG> one sec ...
15:21:29 <HenryG> https://review.openstack.org/340381
15:21:47 <mlavalle> HenryG: thanks! I'll update the bug with this
15:22:37 <mlavalle> Those were all the bugs I had this week
15:22:45 <mlavalle> any other bugs from the team?
15:23:27 <mlavalle> If not, let's move on
15:23:35 <mlavalle> #topic Routed Networks
15:23:41 <carl_baldwin> Hi
15:24:02 <carl_baldwin> Things are moving pretty well.
15:24:31 <carl_baldwin> I think we're over the hump in terms of being useable.  It is kind of fun.
15:24:38 <mlavalle> ++
15:24:40 <carl_baldwin> I don't know if I have anything to discuss.
15:24:48 <carl_baldwin> Does anyone else?
15:25:18 <john-davidge> On the related note of service subnet, I'm still having issues with the model/db sync
15:25:29 <john-davidge> If anyone knows that area well I'd appreciate some feedback https://review.openstack.org/#/c/337851
15:26:03 <john-davidge> Or I think I am anyway, currently waiting on the gate tests to confirm
15:26:22 <john-davidge> Other than that, that patch is in pretty good shape now I think
15:26:35 <carl_baldwin> john-davidge: I can have a look.
15:26:46 <john-davidge> carl_bladwin: Thanks
15:26:58 <john-davidge> haha, sorry, can't spell today
15:27:16 <mlavalle> On the Nova scheduler integration subject, I have made good progress deploying the generic resource pools in my test environment. Also, I already have an almost completely functional client for the generic rsource pool api, so soon I will start prototyping the integration with it in Neutron
15:27:16 * haleyb will look as well
15:28:24 <carl_baldwin> mlavalle: great progress
15:28:52 <mlavalle> ok, moving on...
15:29:11 <mlavalle> #topic BGP Dynamic Routing
15:29:18 <tidwellr> hi
15:29:43 <tidwellr> made some awesome progress on getting some of the check jobs to run
15:30:01 <tidwellr> we got the infra help we need, now the ball is back in my court
15:31:02 <steve_ruan> the are some patch for bgpvpn advertisement
15:31:12 <steve_ruan> and the spec need review
15:31:34 <steve_ruan> https://bugs.launchpad.net/neutron/+bug/1509431
15:31:35 <openstack> Launchpad bug 1509431 in neutron "[RFE] Enhance BGP Dynamic Routing with L2VPN/L3VPN support" [Wishlist,In progress] - Assigned to Henry Dong (henry-dong)
15:31:40 <tidwellr> steve_ruan: I'll take a look at the spec again, I just had some nits last time I looked
15:31:59 <steve_ruan> thanks
15:33:23 <mlavalle> anything else tidwellr, steve_ruan?
15:33:35 <tidwellr> nothing else from me
15:33:45 <tidwellr> well
15:34:05 <tidwellr> we could use an approval on https://review.openstack.org/#/c/333668/
15:34:21 <steve_ruan> still coding for the advertisement, not finish yet
15:34:50 <tidwellr> I had initially written this off as a non-issue, but it turns out we need https://review.openstack.org/#/c/333668/ to make the check jobs go'
15:35:17 <tidwellr> I +2'ed it, it just needs another +2
15:35:25 <tidwellr> that's all I had
15:36:09 <mlavalle> tidwellr, steve_ruan: Thanks for the update
15:36:17 <mlavalle> Moving on...
15:36:31 <mlavalle> #topic FWaaS
15:36:42 <mlavalle> njohnston: you are up
15:37:01 <njohnston> Hi all!  So our movement has been a little slow the last week because of teammembers on vacation and whatnot.
15:37:15 <mlavalle> yeah, Summer
15:37:38 <njohnston> But I have fixed up https://review.openstack.org/329701 and I think it's ready to be merged, I just need to make sure the shim class I introduced for backwards compatibility will cut the mustard.
15:38:11 <njohnston> once that is done I will get busy with https://review.openstack.org/#/c/339246/, the second stage
15:38:32 <njohnston> and I believe yushiro is working on the fwaas agent extension that will plus into this agent extension management framework
15:38:56 <njohnston> That's it for me.
15:39:17 <mlavalle> njohnston: thanks for the update
15:39:36 <mlavalle> #topic Conversion to Pluggable IPAM
15:40:28 <pavel_bondar> not much progress on my side during this week on that topic
15:40:48 <johnbelamaric> I still hope to get to the docs this week or early next week
15:40:54 <carl_baldwin> pavel_bondar: Did you see my notes about the test failure in the api job?
15:41:38 <carl_baldwin> I rebased your patch and it has passed Jenkins.  We need a few more rechecks.  And, we might need to follow up on that problem even if it isn't failing any more.
15:41:40 <pavel_bondar> carl_baldwin: yes, I saw, but I need to dive deep into details to say for sure if there is an issue or not
15:41:58 <carl_baldwin> pavel_bondar: I suspect the rollback mechanism is not working properly.
15:42:13 <carl_baldwin> I can't remember where I made my notes so I can't find them now.
15:42:47 <pavel_bondar> I guess you mean one on review https://review.openstack.org/#/c/181023/89
15:43:25 <tidwellr> one more thing we need to do is the contract migration for removing IpAvailabilityRanges
15:44:59 <pavel_bondar> tidwellr: right, as I see it can be prepared in parallel to switch to pluggable ipam, since IpAvailabilityRanges is no longer used
15:45:34 <tidwellr> right, just one little thing still hanging out there
15:45:41 <carl_baldwin> pavel_bondar: Yes, that was it.
15:46:38 <mlavalle> anything else on this topic?
15:46:53 <pavel_bondar> carl_baldwin:(about rollback) I think if you have session that is already broken, we still need to call rollback for ipam driver, since driver itself might not use session and be able to do rollback
15:47:20 <pavel_bondar> this is not the case for reference driver, since it uses the same session as neutron
15:48:04 <carl_baldwin> It looks like we might be able to fix it by inserting a session.rollback() or something.  I haven't had a chance to play with it.
15:48:22 <carl_baldwin> Do we have any tests that exercise the rollback mechanism in this way?
15:48:25 <carl_baldwin> pavel_bondar: ^
15:48:37 <pavel_bondar> carl_baldwin: yeah, I guess it could help
15:49:24 <carl_baldwin> pavel_bondar: Do you know if we have such tests?
15:50:06 <pavel_bondar> carl_baldwin: no, I guess we don't have tests that break session
15:50:27 <pavel_bondar> there are a few that do rollback on oridinary exceptions
15:51:03 <pavel_bondar> but no tests that operate with broken session, probably we need one
15:51:39 <carl_baldwin> I'll create a bug and try to write a logstash query to spot this bug.
15:51:53 <carl_baldwin> We were having trouble with logstash last week and couldn't make it work.
15:52:26 <carl_baldwin> #action carl_baldwin will create a bug for rollback after broken session and try to write logstash query.
15:53:27 <carl_baldwin> Since the API test was "fixed" with another patch, we run the risk of this problem being forgotten about.  You know, out of sight, out of mind.
15:53:48 <carl_baldwin> pavel_bondar: Otherwise, let's make sure we get a few rechecks on the latest version of the migration.
15:53:59 <carl_baldwin> Hopefully, those continue to go well.
15:54:34 <pavel_bondar> carl_baldwin: yeah, it is better to fix rollback before merging migration
15:55:24 <carl_baldwin> pavel_bondar: Do you think you'll have any time to write a test?
15:56:19 <pavel_bondar> carl_baldwin: I'll try to find time for that during next couple of days
15:56:26 <carl_baldwin> pavel_bondar: Thanks.
15:56:37 <carl_baldwin> Let me know if you need anything.
15:57:10 <pavel_bondar> carl_baldwin: sure
15:57:32 <carl_baldwin> mlavalle: I think that's it.
15:57:45 <mlavalle> carl_baldwin, pavel_bondar Thanks
15:57:52 <mlavalle> #topic Open Agenda
15:58:07 <mlavalle> any topics to discuss in the 3 minutes we have left?
15:58:11 <john-davidge> I take back what i said earlier about model/db sync issues, gate tests have passed. #link https://review.openstack.org/#/c/337851 is ready for review
15:58:24 <john-davidge> (service subnets)
15:59:08 <mlavalle> ok, Thanks for attending. Have a nice rest of the week
15:59:14 <mlavalle> #endmeeting