15:01:02 <tidwellr> #startmeeting neutron_l3
15:01:03 <openstack> Meeting started Thu Jul 21 15:01:02 2016 UTC and is due to finish in 60 minutes.  The chair is tidwellr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:07 <openstack> The meeting name has been set to 'neutron_l3'
15:01:34 <tidwellr> #chair carl_baldwin mlavalle
15:01:35 <openstack> Current chairs: carl_baldwin mlavalle tidwellr
15:01:44 <mlavalle> o/
15:01:58 <tidwellr> #topic Annpuncements
15:02:32 <tidwellr> neutron mid-cycle is coming up
15:03:42 <tidwellr> any more annoncements?
15:04:32 <tidwellr> if not, let's dive in
15:05:00 <tidwellr> #topic Bugs
15:05:20 <tidwellr> working from the bottom of the list
15:05:47 <tidwellr> oh, by the way the agenda is here https://etherpad.openstack.org/p/neutron-l3-subteam
15:06:02 <tidwellr> https://bugs.launchpad.net/neutron/+bug/1603162
15:06:02 <openstack> Launchpad bug 1603162 in neutron "IP deallocation failed on external system with pluggable IPAM" [High,New] - Assigned to Pavel Bondar (pasha117)
15:06:58 <pavel_bondar> hi
15:06:58 <carl_baldwin> pavel_bondar: any progress?
15:06:59 <tidwellr> pavel_bondar carl_baldwin: This looks new, any updates?
15:07:15 <pavel_bondar> not much progress yet on my side
15:07:17 <mlavalle> yeah, pavel_bondar filed it a few minutes ago
15:07:37 <pavel_bondar> mlavalle: that is another one
15:07:42 <mlavalle> ok
15:07:52 <pavel_bondar> one that I filed is: https://bugs.launchpad.net/neutron/+bug/1605277
15:07:52 <openstack> Launchpad bug 1605277 in neutron "[IPAM] 'Internal' ipam driver does not allow to delete all pools on subnet update" [Undecided,In progress] - Assigned to Pavel Bondar (pasha117)
15:08:29 <pavel_bondar> as for 1603162, no progress yet, but I will pick it as my next task
15:08:59 <carl_baldwin> pavel_bondar: let me know if you want help
15:09:54 <tidwellr> pavel_bondar: thanks for the update on these
15:10:05 <pavel_bondar> carl_baldwin: sure, as I got for now this ticket is about writing UT to cover rollback case and emulating db transaction breakage
15:10:12 <pavel_bondar> is it correct?
15:10:19 <carl_baldwin> pavel_bondar: yes
15:10:43 <pavel_bondar> carl_baldwin: ok, will try to do soon
15:11:25 <pavel_bondar> that is it from my side about this ticket
15:11:47 <tidwellr> https://bugs.launchpad.net/neutron/+bug/1600530
15:11:47 <openstack> Launchpad bug 1600530 in neutron "Part 2 of engine DB facade breaks metadata agent" [High,In progress] - Assigned to Henry Gessau (gessau)
15:13:04 <tidwellr> looks like a fix is already in
15:13:07 <mlavalle> I think that one should be closed now
15:13:18 <tidwellr> ok
15:13:36 <mlavalle> I'll move it to fix released
15:14:01 <tidwellr> mlavalle: thanks, I moved it off the agenda
15:14:13 <tidwellr> https://bugs.launchpad.net/neutron/+bug/1599329
15:14:13 <openstack> Launchpad bug 1599329 in neutron "Potential regression on handing over DHCP addresses to VMs" [High,In progress] - Assigned to Kevin Benton (kevinbenton)
15:15:32 <tidwellr> looks like kevinbenton and ajo are on this one
15:15:55 <carl_baldwin> I haven't low at the proposed fix yet.
15:16:55 <mlavalle> well, it seems more like they are researching it
15:16:55 <carl_baldwin> *looked
15:17:08 <mlavalle> kevinbenton proposed a fix but was then abandoned
15:17:09 <carl_baldwin> mlavalle: could be
15:17:41 <tidwellr> I see https://review.openstack.org/#/c/344545/, but it has a sticky -2 while someone does their due diligence
15:17:43 <mlavalle> and ajo reported some research results just 15 minutes ago
15:20:25 <tidwellr> ok, anything else to add?
15:20:26 <tidwellr> if not we can move on and take an action item to follow this one
15:20:27 <tidwellr> https://bugs.launchpad.net/neutron/+bug/1596075
15:20:27 <openstack> Launchpad bug 1596075 in neutron "Neutron confused about overlapping subnet creation" [High,In progress] - Assigned to Kevin Benton (kevinbenton)
15:21:31 <tidwellr> looks like we have  a fix for this one
15:22:18 <mlavalle> yeah, but kevinbenton is asking the reported to do some things, right above the merge
15:22:45 <mlavalle> so I say let's keep as is and keep an eye on it
15:22:54 <mlavalle> the fix might be partial
15:23:19 <tidwellr> ah, partial fix
15:23:23 <mlavalle> I would like to hear back from the reporter
15:23:40 <tidwellr> definitely
15:23:56 <tidwellr> keep watching this one then
15:25:14 <tidwellr> ok, I think we've worked through the bugs. Are there any I missed that need to be discussed?
15:25:27 <mlavalle> Yes I want to add one
15:25:37 <mlavalle> https://bugs.launchpad.net/neutron/+bug/1604370
15:25:37 <openstack> Launchpad bug 1604370 in neutron "functional: test_legacy_router_ns_rebuild is unstable" [High,New]
15:25:53 <mlavalle> I just raised its importance to high
15:26:22 <mlavalle> there are 17 ocurrences over the past 7 days
15:26:49 <mlavalle> so it warrants further investigation
15:26:58 <mlavalle> I will dig in later today
15:27:07 <tidwellr> malvalle: thanks, I've added that to the etherpad
15:27:26 <mlavalle> thanks
15:27:37 <carl_baldwin> mlavalle: thanks for staying on top of it
15:27:44 <tidwellr> any more bugs to discuss?
15:28:19 <pavel_bondar> one that I filed today: https://bugs.launchpad.net/neutron/+bug/1605277
15:28:19 <openstack> Launchpad bug 1605277 in neutron "[IPAM] 'Internal' ipam driver does not allow to delete all pools on subnet update" [Undecided,In progress] - Assigned to Pavel Bondar (pasha117)
15:28:42 <pavel_bondar> this one was found during analysing test failures for migration to pluggable ipam
15:28:56 * john-davidge was just reading that one
15:29:30 <pavel_bondar> I have proposed fix for it: https://review.openstack.org/#/c/345498/
15:29:36 <carl_baldwin> pavel_bondar: good find
15:29:55 <carl_baldwin> I was starting to look in to that failure yesterday myself
15:30:11 <carl_baldwin> Will look at your fix.
15:30:27 <pavel_bondar> carl_baldwin: great, thanks
15:30:45 <pavel_bondar> fix is pretty trivial by the way
15:31:11 <pavel_bondar> that is probably it about it
15:31:13 <tidwellr> pavel_bondar: thanks for the update, we like easy fixes :)
15:31:24 <mlavalle> by all means
15:31:27 <pavel_bondar> :)
15:31:48 <tidwellr> #topic Routed Network Segments
15:32:23 <tidwellr> carl_baldwin mlavalle: what do you have cooking at the moment?
15:32:57 <carl_baldwin> I have a plan now with nova to get the deferred ip fix to merge.  Discussed it with them yesterday.
15:33:06 <mlavalle> ++
15:33:45 <carl_baldwin> It is official that we won't have ip availability aware scheduling in Newton.
15:34:11 <tidwellr> :(, good progress was still made though
15:34:39 <carl_baldwin> Yes, we've done a ton of work
15:36:45 <tidwellr> carl_baldwin: thanks, anything else?
15:37:12 <carl_baldwin> Just keep plugging away.  We'll have something workable in Newton.
15:37:43 <tidwellr> carl_baldwin: sounds good
15:38:01 <tidwellr> #topic FWaaS
15:38:08 <njohnston> Hi
15:38:28 <njohnston> So the first part of the agent work is complete and merged: https://review.openstack.org/329701
15:38:34 <njohnston> thanks to all who helped with that
15:39:05 <njohnston> but that was just making the l2 code generalized and available to the l3 agent
15:39:30 <njohnston> the second step is creating the intermediate classes necessary for an l3 agent extension to run: L3 agent extension implementation: https://review.openstack.org/337699
15:39:55 <njohnston> I am starting to test that out now
15:40:09 <njohnston> I will file a follow-up patch with a fullstack test to really test it out
15:40:22 <njohnston> The fullstack test creates a dummy l3 agent extension and loads it and then sends some router add/update/delete messages to the agent.  The extension communicates back over a TCP socket to say "I was called with X payload" so the test can verify the extension was called correctly.
15:40:51 <njohnston> but I don't want to hold up 337699 while I work out the complexities of that
15:41:40 <carl_baldwin> njohnston: ack
15:41:45 <njohnston> There are a couple of people working on the actual FWaaS l3 agent extension (mfranc213 and yushiro) and that is coming along.
15:41:56 <njohnston> I am still optimistic that we will make Newton in good form
15:42:38 <tidwellr> njohnston: very nice, thanks for the update. Is there any help you need at the moment?
15:43:31 <njohnston> No, nothing per se... I think once I can get the l3 agent extension to really work, then I think it's just left for things to start plugging into it.
15:43:54 <njohnston> Perhaps in a week I will be ready for reviews on 337699
15:44:19 <tidwellr> njohnston: great
15:44:31 <tidwellr> njohnston: anything to share with the team?
15:44:38 <tidwellr> *else
15:44:43 <njohnston> Nope, that's it got me
15:44:47 <njohnston> s/got/for/
15:45:04 <tidwellr> njohnston: :)
15:45:20 <tidwellr> topic BGP Dynamic Routing
15:45:49 <njohnston> ^^ #?
15:45:59 <tidwellr> oh yeah
15:46:05 <njohnston> :)
15:46:07 <steve_ruan> Tidwellrm
15:46:09 <steve_ruan> https://review.openstack.org/#/c/337662/
15:46:11 <tidwellr> #topic BGP Dynamic Routing
15:46:28 <steve_ruan> this patch need some help review
15:46:38 <steve_ruan> Hi tidwellr
15:46:45 <tidwellr> steve_ruan: I saw that this morning
15:47:09 <tidwellr> it had subnetpools in the title so it caught my attention :)
15:47:09 <steve_ruan> this patch has a small change about subnetpool event
15:47:17 <steve_ruan> thanks
15:47:47 <tidwellr> steve_ruan: I can give that a look
15:48:10 <tidwellr> steve_ruan: how is everything else going, any updates to share?
15:48:33 <steve_ruan> still working on evpn advertisement
15:48:38 <steve_ruan> almost finished
15:48:46 <steve_ruan> will submit soon
15:49:26 <tidwellr> steve_ruan: I see the code starting to be proposed, how is the spec doing? I haven't seen any updates for a while
15:49:50 <mickeys> tidwellr: I think the spec is in decent shape. Needs more reviews.
15:50:09 <steve_ruan> there is no more doubt about the spec, right?
15:51:02 <tidwellr> mickeys: my apologies, I'm drowning here. I missed the updated patch set almost 2 weeks ago
15:51:23 <tidwellr> #action tidwellr to look over https://review.openstack.org/#/c/322654/
15:52:42 <tidwellr> I was able to get the tempest tests in neutron-dynamic-routing cleaned up and running in the check jobs
15:53:22 <tidwellr> I'm now more comfortable with code being proposed against the project now, the next step is to just make that job a voting job
15:54:06 <tidwellr> mickeys steve_ruan: anything else to add?
15:54:15 <steve_ruan> no
15:54:19 <mickeys> Nothing else from me
15:54:35 <tidwellr> #topic Open Discussion
15:55:01 <john-davidge> The Service Subnets patch has been updated since yesterday https://review.openstack.org/#/c/337851/
15:55:13 <john-davidge> Thanks to everyone for the reviews
15:55:28 <tidwellr> john-davidge: sweet, I didn't realize that was up for review
15:55:53 <john-davidge> tidwellr: It's in pretty good shape now I think
15:56:20 <john-davidge> Once the positive reviews start appearing I'll get started on the follow-up for the port creation logic
15:56:24 <carl_baldwin> john-davidge: thanks
15:56:41 <carl_baldwin> john-davidge: As I recall it was pretty close.  I'll have a look today.
15:57:08 <john-davidge> carl_baldwin: Thanks Carl, your reviews have been very helpful!
15:57:25 <tidwellr> anything else to discuss?
15:58:34 <carl_baldwin> Thanks, tidwellr !
15:58:39 <tidwellr> alright, let's call it a meeting then
15:58:47 <tidwellr> thanks everyone!
15:58:54 <tidwellr> #endmeeting