15:00:22 <mlavalle> #startmeeting neutron_l3
15:00:23 <openstack> Meeting started Thu Jan 5 15:00:22 2017 UTC and is due to finish in 60 minutes. The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:26 <openstack> The meeting name has been set to 'neutron_l3'
15:00:49 <mlavalle> hi there!
15:01:00 <janzian> o/
15:01:08 <haleyb> happy new year
15:01:30 <mlavalle> haleyb, janzian: happy new year!
15:01:47 <baoli> hi,happy new year
15:01:57 <mlavalle> welcome baoli !
15:02:27 <mlavalle> #topic Announcements
15:02:51 <mlavalle> Agenda for today is here: https://etherpad.openstack.org/p/neutron-l3-subteam
15:04:06 <mlavalle> We are less ~ 3 weeks from Ocata-3: January 23 - 27
15:04:25 <mlavalle> #link https://releases.openstack.org/ocata/schedule.html
15:05:41 <mlavalle> Before we now it, it will be Project Team Gathering time, February 20 - 24
15:05:58 <mlavalle> #link https://www.openstack.org/ptg/
15:06:48 <mlavalle> any other announcements?
15:06:53 <haleyb> Yes, we need to start a wiki page for discussion topics (if someone hasn't already)
15:07:10 <mlavalle> haleyb: for the PTG?
15:07:44 <haleyb> mlavalle: yes
15:07:58 <mlavalle> why not an etherpad?
15:08:14 <mlavalle> I find them friendlier
15:08:36 <haleyb> mlavalle: because wiki is easier to type :) yes, i meant etherpad
15:09:16 <mlavalle> LOL, ok..... I'll start one if you want and send a message to the ML. Does that work?
15:09:51 <haleyb> mlavalle: well there might already be a neutron one, i just haven't checked
15:10:32 <mlavalle> haleyb: ahhh, ok. Maybe we can ask this question on Monday, during the Neutron meeting
15:10:52 <mlavalle> I haven't seen a message in the ML from armax
15:11:01 <haleyb> sounds good
15:11:31 <mlavalle> #action mlavalle to question about PTG etherpad during the next Neutron meeting
15:11:59 <mlavalle> #topic Bugs
15:15:47 <mlavalle> With the holidays slowdown there hasn't been much change in the overall picture
15:15:47 <mlavalle> First one is https://bugs.launchpad.net/neutron/+bug/1610483
15:15:47 <mlavalle> This is the one about the IPAM rollback mechanism not being robust enough
15:15:47 <mlavalle> (bot seems to be slow today)
15:15:48 <openstack> Launchpad bug 1610483 in neutron "Pluggable IPAM rollback mechanism is not robust" [High,In progress] - Assigned to Aliaksandr Dziarkach (aliaksandr-dziarkach)
15:15:49 <mlavalle> Proposed fix is here: https://review.openstack.org/390594
15:15:49 <mlavalle> I encourage folks to review the fix
15:15:51 <mlavalle> any other comments?
15:16:55 <mlavalle> ok, next up is https://bugs.launchpad.net/neutron/+bug/1570122
15:16:55 <openstack> Launchpad bug 1570122 in neutron "ipv6 prefix delegated subnets are not accessable external of the router they are attached." [High,In progress] - Assigned to John Davidge (john-davidge)
15:17:56 <mlavalle> john-davidge is working on this one. Proposed fix is https://review.openstack.org/#/c/407025/
15:18:22 <haleyb> looks to just need a test
15:18:27 <mlavalle> since john-davidge is off this week, we won't see any change until next week
15:19:29 <mlavalle> yeah, I think he will address that when he comes back
15:19:57 <mlavalle> any other comments?
15:21:25 <mlavalle> Next one is https://bugs.launchpad.net/neutron/+bug/1627424
15:21:25 <openstack> Launchpad bug 1627424 in neutron "FlushError on IPAllocation" [High,Confirmed] - Assigned to Miguel Lavalle (minsel)
15:21:51 <mlavalle> We've had 17 hits of this one over the past week
15:22:19 <mlavalle> It mostly happens as a consequence of rally tests
15:22:35 <mlavalle> IN those cases, it happens when deleting a subnet
15:22:55 <mlavalle> when deleting the ports
15:23:08 <mlavalle> I am narrowing it down from there right now
15:23:25 <mlavalle> any comments, advice, questions?
15:24:13 <haleyb> thanks for continuing to look at it miguel
15:24:33 <mlavalle> :-)
15:25:53 <mlavalle> There are other paths that trigger it, but yesterday I decided to exhaust the rally one in my digging. That way I can accumulate some knowledge. Let's see where I get over the next couple of days
15:26:49 <mlavalle> Next one is https://bugs.launchpad.net/neutron/+bug/1627480
15:26:49 <openstack> Launchpad bug 1627480 in neutron "create_port can succeed without returning fixed_ips on all requested subnets" [High,Confirmed]
15:27:30 <mlavalle> I don't have any updates here, other than when I am done with the previous one, I'll pursue this one. If someone wants to take it please go ahead
15:28:55 <mlavalle> any other bugs from the team?
15:29:30 <mlavalle> ok....
15:29:39 <mlavalle> #topic Prefix Delegation
15:29:49 <mlavalle> any updates baoli?
15:30:23 <baoli> mlavalle: I have a couple of patches for review, both of them have passed jenkins
15:30:39 <baoli> haleyb: thanks for review and the +2
15:31:44 <haleyb> baoli: thanks for the change, i need to get to the other review
15:32:08 <mlavalle> baoli: ok, I'll take a look at https://review.openstack.org/#/c/408306/
15:32:42 <baoli> mlavalle: thanks!
15:33:12 <mlavalle> baoli: most likely I'll do it tomorrow :-)
15:34:04 <mlavalle> any other comments?
15:34:44 <mlavalle> ok
15:34:59 <mlavalle> #topic Service Subnets
15:35:26 <mlavalle> I see good progress was made on https://review.openstack.org/#/c/411463/
15:35:34 <mlavalle> before the holidays
15:35:55 <mlavalle> the docs guys are reviewing it
15:36:05 <mlavalle> any other comments?
15:36:13 <haleyb> mlavalle: i was going to update it today, but others were nice to update while i was out
15:36:28 <mlavalle> yeah, I can see it
15:36:59 <mlavalle> Let's keep an eye on it:-)
15:37:13 <mlavalle> #topic Routed Networks
15:37:50 <mlavalle> On this topic I made great progress over the holidays (while juggling visiting kids and wife)
15:38:01 <mlavalle> I have two patchsets up for review
15:39:23 <mlavalle> The first one is the ReST client that we need in Neutron to talk to the placement API in Nova to update it about the availability of IPv4 addresses in routed networks subnets
15:39:32 <mlavalle> #link https://review.openstack.org/#/c/414726/
15:40:14 <mlavalle> I tested it extensively over the holidays and is fully functional. I encourage folks to review it
15:40:33 * haleyb adds to review queue
15:41:12 <mlavalle> The second one is the piece in Neutron server that uses the aforementioned client to actually update Nova with the IPv4 inventories
15:41:22 <mlavalle> #link https://review.openstack.org/#/c/358658
15:41:57 <mlavalle> I also tested it extensively over the holidays. It is also fully functional, with a little exception
15:42:39 <mlavalle> during my testin I uncovered a bug on the Nova side:
15:42:46 <mlavalle> #link https://bugs.launchpad.net/nova/+bug/1652642
15:42:46 <openstack> Launchpad bug 1652642 in OpenStack Compute (nova) "Nova API doesn't return aggregate's uuid, which is needed when using the placement API" [High,In progress] - Assigned to Jay Pipes (jaypipes)
15:43:03 <haleyb> mlavalle: so holidays != rest ? :)
15:43:34 <janzian> In his case, holidays = ReST
15:43:46 <mlavalle> The Nova team jumped at it really quickly so I am getting all the help I need from that side
15:44:18 <haleyb> janzian: nice one!
15:44:38 <janzian> :)
15:44:42 <mlavalle> I encourage people to review the code in my patchset. The places where the bug affects it is very well isolated and marked with TODOs
15:45:50 <mlavalle> so I think we can make progress in parallel with the Nova guys if Neutron reviewers take a look at the code ignoring those few TODOs
15:46:55 <mlavalle> any questions / comments?
15:47:42 <mlavalle> I plan to update the blueprint with this progress prior to the Neutron meeting on Monday
15:48:06 <mlavalle> #topic Open Agenda
15:48:15 <mlavalle> Any other topics from the team?
15:49:08 <mlavalle> Going once....
15:49:40 <mlavalle> Going twice....
15:50:12 <mlavalle> Sold!
15:50:18 <mlavalle> #endmeeting