14:01:36 <dougwig> #startmeeting neutron lbaas
14:01:37 <openstack> Meeting started Thu Aug 28 14:01:36 2014 UTC and is due to finish in 60 minutes.  The chair is dougwig. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:41 <openstack> The meeting name has been set to 'neutron_lbaas'
14:01:47 <dougwig> #chair blogan
14:01:48 <openstack> Warning: Nick not in channel: blogan
14:01:49 <openstack> Current chairs: blogan dougwig
14:01:59 <blogan_> jorgem is running late
14:02:12 <blogan_> markmcclain: update on incubator?
14:02:17 <dougwig> we don't have an agenda this week, so toss out topics, or we'll just go straight to open discussion.
14:02:29 <blogan_> first topic tossed out
14:02:37 <dougwig> #topic incubator update
14:02:53 <markmcclain> blogan_: yeah.. so after chatting with infra we're having to tweak a bit of the incubator procedural setup
14:03:08 <TrevorV> o/
14:03:11 * TrevorV sorry I'm late again :(
14:03:20 <markmcclain> it will not impact you all since the long term we discussed in Atl is separate project
14:03:46 <jorgem> hey there
14:03:57 <dougwig> #chair jorgem
14:03:58 <openstack> Current chairs: blogan dougwig jorgem
14:04:07 <markmcclain> (the biggest change coming is for code that is destined to be folded back into neutron we'll have to designate feature branches)
14:04:14 <blogan_> markmcclain: yeah we've been focusing on octavia right now, so really its just a matter of when the code can go into the repository
14:04:15 <jorgem> sorry entrance ramp closed this morning :/
14:04:33 <sballe_> markmcclain, so are you saying that the new lbaas model will go into an lbaas incubator project and eventual into a separate openstack project?
14:04:55 <markmcclain> sballe_: yes that is the current target
14:05:12 <sballe_> markmcclain,  it the whoel Neutron LBaaS that goes into incubator?
14:05:28 <markmcclain> sballe_: still working on the mechanics of everything and we'll have lots of boring procedural stuff in Kilo to do
14:05:50 <xgerman> it's exciting for us ;-)
14:05:58 <sballe_> markmcclain, I am just trying t understand the difference and the focus
14:06:17 <sballe_> if it is only new stuff or Neutron LBaaS that goes int incubator
14:06:26 <jorgem> markmcclain: Is the wiki constantly being updated with this information? Where can I find the WIP "rules" document (if that exists)?
14:06:39 <markmcclain> sballe_: same items will be still be going into the incubator this cycle
14:07:00 <sballe_> can you clarify "items"?
14:07:11 <blogan_> i'd assume GBP
14:07:14 <markmcclain> jorgem: haven't published updates yet mainly because still be hammering out the proposed text
14:07:31 <markmcclain> group policy and fwaas are immediate candidates
14:07:41 <jorgem> markmcclain: roger that. I'm sure you'll ping us ;)
14:07:43 <markmcclain> sslvpn is another but likley won't enter until next cycle
14:08:37 <blogan_> markmcclain: are you saying lbaas v2 won't get into the incubator until kilo cycle?
14:08:41 <sballe_> markmcclain, Where does that leave our stuff?
14:08:47 <sballe_> blogan_, +1
14:09:00 <markmcclain> blogan_: lbaas and gbp will enter this cycle
14:09:05 <blogan_> oh okay
14:09:09 <markmcclain> we're likely to add 1-2 things for kilo
14:09:13 <blogan_> good
14:09:14 <sballe_> good to know :)
14:09:25 <jorgem> + :)
14:10:07 <dougwig> any other incubator updates or questions before we move on?
14:10:13 <sballe_> markmcclain, so I am just trying to get this righ lbaas v1 is in neutron, lbaas v2 will be in incubator mode soon /before Kilo
14:10:57 <markmcclain> sballe_: yes and we'll declare v1 frozen if not deprecated to steer folks towards v2
14:10:59 <sballe_> if that is true then I think this is a great outcome
14:11:07 <sballe_> markmcclain, +1
14:11:08 <xgerman> +1
14:11:12 <blogan_> excellent
14:11:45 <dougwig> +1
14:11:49 <blogan_> and until then we'll just focus on octavia, i'll do whatever is necessary to get it into the incubator though
14:11:58 <blogan_> code wise i mean
14:12:09 <dougwig> me too
14:12:28 <markmcclain> awesome.. sorry this has take so long.. coordinating with everyone has been an adventure
14:13:20 <blogan_> markmcclain: you should adopt blizzard's release estimations, always will be released "soon"
14:13:23 <TrevorV> markmcclain, adventures are fun! Don't you watch movies?
14:13:37 <markmcclain> haha
14:13:42 <dougwig> #topic open discussion
14:13:49 <blogan_> open mic!
14:13:54 <dougwig> if anyone wants the floor for a specific topic, msg me.  otherwise it's open.
14:14:32 <dougwig> and if it's a light meeting day, i'll let everyone go back to bed.  :)
14:14:39 <blogan_> xgerman: any update from min about the docs?
14:14:50 <xgerman> she is working on it
14:15:06 <xgerman> said it should be finished soon
14:15:16 <dougwig> markmcclain: thanks for the update.
14:15:35 <markmcclain> dougwig: you're welcome
14:15:50 <blogan_> markmcclain: just so you know, the docs for neutron lbaas were updates to v2, and v1 is no longer in.  Min from HP is rectifying that so that v1 docs get back in
14:16:06 <dougwig> do we have a bug opened on that?
14:16:13 <xgerman> it
14:16:16 <xgerman> 's a feature
14:16:28 <blogan_> so a blueprint lol?
14:16:51 <blogan_> i don't know of a bug, but that would be quite beneficial
14:17:05 <blogan_> i'll make one today if there isn't one
14:17:10 <dougwig> xgerman: can you or min file a bug, and make sure kyle gets it on the juno radar?
14:17:33 <dougwig> ok
14:17:39 <sballe_> mestery, what is the dealine for juno final?
14:17:51 <mestery> sballe_: 9-4-2014
14:17:55 <dougwig> #action blogan_ file bug for v2 docs being in juno, but not v2
14:18:06 <sballe_> mestery, thx
14:18:36 <dougwig> any other topics?
14:18:48 <xgerman> design summit?
14:18:56 <dougwig> #topic design summit
14:19:06 <dougwig> xgerman: the floor is yours.
14:19:10 <xgerman> when is the proposal deadline?
14:19:23 <sballe_> I talked to mestery and he told me we cannot submit design sessions yet
14:20:18 <xgerman> ok, so maybe this is something for next week then?
14:20:33 <sballe_> do we agree that we want 3 sessions? one on flavors, one on Neutron LBaaS and one on Octavia?
14:20:51 <xgerman> +1
14:20:59 <blogan_> sballe_: wouldn't eugene or mark do a design session on flavors?
14:21:14 <xgerman> that doesn't preclude us from wanting one
14:21:17 <sballe_> blogan_, that was my next question ;-)
14:21:22 <blogan_> ah okay
14:21:44 <blogan_> i don't see how there won't be a design session on flavors, but crazier things have happene
14:21:45 <blogan_> d
14:21:53 <vivek-ebay> we may need more than one design session for Neutron LBaaS
14:21:58 <vivek-ebay> one is not enough :)
14:22:07 <sballe_> so we shoudl submit 2: Neutron LBaaS and Octavia. And coordinate to make sure the 3rdne happens
14:22:27 <sballe_> vivek-ebay, I agree
14:22:29 <blogan_> sounds good to me
14:22:38 <dougwig> folks, folks, aren't we forgetting the UDP session?
14:22:41 <sballe_> vivek-ebay, we could also do extra work at the Neutron ods
14:22:42 <blogan_> if neutron lbaas needs multiple, I'd say Octavia would need double that
14:22:50 <xgerman> +1
14:22:59 <xgerman> we should get a whole Octavia track
14:23:01 <sballe_> s/ods/pods
14:23:06 <markmcclain> dougwig: I have a bar picked out for that session
14:23:24 <vivek-ebay> :)
14:23:30 <blogan_> UDP Ale
14:23:31 <dougwig> markmcclain: i'm in.
14:23:39 <xgerman> +1
14:23:50 <sballe_> markmcclain, dougwig count me in ;-) on the UDP session
14:24:05 <markmcclain> also if you haven't see this thread from yesterday...
14:24:07 <markmcclain> #link http://lists.openstack.org/pipermail/openstack-dev/2014-August/044169.html
14:24:25 <markmcclain> the design summit format is changing quite a bit
14:24:50 <blogan_> i have not seen that, thanks!
14:24:51 <sballe_> more changes ;-)
14:25:12 <xgerman> "but could continue the discussion
14:25:13 <xgerman> in a local bar"
14:26:33 <dougwig> anything else on design summits?
14:26:40 <sballe_> Octavia seems to fit the new critaria for the sessions
14:27:27 <dougwig> #topic moments of zen
14:27:34 <dougwig> any final words, or any new topics?
14:27:42 <blogan_> i like turtles
14:27:47 <sballe_> lol
14:28:34 <jorgem> I like ninja turtles
14:28:47 <blogan_> i like teenage mutant ninja turtles
14:28:56 <jorgem> doh!
14:28:57 <blogan_> i'd say we have nothing else to talk about
14:29:00 * dougwig worries at the direction this is taking.
14:29:16 <dougwig> on that note...   see you next time, or in channel.
14:29:20 <jorgem> alright I think we are done as well
14:29:23 <xgerman> teenage mutant ninja turtles programmers?
14:29:27 <dougwig> #endmeeting