14:00:05 <dougwig> #startmeeting neutron lbaas
14:00:06 <openstack> Meeting started Thu Sep 25 14:00:05 2014 UTC and is due to finish in 60 minutes.  The chair is dougwig. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'neutron_lbaas'
14:00:20 <dougwig> #topic Announcements
14:00:33 <dougwig> kilo design summit reminder:
14:00:34 <dougwig> #link https://etherpad.openstack.org/p/kilo-neutron-summit-topics
14:00:47 <dougwig> any other announcements?
14:01:22 <dougwig> moving on
14:01:24 <dougwig> #topic Incubator Update
14:01:45 <sballe_> morning
14:01:52 <dougwig> we're giving a feature branch a try.  i wrote a small wiki, but it's crazy short, because it's basically, "go track this remote branch"
14:01:59 <dougwig> #link https://wiki.openstack.org/wiki/Neutron/FeatureBranch
14:02:12 <dougwig> (someone, anyone, feel free to edit that.)
14:02:20 <dougwig> many of the reviews have been moved:
14:02:22 <dougwig> #link https://etherpad.openstack.org/p/lbaas_reviews
14:02:31 <dougwig> driver reviews will be moved once the current ones are passing jenkins again.
14:02:52 <dougwig> any questions/comments on the v2 feature branch?
14:03:12 <sbalukoff> Yay for having it?
14:03:18 <sballe_> +1
14:03:29 <jamiem> heh
14:03:57 <sballe_> As a passing comment it looks like Monty and the infra team are working towards somethign llike this: http://inaugust.com/post/108
14:03:57 <vjay7> hi
14:04:33 <xgerman> so fewature branch means we are part of Kilo?
14:04:59 <sballe_> yes that is what I am told. We should merge in kilo
14:05:07 <dougwig> no, feature branch means that we have a playground to get things into without as many rules as master.  "graduation" requirements have not yet been set.
14:05:20 <dougwig> it likely means kilo, though.
14:05:35 <xgerman> so it's like  a stealth incubator?
14:05:55 <sballe_> without that many rules
14:05:58 <dougwig> without the visibility or packaging benefits, but shorter-lived, yes.
14:06:07 <xgerman> ok, got it
14:06:29 <sbalukoff> Any path forward is better than no path forward, eh.
14:06:45 <TrevorV> sbalukoff, I prefer to run in circles o_0
14:07:09 <sballe_> sbakukoff +1
14:07:48 <sbalukoff> TrevorV: Haha!
14:07:50 <dougwig> on that note, please go give feedback on the top couple of reviews.  we want to start getting them in.
14:08:36 <sballe_> ok
14:09:03 <dougwig> any questions here?  else we'll move on.
14:09:40 <vjay7> so if someone downloads juno they cant get v2 at all?
14:10:21 <dougwig> no, it's not in juno at all.  if they download the git repo, then they'll have access to the remote branch if they know about it.
14:11:07 <sballe_> dougwig, we should make sure we send an email to the ML advertisign for it
14:11:23 <dougwig> sballe_: good idea
14:11:32 <dougwig> #action dougwig email ML about feature branch
14:12:15 <dougwig> ok, moving on
14:12:17 <dougwig> #topic Open Discussion
14:12:49 <dougwig> i've got one small item, which is that the meeting wiki is getting crazy long.  are there standards for trimming it, or will anyone be upset if we chop out a bunch of old meeting agendas?
14:13:02 <blogan> chop it
14:13:06 <xgerman> +1
14:13:17 * dougwig fuels his chainsaw.
14:13:28 <sballe_> dougwig, can we put the chopped pages into a seperate page? I like to keep the history
14:13:40 <dougwig> sballe_: sure
14:13:43 <sballe_> thanks
14:13:57 <blogan> good bedtime stories
14:14:01 <dougwig> any other items for open discussion?
14:14:03 <sballe_> I can do this later today
14:14:04 <sbalukoff> Cool.
14:14:11 <sballe_> the chopping ;-)
14:14:29 <blogan> any update on the keystone/barbican issue?
14:14:41 <dougwig> rm_work ?
14:14:51 <xgerman> I wrote back to him :-)
14:15:27 <sbalukoff> One thing I did want to point out: Sorry I had to duck out of the Octavia meeting yesterday. I know there was a lot of confusion around the launchpad blueprint stuff. I've written up my thoughts in an e-mail that I've sent to the openstack-dev list. I would love to get your feedback on that, once you've had time to actually read it. :)
14:15:59 <sballe_> sbalukoff, sounds good. I was going to ask about that :)]
14:16:38 <dougwig> is the subject, "my reign of tyranny continues..." ?
14:16:54 <sbalukoff> dougwig: Ooh, dang! I totally missed an opportunity there.
14:17:01 <sballe_> dougwig, lol
14:17:20 <blogan> it should be "my reign of book writing continues"
14:17:28 <dougwig> lol
14:17:52 <sbalukoff> Haha!
14:18:22 <johnsom> sbalukoff Thanks for the email.
14:18:42 <TrevorV> sbalukoff, #action learn to TLDR
14:19:03 <dougwig> i don't see rm_work responding.  so unless anyone has anything else for open discussion, we'll end early.  going once?
14:19:11 <TrevorV> rm_work, rm_you|wtf
14:19:18 <sbalukoff> TrevorV: Aren't you the one good at condensing stuff into digestible verbage?
14:19:30 <TrevorV> either of those is him, and the |wtf means his server is failing in some way
14:19:39 <TrevorV> sbalukoff, touche
14:20:00 <rm_work> I am here, sorry
14:20:02 <rm_work> bathroom
14:20:14 <vivek-ebay> who is rm_you|wtf ?
14:20:26 <TrevorV> vivek-ebay, rm_work's other account
14:20:36 <rm_work> dougwig: yeah, I need to read your response this morning
14:20:59 <dougwig> you mean xgerman's?  i don't recall sending one yet.  :)
14:21:05 <rm_work> oh
14:21:12 <rm_work> man, it's early
14:21:20 <rm_work> i read that as you
14:21:28 <TrevorV> rm_work, can't function before noon
14:21:34 <rm_work> yeah, I responded to xgerman, could use more people chiming in
14:21:52 <rm_work> pretty much, TrevorV  <_<
14:22:19 <xgerman> well, r_work can you ask with HOrizon in the tittle?
14:22:53 <TrevorV> rm_work, ^^
14:22:56 <rm_work> Yeah, I guess I can forward that -- my assumption was that we could do that, it would just be "is that ok"
14:23:05 <rm_work> because coming from the API, it's another action
14:23:14 <rm_work> no simple yes/no button
14:23:29 <xgerman> yeah, if it can be condensed in a heat template it would be ok, there, too
14:23:41 <xgerman> or the client deals with it
14:23:46 <rm_work> well, I don't know how Heat would do it
14:23:51 <sbalukoff> Is there really any viable alternative that's likely to be approved?
14:23:59 <rm_work> since Heat specifically can't create Trusts
14:24:08 <rm_work> sbalukoff: don't think so :/
14:24:18 <dougwig> so how would heat create LBs' with certs?
14:24:30 <sbalukoff> That's what I figured. Anyway, I'll chime in with that on the discussion.
14:24:38 <rm_work> really the point of this was to get everyone to read this and accept it now so I don't get a lot of complaints later :P
14:24:50 <sbalukoff> rm_work: Smart move!
14:25:01 <rm_work> dougwig: once the Trust is created a single time, it's good moving forward indefinitely
14:25:59 <dougwig> ahh, so it becomes an on boarding step for new users, before you can let heat do anything with it.
14:26:03 <rm_work> yes
14:26:29 <xgerman> that sounds fair
14:26:51 <dougwig> give me your name, email, address.  now credit card.  now click yes to these next 20 dialogs (lbaas, vpnaas, ...).  sweet, you're a cloud user, welcome!
14:26:57 <rm_work> ok cool. I'll investigate the actual Horizon integration to make sure Horizon CAN create a Trust somehow
14:27:19 <rm_work> and that the kind of dialog we're envisioning is kosher
14:27:52 <rm_work> and we just agree that if the user is coming in through the API directly, they'll have to figure out the Trust thing once :(
14:27:55 <rm_work> we'll give some hints
14:28:41 <dougwig> error message: "yo dawg, imma let you finish, but first you have to go create the best trust of all time."
14:28:47 <rm_work> lolol
14:28:54 <sbalukoff> hah
14:29:01 <rm_work> so true
14:29:43 <rm_work> so, that's it for me I think
14:29:52 <dougwig> ok, thanks for the update
14:29:59 <dougwig> anything else from folks?
14:30:33 <TrevorV> *crickets*
14:30:40 <dougwig> ok, ending early today....
14:30:44 <sbalukoff> Back to bed for me!
14:30:45 <sbalukoff> Yay!
14:30:47 <sballe_> bye
14:30:58 <TrevorV> o/
14:31:00 <rm_work> o/
14:31:03 <dougwig> #endmeeting