16:00:03 <dougwig> #startmeeting neutron lbaas
16:00:04 <openstack> Meeting started Tue Dec  2 16:00:03 2014 UTC and is due to finish in 60 minutes.  The chair is dougwig. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:07 <openstack> The meeting name has been set to 'neutron_lbaas'
16:00:11 <dougwig> #topic Roll call and Agenda and general waking up...
16:00:21 <johnsom> o/
16:00:22 <ajmiller> here
16:00:24 <xgerman> o/
16:00:24 <dougwig> agenda:
16:00:26 <dougwig> #link https://wiki.openstack.org/wiki/Network/LBaaS#Meeting_02.12.2014
16:00:34 <sbalukoff> Morning!
16:00:37 <rm_work> o/
16:00:42 <xgerman> anyhting form the Neutron meeting I tend to skip?
16:00:49 <blogan> \o/
16:00:53 <dougwig> yep, but that's later in the agenda.
16:01:01 <xgerman> suspensew
16:01:47 <evgenyf> Hi
16:01:52 <jamiem> o/
16:01:57 <dougwig> #topic Announcements
16:02:05 <dougwig> Review of the week:
16:02:07 <dougwig> #link https://review.openstack.org/#/c/123487/
16:02:17 <dougwig> that's the first half of the agent-less ref driver.  needs eyes.
16:02:26 <dougwig> any other announcements from anyone?
16:02:38 <blogan> needs to rerun the testst oo
16:02:40 <blogan> too
16:02:51 <dougwig> jenkins was unhappy last night
16:02:57 <blogan> is it recheck or recheck no bug?
16:03:01 <dougwig> recheck
16:03:01 <blogan> used to be recheck no bug
16:03:04 <xgerman> ajmiller discovered that one of the Neutron changes broke our migrations
16:03:06 <dougwig> they changed it
16:03:29 <dougwig> you can check status.openstack.org/zuul to see if it re-queues.
16:03:34 <dougwig> #topic Flavors
16:03:40 <dougwig> #link https://review.openstack.org/#/c/102723
16:03:53 <dougwig> the spec has been resurrected.  whether it is undead or reanimated remains to be seen.
16:04:05 <sballe> lol
16:04:07 <dougwig> spec approval deadline is 12/14, so please weigh in with feedback.
16:04:34 <dougwig> any flavors questions/comments/feedback now?
16:04:56 <blogan> need to refresh my memory
16:05:10 <xgerman> same here
16:05:12 <dougwig> ok, i'll ping again next week.
16:05:27 <dougwig> #topic Advanced services split discussion
16:05:32 <dougwig> #link https://review.openstack.org/#/c/136835/
16:05:37 <dougwig> Some discussion at the neutron meeting this morning, at timestamp 14:26:13
16:05:41 <dougwig> #link http://eavesdrop.openstack.org/meetings/networking/2014/networking.2014-12-02-14.01.log.html
16:06:10 <dougwig> current spec creates four teams (neutron, lbaas, fwaas, vpnaas), and current decision is to share the neutron database with separate tables/migration chains.
16:06:31 <dougwig> we need that spec to solidify this week if we're going to get it in early in the cycle.
16:06:45 <blogan> sounds ambitious given all the comments
16:07:03 <sbalukoff> Doug is doing a good job of addressing what he can in the comments.
16:07:12 <blogan> yes he is
16:07:27 <xgerman> +100
16:07:28 <sbalukoff> But yes, there are probably a few things that others in the group are simply not going to agree on.
16:07:29 <blogan> i think the extensions decision and the same db will speed up the acceptance though
16:07:43 <sbalukoff> I guess we'll see how willing people are to compromise.
16:08:11 <sbalukoff> Yeah, there are a lot of trade-offs which are being made in the interest in speeding up acceptance.
16:08:22 <dougwig> indeed.
16:08:47 <sbalukoff> Even if we can't come to terms on the governance issue, having a technical plan to get split repositories is a step in the right direction, IMO.
16:09:10 <xgerman> did governace get even discussed today?
16:09:26 <xgerman> I think we are doing a good job dancing around that :-)
16:09:29 <dougwig> governance is pretty simple, actually.  either we're in the networking program, and it's up to mestery, or we go to stackforge, with all that entails.  both are viable options.
16:09:42 <mestery> ++
16:09:48 <sbalukoff> Oh hey!
16:10:05 <sbalukoff> I won't call you the devil this time. ;)
16:10:22 <sbalukoff> (You know, speak of the devil...)
16:10:47 <sbalukoff> Sorry, it's early and my brain is trying hard to humor.
16:10:49 <dougwig> if we're insulting kyle, we say kyle, not mestery, so his irc client doesn't light up.
16:11:03 <mestery> lol
16:11:04 <dougwig> i think there's a gerrit spec about that somewhere.
16:11:12 <xgerman> lol
16:11:12 <sbalukoff> Ha!
16:11:32 <dougwig> alright, any split comments/feedback/questions?  meeting slots on this topic have been pretty quiet, which is either awesome or worrisome.
16:11:46 <xgerman> we just want it done -)
16:11:52 <sbalukoff> Actually, I feel like we're in a pretty good place with that spec...
16:11:56 <blogan> im just interested in getting progress done, path of least resistance at this point
16:11:57 <johnsom> +1 on done
16:11:58 <sbalukoff> Let's push hard for consensus.
16:12:49 <xgerman> I don't think there is much we can do except +1
16:13:10 <blogan> i can +1000
16:13:15 <dougwig> ok, then please leave some comments or whatnot on the gerrit spec, and let's get this rolling.  it'll get an update this morning for the decisions from today's neutron meeting.
16:13:25 <xgerman> +1000
16:13:30 <sballe> mestery: I would like to attend the neutron meetup remote. Anything around taht yet?
16:13:35 <dougwig> i'll post in channel when it's ready for action again.
16:13:56 <dougwig> sballe: he mentioned in the meeting this morning that he's working on it.  see the beginning of that chat log, in announcements.
16:13:58 <sbalukoff> sballe: +1
16:13:59 <mestery> sballe: We will have remote participation, the plan for people coding is to have an etherpad where people can pick items, and we'll be in-channel on #openstack-neutron
16:14:03 <mestery> I'll see about Hangouts as well
16:14:10 <mestery> Though that depends on what Adobe can offer there too :)
16:14:28 <blogan> they can't photoshop everyone in?
16:14:31 <dougwig> i can offer a webex if it helps.
16:14:31 <sballe> dougwig: I know I was there. I just wanted mestery to know that I am interested in attendign even thought I didn;t put my name onthe wiki
16:14:43 <rm_work> blogan: +1
16:14:47 <mestery> sballe: Got it
16:14:52 <mestery> blogan: lol
16:15:06 <dougwig> #topic Open discussion
16:15:09 <kobis> I wonder - if vendor code is pushed out of neutron, will the *aas repos include vendor code?
16:15:30 <blogan> kobis: it will icnlude the vendor drivers
16:15:32 <dougwig> kobis: that is mentioned in the spec.  yes, because we're still trying to grow community
16:15:35 <sbalukoff> kobis: Yes, according to the latest spec.
16:15:47 <sbalukoff> Heh!
16:15:48 <kobis> ok 10x
16:15:54 <xgerman> yep, we also said so at the summit
16:16:04 <dougwig> i would expect the long-term to look similar to neutron, though.
16:16:10 <xgerman> me, too
16:16:35 <dougwig> any other topics for today?
16:16:37 <blogan> yes
16:16:42 <blogan> neutron lbaas meetup
16:16:50 <dougwig> #topic neutron lbaas meetup
16:16:52 <dougwig> go
16:17:49 <dougwig> blogan?
16:17:56 <blogan> does everyone feel it is worth having it separate from an octavia meetup?  I'm sure we want octavia to focus on octavia, but just getting everyone's thoughts
16:18:11 <xgerman> no, we should combine
16:18:18 <xgerman> dougwig - time for #vote
16:18:30 <blogan> well we need to get everyone's thoughts on it first
16:18:46 <sbalukoff> What do we hope to accomplish at the neutron LBaaS meetup?
16:18:48 <sballe> if we combine will we have another face 2 face in January? LBaaS/Octavia?
16:18:48 <blogan> neutron lbaas this time aroudn will have a lot to do, especially with the split
16:18:58 <dougwig> i think there's quite a bit of v2 work left, and having folks in the same room, with enough cores to make a difference, would help a lot.
16:19:12 <sbalukoff> Ok.
16:19:14 <dougwig> plus, it needs to be later than december, to give the split time to settle
16:19:15 <sbalukoff> I agree
16:19:17 <blogan> i agree with that
16:19:33 <dougwig> IMO
16:19:34 <sbalukoff> I'm in favor having it separate
16:19:42 <sbalukoff> Given those requirements.
16:19:45 <blogan> however, i worry that having another meetup may cause a low attendance outcome
16:19:50 <sbalukoff> Or objectives, rather.
16:19:57 <xgerman> blogan +10
16:20:20 <sbalukoff> Well, we likely won't get a second Octavia face to face this cycle then.
16:20:23 <dougwig> i wouldn't object to an octavia/lbaas meetup in late january.  the holidays and the split is just making the december meetup tough.
16:20:25 <xgerman> also there is the advanced services meetup
16:20:25 <sballe> and markmcclain will be at the Octavia one. We could use him to do some +2 on LBaaS stuff
16:20:39 <sbalukoff> As long as people are OK with some folks working on Octavia stuff at the Neutron LBaaS meetup, I'm OK with that.
16:20:45 <dougwig> it'd need the full 5 days, and we'd want to schedule some of those days for lbaas only, and some for octavia only, IMO.
16:21:00 <blogan> xgerman: im not sure there will be one now, though I am not sure
16:21:12 <dougwig> sbalukoff: as long as octavia doesn't prevent v2 from making progress, they're the same teams.
16:21:20 <sbalukoff> True
16:21:21 <sballe> dougwig: +1
16:21:23 <xgerman> ok, with the family I am waty to be gone two weeks in January
16:21:39 <mestery> Folks: Any reason not to just have a single meetup for lbaas in december? Why are two needed?
16:21:44 * mestery goes back to lurking
16:21:44 <sbalukoff> Let's have our employers rent out a conference center for the whole month of January and meet there and work on both.
16:21:45 <sbalukoff> ;)
16:21:58 <sballe> sbalukoff: +1
16:22:00 <blogan> mestery: the main reason is there is a lot to do on both fronts
16:22:10 <sbalukoff> Yep.
16:22:13 <sballe> sbalukoff: thinks this is a good idea. not distractions or meetings
16:22:23 <dougwig> mestery: because the current december date is holidays for many (me!), and the split won't be done yet.
16:22:33 <mestery> Ah, got it dougwig and blogan. Just curious
16:22:34 <sbalukoff> sballe: Unfortunately totally impractical. ;)
16:22:51 <sballe> sbalukoff I know
16:22:55 <blogan> well rackspace can host this meeting if it is determined we want it
16:22:56 <dougwig> mestery: curiosity will be punished.
16:23:02 <markmcclain> I'm on the road nearly all of January… so I won't be able to attend either in person/remote
16:23:03 <mestery> lol
16:23:11 <sbalukoff> blogan; I'm pretty sure we want it.
16:23:18 <sbalukoff> Also, Texas is nice in January.
16:23:31 <xgerman> so is Seattle :-)
16:23:43 <xgerman> or Boise :-)
16:23:45 <sbalukoff> xgerman: In January?
16:23:48 <rm_work> seattle is cold and possibly snowy in January :P
16:23:49 <blogan> is it worth having without mestery and markmcclain there? if we can't get fast +2 eyes?
16:23:55 <sballe> how about Boston ;-)
16:23:57 <xgerman> yep, we can go to the slopes and ski
16:24:09 <mestery> blogan: By then LBaaS will be it's own repo with at least you and dougwig as +2 :)
16:24:09 <sbalukoff> Haha!
16:24:12 <rm_work> but if I need to stay in WA longer let me know so I can cancel my return flight :)
16:24:28 <sbalukoff> mestery: That's very optimistic of you. ;)
16:24:34 <xgerman> rm_work just move there and start RAX west
16:24:37 <blogan> mestery: good point, that totally escaped me
16:24:46 <mestery> lol
16:24:55 <rm_work> xgerman: RAX West is called the SFO office :)
16:25:17 <rm_work> … which would be awesome to work out of, I think
16:25:22 <blogan> okay so are we in agreement that we want one in January?
16:25:30 <dougwig> alright, where's consensus at on this point?  merged or separate?
16:25:31 <dougwig> ha, jinx
16:25:37 <xgerman> or shoudl we aim for later in case the plit gets dealyes...
16:25:47 <blogan> later would be nearing the end of kilo
16:26:06 <xgerman> but we could make the last big push
16:26:18 * dougwig would prefer some soak time.
16:26:51 <blogan> but if we have specs approved and mestery and markmcclain are okay with some exceptions to a late spec, then I'd be fine with later
16:26:53 <dougwig> i'd think the last push should be for making octavia 1.0 be the ref.  IMO.
16:27:11 <dougwig> which implies we need v2 solid earlier.
16:27:19 <blogan> yep
16:27:38 <rm_work> oh god, 1.0 by Kilo *and* made the ref for n-lb?
16:27:39 <rm_work> >_>
16:27:44 <dougwig> that might too ambitious.  :)
16:27:53 <dougwig> but you've gotta have goals.
16:28:00 <sbalukoff> Heh!
16:28:04 <blogan> couldn't 0.5 be the ref impl?
16:28:06 <rm_work> honestly not sure what I think of Octavia being the ref driver for n-lb still...
16:28:09 <blogan> adn then it gets upgraded to 1.0
16:28:10 <sbalukoff> Big Hairy Audacious Goals?
16:28:13 <dougwig> blogan: i thought 0.5 wasn't scalable?
16:28:20 <blogan> its not
16:28:29 <xgerman> depends on the hardware
16:28:38 <rm_work> I like the idea of the "reference" driver being something SIMPLE so it can be easily updated when the API changes
16:28:46 <dougwig> better or worse than the agent-ified haproxy namespace driver?
16:28:49 <sbalukoff> Also, Neutron LBaaS v1 reference is not scalable.
16:28:54 <rm_work> Octavia seems a bit complex (and out of tree)
16:29:05 <blogan> sbalukoff: it is
16:29:09 <dougwig> it's scalable with the agent on other machines.  just not pleasantly.
16:29:11 <xgerman> let's not get too far off topic
16:29:25 <rm_work> IMO leave the namespace driver as the ref <_<
16:29:29 <dougwig> thank you, back to topic.
16:29:38 <blogan> well thats antoehr discussion at a later time
16:29:43 <blogan> back to meetup
16:29:47 <dougwig> what's the vote syntax?
16:29:59 <blogan> #startvote
16:30:00 <openstack> Only the meeting chair may start a vote.
16:30:06 <xgerman> well, we should find out if the adv services meetup is happening
16:30:20 <rm_work> I mean, what are we voting on?
16:30:29 <sbalukoff> .#startvote question? Yes No Maybe
16:30:33 <rm_work> Just "Yes/No" to "have two meetings"?
16:30:35 <blogan> xgerman: im almost certain that was going to happen with adv svc was spinning out as one
16:30:40 <dougwig> i was just going to take the temperature of the room.
16:30:48 <rm_work> or something more specific
16:31:17 <dougwig> #startvote Are you ok with two meetups? Yes No Maybe
16:31:18 <xgerman> ok, and that was split related also -- so we will have two split related meetups in jan
16:31:18 <openstack> Begin voting on: Are you ok with two meetups? Valid vote options are Yes, No, Maybe.
16:31:19 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:31:24 <blogan> #vote Yes
16:31:25 <sbalukoff> #vote Yes
16:31:29 <rm_work> i am a LITTLE worried about making everyone travel so often
16:31:35 <dougwig> auto-correct changed meetups to metopes.  that is some high end dictionary action.
16:31:38 <xgerman> #vote Maybe
16:31:44 <dougwig> #vote yes
16:31:44 <johnsom> #vote Maybe
16:31:45 <sballe> #vote yes
16:31:49 <TrevorV> #vote maybe
16:31:54 <rm_work> #vote Maybe
16:32:06 <blogan> switzerland
16:32:12 <ptoohill> #vote maybe
16:32:22 <dougwig> good heavens, commit people.  :)
16:32:26 <dougwig> #endvote
16:32:26 <rm_work> "If I don't make it, tell my wife I said -- Hello."
16:32:27 <openstack> Voted on "Are you ok with two meetups?" Results are
16:32:28 <openstack> Maybe (5): xgerman, rm_work, ptoohill, johnsom, TrevorV
16:32:29 <openstack> Yes (4): dougwig, sballe, sbalukoff, blogan
16:33:08 <dougwig> blogan: this is your topic.  did you get what you needed?
16:33:20 <blogan> well if that vote is a binding contract
16:33:24 <sbalukoff> rm_work: Those who don't want to / can't travel can always attend remotely.
16:33:28 <blogan> which i dont think it is
16:33:33 <dougwig> it is not
16:33:37 <rm_work> https://www.youtube.com/watch?v=ussCHoQttyQ  https://www.youtube.com/watch?v=fpaQpyU_QiM
16:33:40 <ptoohill> i guess if its here im fine with it. anywhere else we cant go. and on that note im interested how the remote aspect for the upcoming meetup is going to work
16:33:43 <blogan> so if we had it in January
16:33:58 <blogan> does the week of the 19th work for people?
16:34:03 <sbalukoff> I'm OK with having it in Texas.
16:34:13 <sbalukoff> blogan: AFAIK, yes.
16:34:27 <sballe> sballe is checking her calendar
16:35:01 <sballe> Can we have it in Austin if it is Texas?
16:35:21 <ptoohill> I would love to have it in Austin
16:35:27 <rm_work> heh, yeah, me too
16:35:31 <dougwig> sballe: is HP volunteering space in Austin?
16:35:40 <johnsom> I think I would only be able to make the first three days the week of the 19th
16:35:46 <rm_work> though we'd have to start later so we have time to take the shuttle in the morning from SA :P
16:35:47 <xgerman> we have space everywhere :-)
16:35:55 <ptoohill> EVERYWHERE
16:36:01 <jorgem> rm_work: or we could carpool together :)
16:36:04 <sballe> I know RAX has space in Auston too. But HP we have space too
16:36:05 <blogan> can it be a week long replay of the hp paris party?
16:36:07 <dougwig> monday the 19th is MLK day, fyi.
16:36:07 <TrevorV> I'm not gonna lie, I'm probably not going to travel to Austin daily for that.
16:36:12 <rm_work> jorgem: gah
16:36:21 <sbalukoff> Oh...
16:36:30 <sbalukoff> Yeah, let's avoid the week of the 19th then.
16:36:33 <dougwig> meetup proposal is 20-22, i think.
16:36:43 <blogan> well what about just start on Tuesday the 20th
16:36:51 <xgerman> I think that week is anyway pretty close to the other meetup
16:36:52 <ptoohill> I would do anything to get out of SA daily
16:37:06 <sbalukoff> Have it be a 3-day thing?
16:37:10 <xgerman> blogan then you only get 4 days
16:37:10 <sbalukoff> That works.
16:37:16 <sbalukoff> I can't attend the 23rd either.
16:37:49 <xgerman> so 36-39 would be better for sbalukoff
16:37:54 <blogan> most meetups are only 3 days anyway, so people dont ahve to travel on weekends
16:37:55 <xgerman> 23-29
16:37:56 <sbalukoff> xgerman: Which other meetup?
16:38:03 <xgerman> adv services
16:38:06 <sbalukoff> Aah.
16:38:10 <blogan> xgerman: i dont think they're having one
16:38:26 <xgerman> I thought you said they would
16:38:37 <blogan> when we were going to split out as one yes, but now we're not
16:38:52 <sbalukoff> If the split entails 4 different repositories, the need for an advanced services meetup starts to make less sense.
16:38:53 <sballe> I am not available 26-30 I will be in Sunnyvale and Seattle
16:38:58 <ptoohill> that message should be talked about a bit louder
16:39:18 <blogan> sbalukoff: indeed
16:39:54 <blogan> if the toher advanced services want to have a meetup, then they may choose that
16:39:55 <dougwig> let's go for some closure here.   if we don't have consensus on good timing/location here, let's fire up an etherpad.
16:40:06 <xgerman> dougwig +1
16:40:12 <sbalukoff> dougwig +1
16:40:13 <sballe> =1
16:40:16 <sballe> +1
16:40:54 <blogan> ill fire one up
16:41:04 <dougwig> #action blogan setup lbaas meetup etherpad
16:41:13 <dougwig> thank you
16:41:14 <dougwig> #topic Open discussion
16:41:18 <sbalukoff> Sweet.
16:41:19 <dougwig> other topics?
16:41:22 <xgerman> sure
16:41:41 <xgerman> just a PSA we founbd that one of the lastest Neutron topics breaks our feature branch
16:41:59 <blogan> do we need to fix a merge conflict?
16:42:07 <blogan> or is it a functional break?
16:42:07 <ajmiller> There is a problem when upgrading the neutron database.
16:42:18 <ajmiller> I am working on suggesting a patch.
16:42:34 <dougwig> do we just need another merge from master?
16:42:44 <blogan> what is the break?
16:42:45 <dougwig> if so, mestery needs to submit it.
16:43:12 <ajmiller> Merge from master would probably fix it.  There has been a database upgrade on master, and that breaks the neutron upgrade.
16:43:41 <blogan> is it just bc another db migration came in?
16:43:46 <xgerman> yep
16:43:47 <ajmiller> blogan yes
16:44:09 <blogan> oh okay well thats expected, if its just an alembic sequence issue
16:44:17 <ajmiller> yes
16:44:19 <blogan> im not sure if thats something we always want to merge master for
16:44:21 <dougwig> ok, i'll ask for another merge.  i found out the hard way last time that only someone in the neutron release group can submit the patch.
16:44:48 <sbalukoff> Eew.
16:44:49 <blogan> if we merge master for every new migration, thats a lot of contacting neutron release group to merge
16:45:04 <xgerman> well, once the split happends
16:45:08 <sbalukoff> ...
16:45:09 <dougwig> is the feature branch broken, or just swapping between feature and master on the same install?
16:45:14 <sbalukoff> There is that.
16:45:22 <dougwig> because if it's the latter, i agree with blogan.  wipe and reset
16:45:24 <blogan> yeah so why dont we wait until the split is ready, then do one merge
16:45:40 <rm_work> +1
16:46:26 <xgerman> But inquisitive minds want to try out LbaaS v2
16:46:30 <xgerman> ...
16:46:31 <blogan> the feature branch should still work on its own
16:47:14 <blogan> hopefully inquisitive minds can do a git checkout feature/lbaasv2 and restart?
16:47:25 <blogan> unless they need some features that are in master as well
16:47:45 <dougwig> xgerman: use neutron-db-manage to rollback to feature back alembic and then go forward.
16:47:51 <dougwig> /back/branch
16:47:58 <dougwig> i can add instructions for that to the devstack wiki
16:48:00 <blogan> oh yeah that too
16:48:04 <blogan> lol
16:48:15 <xgerman> well, so we decided to not track master with our feature branch?
16:48:27 <xgerman> Just making sure we are on the same page
16:48:46 <blogan> xgerman: i think waiting until the split to do one final merge is the best option
16:48:49 <xgerman> I am ok with that -- I just like it spelled out
16:49:11 <dougwig> when the branch was created, folks wanted to minimize the number of master merges.  if there's something broken between them (which happened with jenkins jobs once), we merge.  if it's just diverging migrations, we'll reset the chain for the final merge.
16:49:31 <dougwig> that was our earlier plan, at least.
16:50:34 <dougwig> any other issues there, or any other topics for today?
16:50:45 <xgerman> I am good --
16:51:14 <dougwig> alright, thanks folks, and goodbye
16:51:21 <xgerman> o/
16:51:22 <blogan> adios
16:51:25 <ajmiller> bye
16:51:29 <TrevorV> o/
16:51:34 <dougwig> #endmeeting