16:00:02 <dougwig> #startmeeting neutron lbaas
16:00:03 <openstack> Meeting started Tue Jan 13 16:00:02 2015 UTC and is due to finish in 60 minutes.  The chair is dougwig. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:06 <dougwig> #chair blogan
16:00:07 <openstack> The meeting name has been set to 'neutron_lbaas'
16:00:08 <openstack> Current chairs: blogan dougwig
16:00:11 <dougwig> #topic roll call and agenda
16:00:14 <johnsom> o/
16:00:16 <dougwig> #link https://wiki.openstack.org/wiki/Network/LBaaS
16:00:18 <dougwig> hi folks
16:00:23 <dougwig> wake up wake up!
16:00:24 <blogan> here!
16:00:49 <ajmiller> good morning
16:01:06 <dougwig> #topic Announcements
16:01:07 <xgerman> o/
16:01:28 <dougwig> Kilo-2 ends February 5, so we really need to get at least the first big part of lbaasv2 in by then (more on that in a minute.)
16:01:31 <dougwig> Any other announcements?
16:01:38 <rm_work> po/
16:01:42 <rm_work> err, o/
16:01:56 <dougwig> we translated morning adam.
16:02:06 <dougwig> ok, moving on to the fun part.
16:02:12 <a2hill> 0/
16:02:18 <dougwig> #topic Mid-cycle meetup details
16:02:24 <dougwig> #link https://etherpad.openstack.org/p/lbaas-kilo-meetup
16:02:42 <dougwig> we have tried to list discrete tasks that need completing this mid-cycle.
16:03:08 <dougwig> please update your attendance info and signup for items.  lbaas v2, tis, l7, cli, and tempest are things that we really need in order to be able to ship this thing in Kilo.
16:03:22 <dougwig> also add any items that you know of.
16:03:50 <dougwig> please take a moment to look at it/edit it now, and let's circle back with questions or comments.
16:04:24 <xgerman> also make sure to add your name to the color
16:04:58 <rm_work> ack my color is sbalukoff's color :/
16:05:12 <dougwig> i think i have three colors on that etherpad now.
16:05:17 * TrevorV missed the link
16:05:35 <johnsom> #link https://etherpad.openstack.org/p/lbaas-kilo-meetup
16:05:37 <dougwig> #link https://etherpad.openstack.org/p/lbaas-kilo-meetup
16:06:13 <TrevorV> thanks guys
16:07:23 <xgerman> also I assume we will have a remote option...
16:07:59 <blogan> yes, but not for you
16:08:16 <sballe> morning
16:08:25 <blogan> im sure we can set up something similar to what we did in seattle
16:08:25 <xgerman> I figured that I need to send johnsom and ajmiller with spy tech ;-)
16:08:39 <rm_work> yeah, hopefully should have something up
16:08:42 <dougwig> send spy tech for everyone.
16:08:45 <sbalukoff> Morning, folks!
16:08:48 <sballe> blogan: that would be great! I cannot travel that week either
16:08:59 <rm_work> I can bring my camera and TrevorV can bring his studio mic setup :P
16:09:00 <dougwig> morning.  for the newcomers, we're reviewing/editing this: https://etherpad.openstack.org/p/lbaas-kilo-meetup
16:09:08 <dougwig> please update your attendance info and signup for items.  lbaas v2, tis, l7, cli, and tempest are things that we really need in order to be able to ship this thing in Kilo.
16:09:17 <TrevorV> rm_work don't volunteer my stream equipment... crazy head
16:09:24 <rm_work> TrevorV: too late just did :P
16:10:11 <xgerman> awesome!!
16:10:15 <blogan> agent is a really needed one, and pretty fun
16:11:01 <dougwig> yeah, the top ones that need owners: agent driver and CLI/client.
16:11:15 <dougwig> i'd like to see those merged by the end of the mid-cycle.
16:11:43 <rm_work> did ctracey get pulled off the client stuff from BBG?
16:11:49 <dougwig> yes.
16:11:54 <dougwig> he got busy with other things.
16:11:55 <rm_work> :(
16:12:00 <xgerman> ctracyes's stuff actually works - we played with it extensively
16:12:01 <blogan> his code is still up there somewhere
16:12:07 <rm_work> k
16:12:08 <dougwig> rohara is working on the octavia client. i'm not sure if he's also planning on neutron lbaas, but he's not on the attendance list.
16:12:21 <blogan> yeah i havent seen him around lately
16:12:25 <rm_work> is rohara HP?
16:12:28 <xgerman> we might be able to reach out and get him remotely
16:12:29 <blogan> red hat
16:12:29 <dougwig> client person can decide whether to go straight to openstack-client.  it would sidestep the debates that sidelined ctracey
16:12:31 <rm_work> ah right
16:13:06 <rm_work> is openstack-client further along now?
16:13:36 <blogan> devstack is using it
16:13:38 <blogan> i believe
16:13:41 <rm_work> hmm
16:13:56 <dougwig> figuring out whether we use that or not is the first task in getting the client done. :)
16:14:14 <xgerman> maybe we can figure that out beforehand ;-)
16:14:27 <blogan> xgerman: are you volunteering for the client portion?
16:14:29 <blogan> :)
16:15:10 <dougwig> we will have three cores handy (myself and brandon local, mestery remote), so i'm hoping for some fast iteration.
16:15:13 <johnsom> I will work on the client if rohara isn't
16:15:18 <xgerman> I just think we can make the decision openstack vs/. newutron before the hackathon
16:15:36 <blogan> oh im sure we can
16:15:37 <dougwig> johnsom: great, can you note that on the etherpad?
16:15:51 <dougwig> let's have the client as a topic next week.
16:16:00 <xgerman> +1
16:16:02 <dougwig> unless someone has enough info to advocate today.
16:16:07 <johnsom> I thought we had some guidance that openstack client was the way of the future and we should head in that direction
16:16:36 <dougwig> i believe that guidance was from the openstack-client people. :)
16:16:52 <dougwig> my real question is, which one is most accessible to our users in the Kilo timeframe.
16:17:17 <blogan> i vaguely remember rohara saying writing for openstack-client was much easier than neutronclient
16:17:32 <rm_work> woo
16:17:39 <johnsom> I will dig around a bit and see what is going on with the openstack-client
16:17:40 <dougwig> otoh, we have code for the neutronclient
16:17:50 <blogan> very true
16:17:54 <xgerman> yep, which actually works quite well
16:17:54 <dougwig> ok, johnsom is on that one.
16:18:01 <sballe> would it make sense that johnsom write down the pros and cons and we decide at the next meeting?
16:18:03 <blogan> which will need a few modifications
16:18:10 <xgerman> sballe +1
16:18:34 <dougwig> #action johnsom research neutron client vs openstack client
16:18:39 <dougwig> any other comments/questions/other we need for logistics about the mid-cycle?
16:18:56 <SantoshNetScaler> Hi All , I am new neutron lbaas. I am curious to know if we can use   mentioned neutron-lbass from git to devstack setup ?
16:19:17 <dougwig> SantoshNetScaler: hi, and welcome. can you ask that in open discussion in a  few minutes?
16:19:30 <SantoshNetScaler> Sure
16:20:32 <dougwig> ok, we'll be bugging people to be owners/working with owners more this week, to try and get lbaas v2 ready for coding on the first day of the sprint.
16:20:34 <dougwig> moving on
16:20:41 <dougwig> #topic Open Discussion
16:20:58 <rm_work> if anyone has *zero* budget like I usually do -- I have a guest room. just FYI :P
16:21:02 <dougwig> SantoshNetScaler: neutron-lbaas is used automatically if you specify q-lbaas in your conf file.
16:21:08 <rm_work> … also a super long-hair cat
16:22:48 <blogan> btw this is what I believe is the final draft of the "improved" neutron lbaas v2 API
16:22:50 <blogan> #link https://review.openstack.org/#/c/144833/
16:23:29 <rm_work> WIP?
16:23:33 <blogan> just the extension, but if you can read the RESOURCE_ATTRIBUTE_MAP (which is a task in itself) you can see it
16:23:47 <xgerman> did we ever settle the status question?
16:24:09 <blogan> WIP bc there is the possibility of change, like the statuses
16:24:23 <blogan> and the plugin code in neutron-lbaas is still a WIP
16:25:03 <blogan> xgerman: I believe we loosely decided that we would just add operating and provisioning statuses
16:25:09 <blogan> but thats not in the extension yet
16:25:22 <xgerman> so I guess we should talk that through bext weekm too
16:25:31 <xgerman> so we cna hit the ground running at the Hackathon
16:25:36 <blogan> agreed
16:25:41 <blogan> or we can talk about it nwo
16:25:43 <blogan> now
16:25:58 <dougwig> #topic Object status
16:26:03 <dougwig> it's magic.
16:26:11 <xgerman> the status?
16:26:20 <dougwig> no, the meeting room can hear us.
16:26:31 <sbalukoff> Heh!
16:26:39 <xgerman> I have trouble channeling my inner Radware and they had the most issues with status
16:26:57 <blogan> so statuses to be like what octavia already has?
16:27:12 <blogan> which woudl lead into another question
16:27:31 <blogan> how much do we care about migrating v1 to v2
16:27:46 <xgerman> I wouldn't care at all
16:27:49 <blogan> lol
16:27:55 <dougwig> i don't, but i also don't want to be in a nova-network scenario.
16:28:20 <xgerman> we never met the unicorn which was running LBaaS V1
16:28:27 <blogan> this would be 1% of nova-networks user base probably
16:28:37 <dougwig> we should ask the upgrade question in the next neutron meeting.
16:28:49 <blogan> good idea
16:28:53 <xgerman> +1
16:28:55 <sballe> dougwig: +1
16:28:57 <blogan> thats the monday afternoon one
16:29:04 <blogan> and before the next lbaas meeting
16:29:33 <dougwig> #action dougwig put lbaasv1 upgrade question on neutron on-demand agenda for next week
16:29:35 <sbalukoff> I think we would all like to avoid the v1->v2 upgrade.
16:29:40 <blogan> in the meantime, do we just want to shoot for the statuses with what we have in octavia?
16:29:45 <sballe> sbalukoff: +1
16:29:53 <dougwig> is that oper/prov separate fields?
16:30:04 <blogan> yeah but prov only on lb and listener
16:30:04 <sbalukoff> er... migration
16:30:26 <xgerman> sounds good - as I said Radware ahd the most trouble with that
16:30:31 <sballe> sbalukoff: I knew what you meant ;-)
16:30:36 <dougwig> blogan: odd, i'd think prov would be on everything and oper would be less.
16:31:14 <rm_work> doesn't look like we have anyone from radware today? don't see samuel
16:31:20 <blogan> dougwig: well if you change a child of lb or listener, the lb and/or listener's prov status gets put into PENDING_*
16:31:42 <dougwig> err, provisioning is the one that doesn't change based on the tree.
16:31:53 <dougwig> or, i guess that'd be driver specific.
16:32:26 <dougwig> let's take this one offline/into channel and circle back next week?
16:32:32 <blogan> sounds good
16:32:41 <dougwig> #topic Open Discussion
16:32:46 <dougwig> anything else today?
16:33:07 <SantoshNetScaler> I have enable neutron service with devstack setup. I want to use neutron-lbaas v2 API
16:33:40 <blogan> SantoshNetScaler: did you enable q-lbaas in devstack conf?
16:33:48 <SantoshNetScaler> yes
16:34:11 <xgerman> isn't v2 still in reviews and you would need to get it straight from git
16:34:16 <xgerman> ?
16:34:22 <blogan> SantoshNetScaler, then you'll have to make a few changes in the neutron.conf and restart neutron-server
16:34:32 <dougwig> xgerman: the core api is in. if you want to run it all the way, you need a review.
16:34:47 <blogan> SantoshNetScaler: the only driver available for it now though is the noopdriver
16:34:48 <xgerman> thanks
16:34:49 <dougwig> if you just want to hit the api with your own driver, what's in the repo will suffice.
16:34:57 <xgerman> cool
16:35:22 <dougwig> SantoshNetScaler: join us in #openstack-lbaas if you have questions outside of meeting time.
16:35:51 <dougwig> anything else for today?
16:36:21 <dougwig> alright, let's blast out of here.  thanks, folks.
16:36:25 <sballe> bye
16:36:33 <a2hill> 3,2,1
16:36:37 <blogan> #endmeeting