15:59:51 <dougwig> #startmeeting neutron lbaas
15:59:51 <openstack> Meeting started Tue Mar  3 15:59:51 2015 UTC and is due to finish in 60 minutes.  The chair is dougwig. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:56 <sballe__> o/
15:59:56 <openstack> The meeting name has been set to 'neutron_lbaas'
16:00:01 <Aish> o/
16:00:02 <dougwig> #topic roll call
16:00:05 <TrevorV> o/
16:00:06 <johnsom> o/
16:00:06 <ajmiller> o/
16:00:07 <sballe__> o/
16:00:08 <madhu> 0/
16:00:14 <blogan> present
16:00:14 <barclaac> O/
16:00:33 <xgerman> o/
16:01:04 <bharath> o/
16:01:30 <dougwig> i'm behind, so i didn't type up an agenda, but it's similar to last week.
16:01:33 <jamiem> o/
16:01:35 <dougwig> #topic Announcements
16:01:40 <dougwig> copied from the neutron meeting:
16:01:43 <dougwig> 21:01:47 <mestery> #info Feature Proposal Freeze: March 5
16:01:43 <dougwig> 21:01:55 <mestery> #info Feature, String, and Dependency Freeze: March 19
16:01:43 <dougwig> 21:01:58 <mestery> #info RCs: April 9-23
16:01:43 <dougwig> 21:02:02 <mestery> #info Kilo release: April 30
16:01:53 <blogan> i think one has been created
16:02:02 <dougwig> to put this another way, anything not submitted by thursday *will not be in kilo*.
16:02:25 <blogan> what if it is a 1 line placeholder for an eventual 1000 line patch?
16:02:30 <dougwig> oh, nice.  agenda:
16:02:30 <dougwig> https://wiki.openstack.org/wiki/Network/LBaaS
16:02:58 <dougwig> blogan: i'm sure we'll sneak that in.  but if you have a new driver, or feature, thursday is it.  and gate merges start getting iffy from here on out.
16:03:17 <blogan> yep
16:03:29 <rm_work> o/
16:03:46 <dougwig> #topic v2 update, Docs and Tests
16:03:59 <ptoohill> o/
16:04:02 <dougwig> the agent driver got approved yesterday, and we'll be reviewing the tests and TLS hard today.
16:04:07 <dougwig> anyone blocked or need help on anything?
16:04:27 <ajmiller> I am trying to get the agent driver running, not having 100% success.
16:04:31 <madhu> I need help with testing
16:04:40 <evgenyf> Hi, I have a question about CI
16:04:47 <TrevorV> Not sure if fnaval is here, but I think we got the neutron lbaas v1 scenario test running for v2 (configuration issues out the booty) so we might be able to have that ready for review soon :D
16:05:01 <Aish> And dougwig I have few questions on tox.
16:05:04 <madhu> synced with fnaval, but could not get the enough time to sync u
16:05:07 <madhu> up*
16:05:20 <dougwig> ok, let's do these one at a time.  ajmiller, what's your issue?
16:06:01 <ajmiller> I set things up in devstack, and things look OK but when I try to create a load balancer it says there aren't any appropriate agents
16:06:14 <blogan> do you have the lbaasv2 agent running?
16:06:45 <ajmiller> It may be better to save this for after the meeting and discuss with smaller group.  I'm running the https://review.openstack.org/#/c/158189/ patch
16:07:06 <ajmiller> with the devstack mods I posted last night.
16:07:07 <dougwig> ok, let's move that one in channel afterwards.
16:07:09 <blogan> okay ptoohill or I can help you out with it
16:07:15 <dougwig> madhu: what's up?
16:07:17 <ajmiller> Yes, sounds good.
16:07:55 <madhu> i ran the lbaas v agent with this patch https://review.openstack.org/#/c/158189/, and the tests are not hitting well, but its working for fnaval. Looks strange though
16:08:37 <fnaval> madhu the errors that you pasted looks like you're not pointing to the right neutron_lbaas
16:08:45 <fnaval> it looks like it's using the old neutron_lbaas 1.0
16:09:01 <ptoohill> yea, there may be just some config issues here
16:09:12 <blogan> once the devstack plugin gets setup with the agent, this will become much easier
16:09:14 <ptoohill> maybe the new devstack mods help here?
16:09:25 <ptoohill> ok, yea, thats not ready then :)
16:09:39 <blogan> well thats what ajmiller needs help with
16:10:07 <madhu> okay fnaval and ptoohill, how about having sometime to discuss this oftnoon
16:10:18 <Aish> So yday, dougwig said that tox -e functional, tox -e api, tox -e tempest, in neutron, are examples of them putting tempest style tests in-tree, and setting up the right scripting/environment for it to work.  Neutron support is required
16:10:32 <dougwig> evgenyf: what's up?
16:10:42 <evgenyf> Tempest does not test v2 currently so CI should just keep testing v1?
16:10:55 <blogan> madhu: try to be in the same discussion we'll be having with ajmiller, i bet that'll solve your issues too
16:11:22 <madhu> sure blogan, looking forward to it
16:12:04 <Aish> But when i ran tox -e api against neutron, it throws error saying that Neutron support is required..
16:12:31 <Aish> dougwig: is it working in your env..?
16:12:32 <dougwig> evgenyf: since we're late on that, a vendor CI that hits v1, or just loads and tests the api tests with the noop driver, will be enough to continue with reviews.
16:13:14 <xgerman> well, this is a neutron problem so we should take it up with them
16:13:25 <dougwig> Aish: those tests require linux and installed devstack, unless you're doing them via devstack-gate.  they don't pre-setup their entire environment like the units.
16:13:29 <evgenyf> dougwig: Will keep v1 CI listening to neutron-lbaas
16:14:22 <xgerman> dougwig - we had both running but there still was a configuration problem but I don't think w eneed to solve that problem to get ahead with neutron-lbaas
16:14:29 <dougwig> Aish: let's take this offline, can you pastebin me your output/logs ?
16:14:36 <dougwig> xgerman: ok
16:14:44 <Aish> dougwig: ok.. I will do that
16:14:57 <evgenyf> dougwig: Should CI be registered somehow bc it's moving from neutron to neutron-lbaas?
16:15:12 <dougwig> #action dougwig submit non-voting job for v2 tempest tests, to provide a simpler environment for Aish's testing
16:15:39 <dougwig> evgenyf: your vendor CI?  if you use zuul, it's just a layout edit.  you don't need to do anything official.
16:16:01 <evgenyf> dougwig: OK
16:16:03 <dougwig> did i miss anyone's questions/issues, or have we talked about and/or punted all until after?
16:16:17 <ajmiller> I have another issue
16:16:31 <dougwig> fyi, grenade is busted because of an lbaas change. all grenade, so rechecks won't help right now.  blogan is working on it.
16:16:34 <dougwig> ajmiller: shoot
16:16:37 <ptoohill> ><
16:16:48 <ajmiller> dougwig that was my issue.
16:17:06 <dougwig> ajmiller: my red bull is working today, if i can answer before you ask.
16:18:04 <fnaval> dougwig: thanks for the grenade update; was wondering why it wasn't passing
16:18:07 <dougwig> #topic "Make subnet_id for lbaas v2 member create optional"?
16:18:15 <dougwig> who's item is this?  you have the floor.
16:18:29 <xgerman> mine
16:18:55 <xgerman> we had this patch/bug and never decided if this is a good idea + if it should be done for Kilo
16:19:29 <johnsom> We would need to update the client, api docs, and client docs for this change.
16:19:34 <xgerman> in order to get it in we need changes in docs + CLI so I am just wondering if we should punt it o liberty or decide it;s important enough to move it in
16:19:35 <evgenyf> xgerman: what is the reason behind?
16:19:53 <xgerman> well, it's not my patch I am just opposed to have it in Kilo
16:20:16 <xgerman> (for schedulingreasons)
16:20:44 <blogan> i put the bug in, i thought it was something we had agreed on, plus i think its just better on the end user to not have the subnet_id required on the member
16:21:10 <blogan> but if we keep it required now and make it optional later, that doesn't break backwards compatibility
16:21:25 <ajmiller> The patch xgerman is referring to is https://review.openstack.org/#/c/160460/
16:21:36 <evgenyf> blogan, so subnet will be taken from lb?
16:21:59 <xgerman> yeah, as I said my main worry is that we won't get evryhting done for kilo
16:22:13 <dougwig> isn't subnet something you can just lookup from the member, if it's a nova vm?
16:22:23 <blogan> evgenyf: essentially it just means the user expects that member ip doesn't need anything extra set up
16:22:35 <blogan> if the member is a nova vm, but thats not always the case
16:23:39 <dougwig> anyone feel strongly, or can we punt this?
16:24:46 <dougwig> the sound of deafening silence sounds like punting to me.
16:24:49 <blogan> punt it
16:24:52 <xgerman> +1
16:24:52 <dougwig> #topic Open discussion
16:25:10 <ajmiller> Any ETA on the grenade fix?
16:25:10 <dougwig> feel free to discuss the test questions here, or we can close this meeting and switch to channel.
16:25:16 <Santosh_NS> Is there any wiki/notes for CI setup for devstack,neutron-lbaas
16:26:39 <dougwig> Santosh_NS: if you want to use vanilla devstack-gate/jenkins/zuul, my entire config is here: https://github.com/a10networks/neutron-thirdparty-ci
16:27:39 <fnaval> Santosh_NS: this should work also: https://wiki.openstack.org/wiki/Neutron/LBaaS/DeployWithDevstack
16:27:59 <fnaval> however, you'll still need to configure it for 2.0
16:28:57 <dougwig> on a different note, the vpnaas team meeting is merging into the neutron on-demand meeting. that's one input for our "which way to merge" discussion.
16:29:18 <Santosh_NS> I am concerned for neutron-lbaas v2 api  tests
16:29:42 <xgerman> dougwig: Q about https://review.openstack.org/153079
16:29:52 <xgerman> should we move the docs into our tree?
16:30:07 <pc_m> dougwig: Yeah, my email to ML didn't go out, so I'm resending, to let team decide, but pretty sure we'll go to on-demand.
16:30:26 <pc_m> dougwig: Only 1-2 people at meetings
16:30:39 <dougwig> xgerman: i'm a fan of anything that can go in-tree, does.
16:30:48 <xgerman> me, too
16:30:59 <xgerman> just checking if you heard about that somewhere else
16:31:28 <dougwig> if not, let's push the envelope.  :)
16:31:42 <xgerman> ok, I will advise Aish to do that ;-)
16:32:15 <dougwig> ok, let's close this meeting and move the test related questions to channel.  expect blogan to be scarce until the grenade issue is sorted.
16:32:45 <dougwig> #endmeeting