16:00:23 <dougwig> #startmeeting neutron lbaas
16:00:24 <openstack> Meeting started Tue Mar 10 16:00:23 2015 UTC and is due to finish in 60 minutes.  The chair is dougwig. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:26 <zhhuabj> bye
16:00:27 <xgerman_> o/
16:00:28 <openstack> The meeting name has been set to 'neutron_lbaas'
16:00:29 <dougwig> #topic roll call
16:00:30 <johnsom> o/
16:00:31 <dougwig> o/
16:00:33 <xgerman_> o/
16:00:35 <madhu_> o/
16:00:42 <evgenyf> o/
16:00:42 <jwarendt> o/
16:02:16 <dougwig> agenda today:
16:02:16 <dougwig> https://wiki.openstack.org/wiki/Network/LBaaS
16:02:27 <dougwig> #topic Announcements
16:02:33 <ptoohill> o/
16:02:45 <dougwig> feature freeze is 3/19.  given gate crush, the realistic last day for approval will be the 16th or 17th.
16:03:40 <dougwig> any other announcements?
16:04:02 <dougwig> #topic v2 update, Docs, Tests, and Vendor Drivers
16:04:19 <evgenyf> dougwig: what about tempest tests for LBaaS v2.0? Isn't it blocker for LBaaS v2.0 to enter kilo?
16:04:22 <dougwig> I've seen lots of activity on the testing front, and our experimental jenkins job merged (you can see one in the queue now.)
16:04:42 <dougwig> evgenyf: as soon as the experimental job passes, it'll be promoted to a voting gate job.
16:05:17 <ptoohill> evgenyf, i have some changes we need to make to the tls ext, maybe we can speak more about it after this
16:05:20 <dougwig> evgenyf: it should be in a state that's clonable for vendor CI's by the end of the week.
16:05:54 <evgenyf> ptoohill: sure
16:06:22 <blogan> im sucha  moron
16:06:33 <blogan> sorry ive been at my computer and forgot this was going on
16:06:48 <ptoohill> and in comes the blogan
16:07:00 <evgenyf> dougwig: you mean tempest tests?
16:07:10 <dougwig> evgenyf: yes
16:07:25 <dougwig> evgenyf: https://review.openstack.org/#/c/161432/
16:07:41 <blogan> tempest tests, other than scenario tests, should just work now, through tox
16:07:45 <evgenyf> experimental8 hour history of changes in pipeline (3)
16:08:04 <dougwig> yeah, it has to run behind the check queue, i think.
16:09:05 <dougwig> i'm planning on reviewing vendor drivers this week (tomorrow), in advance of the CI stuff being ready.
16:09:11 <dougwig> xgerman_: do we have a docs update?
16:09:34 <evgenyf> experimental8 hour history of changes in pipeline (3)
16:09:47 <xgerman_> yes, Aish docs are in purgatory (see extra agenda item) - rest merged
16:09:51 <evgenyf> dougwig: can I catch you for 5 mins after the meating for some technical questions?
16:09:59 <dougwig> evgenyf: yes
16:10:13 <dougwig> great.
16:10:35 <dougwig> anything else we need to co-ordinate here?  i know the test team is meeting separately and making great progress.
16:10:42 <xgerman_> +1000
16:10:49 <xgerman_> great progress
16:10:55 <dougwig> ok, moving on
16:10:59 <dougwig> #topic pinning neutron version for unit tests (dougwig, marun)
16:11:46 <dougwig> the idea was brought up in this morning's neutron meeting to pin our unit tests to a specific commit of neutron, and then keep that updated regularly.  this would avoid the random gate breakages, at the cost of some extra maintenance.
16:12:04 <dougwig> you can see some early WIP's here:
16:12:05 <dougwig> https://review.openstack.org/#/c/163026/
16:12:13 <dougwig> https://review.openstack.org/#/c/163062/
16:12:30 <blogan> i actually dont recall any gate breakages yet, other than teh grenade job we broke, but this is still smart to do
16:12:40 <dougwig> anyone have any comments, questions, feedback?
16:12:42 <xgerman_> yep, I am all for it
16:13:11 * dougwig gives folks a moment to digest.
16:13:19 <blogan> should tempest tests run against that same pinned neutron version?
16:13:30 <xgerman_> yep
16:13:42 <dougwig> in our repo, yes.  in neutron, it should run against the submission.
16:13:51 <dougwig> the latter being the hated co-gate.
16:14:14 <xgerman_> Q: we wnated to vote on neutron submissions which break lbaas -- how will that work?
16:14:29 <blogan> co-gate
16:14:42 <blogan> the toothpaste!
16:14:52 <xgerman_> yeah, so we pin to some neitron version; they pin to lbaas trunk?
16:14:55 <johnsom> That was my question, I am assuming that our gate in neutron will catch the strangeness coming into neutron
16:15:06 <dougwig> the upcoming lbaasv2 tempest job will also be added to neutron, and it will not pin, but instead use the neutron in the gerrit submission.
16:15:23 <dougwig> at least, i think that's how it should work.
16:15:34 <blogan> the tox tempest?
16:15:50 <xgerman_> ok, so we will pin; but neutron will eat our trunk
16:15:54 <blogan> bc that will pull down the version of neutron specified in [testenv], which woudl be the pinned one
16:16:39 <dougwig> i'm not intending to fully hard-code that revision.  if the jenkins branch settings are there, we can use them instead.
16:16:50 <dougwig> the review above is a WIP.  :)
16:16:52 <blogan> okay
16:17:14 <dougwig> at least until we can get rid of the co-gate entirely.
16:17:28 <xgerman_> yeah, my main fear is that we will catch problems too late in the cycle but it's probbaly something we need to live first
16:17:29 <blogan> ok so now im unclear on this
16:17:58 <blogan> if i ran tox tempest locally, what version of neutron would i be running?
16:18:05 <dougwig> pinned.
16:18:07 <blogan> and what verson of neutron would the job run?
16:18:36 <dougwig> hmm, wait, it uses whatever is running neutron-server, right?
16:18:54 <blogan> what is it?
16:18:56 <blogan> "it"
16:19:04 <dougwig> so this ends up just pinning library calls (and unit tests).
16:19:06 <dougwig> it == tempest
16:19:16 <blogan> yeah it makes calls to neutron-server
16:19:21 <blogan> so thats just devstack
16:19:31 <blogan> or some other environment running neutron-server
16:19:33 <dougwig> which is co-gated against neutron master, so that should be ok.
16:19:51 <blogan> so yeah neutron version doesn't even matter for tox in that case
16:20:15 <dougwig> no, it still does, because the import neutron in lbaas will grab the venv version.
16:20:35 <blogan> ah you're right, brain meltdown incoming
16:20:39 <dougwig> so either we are happy with lib/server being different, or we make the pinning only happen for units.
16:20:52 <marun> so, for now devstack-deployed neutron will entail some work to get it to the pinnned version
16:21:34 <xgerman_> mmh
16:21:38 <dougwig> should we just start with units, since they're the pain point, and add tempest pinning in a subsequent pass?
16:21:46 <blogan> marun: cant we specify a version of neutron in localrc?
16:21:59 <blogan> i know we can a review ref
16:22:02 <marun> blogan: locally, yeah.  I was thinking in the gate
16:22:03 <blogan> at least i think i know lol
16:22:32 <blogan> i dont know much about the gate, but i suppose we don't have any hooks into changing that
16:24:07 <marun> blogan: it's software
16:24:20 <marun> blogan: we can make it meet our needs.
16:24:32 <blogan> of course, jsut a matter of how much effort required
16:24:53 <marun> blogan: ...and how important the work is
16:25:50 <blogan> okay so is the solution to wait to add tempst pinning? which in turn gives us no tempest tests?
16:25:54 <blogan> dougwig: ^
16:26:09 <dougwig> alright, where are we at the moment. we can tackle this for units quickly and try it out. the gate will need some investigating.
16:26:48 <dougwig> sorry, units locally and in the gate we can tackle quickly.  tempest in the gate will need more investigating.
16:26:57 <blogan> ah okay, i get ya now
16:27:18 <marun> I'm willing to help in getting this working, so if the effort is large hopefully we can spread across folks.
16:27:36 <marun> although, dougwig can probably do it faster by himself ;)
16:27:47 <blogan> patch incoming
16:27:49 <dougwig> oh, i always like help. :)
16:28:10 <blogan> marun will be a hollowed out husk of his former self after all of this
16:28:25 <dougwig> ok, just so everyone is aware this is happening, and the interested folks will take this offline/into gerrit.
16:28:38 <dougwig> #topic Where to put the devstack install documentation? (Aish)
16:29:10 <Aish> Yes.. There has been a confusion in where to put the devstack installation doc...
16:30:12 <Aish> Garyk wants it to be with lbaas
16:30:46 <xgerman_> so he is -1 us all the time
16:30:55 <dougwig> review link?
16:31:01 <xgerman_> in agenda
16:31:01 <Aish> https://review.openstack.org/#/c/158512/
16:31:33 <dougwig> ok, folks should chime in on that review.
16:31:50 <dougwig> i'll put in my $0.02 after the meeting.
16:32:17 <Aish> dougwig: okay.
16:32:55 <dougwig> #topic Open Discussion
16:34:12 <blogan> need to get tls reviewed, tested, and merged
16:34:21 <dougwig> links to focus on?
16:34:36 <evgenyf> https://review.openstack.org/#/c/145085/21
16:34:50 <blogan> what he said ^
16:35:01 <blogan> follow the chain down
16:35:11 <blogan> well just a 2 link chain
16:35:28 <blogan> probably need to add tempest test for this
16:36:01 <xgerman_> yep, I just made madhu aware of this
16:36:11 <rm_work> blogan: fix the config loading for the neutron-lbaas agent >_<
16:36:31 <blogan> rm_work: https://review.openstack.org/#/c/162883/
16:36:35 <rm_work> blogan: fix it more
16:36:38 <rm_work> blogan: it's still borked
16:36:43 <ptoohill> :)
16:36:45 <blogan> no its not
16:36:53 <madhu_> yes
16:36:54 <dougwig> #chair blogan
16:36:55 <openstack> Current chairs: blogan dougwig
16:36:56 <rm_work> blogan: definitely is :P
16:37:00 <blogan> argh!
16:37:24 <ptoohill> it may be another pebkac issue with the agent
16:37:56 <blogan> well the agent shouldn't really have any issues with this review
16:38:14 <ptoohill> just having config issues everywhere
16:38:38 <blogan> ill talk to you offline
16:38:41 <blogan> about it
16:38:51 <blogan> well online, in lbaas channel
16:38:54 <blogan> you know what i mean
16:39:31 <blogan> anything else
16:39:54 <evgenyf> yesp
16:39:58 <evgenyf> this is sam
16:40:02 <blogan> evgenyf: go!
16:40:05 <blogan> sam: go!
16:40:12 <xgerman_> hi sam!
16:40:24 <evgenyf> is there anything missing from getting lbaas v2 into kilo at this stage?
16:40:35 <xgerman_> not that I know of
16:40:44 <xgerman_> but we like TLS/SSL as well :-)
16:40:50 <evgenyf> does having horizon support mnot mandatory?
16:41:01 <blogan> evgenyf, sam: well technically its merged, we're just getting tempest tests and tls worked out now, trying to make it into kilo for that
16:41:09 <blogan> evgenyf, sam: no
16:41:13 <evgenyf> good
16:41:31 <evgenyf> what about discussion with packagers about this?
16:42:09 <evgenyf> for example, redhat. mirantis, ubuntu, etc....
16:42:19 <evgenyf> as lbbas is not neytron package anymore
16:42:20 <xgerman_> I think they include whatever is in the release...
16:42:37 <xgerman_> at least Helion will ;-)
16:42:40 <evgenyf> can someone access kylo ont his
16:42:48 <evgenyf> Kyle
16:43:11 <evgenyf> at the past, the PTL did some work on this with the community
16:43:23 <xgerman_> mestery? yt?
16:43:26 <evgenyf> but, mybe i am wrong here
16:43:36 <xgerman_> (let's try to summon him :-)
16:43:44 <evgenyf> yes, mestery
16:43:44 <mestery> xgerman_: here
16:43:49 <mestery> xgerman_: Whats up?
16:43:55 <evgenyf> hi kyle
16:44:09 <xgerman_> what about discussion with packagers about this?
16:44:09 <xgerman_> for example, redhat. mirantis, ubuntu, etc....
16:44:09 <xgerman_> as lbbas is not neytron package anymore
16:44:28 <xgerman_> aka will they include Neutron LBaaS v2 by default or we need to convince them
16:44:30 <blogan> hwo the split affects packagers
16:44:37 <mestery> xgerman_: I think we are doing this, but we should focus on it.
16:44:44 <mestery> I know Red Hat is already packaging the new aaS repos.
16:45:00 <johnsom> Ubuntu is already packaging: https://launchpad.net/~openstack-ubuntu-testing/+archive/ubuntu/kilo
16:45:40 <mestery> nice!
16:45:47 <evgenyf> gr8!
16:46:11 <dougwig> anything else today, or can we wrap up?
16:46:37 <xgerman_> well, I think we should make sure that all the packagers we care about are including us
16:46:37 <evgenyf> Kyle, does it make sense to post a note for example ML?
16:46:56 <xgerman_> but I am not sure who I care about besides Ubuntu :-)
16:48:09 <dougwig> is there an action for the packaging task?  otherwise, if ubuntu and redhat are already doing it, i think we can call that done.
16:48:12 <evgenyf> mestery, does it make sense to post a note for example ML?
16:48:37 <mestery> evgenyf: yes! Lets discuss it there
16:48:52 <evgenyf> Ok
16:48:56 <dougwig> #action mestery post to ML about packaging
16:49:06 <dougwig> ok, anything else today?
16:49:08 <blogan> is anyone else intimidated by sam's ability to possess evgenyf?
16:49:28 <blogan> im done
16:49:45 <evgenyf> sam: not me
16:50:04 <evgenyf> :-p
16:50:05 <dougwig> ok, bye folks
16:50:08 <blogan> lol of course not
16:50:10 <xgerman_> bye
16:50:10 <blogan> bye!
16:50:12 <evgenyf> bye
16:50:18 <madhu_> bye!
16:50:35 <dougwig> #endmeeting