16:01:27 <mlavalle> #startmeeting neutron_performance
16:01:28 <openstack> Meeting started Mon Nov  5 16:01:27 2018 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:31 <openstack> The meeting name has been set to 'neutron_performance'
16:01:44 <njohnston_> o/
16:01:59 <rubasov> o/
16:02:04 <mlavalle> hey guys
16:02:20 <mlavalle> rubasov: when are you arriving to Berlin?
16:02:40 <rubasov> mlavalle: monday early afternoon
16:02:49 <rubasov> mlavalle: the same plane as gibi
16:03:12 <mlavalle> I'll be there since Friday morning. I'm attending the edge computing hackathon
16:03:24 <mlavalle> during the weekend
16:03:42 <rubasov> mlavalle: sounds interesting
16:04:06 <bcafarel> this time it's not my fault holding the others from being there :)
16:04:18 <mlavalle> bcafarel: duly noted
16:04:21 <mlavalle> LOL
16:04:55 <mlavalle> let's wait one more minute
16:04:59 <mlavalle> for slaweq
16:05:59 <mlavalle> ok, let's get started
16:06:10 <mlavalle> #topic last week's action items
16:06:34 <mlavalle> First rubasov to add top request offenders to rally job
16:07:01 <rubasov> I'm sorry to report but I didn't make much progress
16:07:07 <rubasov> started to learn about rally
16:07:15 <rubasov> but then got busy with other stuff
16:07:23 <mlavalle> yeah, I imagine
16:07:28 <mlavalle> the demo, maybe?
16:07:32 <rubasov> yep
16:07:40 <mlavalle> np
16:07:45 <slaweq> hi
16:07:52 <rubasov> but I still have it on my todo list
16:07:55 <slaweq> sorry for being late
16:08:04 <rubasov> so I will get to it at some point
16:08:08 <mlavalle> let's move that action item for the next meeting
16:08:23 <mlavalle> #action rubasov to add top request offenders to rally job
16:09:04 <mlavalle> next one is slaweq to create a experimental rally job with osprofiler enabled
16:09:34 <slaweq> so, I proposed patch for rally https://review.openstack.org/#/c/615340/
16:09:55 <slaweq> and then I have WIP patch which depends on it: https://review.openstack.org/#/c/615350/
16:10:12 <slaweq> it basically works, and I can see trace id in rally result
16:10:34 <slaweq> but now I need to copy somehow redis db to job result files
16:10:44 <slaweq> so I will continue work on this in next days
16:11:11 <mlavalle> Great progress slaweq. Thanks
16:12:03 <mlavalle> next action item was mlavalle to simplify the DB traces
16:12:33 <mlavalle> I just proposed this patch https://review.openstack.org/#/c/615585
16:13:31 <mlavalle> I made sure that the code that I am removing is the only one in Neutron that add traces for SQLAlchemy
16:14:07 <mlavalle> so after this one merges, we should get much cleaner reports
16:14:17 <mlavalle> with less duplicate information
16:14:34 <mlavalle> which will make the reports easier to analyze
16:14:41 <mlavalle> ok
16:14:51 <mlavalle> that's it for action items
16:15:00 <mlavalle> #topic On demand agenda
16:15:26 <njohnston_> I just wanted to note that the ipam work I have been doing has some promising speed results
16:15:46 <mlavalle> how so?
16:17:09 <njohnston_> https://review.openstack.org/#/c/592164/ look at my last comment
16:17:41 <njohnston_> the rally task "Action neutron.create_port (x50)" looks like it is ~30% faster
16:18:25 <mlavalle> wow, nice!
16:18:42 <mlavalle> should we add some profiling calls to the IPAM code?
16:18:45 <njohnston_> This is mostly accomplished by taking the code in ipam to try to randomly select new IPs (to avoid contention) and replacing it with random.sample
16:19:33 <njohnston_> mlavalle: We could, although I think we may have wrung all the speed gains we can out of this code.  But I'm definitely open to adding profiling to confirm it. :-)
16:20:39 <mlavalle> mhhhh, no, if you don't see it evidently worthwhile at this point, let's wait until we can see results from the rally jobs
16:21:20 <mlavalle> with more data, we may conclude that further investigation is warranted
16:21:41 <mlavalle> but at this point I think we are still "shooting in the dark"
16:22:13 <mlavalle> but I think this work will definitely have impact
16:22:23 <mlavalle> becuase port creation is among the top offenders
16:22:34 <mlavalle> which this work with IPAM impacts
16:23:05 <mlavalle> great job, njohnston_
16:23:26 <njohnston_> I agree - and I want to thank tidwellr and Roman (I don;t know his IRC) for great review feedback
16:23:33 <njohnston_> would not have happened without them
16:24:06 <slaweq> njohnston_: Roman's nic is gryf :)
16:24:26 <njohnston_> Ah thanks :-)
16:24:50 <mlavalle> yeah, tidwellr did a lot of work in IPAM code a couple of yeards ago
16:25:18 <mlavalle> and gryf was probably with John Bellamaric's group
16:25:28 <mlavalle> and they also did great work in IPAM
16:26:04 <mlavalle> ok, let's move on
16:26:16 <mlavalle> I think that at this point what we need is data
16:26:37 <mlavalle> to start gleaning insight
16:26:54 <mlavalle> and to get to that point we need to finish our action items
16:26:58 <mlavalle> do we agree?
16:27:04 <njohnston_> +1
16:27:10 <slaweq> +1
16:27:27 <mlavalle> so let's focus on concluding our action items
16:27:32 <rubasov> yep
16:27:40 <mlavalle> and we can re-take the discussion next meeting
16:27:49 <mlavalle> ok?
16:27:56 <njohnston_> sounds like a plan!
16:27:59 <slaweq> ok for me :)
16:28:09 <mlavalle> ok, guys, thanks for attending
16:28:25 <rubasov> thank you guys
16:28:34 <njohnston_> thanks all
16:28:42 <mlavalle> #endmeeting