14:04:07 <ajo> #startmeeting neutron_qos
14:04:08 <armax> ajo: pull me in if needed…I am pulled into some other meeting
14:04:08 <openstack> Meeting started Wed Jul  8 14:04:07 2015 UTC and is due to finish in 60 minutes.  The chair is ajo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:11 <openstack> The meeting name has been set to 'neutron_qos'
14:04:16 <ajo> armax, ack, thank you
14:04:35 <ajo> #topic Announcements
14:04:52 <ajo> We had the QoS mid cycle in Israel last week,
14:05:10 <ajo> a little report here: http://www.ajo.es/post/123458887419/neutron-quality-of-service-coding-sprint
14:05:17 <ajo> #link http://www.ajo.es/post/123458887419/neutron-quality-of-service-coding-sprint QoS mid cycle report
14:05:45 <ajo> it was very nice to collaborate in sprint mode
14:05:53 <ajo> lots of patches merged
14:06:50 <ajo> not everything fully tested because we wanted to assemble a fast POC, and then iterate over TO-DO's and missing tests
14:07:08 <ajo> regarding that
14:07:15 <ajo> #topic Testing gaps
14:07:21 <ajo> #link https://etherpad.openstack.org/p/neutron-qos-testing-gaps
14:07:29 <ajo> we have put this together today,
14:07:49 <ajo> defining a list of POC-essential patches, which we may allow to go in without full testing until the POC is complete
14:08:04 <ajo> any other patches should start to add unit test/functional test/or any relevant tests
14:09:02 <ajo> and, we should build a checklist of tests to start including as a follow up
14:09:18 <ihrachyshka> ajo, and those who were happy to get their patches in without proper testing/docs, should go back and write those to those patches already merged ;)
14:09:19 <ajo> as our goal is to get everything working, correctly tested, and merged back to master
14:09:50 <ajo> yes, or ask for help where they don't have time, and we will find somebody to do it. But ideally the writer of the patch is the best to test it.
14:10:07 <ajo> (not sure what a testing expert would say about that statement ^)
14:10:13 <ajo> it will be faster at least
14:10:40 <ajo> The full list of files that build the POC (+/-) is  http://paste.fedoraproject.org/241292/36363675
14:10:44 <ihrachyshka> yes, schedule is tight
14:10:55 <ajo> #link  http://paste.fedoraproject.org/241292/36363675 POC files which may need testing
14:11:12 <ajo> if I dint' screw it up when doing the git diff :)
14:11:40 <ramanjaneya_> Ajo, neutron client changes started unit test cases.  Done for policy clis, pending for rule cmds and working on the same
14:11:45 <ajo> #link  http://paste.fedoraproject.org/241295/14363637 the full POC patch (don't try to test as-is, it's only for reference)
14:11:54 <ajo> ramanjaneya_++
14:12:19 <ajo> thanks, that's awesome, we will definitely need them on python-neutronclient, since we don't have a feature branch there.
14:12:38 <ihrachyshka> ramanjaneya_, cool. I believe we won't be able to merge neutronclient changes though until we are merged back into master
14:12:55 <ajo> #link  http://paste.fedoraproject.org/241300/63640691 grep -C 5 "TODO([Qq]o[Ss])" over the previous link
14:12:59 <ramanjaneya_> Also please review the patches and let us know if any comments
14:13:20 <ajo> ramanjaneya_ I will test every command manually soon
14:13:21 <moshele> ajo on the Agent side patches you are missing https://review.openstack.org/#/c/195441/
14:13:45 <ajo> moshele, I didn't consider it essential for a "POC" :)
14:13:52 <ajo> I don't have a SRIOV card for testing it :)
14:14:05 <ramanjaneya_> Ajo, ok.
14:14:06 <ajo> moshele, but of course it should go in as soon as we verify/fix the full stack
14:14:19 <moshele> ajo: ok
14:14:41 <ajo> moshele, but of course, this should be part of the final artwork and get into master, no doubt
14:14:59 <ajo> hi irenab  :)
14:15:05 <irenab> hey :-)
14:15:09 <ajo> irenab: https://etherpad.openstack.org/p/neutron-qos-testing-gaps
14:15:26 <moshele> ajo: I will start with  https://review.openstack.org/#/c/195440/ + it's unit tests
14:15:26 <ajo> you may want to look into this, we were discussing until the full diff, then look at the meeting logs later :)
14:15:51 <ajo> moshele, ack, put the unit tests in a separate patch
14:16:02 <ajo> moshele, as we may want 195440 merged ASAP to have the full POC in
14:16:37 <moshele> ajo: ok
14:16:41 <irenab> ajo: sorry if you already discussed it, I have a question
14:17:10 <ajo> irenab, go ahead :)
14:17:12 <ajo> we have time
14:17:14 <irenab> is there any gap that need to be coded or just review + unit tests?
14:17:37 <ajo> irenab, yes, there are gaps to be coded,
14:17:41 <ajo> rule updates, for example
14:17:55 <ihrachyshka> irenab, all todo (well, most) should go away
14:17:59 <ajo> at worst scenario we could just disable "PUT" of rules in this version, for example
14:18:11 <irenab> ok thanks. so the scope for POC is create/delete?
14:18:12 <ihrachyshka> ajo, it won't fly for merge
14:18:14 <ihrachyshka> I believe
14:18:37 <ihrachyshka> ah, you're talking about poc.
14:18:38 <ajo> ihrachyshka, worst case scenario, I don't know, there was pull not to include updates during reviews
14:18:46 <ajo> (spec reviews)
14:18:56 <ajo> ihrachyshka: for poc, 100% no updates
14:19:16 <ajo> but ok, disallowing PUT of rules won't be necessary I think :)
14:19:30 <ajo> most of the layers and the design is ready to handle it
14:19:46 <ajo> and yes, all the TO-DOs
14:19:53 <ajo> check for the 3rd fpaste link in etherpad
14:19:57 <ajo> irenab ^
14:20:25 <ajo> ihrachyshka, can I ask a question about the etherpad details or could you go over "We also need a high level, per module description of the architecture, with logical split of the changes into separately reviewable pieces." ?
14:20:26 <ajo> :)
14:21:24 <ajo> #topic Test/TODO checklist
14:21:32 <ajo> I should have changed topic before ;)
14:22:01 <ajo> so far, priorities: 1) minimal POC, 2) add testing 3) Handle the TO-DOs
14:22:19 <ajo> 4) Get everything ready with testing included in patchsets to be merged right away
14:22:40 <ajo> ihrachyshka ping
14:22:41 <ihrachyshka> ajo, ehm, so now that I think how acceptance into master could look like, I realize that it will be hard for anyone to comprehend all changes in one go. So we'll need to come up with description of the system, per module, and ask people to look at those separately
14:22:58 <ihrachyshka> because just providing 2000+ lines of code won't fly
14:23:20 <irenab> the plan after POC to move to master?
14:23:30 <ihrachyshka> but that's after we get coverage for existing code and TODOs handled
14:23:30 <ajo> ihrachyshka, ok, that makes sense, we can assemble an small devref with description of the design
14:23:43 <ajo> "small"
14:23:47 <ihrachyshka> irenab, no way. we need to cover tests, write docs, handle TODOs
14:23:52 <ihrachyshka> that's a huge piece of work
14:23:57 <ajo> yes
14:24:07 <ihrachyshka> and we have ~month if we set start of L3 as goal
14:24:22 <ihrachyshka> ajo, devref is needed anyway. we have a stub in the tree.
14:24:22 <ajo> And we should target L-2 (optimistically) -end of july- or start of L-3,
14:24:32 <ajo> the later the worst, because L-3 end is feature freeze
14:24:48 <ihrachyshka> yes, if we get later, we risk to slip to M
14:26:00 <irenab> I guess major concern would be for agent/rpc changes, the rest is quite decoupled from the core neutron
14:26:10 <ajo> we need to do a final push, and properly communicate that
14:26:31 <ajo> irenab, correct, but agent/rpc changes are very cool IMHO ;)
14:26:44 <ajo> good design ;) irenab++ moshele++
14:26:46 <irenab> maybe need core reviewers of relevant areas already looking
14:26:59 <ihrachyshka> irenab, yes, and we should make sure all is as clear as possible for those who will decide on getting the code in master (not us)
14:27:09 <irenab> ago: + gampel
14:27:21 <ajo> +gampel +gsagie ;)
14:27:37 <ajo> We don't want to start bikesheeding for merging back,
14:27:47 <ajo> but we may expect requests to change things
14:28:03 <ajo> for example, we should sync with the new callback interface armax is working on to extend resources
14:28:11 <ajo> instead of using AFTER_READ dict extension
14:28:33 <irenab> ajo: this this already for review?
14:28:45 <irenab> I mean armax change
14:28:53 <ihrachyshka> ajo, I believe this one can be actually postponed to when it's in master
14:28:55 <ajo> irenab, no, it's just a plan, I think he started it and will send for review, we talked about it yesterday
14:29:11 <irenab> cool, thanks
14:29:20 <ajo> ihrachyshka, it could be, as long as the long-term plan is clear.. I'm ok with that
14:29:32 <ajo> so,
14:29:36 <ajo> with this plan in mind
14:29:56 <ajo> we want to talk to mestery to make sure everything is aligned
14:30:09 <ajo> any comments about the plan?
14:30:55 <ajo> moshele, irenab , sc68cal , vhoward , will you have some time to write tests? :)
14:31:10 <ajo> otherwise, ping for help fast, so we can look for resources, we don't want to risk delaying to M
14:31:29 <moshele> ajo: I will need help with tests
14:31:34 <ajo> also, to make things funnier, I'll be PTO since Jul 20th to Aug 3
14:31:49 <irenab> ajo: I am afraid I have limited cycles, but can try to help.
14:32:16 <ajo> Ok, I will try to pull in help from Red Hat
14:33:23 <ajo> moshele, irenab , please identify the modules you know about which need testing, and ping us with what you won't be able to test, so we can find stakeholders :)
14:33:42 <ajo> you know about -> you participated on development
14:33:56 <irenab> ajo: can we include the rule_types patch in the POC scope? Will be nice to get some feedback
14:34:39 <ajo> irenab, It needs to be finished, isn't it? :) right now it has a few "pass" which will do nothing
14:34:55 <ajo> if I'm not wrong
14:35:07 <irenab> the API is there, so it need to be connected with ihrachyshka code
14:35:23 <ihrachyshka> via service_plugin. it's in review.
14:35:42 <irenab> so if we merge the API, it can be connected together
14:35:57 <irenab> just not to make more dependencies between patches
14:36:09 <ajo> yes, we need to merge more patches to clear the dependency mess :=)
14:36:34 * ajo had a nice day today assembling the POC and going back to rebase patches because of horrendous conflicts while cherry-piling
14:37:11 <ajo> irenab, when we have the integration ping me, we will need to write the tests anyway soon :)
14:37:19 <irenab> link to the patch https://review.openstack.org/#/c/199066/
14:37:50 <irenab> ajo: sure
14:38:13 <ajo> very low attendance today,
14:38:25 <ihrachyshka> ajo, the problem with your poc is it seems the deps are broken. (or at least the order): I see one failure that suggests you use some modules in a patch that are not yet avail at that point in your mountain
14:38:42 <ajo> ihrachyshka, it probably is
14:38:45 <ihrachyshka> I suspect we should have better merged disconnected pieces and then integrate
14:38:53 <ajo> I need to refine it during today/tomorrow to verify it's really a poc
14:38:57 <irenab> ihrachyshka: +1
14:38:58 <ajo> right now, it's just "a patch"
14:38:58 <ihrachyshka> integrating in git is... fun
14:39:19 <ajo> it's good to find out what we have done, and what's missing testing
14:39:20 <ajo> but I will discover soon
14:39:24 <ihrachyshka> ajo, yeah, but you updated existing, mergeable versions of patches
14:39:32 <ihrachyshka> anyway
14:39:34 <ajo> I just finished cherry-piling and rebasing stuff before themeeting
14:39:37 <ihrachyshka> I trust you solve it :)
14:39:45 * ajo crosses fingers
14:40:24 <ajo> ok, any more comments about this topic?
14:40:27 <ajo> we need to run! ;)
14:40:58 <ajo> ok
14:41:05 <ajo> another topic which it's been around
14:41:10 <ajo> #topic Summit presentation(s)
14:41:26 <ajo> vikram approached me about working on a QoS presentation for next summit
14:41:39 <ajo> I believe moshele , irenab , you may want to be in
14:41:44 <moshele> yep
14:42:00 <ajo> I will collaborate with content, but probably I won't attend this summit for family reasons
14:42:18 <irenab> I need to check, but probably will
14:42:23 * ajo will envy all the Tokio visitors :)
14:42:55 <ajo> It could be interesting even to work in two different sessions
14:43:08 <ajo> one about general usage, and explaining what have we done, and how it works
14:43:21 <ajo> and another about lower level, and... explaining vendors how to integrate their plugins with QoS
14:43:40 <ajo> we may want to loop Eran about the 2nd one :)
14:43:58 <irenab> and Gal
14:44:10 <ajo> and Gal, true
14:44:21 <ajo> we may divide people between both presentations, not to clutter the stage :)
14:44:54 <irenab> cool, loop me in for content part for sure. And would love to participate in presentation if will attend
14:45:05 <ajo> moshele, irenab , probably you must be a must for the user facing one (more visible)
14:45:27 <irenab> API?
14:45:40 <ajo> yes I think we should do two probably?
14:45:55 <ajo> 1) API explanation, CLI usage, configuration , etc...
14:46:12 <ajo> 2) low level integration for other vendors
14:46:23 <ajo> may be 45m is enough for both?
14:46:25 <ajo> I'm not sure
14:46:33 <irenab> what do you mean by low level?
14:46:48 <irenab> write your own qos plugin?
14:46:50 <ajo> 2) explain the internal design of the service,
14:47:05 <ajo> explain how to write a backend driver for qos
14:47:29 <ajo> just an idea,
14:47:38 <ajo> I will put everybody interested in a mail thread
14:47:49 <irenab> if we have Midokura support by then, it will be cool to show….I need to check
14:47:52 <ajo> so we can decide how to do it
14:47:57 <ajo> irenab++
14:48:01 <ajo> that'd be super awesome :D
14:48:24 <moshele> we want to show also the agent side ?
14:48:36 <moshele> for other ml2 agents ?
14:48:53 <ajo> moshele, probably, as an example to others who use ovs, for example... or sr-iov
14:48:54 <irenab> I think yes, end to end. Can be both sriov and ovs
14:49:00 <ajo> yep
14:49:12 <moshele> cool
14:49:57 <irenab> There is talks submission deadline July 15
14:50:06 <ajo> yes, time is tight :)
14:50:16 <irenab> as always :-)
14:50:28 <ajo> I'm too toasted now to even write an email, but I can do it first thing tomorrow morning
14:50:31 <ajo> or ping vikram to do it
14:50:46 <ajo> toasted = 35-37ºC
14:50:57 <ajo> generally I don't need A/C in my office, but this summer is horrible!
14:51:23 <ajo> ok
14:51:31 <ajo> anything else, or shall we close the meeting?
14:51:55 <ajo> I will also communicate our plan in openstack-dev with CC to mestery to see how it flies
14:52:09 <ajo> #action ajo write email about presentations to all interested parties
14:52:27 <ajo> or ihrachyshka , do you want to do that 2nd part? :)
14:52:32 <ajo> I was about to write an action to myself..
14:52:45 <ihrachyshka> ajo, which part, sorry. presentation?
14:52:58 <ajo> ihrachyshka, no, I mean, communicating or feature/qos plan to openstack-dev
14:53:10 <ajo> to get it merged back to master by L2/L3.start
14:53:18 <ajo> L-2, L-3 :D
14:53:19 <ihrachyshka> hm, not sure I will have it today. let's sync tomorrow.
14:53:23 <ajo> L2/L3 seems like OSI layers
14:53:31 <ajo> ihrachyshka, tomorrow is ok,
14:53:36 <ihrachyshka> I can come up with draft, then we'll discuss
14:53:39 <ajo> it's a bit late already for CEST
14:53:40 <ajo> ack
14:54:14 <ajo> #action ihrachyshka communicating feature/qos plan to openstack-dev towards merging back to master
14:54:33 <ihrachyshka> yes, my load
14:54:36 <ihrachyshka> *lord
14:54:39 <ajo> %)
14:54:40 <ajo> thanks ihrachyshka  :D
14:55:49 <ajo> omg: https://weather.yahoo.com/spain/madrid/madrid-766273/# 39ºC
14:55:50 <ajo> ok
14:55:55 <ajo> we can close the meeting :)
14:56:02 <ajo> o/
14:56:07 <irenab> ajo: time to go to the pool :-)
14:56:15 <ajo> thanks moshele , irenab , ihrachyshka , ramanjaneya_
14:56:21 <ihrachyshka> cu. and everyone, keep bombing us with patches
14:56:23 <ajo> yey!
14:56:28 <ajo> go go go! :)
14:56:29 <moshele> or to israel
14:56:43 <moshele> bye
14:56:45 <ajo> yeah, this weather is insane
14:56:45 <ihrachyshka> moshele, yeah, Israel seems like a cold heaven
14:56:49 <ramanjaneya_> Bye
14:56:51 <irenab> bye
14:56:55 <ajo> yeah, the weather was very nice ;)
14:57:03 <ajo> #endmeeting