14:01:51 <ihrachyshka> #startmeeting neutron_qos
14:01:51 <openstack> Meeting started Wed Aug  5 14:01:51 2015 UTC and is due to finish in 60 minutes.  The chair is ihrachyshka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:55 <openstack> The meeting name has been set to 'neutron_qos'
14:01:56 * abregman throws party away
14:02:02 <ihrachyshka> hi all :)
14:02:05 <jlibosva> o/
14:02:08 <vichoward_> o/
14:02:15 <ihrachyshka> I hope this will be the last meeting prior to merge-back ;)
14:02:38 <ihrachyshka> #topic Announcements
14:02:56 <ihrachyshka> so L2 is behind us, and mestery expects us to merge back next week
14:03:00 <gcossu> ihrachyshka: hi
14:03:21 <ihrachyshka> the schedule is tight and we should make it, since other feature branches depend on us going first
14:03:47 <ihrachyshka> not making it till the next week may mean no merge this cycle ;) but it seems we make it
14:03:54 <jschwarz> ihrachyshka, what days exactly are we aiming at?
14:04:00 <ihrachyshka> anyway, that's your piece of caution for today
14:04:25 <ihrachyshka> jschwarz, I *think* that we should have rpc + functional + some cleanups here and there this week.
14:04:49 <vichoward_> is there anything you need an exgra push on that we can run with this week?  unsure what to grab off the etherpad at this point
14:05:00 <moshele> ihrachyshka: regarding the SR-IOV this can be continue on master right ?
14:05:02 <ihrachyshka> then we have time to update devref Sat-Mon and should push for review process starting from Tue-Wed. this should give everyone involved in review some time to actually review code
14:05:21 <ihrachyshka> moshele, I don't believe sriov is a blocker and belong to required deliverables
14:05:37 <vichoward_> can reach out after meeting
14:05:43 <ihrachyshka> vichoward_, re what to grab. there are some TODOs that are still not handled
14:05:52 <ihrachyshka> it would be great if people take them one by one and squash
14:06:04 <ihrachyshka> most of them should not take much time but will all raise chance for smooth merge
14:06:08 <vichoward_> perfect we will sign up to try to knock them out
14:06:13 <ihrachyshka> #link https://etherpad.openstack.org/p/qos-sync
14:06:29 <ihrachyshka> yeah, please put your name there and send patch and nag me about it :)
14:06:40 <ihrachyshka> another announcement for today is that gate is broken again
14:06:52 <ihrachyshka> specifically, -api job, and it's not just feature/qos but master too
14:07:04 <ihrachyshka> the fix is in gate
14:07:06 <ihrachyshka> #link https://review.openstack.org/209307
14:07:18 <ihrachyshka> once it's in master, I'll grab and create a merge request into feature/qos
14:07:33 <ihrachyshka> then we will be able to rebase on top of it and continue merges
14:07:38 <ihrachyshka> is it clear?
14:07:52 <moshele> yep
14:07:53 <njohnston> sounds good to me
14:08:16 <ihrachyshka> njohnston, hi btw :) you were so quick with the first patch, thanks for that ;)
14:08:28 <njohnston> happy to help!
14:08:50 <ihrachyshka> #topic where we are
14:09:47 <vichoward_> sounds good
14:10:00 <ihrachyshka> the missing pieces that are expected before we merge back are: 1) update notifications (jlibosva is on it); 2) functional tests (jschwarz); 3) fullstack tests (blocked by master, I am working on getting it in there so that we can proceed); 4) devref update (no one is assigned, but I guess it will be me mostly)
14:10:10 <ihrachyshka> and a bunch of TODOs to squash
14:10:34 <jschwarz> ihrachyshka, work on functional has been (really) slow, mainly because I'm really not familiar with the OVS agent...
14:10:38 <ihrachyshka> fullstack is also blocked by 1), I guess we will see it in next day or two though. right, jlibosva? ;)
14:10:59 <jschwarz> perhaps it'll be best if someone else does it instead since I doubt I'll be able to get something working faster
14:11:00 <jlibosva> sure, I also plan to put my nose in functional tests thingy
14:11:04 <ihrachyshka> jschwarz, that's understandable. if you need help, tell me. I am also bad at it though, but we can at least cry together ;)
14:11:20 <jlibosva> I would just point out that fullstack tests rely on neutronclient
14:11:22 <ihrachyshka> jschwarz, ack, let's talk after the meeting, I may take it
14:11:25 <jschwarz> ihrachyshka, crying is nice :)
14:11:36 <jlibosva> and neutronclient qos parts will be merged after merge-back
14:11:44 <jschwarz> ack. perhaps me and jlibosva can trade (I'll do fullstack and he'll do functional?)
14:11:54 <jlibosva> chicken-egg problem, probably fullstack development must be done in master
14:11:57 <ihrachyshka> jlibosva, are right you are. so it means no fullstack in tree before merge-back (since we won't merge client changes before that). still, we may want to have a patch up for review.
14:11:58 * jschwarz might have misunderstood jlibosva
14:12:38 <ihrachyshka> speaking of client... I think jschwarz made a good job to make it work with the latest server. there are some issues though to tackle.
14:12:52 <ihrachyshka> like tenant-id not available for rule creation (needed for noauth mode)
14:13:04 <ihrachyshka> I hope jschwarz is on top of it. right? ;)
14:13:11 <jschwarz> ihrachyshka, I am now ^_^
14:13:18 <gcossu> jschwarz: maybe me and ddepaoli can help on OVS agent, let's keep in touch
14:13:19 <ihrachyshka> cute
14:13:22 <jschwarz> ihrachyshka, is there a list of TODOs for the neutronclient?
14:13:27 <jlibosva> Idea: we can work on fullstack tests locally (with patched neutronclient) and once client gets merged after merge-back, we can come up fast with fullstack tests
14:13:44 <ihrachyshka> gcossu, there are some TODOs in agent, and probably not the most obvious ones. If you can take a look, apart from testing.
14:14:05 <jschwarz> gcossu, excellent. suggest we'll coordinate the testing effort after the meeting with ihrachyshka and jlibosva :)
14:14:09 <ihrachyshka> jschwarz, I think for client, it's mostly in comments. I need to get back to the patch to see whether tests are in better shape than before
14:14:25 <ramanjaneya_> Hi jschwraz, anything pending to do neutronclient?
14:14:34 <gcossu> ok, sounds good for me
14:14:39 <jschwarz> ihrachyshka, I've reworked the tests late last week so they should be in good order
14:14:46 <ihrachyshka> jlibosva, yes, exactly, even if we don't merge, at least we may show we have it planned and handled (in case some reviewers will be concerned)
14:15:09 <jschwarz> ramanjaneya_, perhaps adding a tenant_id for the policy commands
14:15:19 <ihrachyshka> jschwarz, I think for policies it work
14:15:24 <ihrachyshka> it does not for rules
14:15:36 <ihrachyshka> at least that's where I needed to patch the client to make it work
14:15:40 <jschwarz> ihrachyshka, it does indeed. rules don't accept tenant_id (and it shouldn't!)
14:15:54 <ihrachyshka> jschwarz, for noauth mode, you still need to pass those
14:16:01 <moshele> ihrachyshka: sorry I was disconnected, do you need anything on my side or I can continue with SR-IOV ?
14:16:01 <jschwarz> ihrachyshka, even for rules? meh.
14:16:13 <jlibosva> I'm glad to hear (read) client works :) Now I can drop using curl
14:16:14 <ihrachyshka> jschwarz, they are not stored in db, that's right, but you need server to know the tenant context somehow
14:16:37 <jschwarz> ihrachyshka, ahah! tenant_id is an option for qos-bandwidth-limit-rule-create
14:16:38 <jschwarz> XD
14:16:46 <ihrachyshka> moshele, there are some TODOs in agent, you may want to check those. otherwise, keep working on sr-iov
14:17:16 <ihrachyshka> jschwarz, it should be an option, though it does not get into the payload due to a bug in the client. anyway, let's not discuss it here, let's move
14:17:19 <jschwarz> ihrachyshka, I think it's suffice to say the 2 neutronclient patches need good core-reviewers reviews
14:17:42 <ihrachyshka> now I understand one more thing should be handled before we claim completion. we need to update spec.
14:17:46 <ihrachyshka> irenab, are you on it?
14:18:02 <irenab> ihrachyshka: yes
14:18:03 <moshele> ihrachyshka: they are related to update and delete, I need ajo patch which was WIP
14:18:14 <ihrachyshka> moshele, aha. now it's jlibosva's patch :)
14:18:21 <irenab> I submited patch yesterday
14:18:28 <ihrachyshka> irenab, link?
14:18:55 <moshele> ihrachyshka, jlibosva
14:18:55 <moshele> is it working or in a state I can use ?
14:18:59 <ihrachyshka> I will let jlibosva say when he thinks we'll see smth that moshele can rebase on to complete updates/deletes
14:19:08 <irenab> #link https://review.openstack.org/#/c/199112/
14:19:28 <jlibosva> moshele: I hope so, yesterday I got notifications through to agent's registry
14:19:44 <jlibosva> moshele: it needs some additional patch though for using rpc classes
14:19:49 <jlibosva> moshele: ETA today
14:19:54 <ihrachyshka> COOOL
14:20:05 * ihrachyshka makes a note into a notebook
14:20:10 <ajo> jlibosva++
14:20:16 <moshele> jlibosva: can you send them to me
14:20:42 <jlibosva> moshele: https://review.openstack.org/#/c/208943/ if you mean classes
14:20:47 <jlibosva> also reviews are appreciated
14:20:56 <irenab> please review the spec changes, I hope I got them all
14:21:24 <ihrachyshka> irenab, will do.
14:21:54 <ihrachyshka> moshele, note that in jlibosva's patch, classes are not yet bound to agent, so there is nothing that is triggered into qos driver
14:22:17 <jlibosva> right, that's the additional not-existing patch I mentioned above
14:22:20 <ihrachyshka> ok, let's officially claim a new topic... :)
14:22:25 <ihrachyshka> #topic Open Agenda
14:22:42 <ihrachyshka> anyone has anything to ask/complain/praise/wonder?
14:22:52 <ihrachyshka> anyone blocked?
14:23:13 <moshele> I just want the list of patches to start the agent side
14:24:04 <ihrachyshka> jlibosva, do you think you will plug the classes in the agent, or moshele should do it in parallel while you refine your piece?
14:24:14 <jlibosva> I plan to do it
14:24:20 <ihrachyshka> today, right?
14:24:23 <jlibosva> yes
14:24:23 <ajo> Something I can jump in tomorrow to work on?, I will be freed from PTO's and meetings
14:24:31 <jlibosva> ajo: reviews!
14:24:35 <ajo> that for sure
14:24:46 <ihrachyshka> ajo, let's discuss out of the meeting.
14:24:46 <ajo> anything beyond that?
14:24:49 <ajo> ack
14:24:54 <jschwarz> ajo, reviews!
14:24:55 <jschwarz> XD
14:24:57 <ihrachyshka> ;)
14:25:00 <gcossu> :)
14:25:01 <ihrachyshka> ajo, reviews
14:25:02 <ajo> :-)
14:25:05 <ajo> may be reviews?
14:25:06 <ajo> :D
14:25:38 <ihrachyshka> ok, let's wrap up and continue making it happen then?
14:25:39 <vikram> Hi Ajo, wlcome on-board
14:25:45 <vikram> *welcome
14:25:47 <moshele> jlibosva: are doing the subscribe resource in the Qos agent extension and all that
14:25:54 <ajo> thanks vikram :)
14:26:02 <jlibosva> moshele: yep
14:26:15 <moshele> jlibosva: ok cool
14:26:16 <jlibosva> moshele: basically calling agent driver based on notifications, right?
14:26:26 <ihrachyshka> moshele, may you assume for now that you get the object, at least in unit tests?
14:27:03 <jschwarz> ihrachyshka, I suggest adding a list of reviews waiting for.. well.. reviews in every subject (agent, api, neutronclient...)
14:27:22 <jschwarz> ihrachyshka, then, everyone can pitch in for reviews where they know best instead of looking at the list and going "huh"?
14:27:23 <ihrachyshka> jschwarz, subject == ?
14:27:35 <gcossu> I've tested some functionalities using devstack, but I noticed that there are a lot of patches these days... :)
14:27:35 <ihrachyshka> do you mean a review section in the etherpad?
14:27:41 <jschwarz> ihrachyshka, yes
14:27:50 <ihrachyshka> gcossu, it's not these days, it's all days since we started ;)
14:27:56 <gcossu> ahaha
14:27:59 <moshele> ihrachyshka: I undestood jlibosva
14:27:59 <moshele> is doing the agent work as well or I missing something
14:28:09 <gcossu> so it's difficult to stay updated :)
14:28:16 <ihrachyshka> gcossu, testing is highly welcome btw, I don't believe all developers have time to actually try it in real
14:28:35 <gcossu> I see
14:28:53 <ihrachyshka> moshele, yes, but I believe it's till qos agent extension boundary. but anyway, I'll let you cover that out of the meeting.
14:29:03 <moshele> jlibosva: yes for the update, but for the delete I think is more complicate
14:29:22 <moshele> jlibosva: let sync after the meeting
14:29:25 <jlibosva> moshele: ack
14:29:39 <ihrachyshka> #action ihrachyshka create review section in etherpad
14:30:32 <ihrachyshka> ok then. I guess we'll wrap up now and proceed in the neutron channel if needed.
14:30:48 <ihrachyshka> thank you all guys, it wouldn't happen with you all
14:30:49 <ihrachyshka> #endmeeting