14:01:08 <njohnston> #startmeeting neutron_qos
14:01:08 <openstack> Meeting started Wed Jun 15 14:01:08 2016 UTC and is due to finish in 60 minutes.  The chair is njohnston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:12 <openstack> The meeting name has been set to 'neutron_qos'
14:01:17 <njohnston> #chair ajo
14:01:19 <openstack> Current chairs: ajo njohnston
14:01:25 <ajo> hello o/
14:01:28 <ralonsoh> hi
14:01:36 <ajo> hi ralonsoh , mr. njohnston
14:01:43 <njohnston> Good day all!
14:01:48 <njohnston> Let's dive in.
14:01:50 <njohnston> #topic announcements
14:01:57 <njohnston> Less than a month to N-2!  http://releases.openstack.org/newton/schedule.html
14:02:33 <njohnston> Also, as a general note, we should keep an eye on QoS commands for the OSC transition: https://etherpad.openstack.org/p/osc-neutron-support
14:03:19 <njohnston> #topic Merged changes
14:03:24 <njohnston> There have been some things that came up since the last meeting.  I just wanted to note them to celebrate the great progress being made, and to keep everyone in the loop.
14:03:34 <njohnston> #link https://review.openstack.org/#/c/326282/
14:04:04 <ajo> wow, nice njohnston thanks for putting that together
14:04:08 <njohnston> that is to add an API test for shared policy, Iztik knocked that one out
14:04:26 <njohnston> #link https://review.openstack.org/#/c/327935/
14:04:26 <ajo> I mean https://etherpad.openstack.org/p/osc-neutron-support :)
14:04:56 <njohnston> ajo: Oh, I can't claim that, I just made sure the QoS commands were listed :-=)
14:06:10 <njohnston> We also closed a couple of bugs, the "VersionsCallbackNotFound exception when using QoS" was fixed by ajo and "qos-policy update without specify --shared causing it change to default False" was fixed by slaweq
14:06:47 <ajo> slawek++ :)
14:06:51 <njohnston> good job all!
14:07:02 <njohnston> #topic Approved RFEs
14:07:15 <njohnston> #link http://tinyurl.com/qos-rfe-approved
14:07:16 <njohnston> #link https://bugs.launchpad.net/neutron/+bug/1468353
14:07:16 <njohnston> DSCP fullstack: I think this is good now, it just needs an additional +2.
14:07:16 <openstack> Launchpad bug 1468353 in neutron "[RFE] QoS DSCP marking rule support" [Wishlist,Fix committed] - Assigned to David Shaughnessy (david-shaughnessy)
14:07:17 <njohnston> Change is: https://review.openstack.org/#/c/288392
14:07:46 <njohnston> that's the last of DSCP
14:08:07 <njohnston> #link https://bugs.launchpad.net/neutron/+bug/1560961
14:08:08 <openstack> Launchpad bug 1560961 in neutron "[RFE] Allow instance-ingress bandwidth limiting" [Wishlist,In progress] - Assigned to Slawek Kaplonski (slaweq)
14:08:19 <njohnston> last I heard, slaweq has stopped working on this pending https://bugs.launchpad.net/neutron/+bug/1586056  (extended validation)
14:08:20 <openstack> Launchpad bug 1586056 in neutron "[RFE] Improved validation mechanism for QoS rules with port types" [Wishlist,In progress] - Assigned to Slawek Kaplonski (slaweq)
14:08:22 <ajo> yes, we need to bring attention to the DSCP fullstack one
14:08:49 <njohnston> I was hoping to catch jschwartz for the dscp fullstack one
14:08:55 <ajo> yes, improved validation blocks a bit our ability to finish the other ones,
14:08:55 <njohnston> but I think I missed him
14:09:04 <ajo> njohnston, we need another +2,
14:09:31 <ajo> may be garyk, let me ping him
14:09:39 <njohnston> ok great
14:09:40 <njohnston> thanks
14:10:02 <njohnston> # https://bugs.launchpad.net/neutron/+bug/1560963
14:10:02 <openstack> Launchpad bug 1560963 in neutron "[RFE] Minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
14:10:21 <ajo> same about rule validation
14:10:33 <ajo> I need to probably raise that topic on the ML
14:10:37 <ralonsoh> Not working very well
14:10:43 <ajo> with the RFE
14:10:47 <ralonsoh> I sent a mail this morning
14:10:51 <ajo> ralonsoh, go ahead, tell us,
14:10:52 <ajo> hmm
14:10:56 <ajo> what's the topic, I missed it
14:11:09 <ralonsoh> No problem, maybe it's better by mail
14:11:11 <ralonsoh> Too long
14:11:40 <ajo> ralonsoh, what's the topic of the email you sent ?
14:11:43 <ajo> just to link it here
14:11:43 <davidsha> http://markmail.org/message/tdcz32cm5qtllm2d
14:11:47 <ajo> thanks :)
14:11:51 <davidsha> no prob :)
14:11:52 <ralonsoh> Egress qos in ovs is not working
14:11:52 <ajo> #link http://markmail.org/message/tdcz32cm5qtllm2d
14:11:56 <ralonsoh> for min bw
14:12:13 <ajo> ralonsoh, I will check, bit it's working for me
14:12:25 <ajo> I tested it, may be theres some detail that needs polishing on your implementation,
14:12:26 <njohnston> #link http://lists.openstack.org/pipermail/openstack-dev/2016-June/097426.html
14:12:35 <njohnston> oh sorry yopu already got the link ajo
14:12:55 <davidsha> njohnston: that one looks nicer :P
14:13:07 <ajo> ralonsoh, how did you arrange the queues/etc ?
14:13:16 <ralonsoh> Yes, qos and queues
14:13:19 <ralonsoh> and ovs flows
14:13:26 <ajo> ralonsoh, I mean, how did you arrange them
14:13:40 <ajo> I'll probably better look at your patch
14:13:42 <ajo> and review it :)
14:13:47 <ralonsoh> ok
14:13:51 <ralonsoh> i need to upload it
14:14:06 <ajo> please upload it as soon as you could, and ping me (IRC / email)
14:14:12 <ralonsoh> ajo: ok
14:14:17 <ajo> ovs / kernel is very nitpickg about how it works
14:14:22 <ajo> it has to be hierarchical
14:14:29 <ajo> and all queues on the outgoing interface
14:14:39 <ajo> or , in a veth from br-int to br-XXXX
14:14:53 <ajo> top queue has the "max" set to the link speed we know about
14:15:03 <ajo> and the queues under it, have min: set as per flow
14:15:18 <ralonsoh> ajo: I know
14:15:21 <ajo> aha
14:15:33 <ajo> ralonsoh, so did you set them on a veth? or the external interface?
14:15:37 <ajo> ok...
14:15:48 <ralonsoh> ajo: on the external interface
14:15:51 <ajo> may be it's just better to try your code locally and see what's wrong
14:15:52 <ralonsoh> but in the ovs port
14:16:06 <ajo> ralonsoh, in the ovs port?
14:16:11 <ralonsoh> ajo: yes
14:16:42 <ajo> what do you mean by the ovs port?
14:17:00 <ralonsoh> in the port connected to the external interface
14:17:07 <ralonsoh> to shape egress traffic
14:17:19 <ajo> hmm
14:17:26 <ajo> do you mean
14:17:33 <ajo> eth0<--->br-ex1 ?
14:17:36 <ajo> eth0 for example ?
14:17:42 <ralonsoh> yes
14:17:44 <ajo> aha
14:17:51 <ajo> ok, yes, that was the suggested approach from ovn
14:18:09 <ajo> but I didn't understand how to match the queue ID at the ovs side to the queue at that interface
14:18:17 <ajo> anyway
14:18:29 <ajo> to do that, I believe you have to set the set_queue flow in the br-ex1
14:18:30 <ajo> not br-int
14:18:37 <ralonsoh> ajo: ok
14:19:28 <njohnston> anything else before we move on?
14:19:36 <ralonsoh> no, thanks
14:19:41 <ajo> ralonsoh, ping me when your code is around, I'll try to test it and help, and thanks a lot for tackling this hard stone :D
14:19:48 <ajo> njohnston, no, thanks :)
14:19:49 <ralonsoh> ajo: ok
14:19:57 <njohnston> #topic Not Yet Approved RFEs
14:20:04 <njohnston> #link http://tinyurl.com/qos-rfe-unapproved
14:20:12 <njohnston> #link https://bugs.launchpad.net/neutron/+bug/1586056
14:20:12 <openstack> Launchpad bug 1586056 in neutron "[RFE] Improved validation mechanism for QoS rules with port types" [Wishlist,In progress] - Assigned to Slawek Kaplonski (slaweq)
14:20:22 <njohnston> Neutron Drivers did not get to it last time
14:20:28 <njohnston> Slaweq has a change up: https://review.openstack.org/#/c/328655/
14:20:52 <ajo> #action ajo publish ML thread about https://bugs.launchpad.net/neutron/+bug/1586056 "[RFE] Improved validation mechanism for QoS rules with port types"
14:21:03 <ajo> we need to bring attention to that one
14:21:16 <njohnston> it will be an interesting discussion
14:21:23 <ajo> it will ':)
14:21:32 <njohnston> #link https://bugs.launchpad.net/neutron/+bug/1580149
14:21:32 <openstack> Launchpad bug 1580149 in neutron "[RFE] Rename API options related to QoS bandwidth limit rule" [Wishlist,Confirmed] - Assigned to Slawek Kaplonski (slaweq)
14:21:46 <njohnston> The way I read the last comment on this, Slaweq thinks this might not be necessary?
14:22:16 <ajo> njohnston, correct, with improved validation, we can forget that one
14:22:50 <njohnston> should it have a status change to reflect that?
14:22:59 <njohnston> or wait until validation susses out a bit?
14:23:12 <ajo> njohnston, I guess wait for validation, I don't know :)
14:23:16 <njohnston> ok
14:23:24 <njohnston> and lastly
14:23:26 <njohnston> #link https://bugs.launchpad.net/neutron/+bug/1505631
14:23:26 <openstack> Launchpad bug 1505631 in neutron "[RFE] QoS VLAN 802.1p Support" [Wishlist,Confirmed] - Assigned to Reedip (reedip-banerjee)
14:23:28 <njohnston> no activity on that one
14:23:35 <ajo> about DSCP fullstack: "<garyk> ajo: done"
14:23:36 <ajo> :-)
14:23:46 <njohnston> Yep, it's in gate now :-)
14:23:56 <njohnston> #topic Bugs
14:24:04 <ajo> njohnston, yes, I guess QoS VLAN seems low prio RFE unless we have more interest or push
14:24:11 <njohnston> yep
14:24:30 <njohnston> #link https://bugs.launchpad.net/neutron/+bug/1587291
14:24:30 <openstack> Launchpad bug 1587291 in neutron "Specifying '-F' or '--filed' parameter in the qos related commands, returns abnormal result" [Undecided,In progress] - Assigned to dongwenshuai (dong-wenshuai)
14:24:46 <njohnston> this is a newish one, filed end of May
14:24:53 <njohnston> There are three changes to fix this: https://review.openstack.org/#/q/topic:bug/1587291
14:25:09 <njohnston> #link https://review.openstack.org/329852
14:25:10 <njohnston> #link https://review.openstack.org/326902
14:25:10 <njohnston> #link https://review.openstack.org/324545
14:25:34 <njohnston> I wanted to mention them here so folks could go take a look
14:25:51 <ajo> oh nice
14:25:54 <ajo> I wasn't aware of it
14:26:20 <njohnston> #link https://bugs.launchpad.net/neutron/+bug/1566514
14:26:20 <openstack> Launchpad bug 1566514 in neutron "Enable sorting and pagination by default" [Wishlist,In progress] - Assigned to Ihar Hrachyshka (ihar-hrachyshka)
14:26:26 <njohnston> This has 9 changes, 2 of which are QoS related: https://review.openstack.org/#/q/topic:bug/1566514
14:26:36 <njohnston> #link https://review.openstack.org/328259
14:26:36 <njohnston> #link https://review.openstack.org/328273
14:26:36 <njohnston> ihrachys is working on these
14:26:58 <ihrachys> reviews welcome
14:27:34 <njohnston> #link https://bugs.launchpad.net/neutron/+bug/1515564
14:27:34 <openstack> Launchpad bug 1515564 in neutron "Internal server error when running qos-bandwidth-limit-rule-update as a tenant" [Low,In progress] - Assigned to Liyingjun (liyingjun)
14:27:51 <njohnston> #link https://review.openstack.org/#/c/244680/
14:27:55 <njohnston> looks like that needs reviews
14:28:46 <njohnston> we also have one new change that does not have a corresponding bug
14:28:49 <njohnston> #link https://review.openstack.org/325889
14:29:21 <ajo> Hmm, I thought I had reviewed this today, I'll do
14:29:37 <ajo> ah, no I started, but I didn't submit :)
14:29:39 <njohnston> that is for adding a tempest scenario test for QoS; iztik is working on it.
14:29:48 <njohnston> ajo: excellent
14:31:08 <njohnston> #topic Open Discussion
14:31:29 <njohnston> overall there was a lot of great work done the last 2 weeks
14:31:35 <njohnston> so kudos to the team
14:31:38 <davidsha> +1
14:31:47 <ajo> yes, awesome folks
14:31:58 <davidsha> quick open, who is going to the mid cycle?
14:32:08 <ralonsoh> yes, good question
14:32:32 <ajo> if you have time, also review: https://review.openstack.org/323474 & https://review.openstack.org/320439 specs (I had already some help there, thanks davidsha & slawek)
14:32:35 <njohnston> my request for travel was declined
14:32:44 <ajo> I think ihrachys requested
14:32:53 <ajo> and I can't (too much pressure on family)
14:33:07 <ihrachys> ajo: there is no approval yet, we are waiting
14:34:01 <ajo> Just as a note, also
14:34:24 <ajo> I will probably be on PTO from Aug 19th to +2 weeks, awful time in terms of feature freeze / RC,
14:34:42 <ajo> I will be reviewing nightly,
14:35:00 <ajo> but I want to sort out things as soon as possible (before) so I don't block or put any extra stress on anybody
14:35:16 <ajo> as it happened previous year (sorry ihrachys  & jlibosva)
14:35:59 <njohnston> thanks ajo
14:36:11 <ajo> I tried to arrange different dates but it's the only time that works with my wife's job :/
14:36:49 <njohnston> So from a high level it looks like the highest priority work in QoS land is the validation patch, yes?  https://review.openstack.org/#/c/328655/
14:37:23 <njohnston> So if folks could give particular attention to reviews on that, there are a number of things that getting it done will unblock.
14:37:26 <ajo> njohnston, first, agreement on that such way is desired and reasonable from the neutron API point of view
14:37:34 <ajo> then the patch could be finally polished and merged
14:38:00 <ajo> if that doesn't work, option B is separate rules per direction (egress/ingress), but ... again we will have the same problem the day we want to add classifier field to the rules
14:38:23 <njohnston> OK, so perhaps we can have that discussion in the drivers meeting.  ajo will you be able to make the next drivers meeting?
14:38:48 <ajo> njohnston, I can try it, but it's 12am/1am here if I don't remember wrong, let me check
14:39:06 <njohnston> I know you had mentioned an ML thread as well, I just don't want it to drag on too long
14:39:27 <ajo> njohnston, agreed
14:39:31 <ajo> no, I have to mention it on ML
14:39:58 <njohnston> ok, I will try to represent if it comes up in drivers
14:40:00 <ajo> yes Thu 00:00 am to 1am
14:40:18 <ajo> I will try to be present as much as I can
14:40:39 <njohnston> ok, anything else anyone wants to bring up?
14:42:15 <njohnston> Hearing nothing, I'll give 18 minuted back.  Good day all!
14:42:18 <njohnston> #endmeeting