14:00:10 <ralonsoh> #startmeeting neutron_qos
14:00:11 <openstack> Meeting started Wed Jan 11 14:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is ralonsoh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'neutron_qos'
14:00:20 <ralonsoh> #chair ralonsoh
14:00:21 <openstack> Current chairs: ralonsoh
14:00:25 <ralonsoh> Hi everyone
14:00:35 <ralonsoh> Happy new Year!
14:00:50 <slaweq__> happy new Year :)
14:00:55 <ralonsoh> I'll wait 1 min
14:00:58 <slaweq__> ok
14:01:32 <ralonsoh> #topic RFEs
14:01:42 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1634798
14:01:42 <openstack> Launchpad bug 1634798 in neutron "[RFE] Qos DSCP to vlan priority mapping" [Wishlist,Confirmed]
14:01:53 <ralonsoh> The same status: no volunteers
14:02:15 <ralonsoh> Anyone?
14:02:51 <ajo> hi :)
14:02:54 <ralonsoh> Hi
14:03:02 <ajo> (I'm around while my other meeting starts)
14:03:09 <ralonsoh> No volunteers for this one...
14:03:21 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1505627:
14:03:21 <openstack> Launchpad bug 1505627 in neutron "[RFE] QoS Explicit Congestion Notification (ECN) Support" [Wishlist,Incomplete] - Assigned to Reedip (reedip-banerjee)
14:03:21 <ajo> is the RFE clear?
14:03:37 <ralonsoh> Nobody replies you
14:03:41 <ralonsoh> to your comment in the bug
14:03:56 <ralonsoh> So I don't think so
14:04:13 <ajo> ':)
14:04:29 <ralonsoh> I'll reply again in the bug
14:04:35 <ralonsoh> just to ask for feedback
14:04:49 <ralonsoh> next one
14:04:51 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1505627
14:04:51 <openstack> Launchpad bug 1505627 in neutron "[RFE] QoS Explicit Congestion Notification (ECN) Support" [Wishlist,Incomplete] - Assigned to Reedip (reedip-banerjee)
14:05:21 <ralonsoh> ajo: you sadi to move this to incomplete
14:05:22 <ajo> that one is also unclear for a long time, let me scan last reedip coments
14:05:32 <ajo> right
14:05:43 <ralonsoh> nothing since May
14:06:07 <ralonsoh> What should we do?
14:06:23 <ajo> Keep it to incomplete until they provide a clearer use case, I guess
14:06:29 <ralonsoh> ok
14:06:37 <ralonsoh> no more RFEs
14:06:50 <ralonsoh> #topic Bugs
14:06:59 <ralonsoh> https://bugs.launchpad.net/neutron/+bug/1653882
14:06:59 <openstack> Launchpad bug 1653882 in neutron "Creation of QOS policy name with too long name returns "Request Failed: internal server error while processing your request." instead of "Bad Request" error" [Undecided,Incomplete] - Assigned to Reedip (reedip-banerjee)
14:06:59 <ralonsoh> In progress
14:07:20 <ralonsoh> I assigned and going on
14:07:29 <ajo> ralonsoh++
14:07:40 <slaweq__> looks like quite easy bug :)
14:07:49 <ralonsoh> I think so
14:07:51 <ralonsoh> next one
14:07:54 <ralonsoh> https://bugs.launchpad.net/neutron/+bug/1649720
14:07:55 <openstack> Launchpad bug 1649720 in neutron " DSCP packet marking support in Linuxbridge agent" [Undecided,New]
14:08:00 <ralonsoh> slaweq: should be closed??
14:08:14 <slaweq__> yep
14:08:19 <slaweq__> it's about docs update
14:08:24 <ralonsoh> ok
14:08:27 <ralonsoh> I'll close it
14:08:33 <slaweq__> but as I wrote in comment there is no docs to update there
14:08:35 <slaweq__> thx
14:08:50 <ralonsoh> next one
14:08:52 <ralonsoh> https://bugs.launchpad.net/neutron/+bug/1649517
14:08:53 <openstack> Launchpad bug 1649517 in neutron "qos policy attached to network, qos_policy_id is reflecting on neutron net-show , but not on the port with neutron port-show" [Wishlist,New]
14:08:59 <ralonsoh> ajo: should be closed?
14:09:28 <ajo> let me re-read
14:09:50 <ajo> ah, I remember
14:09:52 <ajo> any opinions on this?
14:10:03 <ralonsoh> the same as you
14:10:22 <slaweq__> IMHO it could be good idea to display it separately in port info
14:10:24 <ajo> the alternative is providing a read only field with: (port.qos_policy_id or port.network.qos_policy_id)
14:10:27 <slaweq__> so port_policy_id
14:10:31 <slaweq__> and network_policy_id
14:10:40 <slaweq__> but it's change in API so can be hard :/
14:10:42 <ajo> well, we couldn't change exiting one for now
14:10:45 <ajo> adding is easy
14:10:54 <ralonsoh> but not change
14:10:55 <ajo> removing in the future, hard
14:11:02 <slaweq__> so add field network_policy_id
14:11:17 <slaweq__> and remain policy_id as "port_policy_id"
14:11:36 <ajo> yes
14:11:48 <ajo> my opinion is not strong
14:11:57 <ralonsoh> slaweq: do you want to take this bug?? do you have time?
14:12:10 <slaweq__> ralonsoh: I can
14:12:16 <ralonsoh> perfect!
14:12:22 <ajo> if you think it's beneficial, of course, let's go ahead :)
14:12:26 <slaweq__> great, so I will try to do it
14:12:39 <ajo> I think it'll be more self explanatory to the users,
14:12:49 <ajo> slaweq__++
14:13:10 <ralonsoh> next one
14:13:13 <ralonsoh> https://bugs.launchpad.net/neutron/+bug/1649503
14:13:13 <openstack> Launchpad bug 1649503 in neutron "Mechanism driver can't be notified with updated network" [High,In progress] - Assigned to Hong Hui Xiao (xiaohhui)
14:13:24 <ralonsoh> there is a patch
14:13:39 <ralonsoh> but not continued
14:13:48 <ralonsoh> I'll talk to the owner
14:13:58 <ralonsoh> If the owner doesn't reply, I'll take this bug
14:14:01 <ajo> my meeting starts, brb
14:14:07 <ralonsoh> bye!
14:14:41 <ralonsoh> ok, so I'll follow this bug
14:14:44 <slaweq__> ok
14:14:51 <ralonsoh> https://bugs.launchpad.net/neutron/+bug/1640762
14:14:51 <openstack> Launchpad bug 1640762 in neutron "when I update a Qos policy, value of shared can not be changed to false from true" [Undecided,Incomplete] - Assigned to Slawek Kaplonski (slaweq)
14:15:03 <ralonsoh> no progress
14:15:07 <slaweq__> yep
14:15:09 <ralonsoh> no feedback
14:15:13 <ralonsoh> I'll ask again
14:15:20 <slaweq__> and I cannot reproduce it :/
14:15:25 <slaweq__> as I wrote in comment
14:15:29 <ralonsoh> yes, that's the problem
14:15:31 <slaweq__> IMHO there is no bug in fact
14:15:35 <ralonsoh> we need more feddback
14:15:40 <ralonsoh> yes, I know
14:15:47 <slaweq__> ok, so we will still wait
14:15:55 <ralonsoh> just if you can ask again
14:16:02 <slaweq__> ok, I will try
14:16:06 <ralonsoh> thanks!
14:16:16 <ralonsoh> https://bugs.launchpad.net/neutron/+bug/1640757
14:16:16 <openstack> Launchpad bug 1640757 in neutron "Parameter validation for string type parameters" [Undecided,Incomplete] - Assigned to Slawek Kaplonski (slaweq)
14:16:19 <slaweq__> #action slawek ask about https://bugs.launchpad.net/neutron/+bug/1640762
14:16:19 <openstack> Launchpad bug 1640762 in neutron "when I update a Qos policy, value of shared can not be changed to false from true" [Undecided,Incomplete] - Assigned to Slawek Kaplonski (slaweq)
14:16:34 <ralonsoh> tha same problem
14:16:41 <ralonsoh> no feedback
14:16:44 <slaweq__> exactly
14:16:49 <slaweq__> and IMHO also no issue here
14:17:01 <ralonsoh> I think the same as you
14:17:05 <ralonsoh> so, ask again
14:17:13 <ralonsoh> if no reply, we can close it
14:17:32 <slaweq__> I think so
14:17:39 <ralonsoh> next one
14:17:43 <ralonsoh> https://bugs.launchpad.net/neutron/+bug/1639220
14:17:43 <openstack> Launchpad bug 1639220 in neutron "[RFE] Default action for RBAC" [Undecided,New]
14:17:45 <ralonsoh> for ajo
14:18:02 <ralonsoh> #action ajo reply with status of this bug: https://bugs.launchpad.net/neutron/+bug/1639220
14:18:03 <slaweq__> this is new one
14:18:15 <ralonsoh> yes
14:18:28 <ralonsoh> but we need ajo's knowledge in this one
14:18:40 <ralonsoh> because he has a talk with Kevin
14:18:40 <slaweq__> yep
14:18:48 <ralonsoh> so action for ajo
14:18:57 <slaweq__> ok
14:19:01 <ralonsoh> next one
14:19:04 <ralonsoh> https://bugs.launchpad.net/neutron/+bug/1639186
14:19:04 <openstack> Launchpad bug 1639186 in neutron "qos max bandwidth rules not working for neutron trunk ports" [Low,Confirmed] - Assigned to Luis Tomas Bolivar (ltomasbo)
14:19:18 <ralonsoh> I don't know what is happening....
14:19:27 <ralonsoh> the same problem
14:19:35 <slaweq__> in comments there is no anything new about it
14:20:07 <ralonsoh> this bug involves a lot of things
14:20:12 <ralonsoh> trunks ports
14:20:14 <ralonsoh> and qos
14:20:30 <ralonsoh> Right now, I don't think we can solve this
14:20:45 <slaweq__> I agree
14:21:08 <ralonsoh> But, I need to talk to ajo, because it's important to have qos on trunks
14:21:10 <davidsha> Hi, sorry I'm late
14:21:17 <ralonsoh> hi David
14:21:18 <slaweq__> hello davidsha
14:21:32 <ralonsoh> ok, last one
14:21:34 <ralonsoh> https://bugs.launchpad.net/neutron/+bug/1630748
14:21:34 <openstack> Launchpad bug 1630748 in neutron "project_id is not present on all resources" [High,In progress] - Assigned to Darek Smigiel (smigiel-dariusz)
14:21:41 <ralonsoh> It's finished
14:21:47 <ralonsoh> So I'll close it manually
14:22:11 <ralonsoh> there are patches for newton and master
14:22:30 <slaweq__> ok
14:22:33 <ralonsoh> no more bugs
14:22:42 <ralonsoh> in the list
14:22:48 <ralonsoh> anyone has another bug?
14:23:07 <slaweq__> I don't have anything new
14:23:15 <ralonsoh> ok
14:23:17 <ralonsoh> #topic Other Changes
14:23:23 <ralonsoh> nothing in the list
14:23:29 <ralonsoh> anyone??
14:23:50 <slaweq__> ralonsoh: I reviewed Your huge patch with ingress limit for linuxbridge :)
14:23:57 <ralonsoh> hehehe
14:24:00 <ralonsoh> thanks!
14:24:02 <ralonsoh> I know
14:24:10 <ralonsoh> now I need a core to take a look
14:24:17 <ralonsoh> uhmmm ajo!
14:24:29 <ralonsoh> #action ajo review  https://review.openstack.org/#/c/357865/
14:24:49 <slaweq__> it can be hard to You to find 2 cores who will review it :)
14:25:06 <ralonsoh> I know... I need this one for the RFE strict min bw support
14:25:18 <ralonsoh> ok
14:25:23 <ralonsoh> #topic Open Discussion
14:25:32 <ralonsoh> I have one
14:25:45 <ralonsoh> The BW manager for qos in SRIOV
14:25:46 <ralonsoh> https://review.openstack.org/#/c/401254/
14:26:05 <ralonsoh> is low priority, but could be fine to have some reviews
14:26:31 <ralonsoh> anyone have any query?
14:26:41 <ralonsoh> need for reviews??
14:26:57 <slaweq__> ok, I will try to look on it asap
14:27:04 <ralonsoh> Thank you!!
14:27:07 <slaweq__> but I'm not sriov expert so ...
14:27:25 <ralonsoh> ATLANTA PTG planning!
14:27:31 <ralonsoh> Who is going??
14:27:36 <slaweq__> btw. do You know what is happening with https://review.openstack.org/#/c/396297/3/specs/ocata/strict-minimum-bandwidth-support.rst ?
14:27:44 <slaweq__> ajo assigned me to one of points
14:28:02 <slaweq__> but I don't know in fact if/when I can/should start working on it :)
14:28:02 <ralonsoh> Yes, it's for the next release
14:28:17 <ralonsoh> That's the point: we need to talk with ajo during this meetings
14:28:24 <ralonsoh> I'm doing the first part
14:28:42 <ralonsoh> The previous link: https://review.openstack.org/#/c/401254/
14:28:54 <slaweq__> yep, I know
14:29:10 <slaweq__> I was reviewing BW manager patches for ovs and/or linuxbridge
14:29:19 <ralonsoh> We need also Miguel Lavalle to attend this meeting
14:29:20 <slaweq__> right?
14:29:22 <ralonsoh> yes
14:29:24 <slaweq__> :)
14:29:29 <ralonsoh> and thank you!!
14:29:37 <slaweq__> no prob
14:30:00 <ralonsoh> so, are you going to Atlanta?
14:30:02 <slaweq__> about Atlanta, I'm not going there
14:30:13 <ralonsoh> 8-(
14:30:18 <davidsha> D:
14:30:19 <ralonsoh> Sorry about that
14:30:27 <slaweq__> are You going?
14:30:36 <ralonsoh> If I can go, I'll skype you during the meeting
14:31:25 <slaweq__> would be great
14:31:42 <ralonsoh> is something missing today??
14:32:18 <davidsha> We've covered rfe's, bugs and opens?
14:32:23 <ralonsoh> yes
14:32:33 <ajo> sorry guys, I'm back
14:32:36 <ajo> finished the other meeting
14:32:46 <ralonsoh> almost finish
14:32:47 <slaweq__> You are fast :P
14:32:49 <ralonsoh> no problem
14:33:00 <ralonsoh> Two questions
14:33:04 <ralonsoh> https://bugs.launchpad.net/neutron/+bug/1639220
14:33:04 <openstack> Launchpad bug 1639220 in neutron "[RFE] Default action for RBAC" [Undecided,New]
14:33:13 <ralonsoh> ajo: status?
14:33:22 <ajo> ralonsoh opening the link you posted for review
14:33:47 <ajo> ralonsoh about RBAC default action?
14:33:52 <ralonsoh> yes
14:34:21 <ajo> oh, we could do that, but not the way it was proposed
14:34:30 <ajo> I talked about that with kevinbenton once, and
14:34:43 <ajo> "a default" doesn't make sense in the role based access
14:35:03 <ajo> we could include it in the QoS API if we wanted
14:35:22 <ajo> let me answer again to see if it makes sense to Jens
14:35:26 <ralonsoh> ok
14:35:48 <ralonsoh> If the spec is redefined, I can take this bug
14:36:12 <ajo> ralonsoh
14:36:19 <ajo> how would you define the openstack cli command for this?
14:36:33 <ajo> if we wanted to provide some sort of "default" policy
14:36:51 <ralonsoh> I mean: if you redefine the spec of the bug
14:37:22 <ajo> yes, something very basic in terms of openstack-cli
14:38:23 <ralonsoh> ok, so you will add a new definition in the bug?
14:38:34 <ralonsoh> just to know how to proceed
14:38:39 <ajo> hmm
14:38:42 <ajo> may be
14:38:55 <ajo> openstack network qos policy default set <qos-policy-id> ?
14:39:21 <ajo> I'm seeing a similar pattern with:
14:39:22 <ajo> network ip floating list
14:39:23 <ajo> and
14:39:27 <ajo> network ip floating pool list
14:39:27 <ajo> commands
14:39:49 <ralonsoh> yes, I see
14:39:58 <ralonsoh> Ok, I'll write this in the bug
14:39:59 <ajo> network qos policy default (create/set/delete)
14:40:04 <ajo> ack
14:40:06 <ajo> I'll add that
14:40:18 <ralonsoh> and I'll submit a patch
14:41:01 <ralonsoh> one more, ajo
14:41:02 <ralonsoh> https://review.openstack.org/#/c/357865/
14:41:13 <ralonsoh> LB with min QOS
14:41:32 <ralonsoh> I need a core
14:41:37 <ralonsoh> to review it
14:41:42 <slaweq__> good luck with this one ajo :)
14:41:45 <slaweq__> it's big
14:41:49 <ralonsoh> sorry for that...
14:42:01 <ajo> ack ':D
14:42:11 <ajo> ralonsoh sorry?, thank you ;D
14:42:14 <slaweq__> but IMO it's good
14:42:27 <davidsha> There was also an SR-IOV one right?
14:42:36 <ralonsoh> yes, but low priority
14:42:45 <ralonsoh> the first part of strict bw
14:42:47 <davidsha> kk, link for ref: https://review.openstack.org/#/c/401254/
14:43:08 <ralonsoh> just to know if i'm going in the right direction
14:43:53 <ralonsoh> Nothing but me....
14:43:57 <ralonsoh> Anything else?
14:44:12 <ajo> hmm, the meeting time switch,
14:44:18 <ralonsoh> yes!!!
14:44:22 <ajo> if we call can in any of the timeslots I suggested :)
14:44:27 <ajo> call can?
14:44:29 <ajo> all can...
14:44:35 <ralonsoh> yes, all of them
14:44:39 <slaweq__> for me all of them was fine
14:44:40 <ralonsoh> david??
14:44:48 <ajo> let me look them up again, 1 sec
14:44:53 <ralonsoh> possible timeslots I found for QoS: Tuesdays @ 16:00 UTC  (after the neutron main meeting),  Mondays @ 15:00 UTC,  Thursdays @ 15:00 UTC
14:45:05 <davidsha> those are the times proposed on the main neutron channel right? I'm happy with those.
14:45:21 <ajo> thanks ralonsoh
14:45:57 <ajo> any preference?
14:46:10 <ralonsoh> tuesdays
14:46:19 <slaweq__> ok for tuesday
14:46:33 <davidsha> Tuesday is good
14:46:39 <ralonsoh> perfect!
14:47:17 <ralonsoh> ajo: do you know how to change it?
14:47:19 <ralonsoh> I don't
14:47:21 <ajo> ok, I'll propose a patch right away
14:47:22 <ajo> thank you floks
14:47:23 <ajo> folks
14:47:28 <ralonsoh> thanks
14:47:28 <ajo> yeah, it's a patch to irc-meetings repo
14:47:32 <ralonsoh> ok
14:47:38 <ralonsoh> so anything else?
14:48:10 <ralonsoh> I end the meeting
14:48:14 <ralonsoh> #endmeeting