15:00:02 <ralonsoh> #startmeeting neutron_qos
15:00:03 <openstack> Meeting started Tue Mar 28 15:00:02 2017 UTC and is due to finish in 60 minutes.  The chair is ralonsoh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <openstack> The meeting name has been set to 'neutron_qos'
15:00:13 <ralonsoh> Hello!
15:01:04 <davidsha> hi
15:01:15 <ralonsoh> hi davidsha
15:02:03 <reedip> tuesday is the Networking Day !
15:02:14 <ralonsoh> you are right!
15:02:33 <ralonsoh> ok, let's start
15:02:49 <ralonsoh> I hope ajo and slaweq join us ASAP
15:02:58 <ralonsoh> and mlavalle
15:03:05 <ralonsoh> #topic RFEs
15:03:13 <mlavalle> o/
15:03:24 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1505627
15:03:24 <openstack> Launchpad bug 1505627 in neutron "[RFE] QoS Explicit Congestion Notification (ECN) Support" [Wishlist,New] - Assigned to Reedip (reedip-banerjee)
15:03:30 <ralonsoh> Hi mlavalle
15:03:38 <ralonsoh> reedip, I know
15:03:44 <ralonsoh> we need to review the spec
15:03:58 <ralonsoh> my bad: I didn't have time last week
15:04:14 <ralonsoh> I'll review this spec tomorrow morning
15:04:16 <reedip> ralonsoh : no updates on this. Yeah awaiting your review but also trying to get the working Env up for yamamoto's comments
15:04:21 <reedip> thanks ralonsoh
15:04:40 <ralonsoh> how do you write a todo for someone?
15:04:47 <reedip> #action
15:04:48 <ralonsoh> yes
15:04:51 <davidsha> /action
15:05:14 * ralonsoh ralonsoh to review https://review.openstack.org/#/c/445762/
15:05:21 <reedip> #action ralonsoh will review https://bugs.launchpad.net/neutron/+bug/1505627
15:05:21 <openstack> Launchpad bug 1505627 in neutron "[RFE] QoS Explicit Congestion Notification (ECN) Support" [Wishlist,New] - Assigned to Reedip (reedip-banerjee)
15:05:30 <ralonsoh> next one
15:05:34 <reedip> like this ... I am not the chair so my action wont work
15:05:49 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1634798
15:05:50 <openstack> Launchpad bug 1634798 in neutron "[RFE] Qos DSCP to vlan priority mapping" [Wishlist,Incomplete]
15:06:16 <ralonsoh> now is in incomplete status
15:06:28 <ralonsoh> no feedback from the submitter
15:06:39 <ralonsoh> I'll remove this one from the list until we have something
15:06:51 <ralonsoh> next one
15:06:53 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1657089
15:06:53 <openstack> Launchpad bug 1657089 in neutron "[RFE]Add bandwidth_limit to vip" [Undecided,New]
15:07:08 <ralonsoh> My question here is: should we move this one to Octavia??
15:07:30 <ralonsoh> I'll ask this in the bug
15:07:56 <davidsha> Would this not be something for lbaas repo?
15:08:07 <ralonsoh> yes, that's the point
15:08:13 <reedip> ralonsoh : hi
15:08:21 <reedip> zhaobo and I am working on a spec for this :D
15:08:33 <ralonsoh> reedip: ok
15:08:39 <davidsha> kk, is there a link?
15:08:42 <reedip> wait, lemme find the link
15:08:49 <ralonsoh> but shouldn't be in lbaas?
15:09:04 <reedip> the affected project would be octavia
15:09:33 <ralonsoh> so please change the project
15:10:11 <ralonsoh> do you have the link?
15:10:20 <ralonsoh> You can add it to the bug
15:10:30 <reedip> hi
15:10:30 <reedip> https://review.openstack.org/#/c/441912/
15:10:30 <reedip> this is the link
15:11:00 <reedip> done !
15:11:07 <ralonsoh> Thanks!
15:11:41 <ralonsoh> ok, I updated the link in the bug
15:11:44 <ralonsoh> next one
15:11:52 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1596611
15:11:52 <openstack> Launchpad bug 1596611 in neutron "[RFE] Create L3 IPs with qos (rate limit)" [Wishlist,In progress] - Assigned to LIU Yulong (dragon889)
15:11:58 <ralonsoh> The spec is almost finished
15:12:30 <ralonsoh> #link https://review.openstack.org/#/c/374506/
15:12:47 <ralonsoh> Please take a last review to this spec
15:13:12 <reedip> will do ralonsoh
15:13:17 <ralonsoh> the last one
15:13:20 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1639220
15:13:20 <openstack> Launchpad bug 1639220 in neutron "[RFE] Introduce Network QoS policy "is_default" behaviour" [Low,In progress] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
15:13:40 <ralonsoh> ok, this one is beginning to worry me
15:13:56 <ralonsoh> there is no progress at all
15:14:01 <reedip> reviews ?
15:14:03 <slaweq> hello
15:14:07 <slaweq> sorry for late
15:14:17 <ralonsoh> the first patch is https://review.openstack.org/#/c/401254/
15:14:21 <ralonsoh> hi slaweq
15:14:23 <reedip> ok, I was hoping for reviews and slaweq is here :)
15:14:28 <ralonsoh> I would like a core to review it
15:14:53 <reedip> ralonsoh : you could have asked it in the Weekly meeting of Neutron earlier
15:15:01 <reedip> but you can ping them now ...
15:15:19 <ralonsoh> with this we could continue and mlavalle could start doing the API to Nova
15:15:31 <ralonsoh> I know
15:15:44 <slaweq> yes, and I will probably can start doing displaying it in port_info
15:15:51 <davidsha> ralonsoh: gary reviewed it yesterday and Ihar was discussing with you on the bug, ping them both to have a look.
15:15:52 <ralonsoh> We have a lack of core support in this group
15:16:07 <mlavalle> ralonsoh: I am a core
15:16:11 <ralonsoh> I know
15:16:20 <mlavalle> I will take a look in that review
15:16:23 <ralonsoh> and we need all core possible support
15:16:42 <ralonsoh> in all the RFE and bugs in progress
15:17:13 <ralonsoh> mlavalle: when are you planning to start https://review.openstack.org/#/c/396297/5/specs/pike/strict-minimum-bandwidth-support.rst
15:17:20 <ralonsoh> bullets 2 and 3
15:17:27 <ralonsoh> in work items
15:17:43 <mlavalle> ralonsoh: I was really waiting for the spec to merge
15:18:03 <ralonsoh> yes... we need this first!
15:18:12 <ralonsoh> ok, I'll try to fix this this week
15:18:13 <mlavalle> I actually +2 the spec some days ago
15:18:19 <ralonsoh> I know hehehe
15:18:24 <ralonsoh> ok, no problem
15:18:34 <mlavalle> ralonsoh: but I can start right away
15:18:43 <ralonsoh> no rush
15:18:56 <ralonsoh> ok, next topic
15:18:57 <ralonsoh> #topic Bugs
15:19:08 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1676877
15:19:08 <openstack> Launchpad bug 1676877 in neutron "Increase "TestQosPlugin.test_update_policy_rule" coverage" [Medium,New] - Assigned to Reedip (reedip-banerjee)
15:19:22 <reedip> I JUST got it
15:19:26 <ralonsoh> are you ok with the tests??
15:19:29 <ralonsoh> perfect!
15:19:39 <ralonsoh> do you still have problems?
15:19:50 <reedip> Yes ralonsoh , I have some issues but I will be working on it
15:19:58 <ralonsoh> perfect
15:20:08 <ralonsoh> I'll review your next patch
15:20:09 <reedip> if you would like to increase the Importance to High, please be my guest :)
15:20:27 <ralonsoh> I don't think I'm allowed to do this....
15:20:31 <ralonsoh> yet
15:20:52 <ralonsoh> next one
15:20:57 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1667138
15:20:57 <openstack> Launchpad bug 1667138 in neutron "Minumum bandwidth can be higher than maximum bandwidth limit in same QoS policy" [Medium,In progress] - Assigned to Reedip (reedip-banerjee)
15:21:07 <ralonsoh> the patch is almost finished
15:21:09 <reedip> linked with the earlier bug :)
15:21:22 <reedip> actually the above bug was found by this patch :D
15:21:28 <mlavalle> I have made reviws for that patchset
15:21:28 <ralonsoh> yes, you are right
15:21:44 <reedip> yeah guys, thanks for your reviews
15:21:53 <mlavalle> I can look again
15:22:01 <ralonsoh> perfect
15:22:02 <reedip> now I just hope to finish thios
15:22:25 <ralonsoh> we will wait for it
15:22:30 <mlavalle> reedip: please give me the link and I'll review it today
15:22:32 <reedip> sure mlavalle, though I would like to add the test case if is not yet up
15:22:40 <ralonsoh> https://review.openstack.org/#/c/442375/
15:22:57 <ralonsoh> this is the link mlavalle
15:22:59 <reedip> aah thanks ralonsoh :)
15:23:01 <mlavalle> reddahh ok, I'll star it in my gerrit and will wait for the test
15:23:10 <ralonsoh> fantastic
15:23:10 <mlavalle> reedip: ^^^
15:23:27 <ralonsoh> next one
15:23:31 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1663908
15:23:31 <openstack> Launchpad bug 1663908 in neutron "Qos rules not cleaned by L2 agent" [Undecided,In progress] - Assigned to David Shaughnessy (david-shaughnessy)
15:23:44 <ralonsoh> I think the code is to be merged
15:23:47 <ralonsoh> #link https://review.openstack.org/#/c/449710/
15:24:09 <ralonsoh> davidsha
15:24:12 <reedip> mlavalle : I thought you were saying yeaaah !! :D
15:24:18 <ralonsoh> try to ping garyk
15:24:19 <davidsha> It had a +2 from Gark, I'll ping him and ask for a follow up when he has the time
15:24:30 <ralonsoh> perfect!
15:24:37 <ralonsoh> because this is almost done
15:24:48 <ralonsoh> next one
15:24:53 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1662109
15:24:53 <openstack> Launchpad bug 1662109 in neutron "tempest scenario test_qos fails intermittently" [High,Confirmed] - Assigned to Miguel Angel Ajo (mangelajo)
15:24:56 <mlavalle> I will take also a look
15:25:04 <mlavalle> I mean the previous one
15:25:11 <ralonsoh> ajo: are you there?
15:25:14 <davidsha> mlavalle: Thank you!
15:25:42 <ralonsoh> this bug should be closed because the patches (removing the tests) are merged
15:25:50 <ralonsoh> I'll ping ajo to do this
15:26:17 <ralonsoh> next one
15:26:22 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1659265
15:26:22 <openstack> Launchpad bug 1659265 in neutron "Network level QoS policies should apply to network:router_gateway" [Wishlist,In progress] - Assigned to Maxime (maxime-guyot-p)
15:26:31 <ralonsoh> almost the same
15:26:42 <ralonsoh> the code is ok and should be merged asap
15:26:47 <mlavalle> I also reviewed that one
15:27:02 <mlavalle> give me the link and I'll look again
15:27:03 <ralonsoh> mlavalle: I saw that! perfect
15:27:07 <ralonsoh> https://review.openstack.org/#/c/425218/
15:27:19 <ralonsoh> is waiting for other core
15:27:24 <mlavalle> ah ok
15:27:32 <ralonsoh> 5 +1 and one +2
15:27:53 <ralonsoh> I'll ask in the neutron irc channel
15:28:16 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1649517
15:28:16 <openstack> Launchpad bug 1649517 in neutron "qos policy attached to network, qos_policy_id is reflecting on neutron net-show , but not on the port with neutron port-show" [Wishlist,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:28:35 <slaweq> I didn't do anything on it
15:28:42 <ralonsoh> ok, I know
15:28:57 <ralonsoh> there are other patches with higher priority
15:28:59 <ralonsoh> no problem
15:29:08 <slaweq> in fact I'm not sure if I should write specs for it
15:29:11 <slaweq> or not?
15:29:24 <ralonsoh> ajo proposed to make a rfe
15:29:29 <ralonsoh> so I think so
15:29:44 <ralonsoh> change the topic in the bug to RFE
15:29:56 <slaweq> ok, I will update
15:29:56 <ralonsoh> and I think you should write it
15:30:03 <ralonsoh> perfect and thanks!
15:30:04 <slaweq> *update it
15:30:09 <reedip> slaweq : I can take it up if the other bugs are done from my side, lemme know if thats ok ?
15:30:23 <ralonsoh> reedip: do you want one?
15:30:24 <slaweq> ok, just take it if You want
15:30:26 <ralonsoh> the nex tone
15:30:30 <ralonsoh> next one
15:30:38 <reedip> ralonsoh : which one ?
15:30:44 <ralonsoh> the last bug
15:30:48 <ralonsoh> #link https://bugs.launchpad.net/neutron/+bug/1649503
15:30:48 <openstack> Launchpad bug 1649503 in neutron "Mechanism driver can't be notified with updated network" [High,In progress] - Assigned to Hong Hui Xiao (xiaohhui)
15:30:58 <ralonsoh> There was a patch submitted
15:30:59 <ralonsoh> one sec
15:31:11 <ralonsoh> #link https://review.openstack.org/#/c/410101/
15:31:15 <ralonsoh> 3 months ago
15:31:20 <ralonsoh> and that's all
15:31:29 <ralonsoh> If you can take this one, perfect!
15:31:34 <reedip> ralonsoh : ok , I will take this one !
15:31:39 <slaweq> it's still waiting for kevinbenton opinion :)
15:31:57 <ralonsoh> which one?
15:32:26 <ralonsoh> slaweq: which one is waiting for kevin opinion?
15:32:46 <slaweq> https://review.openstack.org/#/c/410101/  <-- this one
15:32:57 <ralonsoh> ??
15:33:03 <ralonsoh> it's a joke, isn't it?
15:33:20 <reedip> hahahaha :)
15:33:32 <slaweq> no, armax asked for kevinbenton opinion in comment in review for this patch
15:33:48 <ralonsoh> ohhhhh yes!
15:33:56 <ralonsoh> https://review.openstack.org/#/c/410101/1/neutron/plugins/ml2/plugin.py
15:34:00 <ralonsoh> ok, reedip
15:34:29 <ralonsoh> please, take a look at this patch, the bug and ask us if you have a better alternative
15:34:30 <reedip> ok, I am asking for Kevin's suggestion on it
15:34:34 <ralonsoh> and also ask Kevin
15:34:36 <ralonsoh> yes!
15:34:43 <reedip> and looking at a better solution if possible
15:34:44 <ralonsoh> and that's all
15:34:47 <ralonsoh> next topic
15:34:54 <ralonsoh> #topic Other Changes
15:35:07 <ralonsoh> there is no agenda
15:35:12 <ralonsoh> any suggestion?
15:35:31 <slaweq> if I can
15:35:37 <ralonsoh> of course
15:35:37 <slaweq> I would ask for review for https://review.openstack.org/#/c/426946/
15:35:47 <slaweq> it's already +2 from garyk and ralonsoh
15:35:56 <slaweq> but I need another core to review it :)
15:36:10 <ralonsoh> yes, I don't know why I didn't put this in the list....
15:36:11 <mlavalle> slaweq: I will take a look
15:36:13 <slaweq> maybe mlavalle could do this? :)
15:36:16 <slaweq> mlavalle: thx
15:36:31 <ralonsoh> This patch has several +1 and one +2
15:36:35 <mlavalle> slaweq: it's a little big, so expect it to happen over the next 2 3 days
15:36:38 <mlavalle> ok?
15:36:46 <slaweq> mlavalle: that's fine for me
15:36:51 <slaweq> better in 3 days than never :P
15:36:56 <ralonsoh> mlavalle: thanks a lot!
15:37:07 <mlavalle> ralonsoh: in general....
15:37:20 <mlavalle> I see this team is doing a lot of work
15:37:21 <slaweq> if this will be merged finally I will be able to move forward with ingress bw limits
15:37:35 <davidsha> I have something as well...
15:37:43 <mlavalle> so if you need core attention, I will be glad to prioritize this team
15:37:52 <ralonsoh> mlavalle: fantastic
15:37:57 <ralonsoh> davidsha: please, go on
15:38:00 <davidsha> About object versioning... I've been told how we use it is not how it's intended to be used, should we look into how other projects are using it?
15:38:03 <reedip> slaweq : yes , thats a great addition... and thanks a lot mlavalle
15:38:05 <mlavalle> The only caveat is that I don't consider myself a QoS expert
15:38:24 <mlavalle> so I will get up to speed over the next few weeks
15:38:35 <mlavalle> I will go over the devref and the docs and the code
15:38:36 <ralonsoh> davidsha: do you have examples?
15:38:48 <mlavalle> do we have an understanding where I am?
15:39:05 <ralonsoh> mlavalle: yes, of course
15:39:11 <mlavalle> cool
15:39:57 <ralonsoh> davidsha: ?
15:40:07 <davidsha> ralonsoh: not on hand, but what I've been told is it should be using the version to modify interal variables to conform to lower API versions, what we use it for now is micro versioning and throwing exception when the version is lower that a given qos rule is introduced
15:40:36 <ralonsoh> davidsha: you are right
15:40:43 <ralonsoh> and we should change that
15:41:00 <ralonsoh> davidsha: do you have time to open a bug for this?
15:41:09 <davidsha> Will I file a bug and should we make it a priority for this release?
15:41:09 <ralonsoh> (whishlist, please!)
15:41:15 <davidsha> Ack
15:41:20 <ralonsoh> no no
15:41:33 <ralonsoh> we don't have enough hands!!
15:41:42 <ralonsoh> and thanks for the heads up
15:41:49 <mlavalle> LOL
15:41:53 <ralonsoh> hehehe
15:42:05 <ralonsoh> ok, next topic
15:42:07 <ralonsoh> #topic Open Discussion
15:42:07 <davidsha> no problem!
15:42:17 <ralonsoh> the same: no agenda here
15:42:36 <ralonsoh> anyone has a new topic?
15:43:00 <ralonsoh> ok
15:43:11 <ralonsoh> thank you very much for attending
15:43:19 <ralonsoh> and see you in two weeks
15:43:22 <reedip> anyone ot any topic selected in Boston ?
15:43:27 <ralonsoh> (and IRC every day)
15:43:34 <ralonsoh> uhmmm
15:43:36 <reedip> oh we are ending ??? Bye then :D
15:43:42 <ralonsoh> is anyone here going to Boston?
15:43:44 <reedip> never mind, ignore me
15:43:45 <ralonsoh> no no
15:43:48 <ralonsoh> no problem
15:43:49 <reedip> hehe
15:43:54 <ralonsoh> I'm not going to Boston
15:44:19 <ralonsoh> and I did't take a look at the talks
15:44:19 <reedip> neither am I  , but thought of asking out if any QoS presentation got selected ?
15:44:20 <reedip> :)
15:44:28 <slaweq> me neither
15:44:28 <ralonsoh> I need to check this
15:44:39 <reedip> I gave the ECN talk but they didnt select it
15:45:02 <ralonsoh> better luck next time!! once you have the code marged
15:45:05 <ralonsoh> merged
15:45:23 <mlavalle> ralonsoh: I'll be in Boston
15:45:32 <ralonsoh> Lucky you!
15:45:39 <ralonsoh> send pictures
15:45:39 <davidsha> We'll have to try a combined QoS talk for the next summit, we didn't submit one this time did we?
15:45:54 <ralonsoh> davidsha: that's a very good idea!
15:45:55 <mlavalle> ralonsoh: LOL, will do
15:46:19 <ralonsoh> and we have enough topics and material to do this
15:46:36 <reedip> davidsha : thats in Australia , Mate !
15:46:42 <mlavalle> yeah, taht is stating the obvious. Lots of activity here
15:46:43 <slaweq> yeah but it will be in Sydney so can be quite expensive trip
15:47:14 <reedip> slaweq : but a good QoS talk is worth a trip to Sydney !
15:47:15 <ralonsoh> crowdfunding is the solution!!
15:47:16 <reedip> :d
15:47:17 <ralonsoh> heheheh
15:47:33 <reedip> ralonsoh : we need a Big Crowd !
15:47:34 <ralonsoh> OK, thank you guys. See you in two weeks.
15:47:34 <slaweq> reedip: for sure
15:47:44 <reedip> c ya
15:47:47 <davidsha> Thanks guys, see ya!
15:47:53 <slaweq> if You will need help I will be very happy to join such presentation :)
15:48:00 <ralonsoh> hehehe
15:48:01 <slaweq> thx
15:48:04 <ralonsoh> #endmeeting