15:00:33 <slaweq> #startmeeting neutron_qos
15:00:34 <openstack> Meeting started Tue Nov  7 15:00:33 2017 UTC and is due to finish in 60 minutes.  The chair is slaweq. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:37 <openstack> The meeting name has been set to 'neutron_qos'
15:00:42 <slaweq> #chair slaweq
15:00:43 <openstack> Current chairs: slaweq
15:00:47 <slaweq> hello
15:01:28 <slaweq> anyone interested in QoS is around or all people are on Summit? :)
15:01:35 <davidsha> Hi
15:01:53 <slaweq> hi davidsha
15:02:07 <slaweq> it looks like we will be alone here :)
15:02:22 <slaweq> but maybe we will wait 2-3 minutes more?
15:02:27 <davidsha> Sure
15:05:01 <slaweq> ok, I think we can start
15:05:11 <slaweq> #topic RFEs
15:05:28 <slaweq> there is couple of already approved RFEs for QoS
15:05:38 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1560963
15:05:40 <openstack> Launchpad bug 1560963 in neutron "[RFE] Minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
15:06:07 <slaweq> this one is assigned to ralonsoh but he will probably not be able to work on it anymore
15:06:27 <slaweq> davidsha do You know maybe some more details about ralonsoh and status on it?
15:06:34 <slaweq> or should I talk with directly?
15:07:02 <davidsha> Talk to him directly, I'm unsure of some of the details of this feature.
15:07:04 <ralonsoh> hi
15:07:08 <ralonsoh> about #link https://bugs.launchpad.net/neutron/+bug/1560963
15:07:09 <openstack> Launchpad bug 1560963 in neutron "[RFE] Minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
15:07:12 <slaweq> hi ralonsoh :)
15:07:12 <ralonsoh> sriov: merged
15:07:17 <davidsha> Hi
15:07:36 <slaweq> so what is still todo on this one?
15:07:37 <ralonsoh> lb and OVS: hichihira was planning some new patches
15:07:43 <ralonsoh> but I don't have feedback
15:08:12 <slaweq> ok I will then talk with hichihira about it
15:08:36 <slaweq> #action talk with hichihira about progress on https://bugs.launchpad.net/neutron/+bug/1560963
15:08:37 <openstack> Launchpad bug 1560963 in neutron "[RFE] Minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
15:09:03 <slaweq> ok, so next one: https://bugs.launchpad.net/neutron/+bug/1578989
15:09:04 <openstack> Launchpad bug 1578989 in neutron "[RFE] Strict minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
15:09:09 <slaweq> ralonsoh: it's also yours :)
15:10:23 <slaweq> can You tell us something about it?
15:11:50 <slaweq> hmm, I think that ralonsoh is not here anymore :/
15:12:04 <slaweq> so I will talk with him about this one maybe later
15:12:20 <slaweq> #action talk with ralonsoh about https://bugs.launchpad.net/neutron/+bug/1578989
15:12:22 <openstack> Launchpad bug 1578989 in neutron "[RFE] Strict minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
15:12:32 <slaweq> next one: https://bugs.launchpad.net/neutron/+bug/1596611
15:12:32 <openstack> Launchpad bug 1596611 in neutron "[RFE] Create L3 IPs with qos (rate limit)" [Wishlist,In progress] - Assigned to LIU Yulong (dragon889)
15:13:00 <slaweq> this one have already 2 patches ready for review:  https://review.openstack.org/#/c/424466/
15:13:00 <patchbot> patch 424466 - neutron - [L3][QoS] Neutron server side Floating IP QoS
15:13:08 <slaweq> and https://review.openstack.org/#/c/453458/
15:13:08 <patchbot> patch 453458 - neutron - [L3][QoS] Adding L3 rate limit TC lib
15:13:17 <slaweq> davidsha: can You review it?
15:13:38 <davidsha> I will, this is the one that creates a 2nd tc wrapper right?
15:13:54 <slaweq> yep, second from those two
15:13:56 <slaweq> :)
15:14:21 <slaweq> there is also third patch missing for that
15:14:43 <slaweq> I will talk with author of patches if he need some help with it
15:15:21 <slaweq> #action talk with liuyulong about third patch for https://bugs.launchpad.net/neutron/+bug/1596611
15:15:23 <openstack> Launchpad bug 1596611 in neutron "[RFE] Create L3 IPs with qos (rate limit)" [Wishlist,In progress] - Assigned to LIU Yulong (dragon889)
15:15:31 <slaweq> davidsha: anything to add?
15:15:46 <davidsha> No, I'll try and get to those asap
15:15:50 <slaweq> thx
15:15:53 <slaweq> so, move on
15:16:10 <slaweq> https://bugs.launchpad.net/neutron/+bug/1692951
15:16:11 <openstack> Launchpad bug 1692951 in neutron "[RFE] DSCP mark on the outer header" [Wishlist,In progress] - Assigned to Ali Sanhaji (ali-sanhaji)
15:16:26 <slaweq> this one is also ready for review: https://review.openstack.org/#/c/501267/
15:16:27 <patchbot> patch 501267 - neutron - Adding DSCP mark and inheritance in OVS and LB tun...
15:16:32 <slaweq> I need to look at it once again
15:16:37 <slaweq> davidsha: please review it also
15:16:46 <slaweq> You are an expert in DSCP marking :)
15:16:59 <davidsha> Will do, I wouldn't say that ;P
15:17:07 <slaweq> thx
15:17:18 <davidsha> I think I only had nits the last time I reviewed it.
15:17:40 <slaweq> I think I even gave +1 for it last time
15:17:45 <slaweq> but I need to check once again
15:18:07 <davidsha> same
15:18:08 <alisanhaji> Hi, since last time I made some changes after tmorin reviews
15:18:17 <slaweq> hi alisanhaji :)
15:18:42 <slaweq> I saw that tmorin gave +1 already
15:18:46 <alisanhaji> it was just to deprecate tos and use dscp instead while keeping backward compatibility
15:19:16 <davidsha> sounds good.
15:19:42 <slaweq> ok, thx, I will review it asap
15:19:43 <alisanhaji> I think the failure isn't related to my changes
15:20:06 <alisanhaji> Thanks
15:20:33 <slaweq> ok, next one https://bugs.launchpad.net/neutron/+bug/1505627
15:20:35 <openstack> Launchpad bug 1505627 in neutron "[RFE] QoS Explicit Congestion Notification (ECN) Support" [Wishlist,Triaged] - Assigned to Reedip (reedip-banerjee)
15:20:43 <slaweq> I need to ask reedip about status of it
15:21:04 <slaweq> but I think that he is not here now
15:21:37 <davidsha> I think he did go to the summit, didn't he?
15:21:41 <slaweq> #action ask reedip about status of https://bugs.launchpad.net/neutron/+bug/1505627
15:21:43 <openstack> Launchpad bug 1505627 in neutron "[RFE] QoS Explicit Congestion Notification (ECN) Support" [Wishlist,Triaged] - Assigned to Reedip (reedip-banerjee)
15:21:46 <slaweq> davidsha: yes, I think so
15:23:05 <slaweq> ok, last one: https://bugs.launchpad.net/neutron/+bug/1649517
15:23:06 <openstack> Launchpad bug 1649517 in neutron "qos policy attached to network, qos_policy_id is reflecting on neutron net-show , but not on the port with neutron port-show" [Wishlist,In progress] - Assigned to Reedip (reedip-banerjee)
15:24:03 <slaweq> reedip did patch for it and it's ready for review: https://review.openstack.org/#/c/419642/ but we forgot to ask drivers team about it :)
15:24:03 <patchbot> patch 419642 - neutron - Add network_qos_policy_id to port info
15:24:14 <slaweq> so it's now waiting for drivers team
15:24:35 <slaweq> I will talk with mlavalle to triagge it and talk on next drivers meeting
15:24:36 <davidsha> There is no drivers meeting this week so it will have to be next week then.
15:24:48 <slaweq> davidsha: yes, I know
15:25:04 <slaweq> #action talk with mlavalle about triagge of https://bugs.launchpad.net/neutron/+bug/1649517
15:25:05 <openstack> Launchpad bug 1649517 in neutron "qos policy attached to network, qos_policy_id is reflecting on neutron net-show , but not on the port with neutron port-show" [Wishlist,In progress] - Assigned to Reedip (reedip-banerjee)
15:25:20 <slaweq> but davidsha can You maybe take a look on this patch also?
15:25:32 <davidsha> looking at it now
15:25:35 <slaweq> thx
15:25:48 <slaweq> ok, so that's all what I have
15:25:54 <slaweq> #topic Bugs
15:26:17 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1662109
15:26:19 <openstack> Launchpad bug 1662109 in neutron "tempest scenario test_qos fails intermittently" [High,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:26:32 <slaweq> I was checking that one and it wasn't too often
15:26:40 <slaweq> I will have to look on it again
15:26:59 <slaweq> but currently I have no idea why it happens sometimes :/
15:28:09 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1662109
15:28:11 <openstack> Launchpad bug 1662109 in neutron "tempest scenario test_qos fails intermittently" [High,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:28:13 <slaweq> next one :)
15:28:23 <slaweq> sorry wrong link
15:29:02 <slaweq> so next one: https://bugs.launchpad.net/neutron/+bug/1676877
15:29:03 <openstack> Launchpad bug 1676877 in neutron "Increase "TestQosPlugin.test_update_policy_rule" coverage" [Medium,In progress] - Assigned to Reedip (reedip-banerjee)
15:29:07 <slaweq> reedip: is working on it
15:29:31 <slaweq> but there wasn't any update on it since long time
15:29:41 <slaweq> so I will ask reedip if he needs any help on it
15:29:48 <slaweq> #action ask reedip about https://bugs.launchpad.net/neutron/+bug/1676877
15:30:24 <davidsha> I'll run a recheck on it as well
15:30:32 <slaweq> thx davidsha
15:30:39 <slaweq> ok, next one
15:30:42 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1726732
15:30:43 <openstack> Launchpad bug 1726732 in neutron "[qos]set running vms ingress-bandwidth-limit, then delete running vm,but ovs queue is still residual" [Medium,In progress] - Assigned to Zachary Ma (mazengxie)
15:31:37 <slaweq> this one is almost done: https://review.openstack.org/#/c/515566/
15:31:37 <patchbot> patch 515566 - neutron - [Qos] Fix residues of ovs in ingress bw limit
15:31:54 <slaweq> davidsha: can You check this one also?
15:31:58 <davidsha> It looks almost ready to merge
15:32:07 <slaweq> I will also ask core reviewers to look at it
15:32:20 <slaweq> #action ask core reviewers to review https://review.openstack.org/#/c/515566/
15:32:21 <patchbot> patch 515566 - neutron - [Qos] Fix residues of ovs in ingress bw limit
15:32:22 <davidsha> sure
15:32:24 <slaweq> thx
15:32:46 <slaweq> davidsha: I'm moving forward but if You have anything to add, just stop me :)
15:33:03 <slaweq> next one
15:33:08 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1639186
15:33:09 <openstack> Launchpad bug 1639186 in neutron "qos max bandwidth rules not working for neutron trunk ports" [Low,Confirmed]
15:33:11 <davidsha> go ahead
15:33:21 <slaweq> this one is not updated for quite long time
15:33:38 <slaweq> and I don't know if anything is happen with that
15:33:41 <davidsha> It's almost a year old
15:33:46 <slaweq> davidsha: do You have any info about it?
15:34:08 <davidsha> No, I'm not sure I recall seeing it before
15:34:51 <slaweq> yes, I will talk with armax and author of this bug maybe, what to do with it
15:35:07 <davidsha> kk
15:35:07 <slaweq> #action talk with armax about https://bugs.launchpad.net/neutron/+bug/1639186
15:35:08 <openstack> Launchpad bug 1639186 in neutron "qos max bandwidth rules not working for neutron trunk ports" [Low,Confirmed]
15:35:23 <slaweq> next one
15:35:24 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1724729
15:35:25 <openstack> Launchpad bug 1724729 in neutron "ovs-lib not support qos type egress-policer for ovs-dpdk" [Low,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:35:54 <slaweq> davidsha: thx for review, I will have to address Your comments on it
15:36:08 <slaweq> I hope I will be able to do it ASAP (maybe tomorrow)
15:36:27 <davidsha> slaweq: No problem, sorry I missed it earlier!
15:37:09 <slaweq> davidsha: no problem :)
15:37:19 <slaweq> and the last one
15:37:20 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1730605
15:37:21 <openstack> Launchpad bug 1730605 in neutron "neutron qos bindlimit by ovs is not accurate" [Undecided,Incomplete]
15:37:41 <slaweq> it's new one, I asked about more details there
15:37:58 <slaweq> so IMO we should wait for more details about it
15:38:05 <slaweq> davidsha: what You think?
15:38:21 <davidsha> Ya, this may also be an issue of the BW being reported in a different unit maybe?
15:38:56 <slaweq> yep, that's why I asked for details about tc qdisc and class from interfaces
15:39:29 <davidsha> We'll see anyways, they probably should have provided examples.
15:39:40 <slaweq> yep
15:39:49 <slaweq> ok, moving on
15:39:50 <slaweq> #topic Other Changes
15:39:59 <slaweq> I don't have anything in agenda
15:40:07 <slaweq> davidsha: do You have anything?
15:40:39 <davidsha> I'm working on updating the OpenFlow manager, I have a patch for DSCP for it/
15:41:00 <slaweq> can You send it? I will review
15:41:18 <davidsha> https://review.openstack.org/#/c/323963/
15:41:19 <patchbot> patch 323963 - neutron - L2 openflow manager
15:41:30 <slaweq> #action review https://review.openstack.org/#/c/323963/
15:41:31 <patchbot> patch 323963 - neutron - L2 openflow manager
15:41:34 <slaweq> thx
15:41:39 <davidsha> There is an issue with native OpenFlow that I've fixed locally
15:41:59 <davidsha> just working on the firewall to work with it now.
15:42:05 <slaweq> so this patch is not ready yet?
15:42:19 <davidsha> the next iteration should be up in a day or so.
15:42:35 <slaweq> ok, so I will wait and review next PS :)
15:42:42 <davidsha> Thanks!
15:42:52 <slaweq> no prob
15:43:11 <davidsha> related patch for DSCP btw: https://review.openstack.org/#/c/399680/
15:43:12 <patchbot> patch 399680 - neutron - Implement QoS OpenFlowFunction for DSCP
15:43:27 <davidsha> That won't need to be updated I think.
15:43:28 <slaweq> #action review https://review.openstack.org/#/c/399680/
15:43:28 <patchbot> patch 399680 - neutron - Implement QoS OpenFlowFunction for DSCP
15:43:40 <slaweq> ok, I will review it ASAP also
15:43:45 <davidsha> Thanks
15:44:13 <davidsha> Thats all from me unless your interested in CCF and DVR ;)
15:44:31 <slaweq> I can be but it's not for this meeting IMHO :)
15:44:54 <slaweq> especially in CCF as it can be useful for QoS someday
15:45:37 <slaweq> btw. is CCF ready to use to try it? e.g. on devstack
15:45:46 <davidsha> I was hoping to draft a patch for DSCP for it, but I've never had the time to try.
15:46:05 <davidsha> Not quite yet, we're still pushing the patches through for the service plygin.
15:46:05 <slaweq> I was thinking about it for e.g. bw limit
15:46:29 <slaweq> but DSCP can be even easier to implement on backend maybe
15:46:46 <davidsha> I was think a new rule might be better for classification based BW limiting
15:46:49 <slaweq> ok, can I help somehow maybe with this service plugin?
15:47:28 <davidsha> Ijust leave the existing rule as a blanket limit
15:48:23 <davidsha> Some of the patches are in review, I can link them if you're interested?
15:48:27 <slaweq> ah, so existing rule as "top" limit and then other rules to configure limit per traffic type up to this "top" limit
15:48:29 <slaweq> right?
15:48:48 <slaweq> yes, please give me links for it
15:48:58 <slaweq> I will try to look at it if I will have few minutes
15:49:11 <davidsha> exactly what I'm thinking, this is the current one: https://review.openstack.org/#/c/499571/
15:49:12 <patchbot> patch 499571 - neutron-classifier - Add Database Models and OVOs for classifications
15:49:48 <slaweq> ok, I will add it to my review list
15:50:12 <davidsha> This is the follow up patch which contains the actual service plugin, I'll update this soon: https://review.openstack.org/#/c/487182
15:50:13 <patchbot> patch 487182 - neutron-classifier - Version 0 Patch
15:50:47 <slaweq> ok
15:51:31 <davidsha> Thanks!
15:52:00 <slaweq> ok, anything else to add?
15:52:11 <davidsha> I'm good.
15:52:26 <slaweq> ok :)
15:52:29 <slaweq> #topic Open Discussion
15:53:15 <slaweq> I think that we finished Open discussion also with previous topic
15:53:32 <slaweq> but maybe someone want to add something
15:53:34 <davidsha> Same, thanks!
15:53:43 <slaweq> ok
15:53:56 <slaweq> thx
15:53:58 <slaweq> #endmeeting