15:00:25 <slaweq_> #startmeeting neutron_qos
15:00:29 <openstack> Meeting started Tue Dec  5 15:00:25 2017 UTC and is due to finish in 60 minutes.  The chair is slaweq_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <openstack> The meeting name has been set to 'neutron_qos'
15:00:35 <slaweq_> hello
15:00:53 <mlavalle> o/
15:01:21 <slaweq> I think we will wait few minutes for other people
15:01:28 <mlavalle> cool
15:01:39 <mlavalle> I'll be back in a couple of minutes
15:01:44 <slaweq> mlavalle: sure
15:01:49 <davidsha> In a meeting but I'll try to keep up!
15:01:59 <slaweq> hi davidsha :)
15:02:07 <davidsha> Hi!
15:02:59 <slaweq> reedip: are You around?
15:04:01 * mlavalle is back
15:04:23 <slaweq> ok, I think we can start
15:04:29 <slaweq> #topic RFEs
15:04:48 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1560963
15:04:48 <openstack> Launchpad bug 1560963 in neutron "[RFE] Minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
15:05:13 <slaweq> last time when I checked this one, old patch was abandoned
15:05:47 <slaweq> ralonsoh will not continue this work for sure so maybe we should mark it as unassigned and find someone else
15:05:58 <mlavalle> yeah
15:06:24 <slaweq> ok, so it's unassigned for now - maybe there will be someone interested
15:06:28 <mlavalle> my impression is that we need to go through all the RFEs and reasses priorities
15:06:51 <slaweq> ok, we will go through it now
15:06:56 <slaweq> there is not too many of them
15:07:55 <slaweq> next one
15:07:59 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1578989
15:07:59 <openstack> Launchpad bug 1578989 in neutron "[RFE] Strict minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
15:08:15 <slaweq> it's very similar problem here
15:08:20 <slaweq> ralonsoh was working on it
15:08:34 <slaweq> but he will not be able to finish specs for nova and neutron:
15:08:41 <slaweq> Nova: https://review.openstack.org/#/c/502306/
15:08:47 <slaweq> Neutron: https://review.openstack.org/#/c/508149/
15:09:12 <slaweq> I think we should also unassign him from it
15:09:15 <slaweq> mlavalle: what You think?
15:09:21 <mlavalle> yes
15:09:41 <slaweq> ok, done
15:10:30 <slaweq> ok, next one
15:10:50 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1596611
15:10:50 <openstack> Launchpad bug 1596611 in neutron "[RFE] Create L3 IPs with qos (rate limit)" [Wishlist,In progress] - Assigned to LIU Yulong (dragon889)
15:10:57 <slaweq> this one is much better
15:11:04 <slaweq> server side patch is merged
15:11:18 <slaweq> agent side patch waits for review: #link https://review.openstack.org/#/c/521079/
15:11:27 <slaweq> I was reviewing it already
15:11:30 <mlavalle> yeah, we are in good shape here
15:11:52 <slaweq> but I also want to test it locally so I just deployed devstack with it and I will test it
15:12:10 <slaweq> there is also OSC patch for that: #link https://review.openstack.org/#/c/517845/
15:12:18 <slaweq> so please review it in meantime
15:12:29 <mlavalle> and expect another patch with docs
15:12:41 <slaweq> yes but it's not in review yet AFAIK
15:12:54 <mlavalle> no, he hans't pushed it yet
15:13:16 <slaweq> but I think this one can be finished in Queens :)
15:13:40 <slaweq> and the last one
15:13:41 <mlavalle> 'yes
15:13:43 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1692951
15:13:43 <openstack> Launchpad bug 1692951 in neutron "[RFE] DSCP mark on the outer header" [Wishlist,In progress] - Assigned to Ali Sanhaji (ali-sanhaji)
15:14:11 <slaweq> patch is still in review: https://review.openstack.org/#/c/501267/
15:14:22 <slaweq> and it looks like there is nothing happen on it since some time
15:14:50 <slaweq> AFAIR it was (almost) done already
15:15:45 <slaweq> is author of this patch around?
15:15:52 <slaweq> do You know his IRC nickname?
15:16:36 <fouadben> hi, its nike name is alisanhaji
15:16:45 <slaweq> thx fouadben
15:16:57 <slaweq> so it looks that he isn't here now
15:17:28 <slaweq> I will try to catch him and talk about this one
15:18:06 <slaweq> #action slaweq will talk with alisanhaji about help on  https://bugs.launchpad.net/neutron/+bug/1692951
15:18:06 <openstack> Launchpad bug 1692951 in neutron "[RFE] DSCP mark on the outer header" [Wishlist,In progress] - Assigned to Ali Sanhaji (ali-sanhaji)
15:18:51 <slaweq> that's all RFEs which I have for today
15:19:25 <slaweq> mlavalle: there is also one not approved yet: https://bugs.launchpad.net/neutron/+bug/1649517
15:19:25 <openstack> Launchpad bug 1649517 in neutron "qos policy attached to network, qos_policy_id is reflecting on neutron net-show , but not on the port with neutron port-show" [Wishlist,In progress] - Assigned to Reedip (reedip-banerjee)
15:19:25 <mlavalle> how about https://review.openstack.org/#/c/508149/
15:20:05 <mlavalle> I think it is up for discussion in the drivers meeting
15:20:14 <mlavalle> I was looking at it last Thursday
15:20:20 <slaweq> mlavalle: yes it is, I hope it will be discussed this week :)
15:20:28 <mlavalle> I think we will get to it this week
15:20:53 <slaweq> about Your question, specs which You ask for is for https://bugs.launchpad.net/neutron/+bug/1578989
15:20:54 <openstack> Launchpad bug 1578989 in neutron "[RFE] Strict minimum bandwidth support (egress)" [Wishlist,In progress]
15:21:00 <slaweq> which was assigned to ralonsoh
15:21:14 <slaweq> but he will not be able to continue this as he told me
15:21:18 <mlavalle> well, I would like to continue with that
15:21:30 <mlavalle> not necessarily this cycle
15:21:33 <slaweq> mlavalle: that would be great
15:21:37 <mlavalle> but for h next one
15:21:51 <mlavalle> we need to wait for the Nova guys anyway
15:22:01 <slaweq> "h next one"? it will be few years I think ;)
15:22:12 <mlavalle> so I'll assign it to me, with the unserstanding that it will be for next cycle
15:22:22 <slaweq> ok, thx a lot
15:22:30 <mlavalle> :-)
15:23:37 <slaweq> anything else to add about RFEs?
15:23:44 <slaweq> or we can go forward?
15:24:18 <mlavalle> let's move one
15:24:38 <slaweq> ok
15:24:40 <slaweq> #topic Bugs
15:24:43 * mlavalle stepping away from keyboard 1 minute. someone ringing the door bell
15:24:57 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1662109
15:24:57 <openstack> Launchpad bug 1662109 in neutron "tempest scenario test_qos fails intermittently" [High,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:25:18 <armax> hi
15:25:22 <slaweq> to be honest I didn't check it last few weeks and I don't know if it is still an issue
15:25:25 <slaweq> hi armax
15:25:34 <armax> I was deputy during last week
15:25:42 <armax> I don’t have a formal report to share
15:25:51 <slaweq> I think You are late one hour as now it's qos meeting :)
15:25:51 <armax> but I managed to stay on top of all the bugs that came in
15:25:57 <armax> oh shoot
15:25:58 <armax> :)
15:26:00 <armax> sorry
15:26:06 <slaweq> but You are welcome here also
15:26:07 <armax> I see the same people :)
15:26:22 <slaweq> neutron meeting was one hour ago
15:26:35 <armax> that’s ok I am like in 3 meetings at once, I was only going to make a short appearance :)
15:26:37 <mlavalle> armax: LOL
15:26:44 <mlavalle> you are 1 hour late
15:26:53 <armax> :(
15:27:04 * armax walks out of the room in shame
15:27:12 <mlavalle> but still we enjoy your company
15:27:18 <mlavalle> so please stay armax
15:27:18 <slaweq> LOL
15:27:24 <armax> eh
15:28:01 <slaweq> so, about https://bugs.launchpad.net/neutron/+bug/1662109 I think I will have to check if it still happens
15:28:01 <openstack> Launchpad bug 1662109 in neutron "tempest scenario test_qos fails intermittently" [High,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:28:24 <slaweq> #action slaweq check if https://bugs.launchpad.net/neutron/+bug/1662109 is still an issue in the gate
15:28:46 <slaweq> next one is also related to failing tests:
15:28:48 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1733649
15:28:48 <openstack> Launchpad bug 1733649 in neutron "fullstack neutron.tests.fullstack.test_qos.TestDscpMarkingQoSOvs.test_dscp_marking_packets(openflow-native) failure" [High,Confirmed] - Assigned to Slawek Kaplonski (slaweq)
15:28:56 <slaweq> and I am also assigned to it
15:29:20 <slaweq> I was checking agent and server logs from such failed run and I didn't found anything wrong there
15:30:19 <slaweq> I suspect that it can be "changed" tcpdump output and it not match regex in https://github.com/openstack/neutron/blob/master/neutron/tests/common/agents/l2_extensions.py#L121
15:30:51 <slaweq> so I added there log line and I want to monitor and check logs once again if it will happen again
15:31:10 <slaweq> unless someone has got maybe any other idea about that :)
15:31:58 <mlavalle> it's a good idea
15:32:11 <mlavalle> the tcpdump change merged yesterday, right?
15:32:17 <slaweq> today morning
15:32:24 <slaweq> (my morning)
15:32:38 <mlavalle> it might be my yesterday
15:32:49 <slaweq> yes
15:33:31 <slaweq> ok, next one
15:33:33 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1676877
15:33:33 <openstack> Launchpad bug 1676877 in neutron "Increase "TestQosPlugin.test_update_policy_rule" coverage" [Medium,In progress] - Assigned to Reedip (reedip-banerjee)
15:33:41 <slaweq> reedip is doing that
15:33:51 <slaweq> but it's not going too fast
15:34:25 <slaweq> reedip is probably not here now so we will don't have any update from him
15:34:47 <mlavalle> maybe ask in the bug?
15:35:06 <slaweq> I think I should first review proposed patch: https://review.openstack.org/#/c/456773/
15:35:27 <slaweq> #action slaweq review https://review.openstack.org/#/c/456773/
15:36:09 <slaweq> next one
15:36:12 <slaweq> https://bugs.launchpad.net/neutron/+bug/1726732
15:36:12 <openstack> Launchpad bug 1726732 in neutron "[qos]set running vms ingress-bandwidth-limit, then delete running vm,but ovs queue is still residual" [Medium,In progress] - Assigned to Zachary Ma (mazengxie)
15:36:28 <slaweq> patch for this one is in review:
15:36:30 <slaweq> #link https://review.openstack.org/#/c/515566/
15:36:41 <slaweq> please look at this one
15:36:47 <mlavalle> I remember that one
15:36:56 <slaweq> for me it looks good now
15:36:57 <mlavalle> I think it is close to merge
15:37:03 <slaweq> I hope so
15:37:19 <mlavalle> Ihar made some comments last week, I believe
15:37:39 <slaweq> but I think that all are already addressed
15:37:47 <slaweq> there is fullstack test added to it also
15:38:03 <mlavalle> ok
15:38:08 <mlavalle> will take a look
15:38:13 <slaweq> thx
15:38:24 <slaweq> so moving on
15:38:31 <mlavalle> it could be the first patch you merge tomorrow
15:38:45 <slaweq> mlavalle: maybe :)
15:38:55 <slaweq> next one
15:39:06 <slaweq> https://bugs.launchpad.net/neutron/+bug/1730605
15:39:06 <openstack> Launchpad bug 1730605 in neutron "neutron qos bindlimit by ovs is not accurate" [Medium,In progress] - Assigned to Zachary Ma (mazengxie)
15:39:16 <slaweq> this one also has got patch made by Zachary
15:39:22 <slaweq> https://review.openstack.org/#/c/519573/
15:39:39 <slaweq> IMHO this patch is good as this is covered by functional tests
15:40:08 <slaweq> garyk wants some unit tests for it also so maybe author will need to add some tests there
15:40:36 <slaweq> mlavalle: would be good if You could look also on this one
15:40:42 <mlavalle> yes
15:40:46 <slaweq> thx
15:41:44 <slaweq> next one
15:41:50 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1639186
15:41:50 <openstack> Launchpad bug 1639186 in neutron "qos max bandwidth rules not working for neutron trunk ports" [Low,Confirmed]
15:42:01 <slaweq> this one is not easy to fix
15:42:24 <slaweq> and I don't think it will be fixed soon :/
15:42:34 <slaweq> it is not assigned to anyone currently
15:42:47 <mlavalle> what is the issue?
15:43:04 <slaweq> rate limit for trunk ports doesn't work
15:43:15 <slaweq> it is because "internal" port types are used for trunk ports
15:43:22 <slaweq> and QoS is not working on "internal" ports
15:43:57 <slaweq> and it also not works on patch ports
15:44:16 <slaweq> sorry, patch ports are used for trunk and this is exactly reason of this issue
15:44:29 <mlavalle> ahh, ok
15:44:58 <slaweq> so there was proposal to use veth instead of patch ports but armax have got arguments against it
15:45:08 <slaweq> and there should be some other solution found
15:46:14 <slaweq> so, next one
15:46:17 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1724729
15:46:18 <openstack> Launchpad bug 1724729 in neutron "ovs-lib not support qos type egress-policer for ovs-dpdk" [Low,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:46:31 <slaweq> for this one I have patch already: https://review.openstack.org/#/c/513398/
15:46:36 <slaweq> please review it
15:46:50 <slaweq> and thx davidsha for Your review of it as DPDK expert
15:46:51 <mlavalle> yes, it shows up in my radar screen
15:46:56 <slaweq> mlavalle: thx
15:47:02 <davidsha> Np!
15:47:28 <slaweq> and the last one
15:47:31 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1732852
15:47:31 <openstack> Launchpad bug 1732852 in neutron "neutron don't support Router gateway rate limit " [Low,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:47:41 <slaweq> this one is "tricky"
15:48:12 <slaweq> I proposed patch which changed documentation to say that it will work on router gateway port only if "ovs_use_veth" will be set to True
15:48:33 <slaweq> the reason is the same as for trunk ports - rate limiting don't work on "internal" ports
15:49:25 <slaweq> Ihar wants to talk about it and maybe do something like force ovs_use_veth to be true if QoS is enabled but I didn't check yet how it could be done
15:50:03 <slaweq> do You have any idea how it could be fixed maybe?
15:50:36 <mlavalle> nope
15:50:59 <slaweq> so currently it's only mentioned in docs what should be done to make it work
15:51:16 <slaweq> IMHO it is the best "workaround" of this issue
15:51:33 <slaweq> but I'm not sure now if there will be no same issue for FIP QoS also
15:51:43 <slaweq> I want to check it on devstack locally
15:52:39 <slaweq> anyone has something to add?
15:52:49 <slaweq> or we are moving on?
15:52:58 <mlavalle> nothing from me
15:53:20 <slaweq> ok, so that was all bugs related to QoS
15:53:22 <slaweq> #topic Open Discussion
15:53:47 <slaweq> anyone wants to talk about something?
15:53:57 <slaweq> I don't have anything
15:54:02 <mlavalle> yesterday I received a request from Zachary
15:54:13 <mlavalle> to be added to the Neutron busg team
15:54:17 <mlavalle> which I granted
15:54:43 <slaweq> he is doing many things related to QoS in last weeks
15:55:03 <mlavalle> since you, slaweq are closer to his time zone, would you ask him if he can be added to the bugs deputy rotation?
15:55:17 <mlavalle> and let me know
15:55:20 <slaweq> sure I will try to catch him tomorrow and will ask
15:55:24 <slaweq> no problem
15:55:25 <mlavalle> :-)
15:55:35 <mlavalle> that's all I had
15:56:17 <slaweq> so I think we are done and we have few minutes back :)
15:56:24 <slaweq> thx
15:56:38 <mlavalle> next meeting is on the 19th, correct?
15:56:46 <slaweq> right
15:56:52 <mlavalle> ack
15:57:48 <slaweq> ok, I think there is nothing more to add
15:57:50 <slaweq> #endmeeting
15:57:54 <slaweq> thx
15:58:32 <slaweq_> #endmeeting