15:02:31 <slaweq> #startmeeting neutron_qos
15:02:32 <openstack> Meeting started Tue Jan  2 15:02:31 2018 UTC and is due to finish in 60 minutes.  The chair is slaweq. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:36 <openstack> The meeting name has been set to 'neutron_qos'
15:02:40 <slaweq> hi
15:02:43 <alisanhaji> hi
15:02:53 <mlavalle> o/
15:03:24 <slaweq> reedip around?
15:04:01 <slaweq> ok, so let's start
15:04:09 <slaweq> welcome on first QoS meeting in 2018 :)
15:04:18 <slaweq> Happy New Year to all of You
15:04:30 <slaweq> #topic RFEs
15:04:31 <alisanhaji> Happy new year :)
15:05:01 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1560963
15:05:02 <openstack> Launchpad bug 1560963 in neutron "[RFE] Minimum bandwidth support (egress)" [Wishlist,In progress]
15:05:13 <slaweq> there is no anyone assigned to it
15:05:25 <slaweq> today I removed old target milestone as it was Pike-2
15:05:31 <slaweq> mlavalle: is it fine for You?
15:05:36 <mlavalle> yeah
15:05:37 <slaweq> or should I left it as it was?
15:05:49 <slaweq> thx
15:06:24 <slaweq> I think we can think about it in R cycle maybe
15:06:30 <mlavalle> yes
15:06:46 <slaweq> ok, so next one: #link https://bugs.launchpad.net/neutron/+bug/1578989
15:06:47 <openstack> Launchpad bug 1578989 in neutron "[RFE] Strict minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Rodolfo Alonso (rodolfo-alonso-hernandez)
15:07:02 <slaweq> same here, it's not for Q for sure
15:07:15 <slaweq> I hope we can back to it in next release
15:07:36 <slaweq> I don't have anything to add about it
15:07:48 <slaweq> do You have something maybe?
15:07:52 <mlavalle> is this the one that Rodolfo wrote specs for?
15:08:02 <slaweq> mlavalle: yes
15:08:17 <slaweq> and AFAIR You told me that You will try to work on it in R cycle
15:08:23 <mlavalle> correct
15:08:30 <mlavalle> that is why I am asking
15:08:53 <slaweq> it is still assigned to ralonsoh
15:09:04 <mlavalle> we can assign to me
15:09:09 <slaweq> ok
15:09:11 <mlavalle> if that's ok with you
15:09:48 <slaweq> sure
15:09:50 <slaweq> done
15:09:52 <slaweq> :)
15:09:54 <slaweq> thx mlavalle
15:10:01 <mlavalle> :-)
15:10:14 <slaweq> next one is QoS for FIP: #link https://bugs.launchpad.net/neutron/+bug/1596611
15:10:16 <openstack> Launchpad bug 1596611 in neutron "[RFE] Create L3 IPs with qos (rate limit)" [Wishlist,In progress] - Assigned to LIU Yulong (dragon889)
15:10:19 <slaweq> it is almost done
15:10:30 <slaweq> thx LIU Yulong :)
15:10:46 <slaweq> patches still to review are listed in     #link https://review.openstack.org/#/q/topic:bp/floating-ip-rate-limit+(status:open+OR+status:merged)
15:11:01 <slaweq> it's patch for docs, tempest tests and OSC
15:11:13 <mlavalle> ++
15:11:15 <slaweq> so main functionallity is already merged \o/
15:12:00 <slaweq> next one is #link https://bugs.launchpad.net/neutron/+bug/1692951
15:12:01 <openstack> Launchpad bug 1692951 in neutron "[RFE] DSCP mark on the outer header" [Wishlist,In progress] - Assigned to Ali Sanhaji (ali-sanhaji)
15:12:18 <slaweq> alisanhaji: do You want to tell something about it?
15:12:33 <alisanhaji> I tried to reach garyk but couldn't
15:13:17 <alisanhaji> for me it's complete, but if somebody thinks there is something to add or remove, I am waiting for suggestions
15:13:30 <slaweq> mlavalle: please add it to Your review list :)
15:13:37 <mlavalle> ok
15:13:41 <slaweq> thx
15:13:48 <alisanhaji> thanks
15:13:58 <slaweq> alisanhaji: I will also look at it once again this week
15:14:07 <alisanhaji> great thanks slaweq
15:15:03 <slaweq> for the record: patch to review is https://review.openstack.org/#/c/501267/
15:15:19 <mlavalle> thanks
15:15:23 <slaweq> because there were some other patches which are abandoned already
15:15:35 <slaweq> and this one covers all required changes
15:15:49 <slaweq> alisanhaji: please correct me if I'm wrong :)
15:15:57 <alisanhaji> no you are exactly right
15:16:03 <slaweq> alisanhaji: thx
15:16:26 <slaweq> ok, moving on
15:16:46 <slaweq> there are also two rfe not approved by drivers team
15:16:51 <slaweq> first one is #link https://bugs.launchpad.net/neutron/+bug/1649517
15:16:53 <openstack> Launchpad bug 1649517 in neutron "qos policy attached to network, qos_policy_id is reflecting on neutron net-show , but not on the port with neutron port-show" [Wishlist,Triaged] - Assigned to Reedip (reedip-banerjee)
15:17:04 <slaweq> as was already decided it can be changed on OSC side
15:17:22 <slaweq> so I will talk with reedip if he will work on it
15:17:28 <mlavalle> ++
15:17:29 <slaweq> if not, I will take care
15:17:57 <slaweq> #action slaweq will talk with reedip about OSC patch for https://bugs.launchpad.net/neutron/+bug/1649517
15:17:58 <openstack> Launchpad bug 1649517 in neutron "qos policy attached to network, qos_policy_id is reflecting on neutron net-show , but not on the port with neutron port-show" [Wishlist,Triaged] - Assigned to Reedip (reedip-banerjee)
15:18:24 <slaweq> second not aproved rfe: #link https://bugs.launchpad.net/neutron/+bug/1727578
15:18:26 <openstack> Launchpad bug 1727578 in neutron "[RFE]Support apply qos policy in VPN service" [Wishlist,Confirmed]
15:18:57 <slaweq> I know that yamamoto already talked with autor of this bug
15:19:20 <slaweq> for me it's little bit hard as I don't know anything about VPNaaS
15:20:02 <slaweq> from QoS point of view I would like to see some specs with more "low level" details
15:20:31 <slaweq> but it has to be triagged and then discussed with drivers team first, right mlavalle?
15:20:37 <mlavalle> maybe we could mark the rfe triaged
15:20:50 <mlavalle> so we can discuss it in the drivers meeting
15:21:17 <mlavalle> do you feel comfortable triaging it so we can move it to the next step?
15:22:08 <slaweq> yes, I think we can triage it
15:22:27 <mlavalle> cool, please go ahead and do it if you have time
15:22:36 <slaweq> ok, I will
15:23:12 <slaweq> so thats all RFEs which I have today
15:23:18 <slaweq> #topic Bugs
15:23:39 <slaweq> we still have few bugs reported for QoS
15:23:48 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1662109
15:23:49 <openstack> Launchpad bug 1662109 in neutron "tempest scenario test_qos fails intermittently" [High,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:24:26 <slaweq> I was checking it and now I can't check if it is still an issue as logs from this scenario job are probably not indexed on logstash
15:24:55 <slaweq> so I can't search if this test is still failing or not
15:25:45 <slaweq> mlavalle: maybe You could help me to check if I have proper query in logstash or maybe it's just my fault that I can't find anything?
15:26:09 <mlavalle> ok
15:26:35 <slaweq> thx, I will ping You later today, is that fine for You?
15:26:57 <mlavalle> yeah
15:26:59 <slaweq> thx
15:27:04 <slaweq> so, next one
15:27:07 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1733649
15:27:08 <openstack> Launchpad bug 1733649 in neutron "fullstack neutron.tests.fullstack.test_qos.TestDscpMarkingQoSOvs.test_dscp_marking_packets(openflow-native) failure" [High,Confirmed] - Assigned to Slawek Kaplonski (slaweq)
15:27:08 <mlavalle> is it the query at the top of the bug
15:27:10 <mlavalle> ?
15:27:17 <slaweq> no, it's not this one
15:27:56 <slaweq> I didn't put it in bug's comment
15:27:58 <mlavalle> I meant 1662109
15:28:19 <slaweq> mlavalle: yes, it's not this one which is in bug description
15:28:43 <slaweq> this one will not work for current tests for sure as job's name is now different
15:29:25 <slaweq> so about #link https://bugs.launchpad.net/neutron/+bug/1733649
15:29:26 <openstack> Launchpad bug 1733649 in neutron "fullstack neutron.tests.fullstack.test_qos.TestDscpMarkingQoSOvs.test_dscp_marking_packets(openflow-native) failure" [High,Confirmed] - Assigned to Slawek Kaplonski (slaweq)
15:29:47 <slaweq> I proposed patch to change way how tcpdump is stopped in test
15:29:59 <slaweq> it's already merged
15:30:20 <slaweq> so I will again wait if it will fail again and will try to check logs for it
15:30:35 <slaweq> it's not failing a lot so it's not easy to debug it
15:30:59 <slaweq> any questions?
15:31:14 <slaweq> or we can go to next one?
15:31:31 <mlavalle> next one
15:31:39 <slaweq> ok
15:31:40 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1736674
15:31:41 <openstack> Launchpad bug 1736674 in neutron "sg rules are sometimes not applied" [High,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:31:58 <slaweq> patch for this one is already waiting for reviews: #link https://review.openstack.org/#/c/527965/
15:32:26 <slaweq> it's bug with two different instances of IptablesManager used by L2 agent and QoS agent extension
15:32:47 <slaweq> so please review it if You will have some time :)
15:33:57 <slaweq> next one
15:33:59 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1737892
15:34:00 <openstack> Launchpad bug 1737892 in neutron "Fullstack test test_qos.TestBwLimitQoSOvs.test_bw_limit_qos_port_removed failing many times" [High,Confirmed] - Assigned to Slawek Kaplonski (slaweq)
15:34:09 <slaweq> it's also mine :)
15:34:13 <mlavalle> lol
15:34:17 <slaweq> and I have problem with this one
15:34:50 <slaweq> I can reproduce it locally (usually) once for every 20 or 30 times
15:34:58 <slaweq> but I have no idea why it is like that
15:35:35 <slaweq> in logs everything looks good, DbDestroy commands are executed in ovs properly, there is no any error or warning in logs
15:35:59 <slaweq> but sometimes it is failing because QoS/Queue is not removed from ovs
15:36:36 <slaweq> what is strange also is fact that after test is finished (failed) all is cleaned properly, so there is no this QoS or Queue created there
15:36:52 <slaweq> I will continue work on this one
15:37:23 <slaweq> maybe I will ask jlibosva for help if I will not find anything
15:37:48 <slaweq> any questions/suggestions?
15:38:02 <mlavalle> none right now
15:38:08 <slaweq> ok
15:38:11 <slaweq> so next one
15:38:13 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1736792
15:38:14 <openstack> Launchpad bug 1736792 in neutron "DSCP marking QOS policy applied to port not properly updating OVS flow table" [Medium,New]
15:38:23 <slaweq> this one is for me duplicate of #link https://bugs.launchpad.net/neutron/+bug/1739411
15:38:24 <openstack> Launchpad bug 1739411 in neutron "QoS DSCP mark disappear stable/ocata" [Low,Confirmed] - Assigned to Pavlukhin Max (mpavlukhin)
15:38:35 <slaweq> it affects only Ocata branch
15:38:48 <slaweq> and patch is already proposed:     #link https://review.openstack.org/#/c/529315/
15:38:49 <mlavalle> is it being worked on?
15:38:54 <mlavalle> ah ok
15:39:02 <slaweq> so please review it also :)
15:40:20 <slaweq> next one is quite old: #link https://bugs.launchpad.net/neutron/+bug/1639186
15:40:21 <openstack> Launchpad bug 1639186 in neutron "qos max bandwidth rules not working for neutron trunk ports" [Low,Confirmed]
15:40:27 <slaweq> and there is nothing new with it
15:40:53 <slaweq> it is not assigned to anyone and it looks that it is not easy to fix
15:41:19 <slaweq> it is similar like in #link https://bugs.launchpad.net/neutron/+bug/1732852
15:41:21 <openstack> Launchpad bug 1732852 in neutron "neutron don't support Router gateway rate limit " [Low,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:41:30 <slaweq> there is nothing new for it also
15:41:50 <slaweq> this one is in progress only because there is already merged patch for documentation
15:41:54 <slaweq> but nothing else
15:42:39 <slaweq> and the last one is
15:42:40 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1724729
15:42:41 <openstack> Launchpad bug 1724729 in neutron "ovs-lib not support qos type egress-policer for ovs-dpdk" [Low,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:42:55 <slaweq> (also assigned to me :))
15:43:09 <mlavalle> there is a patch already, right?
15:43:09 <slaweq> patch for this is waiting for review:
15:43:11 <slaweq> #link https://review.openstack.org/#/c/513398/
15:43:24 <slaweq> mlavalle: yes, please review it also :)
15:43:28 <mlavalle> ok
15:43:53 <slaweq> so, that's are all bugs which I have for today
15:44:03 <slaweq> any questions/someting to add?
15:45:02 <slaweq> ok, so moving on
15:45:04 <slaweq> #topic Open Discussion
15:45:36 <slaweq> do You have anything else to talk about?
15:45:54 <mlavalle> nope
15:46:08 <slaweq> I have one thing to ask
15:46:34 <slaweq> I wonder if those meetings are still necessary as usually there is quite few people attending on it
15:46:59 <slaweq> last few there was only me and mlavalle and maybe one other person
15:47:17 <mlavalle> well, I think it is a good summary every two weeks
15:47:33 <mlavalle> unless it is burdensome to you
15:47:38 <slaweq> yes, I feel like it is just my summary of what is going on
15:47:44 <slaweq> for me it is good
15:47:53 <mlavalle> let's keep it up
15:47:58 <slaweq> ok, sure
15:48:09 <slaweq> so that's all from my side
15:48:31 <slaweq> I think we can finish it earlier then
15:48:42 <slaweq> thx for attending mlavalle and alisanhaji :)
15:48:47 <mlavalle> o/
15:48:48 <slaweq> #endmeeting