15:00:55 <slaweq> #startmeeting neutron_qos
15:00:56 <openstack> Meeting started Tue Jan 16 15:00:55 2018 UTC and is due to finish in 60 minutes.  The chair is slaweq. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <openstack> The meeting name has been set to 'neutron_qos'
15:01:09 <slaweq> hi
15:01:12 <alisanhaji> Hi
15:01:16 <fouadben> Hi all
15:01:47 <slaweq> please give me one minute and I will be back
15:02:00 <mlavalle> o/
15:04:17 <slaweq> ok, I'm back
15:04:25 <slaweq> let's start
15:04:33 <slaweq> #topic RFEs
15:05:00 <slaweq> we have still couple approved RFEs
15:05:05 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1560963
15:05:06 <openstack> Launchpad bug 1560963 in neutron "[RFE] Minimum bandwidth support (egress)" [Wishlist,In progress]
15:05:13 <slaweq> there is nothing new with this one
15:05:20 <slaweq> not assigned to anyone
15:06:04 <slaweq> so if anyone would be interested in doing that, would be great :)
15:06:27 <slaweq> next one #link https://bugs.launchpad.net/neutron/+bug/1578989
15:06:28 <openstack> Launchpad bug 1578989 in neutron "[RFE] Strict minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Miguel Lavalle (minsel)
15:06:48 <slaweq> it's waiting for next cycle as we decided some time ago with mlavalle
15:07:03 <mlavalle> correct
15:07:07 <slaweq> but ralonsoh did some patches related to it
15:07:18 <slaweq> and he pushed placement api client to neutron-lib
15:07:30 <slaweq> one patch is already merged:  #link https://review.openstack.org/#/c/511936/
15:07:41 <slaweq> and second is in review: #link https://review.openstack.org/#/c/512396/
15:08:03 <slaweq> so please review it if You will have some time
15:08:28 <slaweq> next is almost done: #link https://bugs.launchpad.net/neutron/+bug/1596611
15:08:29 <openstack> Launchpad bug 1596611 in neutron "[RFE] Create L3 IPs with qos (rate limit)" [Wishlist,In progress] - Assigned to LIU Yulong (dragon889)
15:08:51 <slaweq> only docs and tempest tests are still in review
15:09:07 <slaweq> tempest tests are marked as WIP so I didn't review it yet
15:09:39 <mlavalle> I will take a look at the tempest tests
15:09:45 <slaweq> docs are almost ready IMO
15:09:49 <slaweq> ok, thx mlavalle
15:10:21 <slaweq> next is #link https://bugs.launchpad.net/neutron/+bug/1692951
15:10:22 <openstack> Launchpad bug 1692951 in neutron "[RFE] DSCP mark on the outer header" [Wishlist,In progress] - Assigned to Ali Sanhaji (ali-sanhaji)
15:10:22 <mlavalle> that is my impresion also
15:10:46 <alisanhaji> I just rebased for this one
15:10:56 <alisanhaji> after raryk comment
15:10:59 <alisanhaji> garyk
15:11:06 <slaweq> great that it's not only for me :)
15:11:20 <slaweq> alisanhaji: yes, thx a lot
15:11:48 <alisanhaji> no need to :)
15:12:02 <slaweq> mlavalle: please review https://review.openstack.org/#/c/501267/ if You will have some time
15:12:16 <slaweq> I will check it today or tomorrow also
15:12:41 <slaweq> I hope it can be merged finally soon :)
15:12:50 <alisanhaji> yes me too
15:13:41 <slaweq> alisanhaji: I saw that garyk gave +1 already :)
15:13:49 * mlavalle will take a loom also
15:13:49 <alisanhaji> yes just saw it too
15:14:16 <slaweq> ok, and the last (but not least) one is #link https://bugs.launchpad.net/neutron/+bug/1727578
15:14:17 <openstack> Launchpad bug 1727578 in neutron "[RFE]Support apply qos policy in VPN service" [Wishlist,Triaged]
15:14:34 <slaweq> there is specs proposed for it already: #link https://review.openstack.org/#/c/531074/
15:14:50 <slaweq> mlavalle: again, please add it to Your review list :)
15:15:23 <mlavalle> this RFE was approved last drivers meeting
15:15:35 <mlavalle> so the spec is timely
15:16:08 <slaweq> :)
15:16:32 <mlavalle> there was some doubts from yamamoto about how that would be implemented
15:16:53 <mlavalle> so if you can give some guidance, slaweq, it would be very usful
15:17:05 <mlavalle> I mean from your QoS perspective
15:17:10 <slaweq> from QoS point of view it looks like it can be some beginning of classful bw limits
15:17:35 <slaweq> as I understand it, there will be rules based on src/dest IP addresses added in router's namespace
15:17:37 <mlavalle> cool, please provide that guidance in the spec
15:17:53 <slaweq> yes, I was already reviewing it once or twice
15:17:58 <mlavalle> :-)
15:18:00 <slaweq> I will check it also this week
15:18:39 <slaweq> ok, so that was all RFEs which I had for today
15:19:00 <slaweq> #topic Bugs
15:19:48 <slaweq> fortunately there is not too many bugs reported for QoS :)
15:19:57 <slaweq> first one is #link https://bugs.launchpad.net/neutron/+bug/1662109
15:19:58 <openstack> Launchpad bug 1662109 in neutron "tempest scenario test_qos fails intermittently" [High,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:20:39 <slaweq> I still can't check if this is still an issue in gate - I didn't found it in my tests and logstash query for it is still not working IMO
15:20:52 <slaweq> mlavalle: we talked about that some time ago :)
15:20:56 <slaweq> do You remember?
15:21:08 <mlavalle> yes
15:21:24 <slaweq> can we maybe check it this week once again?
15:21:28 <mlavalle> yes
15:21:37 <slaweq> ok, thx
15:21:46 <slaweq> I will ping You later
15:22:28 <slaweq> next one: #link https://bugs.launchpad.net/neutron/+bug/1737892
15:22:29 <openstack> Launchpad bug 1737892 in neutron "Fullstack test test_qos.TestBwLimitQoSOvs.test_bw_limit_qos_port_removed failing many times" [High,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:22:51 <slaweq> patch for this one is almost merged
15:23:06 <slaweq> in fact it is not an issue in QoS code but in ovs agent
15:23:46 <slaweq> I will probably add also similar fullstack test for DSCP marking rule as such rule can be also not removed when port is removed from bridge
15:24:22 <slaweq> ah, and patch related to this bug is on #link https://review.openstack.org/#/c/533318/
15:25:13 <slaweq> any questions/suggestions so far?
15:27:21 <slaweq> mlavalle: alisanhaji: still here? :)
15:27:27 <mlavalle> yes
15:27:29 <alisanhaji> yes
15:27:32 <fouadben> y
15:27:32 <slaweq> should I continue?
15:27:39 <mlavalle> please go ahead
15:27:42 <slaweq> ok
15:27:52 <alisanhaji> I am following
15:28:01 <slaweq> so if there is no questions then next bug
15:28:02 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1736792
15:28:03 <openstack> Launchpad bug 1736792 in neutron "DSCP marking QOS policy applied to port not properly updating OVS flow table" [Medium,New]
15:28:13 <slaweq> for me it is duplicate of https://bugs.launchpad.net/neutron/+bug/1739411
15:28:15 <openstack> Launchpad bug 1739411 in neutron "QoS DSCP mark disappear stable/ocata" [Low,Confirmed] - Assigned to Pavlukhin Max (mpavlukhin)
15:28:22 <slaweq> and I would mark if as duplicate
15:28:30 <slaweq> mlavalle: do You agree?
15:28:41 <mlavalle> mhhh, hang on....
15:28:45 <slaweq> sure
15:29:23 <mlavalle> yes, I agree
15:29:59 <slaweq> ok, so I will close it after meeting
15:30:12 <slaweq> so about https://bugs.launchpad.net/neutron/+bug/1739411
15:30:18 <openstack> Launchpad bug 1739411 in neutron "QoS DSCP mark disappear stable/ocata" [Low,Confirmed] - Assigned to Pavlukhin Max (mpavlukhin)
15:30:28 <slaweq> there is already proposed patch:  #link https://review.openstack.org/#/c/529315/
15:30:39 <slaweq> but there is no response from author for it
15:30:55 <slaweq> I will try to catch him and ask if he can continue this work
15:30:59 <slaweq> or I will handle it
15:31:22 <slaweq> #action slaweq check progress on #link https://review.openstack.org/#/c/529315/
15:31:57 <slaweq> next is #link https://bugs.launchpad.net/neutron/+bug/1724729
15:31:58 <openstack> Launchpad bug 1724729 in neutron "ovs-lib not support qos type egress-policer for ovs-dpdk" [Low,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:32:13 <slaweq> and patch is waiting for review:  #link https://review.openstack.org/#/c/513398/
15:32:21 <slaweq> mlavalle: thx for Your review last week
15:32:51 <slaweq> I changed units according to Your comments as it's in fact different for dpdk ports :)
15:33:07 <mlavalle> yeah, I was surprised by that
15:33:13 <slaweq> me too
15:33:24 <mlavalle> I don't know why they decided to do it that way
15:33:33 <slaweq> me neighter
15:33:46 <mlavalle> I will take a look again today
15:33:52 <slaweq> and I was double checking that it's differently for dpdk ports and for "normal" ports
15:34:01 <slaweq> thx
15:34:11 <mlavalle> on the other hand, their doc is pretty good
15:34:33 <slaweq> yes, everything is described there quite clearly
15:34:34 <mlavalle> or blog entry or whatever it is
15:35:26 <slaweq> next one is our "old friend": #link https://bugs.launchpad.net/neutron/+bug/1639186
15:35:28 <openstack> Launchpad bug 1639186 in neutron "qos max bandwidth rules not working for neutron trunk ports" [Low,Confirmed]
15:35:42 <slaweq> there is no volunteer to work on it still
15:35:47 <slaweq> so nothing new
15:36:38 <slaweq> and the last one on my list for today is #link https://bugs.launchpad.net/neutron/+bug/1732852
15:36:39 <openstack> Launchpad bug 1732852 in neutron "neutron don't support Router gateway rate limit " [Low,In progress] - Assigned to Slawek Kaplonski (slaweq)
15:36:45 <slaweq> there is also nothing new here
15:37:25 <slaweq> I don't have time for it still :/
15:38:05 <slaweq> and as it is documented how it should be configured to make it working I think it's not high priority now
15:38:35 <mlavalle> ok
15:39:31 <slaweq> so that are all bugs which I have for You today
15:39:36 <slaweq> any questions?
15:39:43 <mlavalle> none from me
15:39:53 <alisanhaji> no questions
15:40:23 <slaweq> so last topic in agenda is
15:40:24 <slaweq> #topic Open Discussion
15:40:35 <slaweq> I don't have anything here
15:40:40 <fouadben> I would like to discuss a new spec that I proposed with alisanhaji for congestion reaction in overlay networks using neutron qos policy. #link https://review.openstack.org/#/c/534213/2
15:41:44 <fouadben> A previous version was proposed by reedip to activate ECN in openstack network and routers. https://review.openstack.org/#/c/445762/
15:42:24 <slaweq> so it is continuation of reedip's work?
15:42:43 <fouadben> We can see that.
15:42:47 <fouadben> So, this one proposes new qos policy that handles the congestion in all phases, starting by ensuring  ECN activation because it’s essential to congestion detection, going through the congestion calculation. Finally we react to the congestion if it exceeded the defined threshold using bandwidth limit qos rule.
15:44:12 <slaweq> so You want to change bandwidth limit rules dynamically when it is necessary?
15:45:36 <fouadben> Yes, we use the bandwidth limit rule dynamically en ensure that the source of congestion reduced its traffic, then we release it if the congestion goes below
15:46:14 <slaweq> so source VM will don't need to know about this ECN and don't need to support it
15:46:26 <slaweq> as it will be "supported" by Neutron's QoS rules, right?
15:47:28 <slaweq> fouadben: I will read this spec this week and will left comments there
15:47:32 <fouadben> This solution enfore the ECN activation what ever the VM OS configuration. Everything starts out of the VM.
15:47:48 <fouadben> Thanks slaweq
15:47:50 <slaweq> ok
15:47:53 <alisanhaji> slaweq: yes that's it, the VM doesn't need to know about ECN
15:48:00 <slaweq> that is good :)
15:48:16 <slaweq> I think that You will also need to fill RFE bug about that
15:48:19 <slaweq> mlavalle: right?
15:48:31 <mlavalle> yes, I think so
15:48:35 <fouadben> Already pub https://bugs.launchpad.net/neutron/+bug/1708460
15:48:36 <openstack> Launchpad bug 1708460 in neutron " [RFE] Reaction to network congestion for qos" [Wishlist,New] - Assigned to Fouad Benamrane (ftreqah)
15:49:18 <mlavalle> ok, I will look at it soon
15:49:19 <slaweq> ah, I didn't saw it linked as related-bug in commit message in specs so I thought it's not done yet
15:49:26 <slaweq> thx mlavalle
15:49:53 <slaweq> and thx fouadben and alisanhaji for this proposal :)
15:50:07 <fouadben> y welcome
15:50:22 <slaweq> anything else?
15:50:29 <alisanhaji> none from me
15:50:35 <slaweq> if not we can finish earlier today :)
15:50:39 <fouadben> no
15:51:12 <slaweq> mlavalle: do You have anything else to add?
15:51:18 <mlavalle> nope
15:51:37 <slaweq> ok, so thanks everyone
15:51:38 <mlavalle> thanks for chairing this meeting, slaweq :-)
15:51:49 <slaweq> #endmeeting