15:00:18 <slaweq> #startmeeting neutron_qos
15:00:19 <openstack> Meeting started Tue Sep 25 15:00:18 2018 UTC and is due to finish in 60 minutes.  The chair is slaweq. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:21 <slaweq> hi :)
15:00:23 <openstack> The meeting name has been set to 'neutron_qos'
15:00:30 <rubasov> hello again
15:00:34 <njohnston> o/
15:00:58 <slaweq> #topic RFEs
15:01:22 <mlavalle> again???? these zombies chase me all morning long
15:01:39 <slaweq> what zombies? :)
15:01:57 <mlavalle> slaweq, rubasov, njohnston, etc....
15:02:00 <slaweq> LOL
15:02:20 <slaweq> only 2 hours left for today :P
15:02:27 <mlavalle> yeap
15:02:36 <slaweq> ok, lets start
15:02:41 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1560963
15:02:41 <openstack> Launchpad bug 1560963 in neutron "[RFE] Minimum bandwidth support (egress)" [Wishlist,In progress]
15:02:56 <slaweq> there is still no any progress on this one
15:03:17 <slaweq> but now as ralonsoh is back to Neutron I will try to talk with him about this one
15:03:54 <slaweq> I just pinged him - maybe he will join us here
15:04:19 <slaweq> lets go to the next one
15:04:21 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1727578
15:04:21 <openstack> Launchpad bug 1727578 in neutron "[RFE]Support apply qos policy in VPN service" [Wishlist,Triaged]
15:04:33 <mlavalle> yeah, ralonsoh is a good addition to this team
15:04:51 <slaweq> here also it looks that there was no activity on this one also for some time
15:05:09 <mlavalle> give me an action item on this one for next week
15:05:23 <mlavalle> I will ping zhaobo AND the VPN team
15:05:32 <mlavalle> to get it moving
15:05:48 <slaweq> #action mlavalle to ping zhaobo about vpnaas qos patch
15:05:54 <slaweq> thx mlavalle
15:06:05 <slaweq> next is:
15:06:08 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1757044
15:06:08 <openstack> Launchpad bug 1757044 in neutron "[RFE] neutron L3 router gateway IP QoS" [Wishlist,In progress] - Assigned to LIU Yulong (dragon889)
15:06:25 <slaweq> for this there are 2 patches in review already
15:06:30 <slaweq> server side changes: #link https://review.openstack.org/#/c/424468/
15:06:42 <slaweq> and L3 agent side: #link https://review.openstack.org/#/c/568526/
15:06:49 <slaweq> I will need to review them this week
15:07:12 <mlavalle> server side is failing all zuul tests
15:07:20 <slaweq> #action slaweq to review L3 GW QoS patches
15:07:39 <mlavalle> actually both
15:08:19 <slaweq> looks like we need new neutron-lib release: http://logs.openstack.org/68/424468/26/check/openstack-tox-pep8/0a6f63b/job-output.txt.gz#_2018-09-20_20_25_59_666672
15:08:47 <slaweq> but I don't know if that is only problem with it
15:08:54 <mlavalle> slaweq: let's make sure that in the relase that njohnston we are including a=everything that is needed for these two patches
15:09:17 <mlavalle> so at least we remove that variable
15:09:20 <slaweq> mlavalle: You mean 1.19, right?
15:09:26 <mlavalle> yes
15:09:29 <slaweq> ok
15:09:32 <slaweq> sounds good for me
15:09:43 <njohnston> for the 1.19 release I set the tag where HEAD is right now
15:09:49 <njohnston> so if it has merged by now it is in
15:10:07 <slaweq> https://github.com/openstack/neutron-lib/blob/master/neutron_lib/api/definitions/qos_gateway_ip.py
15:10:15 <slaweq> this api def is merged already
15:10:32 <mlavalle> njohnston, slaweq: cool, thanks :-)
15:10:56 <slaweq> can we go to next one then?
15:11:00 <mlavalle> yes
15:11:03 <slaweq> ok
15:11:05 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1777627
15:11:05 <openstack> Launchpad bug 1777627 in neutron "RFE: QoS – rule's management (set,delete, show…) requires <qos-policy> parameter in addition to <rule-id>" [Wishlist,Triaged] - Assigned to Miguel Lavalle (minsel)
15:11:21 <slaweq> mlavalle: any progress on this? I think You didn't work on it yet
15:12:41 <mlavalle> slaweq: I just realized that arkady is not going to implement
15:12:46 <slaweq> :)
15:12:56 <slaweq> so at least You know now :)
15:13:03 <mlavalle> so I guess I'll start this week. Most likely over the weekend
15:13:23 <slaweq> great, thx mlavalle
15:13:35 <mlavalle> it shouldn't be very difficult
15:13:42 <slaweq> I don't think so
15:13:59 <mlavalle> and if I get in trouble, I'll come to get help from slaweq, the WoS guru
15:14:02 <mlavalle> QoS
15:14:09 <slaweq> LOL
15:14:19 <slaweq> I was wondering what the hell is WoS ;)
15:14:25 <mlavalle> LOL
15:14:51 <slaweq> ok, I have one more on the list
15:14:54 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1578989
15:14:54 <openstack> Launchpad bug 1578989 in neutron "[RFE] Strict minimum bandwidth support (egress)" [Wishlist,In progress] - Assigned to Lajos Katona (lajos-katona)
15:15:01 <slaweq> rubasov: any updates?
15:15:08 <rubasov> slaweq: a bit
15:15:12 <slaweq> demo in Denver was great - thx for that :)
15:15:20 <mlavalle> yeah
15:15:23 <rubasov> I did write that up
15:15:34 <rubasov> there's a mail about on the ML
15:16:01 <slaweq> I saw it :)
15:16:04 <rubasov> lajoskatona made progress with the code while I was slacking in Denver :-)
15:16:55 <rubasov> he has several patches in neutron and a few in neutron-tempest-plugin, where review is always welcome
15:17:24 <rubasov> and I also hope to make a new round on my patches later this week
15:18:10 * mlavalle wished he had included the demo write up in the PTG summary
15:18:22 <rubasov> now that's about all
15:18:46 <rubasov> mlavalle: don't worry about that
15:19:24 <slaweq> rubasov: all patches should be available under this topic like here: https://review.openstack.org/#/q/topic:minimum-bandwidth-allocation-placement-api+(status:open+OR+status:merged) right?
15:19:31 <rubasov> one little thing: I'll be out of office next week, but lajoskatona keeps up with the work
15:19:42 <rubasov> slaweq: yes, that's the topic
15:20:20 <slaweq> rubasov: ok, thx
15:20:37 <slaweq> thx for update and for all Your and lajoskatona work on this feature :)
15:20:52 <rubasov> thanks for all the help
15:20:54 <mlavalle> yeap, great work!
15:21:13 <slaweq> mlavalle: one thing FYI, I updated "implementation" of BP to "good progress" now based on the demo we saw in Denver
15:21:19 <slaweq> I hope it's fine for You
15:21:33 <mlavalle> perfectly fine. Thanks!
15:21:41 <slaweq> k
15:22:04 <slaweq> ok, so that was all RFEs which I had on list
15:22:13 <slaweq> any questions or something else what You want to add?
15:22:24 <mlavalle> not from me
15:22:49 <rubasov> nope
15:23:05 <slaweq> ok, so lets move on to the next topic
15:23:07 <slaweq> #topic Bugs
15:23:31 <slaweq> I didn't see any new bugs related to qos
15:23:45 <slaweq> but we have few existing ones to mention :)
15:23:48 <slaweq> first
15:23:50 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1784006
15:23:51 <openstack> Launchpad bug 1784006 in neutron "Instances miss neutron QoS on their ports after unrescue and soft reboot" [Medium,Confirmed] - Assigned to Miguel Lavalle (minsel)
15:23:59 <slaweq> mlavalle - any progress on this one?
15:24:30 <mlavalle> so I was looking at it lately
15:24:40 <mlavalle> and misunderstood the submitter comment
15:24:49 <mlavalle> I thought it was not an issue anymore
15:25:01 <mlavalle> but last night he left additional comment
15:25:07 <mlavalle> so I'll get back to it
15:25:17 <slaweq> ok, thx
15:26:05 <slaweq> next one then
15:26:08 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1732852
15:26:09 <openstack> Launchpad bug 1732852 in neutron "neutron don't support Router gateway rate limit " [Low,New]
15:26:11 <slaweq> it's long standing one :)
15:26:17 <slaweq> and I have a question here
15:26:29 <slaweq> can we mark it as "duplicate" of  https://bugs.launchpad.net/neutron/+bug/1757044 ?
15:26:30 <openstack> Launchpad bug 1757044 in neutron "[RFE] neutron L3 router gateway IP QoS" [Wishlist,In progress] - Assigned to LIU Yulong (dragon889)
15:26:43 <slaweq> it's not exactly duplicate but in fact both are about the same issue
15:26:49 <slaweq> what You think mlavalle?
15:27:17 * mlavalle looking
15:28:03 <mlavalle> yeah, I think that makes sense
15:28:11 <slaweq> ok, thx
15:28:17 <slaweq> I will do it after this meeting then
15:28:23 <mlavalle> ++
15:28:29 <slaweq> next one
15:28:32 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1779052
15:28:32 <openstack> Launchpad bug 1779052 in neutron "Quality of Service (QoS) in Neutron (documentation) - only different types rules can be combined in QoS policy" [Low,In progress] - Assigned to yanpuqing (ycx)
15:28:41 <slaweq> there is patch https://review.openstack.org/#/c/581941/ but there is no progress on it
15:29:16 <mlavalle> let's leave a warning in the patch
15:29:16 <slaweq> if there will be no update of it this week I will address comments from review and continue it to make it merged finally
15:29:23 <mlavalle> yeap
15:29:28 <slaweq> ++
15:29:33 <mlavalle> leave a comment today
15:29:43 <slaweq> I will write a comment in review after this meeting also
15:29:45 <mlavalle> that if we don't see progress this week, you will it over
15:30:02 <slaweq> ok, I will do that
15:30:07 <mlavalle> Thanks
15:30:10 <ralonsoh> I can continue with this one, if the developer doesn't continue with it
15:30:48 <mlavalle> niuce to see you again in this meeting :-)
15:30:54 <ralonsoh> thanks
15:30:54 <mlavalle> ralonsoh:
15:31:18 <slaweq> ralonsoh: please go ahead if You want and owner will not update it :)
15:31:27 <ralonsoh> slaweq: perfect!
15:31:52 <slaweq> ok, next one then
15:31:54 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1776160
15:31:54 <openstack> Launchpad bug 1776160 in neutron "'burst' does not take effect for neutron egress qos bindlimit by ovs" [Undecided,New]
15:32:02 <slaweq> I didn't have time to reproduce it yet
15:32:33 <slaweq> it was marked as incomplete but reporter wrote some new comment so I switched it to new for now
15:33:21 <slaweq> ok, and the last one:
15:33:24 <slaweq> #link https://bugs.launchpad.net/neutron/+bug/1785189
15:33:24 <openstack> Launchpad bug 1785189 in neutron "Floatingip and router bandwidth speed limit failure" [Undecided,In progress] - Assigned to Brian Haley (brian-haley)
15:33:27 <slaweq> Patch is proposed: https://review.openstack.org/#/c/596637/
15:33:34 <slaweq> please review if You have some time :)
15:34:06 <mlavalle> Liu Yulong left some comments
15:34:49 <slaweq> ahh, there wasn't those comments when I was checking it today morning :)
15:35:52 <slaweq> so let's wait for reply to Liu Yulong's comment and review it :)
15:36:08 <mlavalle> yeap
15:36:23 <slaweq> ok, so that is all what I have for today
15:36:30 <slaweq> #topic Open Discussion
15:36:36 <slaweq> anything You want to talk about?
15:36:52 <mlavalle> not from me
15:37:22 <slaweq> if not I will give You 22 minutes back today :)
15:37:27 <slaweq> thx for attending
15:37:30 <ralonsoh> bye!
15:37:31 <mlavalle> o/
15:37:32 <slaweq> and see You in 2 weeks
15:37:33 <slaweq> o/
15:37:37 <njohnston> o/
15:37:38 <rubasov> bye
15:37:38 <slaweq> #endmeeting