14:01:25 <carl_baldwin> #startmeeting neutron_routed_networks
14:01:25 <openstack> Meeting started Tue Apr  5 14:01:25 2016 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:30 <openstack> The meeting name has been set to 'neutron_routed_networks'
14:01:30 <carl_baldwin> #topic Announcements
14:01:38 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-Routed-Networks
14:02:07 <carl_baldwin> Let's see.  I think the basic segment API is ready to merge.
14:02:25 <carl_baldwin> #link https://review.openstack.org/#/c/296603/
14:02:52 <carl_baldwin> I hope to get someone to merge it today.
14:02:57 <carl_baldwin> Any other announcements?
14:03:14 <mlavalle> Just to mention the summit
14:03:22 <mlavalle> it's 3 weeks away
14:03:38 <carl_baldwin> Yep!  Coming fast.
14:03:52 <mlavalle> We have some sessions relevant to this effort there
14:03:59 <carl_baldwin> I see some feedback from armax on the API patch.  I'll address it early this morning.
14:04:14 <mlavalle> Specifically on Wednesday, discussion with the Nova team
14:04:29 <carl_baldwin> mlavalle: Do you know the specific time / session?
14:05:05 <mlavalle> carl_baldwin: no, but I intend to follow up with mreidem to make sure we have good coverage
14:05:19 <mlavalle> I'll update this team next week during this meeting
14:05:46 <carl_baldwin> The Nova sessions on the schedule still say "tbd"
14:06:03 <carl_baldwin> mlavalle: Thanks for following up on that.  Hopefully, next week we'll know.
14:06:19 <carl_baldwin> Any other announcements?
14:06:25 <mlavalle> yeah, I am passing along what was commented yesterday during the scheduler meeting :-)
14:06:52 <carl_baldwin> #topic Progress
14:07:24 <carl_baldwin> The basic CRUD patches are pretty much ready.  So, nothing to report on that.
14:07:36 <carl_baldwin> #topic Associate Subnets to Segments and IPAM
14:08:17 <carl_baldwin> I'm wrapping up UTs on a patch to allow association of subnets to segments.  It should be ready to go by early tomorrow.
14:09:21 <carl_baldwin> The next part is IPAM related.  My plan is to have a patch for pluggable IPAM up for review by the end of the week.
14:10:20 <carl_baldwin> The idea will be to push some concept of grouping down in to the pluggable driver so that drivers can optionally optimize queries based on groups of subnets (by network, by segment, etc.)
14:10:32 <carl_baldwin> It will still work with existing IPAM drivers.
14:10:53 <carl_baldwin> That's about it.
14:11:02 <blogan> i look forward to it
14:11:06 <ski2> hey carl_baldwin: anything we can help on?
14:11:13 <carl_baldwin> #action carl_baldwin will post review for pluggable IPAM this week.
14:12:09 <carl_baldwin> ski2: At the moment, I just need to get the first patch up for the IPAM part.
14:12:47 <carl_baldwin> From there, it would be nice to have someone actually running the patches on their own to see what testing I may have missed and getting familiar with it.
14:12:47 <ski2> carl_baldwin: did you want us to take it and run with it after you post?
14:13:16 <ski2> carl_baldwin: sure thing, once you post we'll take it on
14:13:45 <carl_baldwin> ski2: Thanks, we'll communicate once I've got it up.
14:14:26 <carl_baldwin> I'll push really hard to get it up by the end of the week.
14:15:00 <carl_baldwin> #topic Nova Scheduler
14:15:06 <carl_baldwin> mlavalle: you're up.
14:15:54 <mlavalle> So I posted a new approach to handle the coordination between Nova and Neutron in the spec https://review.openstack.org/#/c/263898/
14:16:43 <mlavalle> It refers specifically on how to reduce the complexity of handling use case 3 (port created in neutron with ip address)
14:17:04 <mlavalle> I brought it up yesterday during the Nova scheduler meeting
14:17:14 <mlavalle> No specific feedback
14:17:46 <mlavalle> so if carl_baldwin has some time, I would like to see his reaction to it
14:18:00 <carl_baldwin> mlavalle: I'm hoping we can still get that high bandwidth discussion with jaypipes and hopefully others soon.
14:18:29 <mlavalle> yeah, me too. I can follow up with him
14:18:40 <carl_baldwin> mlavalle: I read it over yesterday but I need to read it over again.  I'll point out some things on the review today.
14:18:56 <carl_baldwin> mlavalle: I need to read it over one more time to be sure I understood.
14:19:14 <mlavalle> ping me if at any time if you have questions
14:19:31 <carl_baldwin> My initial reaction was that it could lead to more nova boot failures than they may want.
14:19:45 <blogan> i need to read it over 50 more times :)
14:20:37 <carl_baldwin> #action carl_baldwin will comment on mlavalle 's approach on the nova spec.
14:20:55 <mlavalle> The other thing I've been looking at is in re-thinking where we need to make the calls to Neutron in the Nova code
14:21:00 <carl_baldwin> I encourage all to read it too.
14:21:18 <mlavalle> I think we need to move that from the compute manager to the scheduler manager
14:21:41 <mlavalle> I mentioned this briefly last week to carl_baldwin
14:21:54 <mlavalle> I will elaborate that this week
14:22:20 <carl_baldwin> mlavalle: What is the motivation for that?  Would Nova be making calls to Neutron during scheduling?
14:23:27 <mlavalle> Nova now to make the decision of where to place a port based on IP availability in segments
14:23:34 <mlavalle> has to make^^^
14:24:57 <mlavalle> this doesn't mean we need to touch the Neutron API inside Nova. It means we need to call it from a diferent place
14:25:08 <carl_baldwin> mlavalle: One thing I do know is that it is *very* important to nova that it not have to make external calls during scheduling.  I tend to agree with them.
14:25:54 <mlavalle> ok, i'll take that into consideration
14:26:11 <mlavalle> it's something I've been thinking of and just wanted to shre it here
14:26:21 <carl_baldwin> mlavalle: understood.
14:26:39 <mlavalle> that's all I have on this topic this week
14:26:46 <carl_baldwin> mlavalle: Thanks.
14:27:13 <carl_baldwin> #topic Create / delete segment in ML2
14:27:37 <xiaohhui> I see it is still no owner, right?
14:27:40 <carl_baldwin> This one still has no owner.  I think we're going to need someone pretty familiar with ML2.
14:27:45 <carl_baldwin> xiaohhui: correct.
14:27:53 <xiaohhui> I will be full back to work this week, I think I can do that.
14:28:40 <carl_baldwin> I talked to rkukura about this a bit last week.  He said that it was always the intention to enable create and delete of segments on an existing network.  It was just never implemented.  It sounded feasible.
14:29:50 <carl_baldwin> Anyway, we'll keep this one on the back burner and continue to search for an owner.  We might be able to use the summit to find support.
14:30:11 <carl_baldwin> #action carl_baldwin will add it to the summit etherpad
14:30:45 <carl_baldwin> xiaohhui: your message came in late for me.
14:31:03 <xiaohhui> bad network~
14:31:11 <carl_baldwin> xiaohhui: :)
14:31:26 <carl_baldwin> xiaohhui: will that be difficult with the OVN work you're also doing?
14:32:08 <xiaohhui> I think they might be related, so I would to look them both, together.
14:32:17 <carl_baldwin> xiaohhui: It will be good to get a good start on this.
14:32:54 <xiaohhui> yeah, I do think so
14:33:46 <carl_baldwin> It can follow https://review.openstack.org/#/c/296658/ which I intend to rebase and get in to shape as soon as the preceding one merges.
14:34:03 <carl_baldwin> That one should merge pretty quickly too I should think.
14:34:07 <carl_baldwin> xiaohhui: Thanks!
14:34:37 <carl_baldwin> #topic Segment aware DHCP
14:34:53 <carl_baldwin> blogan talked to me yesterday about this.
14:34:58 <carl_baldwin> blogan: hi
14:35:02 <blogan> hello!
14:35:35 <blogan> but yeah i'll certianly take this on, its definitely a knowledge gap for me but it'll be a good learning exercise even if i fall flat on my face
14:37:27 <carl_baldwin> blogan: You should be able to get a start on this once you can associate subnets with segments.  I have that patch *almost* ready to update.
14:37:45 <blogan> okay ill start on top of that patch then
14:38:15 <carl_baldwin> blogan:  I'll reach out as soon as I get that one posted.
14:38:26 <blogan> carl_baldwin: excellent, thanks!
14:38:51 <carl_baldwin> blogan: Thank you!
14:38:55 <carl_baldwin> #topic Client
14:39:00 <carl_baldwin> rtheis: reedip__ : hi
14:39:05 <rtheis> hi
14:39:29 <reedip__> hello ..
14:40:00 <carl_baldwin> Anything to discuss?
14:40:09 <reedip__> I have some issues with the neutron tests, and have fallen back on the name/desc patch
14:40:41 <reedip__> I will spend tomorrow to see what the problem is...
14:41:10 <reedip__> #link https://review.openstack.org/#/c/293305/
14:41:51 <carl_baldwin> reedip__: That patch keeps falling off my radar.  I think it is because the topic is not "bp/routed-networks"
14:42:10 <reedip__> cant figure out the error properly.. carl_baldwin: Yeah, rtheis suggested the same
14:42:10 <rtheis> Working devref update for newton (https://review.openstack.org/#/c/299399/)... CLI ready once APIs are
14:43:15 <carl_baldwin> rtheis: Thanks.  I'll have a look at that devref too.
14:43:17 <rtheis> carl_baldwin: but it sounds like we won't want entire CLI CRUD since things are coming in stages on API side
14:43:45 <rtheis> maybe I'll break up my patches to match API
14:44:26 <rtheis> nothing else to report fromme
14:44:31 <carl_baldwin> rtheis: that might be good.  It is always strange to have an API land before the capability lands.
14:44:39 <rtheis> :)
14:44:49 <carl_baldwin> reedip__: I'll have a look at your patch too.
14:45:00 <carl_baldwin> Thanks.  Anything else to discuss?
14:45:37 <rtheis> nothing else
14:45:57 <carl_baldwin> rtheis: reedip__ Thanks.
14:46:00 <carl_baldwin> #topic L2 adjacency
14:46:01 <reedip__> carl_baldwin : Nothing else.. I think however, you have a patch for associating segments as well ?
14:46:11 <carl_baldwin> #undo
14:46:12 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0xa8c0c10>
14:46:29 <carl_baldwin> reedip__: Yes, I've committed to getting that patch updated by early tomorrow.
14:46:36 <reedip__> ok
14:47:03 <carl_baldwin> reedip__: It'll be an update to https://review.openstack.org/#/c/288774/ which is now very old but I have new stuff locally.
14:47:20 <reedip__> carl_baldwin: ok...
14:47:34 <carl_baldwin> #topic L2 adjacency
14:48:12 <carl_baldwin> This'll be a pretty straight-forward task, I think.
14:48:52 <carl_baldwin> Basically, just add a read-only attribute to the extension to return true or false based on the network.
14:49:04 <carl_baldwin> It has no owner so I wanted to throw it out there.
14:49:30 <carl_baldwin> That's all.
14:49:35 <carl_baldwin> #topic Open Agenda
14:49:51 <carl_baldwin> xiaohhui: Actually did you have anything regarding OVN to discuss?
14:49:56 <mlavalle> carl_baldwin: are we going to discuss segments host mapping?
14:50:15 <xiaohhui> yeah,, I talked with russellb a little earlier. The code for ovs ovn has been implemented. Now the bridge-mapping and hostname can be found in OVN db. I will add some code in networking-ovn to read them out and use them for routed network. I had some personal affairs in the last two weeks, so I have to say sorry that I still have these in mind, not a patch for them now. I will try my best to post a patch in this week.
14:50:17 <carl_baldwin> mlavalle: Is that missing from the agenda?  Oops.
14:50:24 <ski2> carl_baldwin: we can take the l2 adjacency as well
14:50:27 <russellb> \o/
14:50:27 <reedip__> carl_baldwin: can take up L2 adjacency, should help me understand a bit more ...
14:50:45 <carl_baldwin> reedip__: ping me about it.
14:50:46 <russellb> xiaohhui: thanks again
14:50:55 <russellb> xiaohhui: no worries on delays ... i needed some time to implement those pieces in OVN
14:51:13 <carl_baldwin> reedip__: ski2: Actually ski2 was in there first.
14:51:33 <russellb> xiaohhui: and please let me know if you hit anything else that's needed
14:51:47 <carl_baldwin> xiaohhui: Sounds like good progress.
14:51:51 <reedip__> ski2: can I help ??
14:52:04 <xiaohhui> sure, thanks russellb
14:52:19 <carl_baldwin> russellb: Thanks for getting to that stuff so quickly.
14:52:24 <russellb> no problem
14:53:01 <carl_baldwin> ski2: Can we discuss in the neutron channel later?
14:53:09 <ski2> reedip__: if you want to take it, be my guest :)
14:53:14 <ski2> sure thing
14:54:23 <reedip__> ski2: thanks ... :)
14:54:31 <carl_baldwin> Anything else?
14:54:33 <xiaohhui> And this patch might need some attention https://review.openstack.org/#/c/295173/   it is just a clean up patch, no functionality
14:55:03 <carl_baldwin> xiaohhui: I'll review.  Thanks!
14:55:16 <xiaohhui> thank you, nothing else from me
14:55:38 <carl_baldwin> If that's it...
14:55:39 <carl_baldwin> going once
14:55:49 <carl_baldwin> twice...
14:55:55 <carl_baldwin> #endmeeting