15:01:00 <carl_baldwin> #startmeeting neutron_routed_networks
15:01:00 <openstack> Meeting started Tue May 10 15:01:00 2016 UTC and is due to finish in 60 minutes.  The chair is carl_baldwin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:05 <openstack> The meeting name has been set to 'neutron_routed_networks'
15:01:08 <carl_baldwin> #topic Announcements
15:01:11 <xiaohhui> hi
15:01:17 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-Routed-Networks
15:01:35 <carl_baldwin> The segment CRUD patch merged!
15:01:41 <blogan> hooray!
15:01:48 <mlavalle> ++
15:02:07 <carl_baldwin> I think my next two patches are getting pretty close too.
15:02:27 <carl_baldwin> I'm starting to see momentum pick up again since summit killed it a little.  :)
15:02:38 <blogan> yep, well i haven't dove into the 3rd one yet too much, but the 2nd one is close
15:03:13 <carl_baldwin> We've got just 3 weeks until Newton-1
15:03:15 <carl_baldwin> #link http://releases.openstack.org/newton/schedule.html
15:03:38 <carl_baldwin> blogan: Thanks for helping out with the feedback.  I've almost got another PS to upload for that one.
15:03:58 <carl_baldwin> #link https://review.openstack.org/#/c/288774/
15:04:44 <carl_baldwin> Another announcement is that I created an etherpad to help myself and others to use the patches that are up.
15:05:01 <carl_baldwin> #link https://etherpad.openstack.org/p/routed-provider-networks-notes
15:05:09 <rtheis> carl_baldwin: thanks for that pointer to etherpad
15:05:42 <carl_baldwin> rtheis: yw, I just noticed your question on my abandoned ML2 patch and responded there.  Did you see it?
15:05:59 <rtheis> carl_baldwin: I did see it, thanks
15:06:13 <carl_baldwin> rtheis: good
15:06:52 <carl_baldwin> Basically, we'll leave the segment service plugin disabled by default for now.
15:07:25 <carl_baldwin> Any other announcements?
15:08:21 <carl_baldwin> I think I'd like to move the progress section of the meeting wiki to the etherpad to avoid having to update it in two places.
15:08:38 <mlavalle> ++
15:08:43 <rtheis> sounds good
15:08:56 <carl_baldwin> But, for today, I'll use the wiki to be sure I don't miss anything there.
15:09:26 <carl_baldwin> We've already touched on the first two sections of the wiki.  The subnet / segment association patch is looking pretty good.
15:09:37 <carl_baldwin> So ...
15:09:41 <carl_baldwin> #topic Nova Scheduler
15:09:50 <carl_baldwin> mlavalle: hi
15:09:58 <mlavalle> hi
15:10:20 <mlavalle> the generic pools resource spec is looking very good as far as approval
15:10:36 <mlavalle> #link https://review.openstack.org/#/c/300176
15:10:54 <mlavalle> it was discussed yesterday during the nova scheduler meeting
15:11:12 <mlavalle> the consensus is that it should merge this week
15:11:38 <carl_baldwin> Great!
15:11:46 <mlavalle> the routed networks spec follows after it
15:12:07 <mlavalle> so we should be ready to address comments to it
15:12:56 <mlavalle> I also had yesterday an irc conversation with johnthetubaguy about the refactoring of "allocate_for_instance" to the conductor
15:12:56 <carl_baldwin> I've kept an eye on it.  It has been quiet so far.  But, I'll continue to keep an eye on it.
15:13:16 <carl_baldwin> If any of you notice comments, let me know of the activity.  I miss a lot of gerrit emails.
15:13:28 <carl_baldwin> mlavalle: How did that go?
15:14:01 <mlavalle> the plan is that he will do the refactoring of the method itself. And then on top of that I will add the routed networks bits
15:14:39 <mlavalle> so I plan to review his code as soon as he puts it up and the start adding the routed networks pieces
15:15:04 <carl_baldwin> mlavalle: So, by the time you touch the code, the relevant parts will be running in the conductor with the 3-phase design?
15:15:17 <mlavalle> carl_baldwin: yeap
15:15:25 <carl_baldwin> mlavalle: great!
15:15:43 <carl_baldwin> mlavalle: Does he have any kind of timeline in mind?
15:15:56 <mlavalle> I was hoping johnthetubaguy might want to comment here...
15:16:29 <mlavalle> if he doesn't, i'll follow up with him with the timeline piece :-)
15:16:40 <carl_baldwin> mlavalle: Thanks.
15:17:18 <mlavalle> that's all I have this week on this topic. I will continue monitoring the scheduler team meeting and John's patchsets
15:17:21 <carl_baldwin> mlavalle: Would you mind updating the etherpad?
15:17:33 <carl_baldwin> ... especially when patches start showing up.
15:17:35 <mlavalle> carl_baldwin: I will update it
15:17:43 <carl_baldwin> mlavalle: Thanks!
15:18:06 <carl_baldwin> #topic Host / Segment Mapping
15:18:10 <mlavalle> hi again
15:18:19 <carl_baldwin> mlavalle: I've seen an update to your patch that I haven't fully reviewed.
15:18:26 <carl_baldwin> mlavalle: I will be sure to review it today.
15:18:34 <mlavalle> this past week I made good progress with host segment mapping
15:19:00 <mlavalle> #link https://review.openstack.org/#/c/285548
15:19:13 <mlavalle> I don't consider it WIP anymore
15:19:31 <mlavalle> I think I have addressed the concerns about ML2 details spilling over
15:19:47 <mlavalle> and also added unit tests, which are passing
15:20:01 <mlavalle> the patchset is passing all the jenkins tests, except 1
15:20:29 <mlavalle> I have a conversation going on with HenryG about one test of allembic scripts
15:20:50 <blogan> ill be sure to review that today too
15:20:53 <mlavalle> that test is failing me becasue I depend on a contract script
15:21:18 <carl_baldwin> mlavalle: I hit the same problem in my patch.
15:21:33 <mlavalle> so when I move my migration script to the contract directory, the test gets angry that I have a create table
15:21:43 <HenryG> yep, this is getting tricky
15:22:11 <mlavalle> so I will work with HenryG to fix that. But other than that, the patchset is good
15:22:13 <carl_baldwin> mlavalle: Oh, I didn't hit that error.
15:22:23 <carl_baldwin> mlavalle: I will review today.
15:22:42 <HenryG> We may need to disable that test for a while
15:22:48 <HenryG> I need to speak to Ihar
15:23:07 <mlavalle> xiaohhui: thank you for your review. In summary, yes the idea is that we will process bridge mappings coming from all the in tree mechanism drivers
15:23:19 <mlavalle> I will add unit tests for all of them today
15:23:32 <carl_baldwin> HenryG: Ya, we may need to relax the constraints a bit for Newton.
15:23:39 <xiaohhui> ok, thanks
15:24:06 <mlavalle> Finally, I made excellent progress with the SR-IOV mechanism river: https://review.openstack.org/#/c/312289/
15:24:12 <carl_baldwin> mlavalle: Excellent.  This work is just in time because my IPAM work needs it.  I will work on integrating yours in to mine soon.
15:24:48 <carl_baldwin> mlavalle: Let's get that merged.  I think it has +1s from the right people.
15:24:49 <mlavalle> That patchset is good to merge. I got +1's from irenab and moshele, who are the SR-IOV czar's
15:25:33 <carl_baldwin> HenryG: You're around, would you mind kicking it in?  It isn't too bad to review and has all the right +1s.
15:25:35 <mlavalle> with that patchset, we have a uniform interface in all the mechanism driver in ML2 that we can leverage for the host segments mapping
15:25:56 <carl_baldwin> mlavalle: Great work!
15:26:07 <mlavalle> that's all I have this week
15:26:39 <carl_baldwin> mlavalle: Thanks!
15:26:56 <carl_baldwin> #topic Create / delete segment in ML2
15:27:26 <xiaohhui> carl, I see you set workflow -1 to this patch
15:27:28 <carl_baldwin> xiaohhui: hi
15:27:32 <xiaohhui> hi
15:27:55 <xiaohhui> I haven't get too much to this patch since I get back from summit
15:28:16 <xiaohhui> But I think the next step is to implement segment as extension in ml2, right?
15:28:25 <carl_baldwin> xiaohhui: I think you had a discussion point in the etherpad.
15:28:47 <carl_baldwin> xiaohhui: That was it.
15:29:10 <xiaohhui> Yeap, I added the discussion point just before the meeting
15:29:15 <carl_baldwin> xiaohhui: We're going to have to integrate the service plugin somehow with ML2.
15:29:32 <carl_baldwin> Honestly, I'm not sure yet how that will look.
15:30:18 <xiaohhui> I don't have a clear picture for it too.
15:30:35 <carl_baldwin> I was also thinking that we might want to consult rkukura and maybe the ml2 subteam on this.
15:31:28 <carl_baldwin> I'm wondering if we should put this on their meeting agenda.
15:31:32 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/ML2
15:32:13 <carl_baldwin> They have a meeting tomorrow at 1600UTC.  That is getting pretty late for you.
15:32:39 <carl_baldwin> Maybe I can attend and present the problem and you can read the logs.
15:32:53 <xiaohhui> 12:00AM for me, I guess. That is great, thanks
15:33:09 <carl_baldwin> xiaohhui: Okay, I will plan to do that.
15:33:23 <xiaohhui> And for the discussion point, In which cases, we should allow/forbid deleting network's segment?
15:33:28 <carl_baldwin> #action carl_baldwin will add create / delete segments to ml2 agenda and attend meeting.
15:33:44 <carl_baldwin> xiaohhui: This is something I would like to ask the ML2 team.
15:33:59 * mlavalle will also attend the ML2 meeting. I want to follow up this issue
15:34:07 <xiaohhui> OK,
15:34:34 <carl_baldwin> xiaohhui: Just checking the meeting logs on your Thursday.
15:34:44 <xiaohhui> OK, thanks
15:34:50 <carl_baldwin> Hopefully, we'll be able to get some good feedback from them.
15:34:56 <carl_baldwin> xiaohhui: anything else?
15:35:02 <xiaohhui> nothing else
15:35:37 <carl_baldwin> xiaohhui: Thanks
15:35:51 <carl_baldwin> #topic Segment aware DHCP
15:35:54 <carl_baldwin> blogan: hi
15:36:00 <blogan> oh hello
15:36:05 <carl_baldwin> I did start reading your patch.  I keep getting distracted.
15:36:12 <blogan> lol i know how that goes
15:36:30 <blogan> well ill be pushing up a new patch today, so it may be worth just waiting until i do that
15:36:48 <carl_baldwin> blogan: ack
15:36:50 <blogan> i'll actually be able to devote the rest of the day to this
15:37:02 <blogan> well that and reviews
15:37:11 <blogan> but ill update the etherpad as well
15:37:41 <blogan> would like to get your 2nd patch merged though so i can base my patch off of mlavalle's segment host mapping patch
15:37:58 <carl_baldwin> blogan: Me too.  :)
15:38:05 <mlavalle> lol
15:38:28 <carl_baldwin> Let's get that one merged and then we'll all pile up on mlavalle
15:38:30 <blogan> but thats pretty much my update
15:38:35 <carl_baldwin> ... I mean his patch.  lol
15:38:41 <mlavalle> lol
15:38:47 <blogan> i prefer the first option
15:38:57 <blogan> pile on insults i mean
15:39:06 <mlavalle> :-)
15:39:57 * carl_baldwin thinks blogan and mlavalle have some history there
15:40:03 <alekseyruban> Hi everybody. I have an issue with encryption in Cinder/Nova. When I create an instance on an encrypted volume, Nova replace a link at /dev/disk/by-path and after I remove that instance I get broken link and not able to create volume any more. Help please. How to bypass this issue?
15:40:20 <blogan> alekseyruban: wrong channel i think
15:40:24 <mlavalle> we certainly do :-)
15:40:28 <carl_baldwin> blogan: thanks!
15:40:31 <carl_baldwin> #topic Client
15:40:43 <rtheis> hi
15:40:47 <carl_baldwin> rtheis: anything update?
15:41:34 <carl_baldwin> I just added a client section to the etherpad
15:41:40 <rtheis> summit session result for OSC transition is in and we continue with CLI in OSC repo
15:42:09 <rtheis> I plan to test out the list and show options and may be able to remove WIP soon
15:42:50 <carl_baldwin> rtheis: cool
15:42:59 <rtheis> I can update the etherpad with details
15:43:17 <carl_baldwin> rtheis: great
15:44:00 <rtheis> nothing else from me
15:44:32 <carl_baldwin> rtheis: Thanks.
15:44:42 <carl_baldwin> #topic OVN and routed networks
15:44:50 <xiaohhui> hi
15:44:55 <carl_baldwin> hi
15:45:16 <xiaohhui> the work in OVN has stopped, because the ml2 implementation is not clear now
15:45:50 <rtheis> Also networking-ovn itself is in transition from core plugin to ML2 mech driver
15:46:06 <xiaohhui> yeah, that is another dependency
15:46:24 <xiaohhui> thanks rtheis to bring it out
15:46:25 <carl_baldwin> So, the switch to ML2 is the official plan now?
15:46:32 <rtheis> Here is the OVN patch set https://review.openstack.org/#/c/312705/
15:46:40 <carl_baldwin> I had heard about that switch at the summit but it was not final.
15:47:26 <rtheis> carl_baldwin: baring any critical issues, I think the networking-ovn team would say it is official
15:47:49 <rtheis> but we are in early stages of switch
15:47:55 <carl_baldwin> rtheis: Good to know.
15:48:17 <carl_baldwin> rtheis: And you're taking on the work to switch?
15:48:23 <rtheis> I am
15:48:53 <rtheis> jckasper is working on it too
15:48:57 <mlavalle> we are in good hands :-)
15:50:17 <carl_baldwin> Great!  That should make it easier to integrate with routed networks.
15:50:31 <carl_baldwin> Although, being agentless, we'll still have to come up with host / segment mappings in a new way.
15:51:05 <xiaohhui> There is a patch in OVN to get host / segment mappings
15:51:31 <mlavalle> xiaohhui: do you have the url handy?
15:51:36 <xiaohhui> https://review.openstack.org/#/c/302623/
15:51:43 <mlavalle> thanks!
15:53:40 <carl_baldwin> I've just added it to the etherpad.
15:53:46 <xiaohhui> See it
15:53:55 <carl_baldwin> #topic Deliverables.
15:54:20 <carl_baldwin> Let's talk about Newton-1.  What can we deliver?
15:54:51 <carl_baldwin> I'll commit to the IPAM work which is pretty close as long as host / segment mapping is in.
15:55:07 <mlavalle> let's discuss further after you take a look at segemtns host mapping, b ut I think we can deliver that
15:55:16 <blogan> i'm pretty sure I can get the dhcp agent work done, but I'm not sure if reviews will push it over the deadline
15:55:51 <blogan> after i push up this new patch, i think i'll get a good feeling on it's chances of making it for N-1
15:56:05 <carl_baldwin> blogan: reviews are hard to predict.
15:56:53 <carl_baldwin> I'll also commit to having a Nova spec for deferred IP allocation, unaddressed ports respun.  I'm not sure how much more I can confidently commit to there.
15:57:18 <mlavalle> I'll push for that during the scheduler meetings
15:57:20 <blogan> indeed, but i'm more worried about whether i've totally gone in the wrong direction or if i'm on the right path
15:57:20 <carl_baldwin> mlavalle: Do you think we can have the scheduling spec merged in Nova and work started by N-1?
15:57:51 <carl_baldwin> blogan: I'll review today and hopefully we can get some clarity.
15:57:54 <mlavalle> yeah, mriedem wants to have it merged rioght after generic resource pools
15:58:00 <blogan> carl_baldwin: sounds good
15:58:03 <carl_baldwin> mlavalle: great.
15:58:28 <blogan> carl_baldwin: one question, how is it planned to tie ports to segments? segment_id on the port?
15:58:55 <blogan> we can take it offline too
15:59:13 <carl_baldwin> blogan: That is a good question.
16:00:06 <blogan> we've hit time :)
16:00:09 <carl_baldwin> For now, the plan is to expose segment on the fixed ips.  I've done some thinking about adding segment_id to a port but that gets confusing with hierarchical port binding which can bind multiple segments.
16:00:13 <carl_baldwin> blogan: Thanks.
16:00:15 <carl_baldwin> #endmeeting