23:01:38 <yamahata> #startmeeting neutron/servicevm
23:01:38 <openstack> Meeting started Tue Mar 18 23:01:38 2014 UTC and is due to finish in 60 minutes.  The chair is yamahata. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:01:41 <openstack> The meeting name has been set to 'neutron_servicevm'
23:01:56 <yamahata> #topic logistics
23:02:24 <yamahata> This timeslot is temporal. and there are another proposal.
23:02:34 <yamahata> So we'd like to agree on better timeslot.
23:02:57 <yamahata> So far related timezone is
23:03:02 <s3wong> the current timeslot is OK for us PDT/PST people :-)
23:03:45 <yamahata> Some is uncomfortable with it.
23:03:51 <sweston> I don't have any special needs.  Yes, it is fine in the US, but is fairly undoable for a lot of time zones.
23:04:38 <s3wong> agreed
23:05:01 <yamahata> JST(UTC+9), PST(UTC-8), PDT(UTC-7), EST(UTC-5) and IST(UTC+5.3)
23:05:37 <s3wong> so what is the new proposal(s)
23:05:58 <s3wong> for meeting time
23:06:59 <sweston> what are the requests for? earlier or later?
23:07:58 <yamahata> I'm thinking of some hours later.
23:08:07 <s3wong> now is 23:00 UTC, one would imagine it should be earlier (in the day)
23:08:19 <yamahata> wondering it also works for EST and IST
23:09:14 <yamahata> yes, I mean 2:00UTC, 3:00UTC
23:09:29 <s3wong> yamahata: probably not working for Europe time
23:10:11 <yamahata> s3wong: right. Unfortunately there is no timezome that works for all asia, europe and us.
23:10:33 <sweston> where is the majority of the interest right now?
23:11:19 <s3wong> I am in US (Pacific timezone)
23:11:36 <yamahata> PST/EST, JST, IST. I'm not aware of europe time.
23:12:32 <yamahata> Okay, I'll propose on ML and we'll see it.
23:12:45 <sweston> so utc-5 looks like the best to me
23:13:34 <yamahata> 5:00 UTC works for me
23:14:12 <sweston> ok, I'd say let's give it a week or two on ML for people to respond, then change it.
23:14:29 <s3wong> OK
23:14:50 <yamahata> #action propose new timeslot 5:00 UTC on the ml
23:15:51 <yamahata> #action yamahata propose new timeslot 5:00 utc on the ml
23:16:17 <yamahata> next topic is f2f meeting.
23:16:22 <sweston> meetbot must have left ...
23:16:53 <s3wong> @23:00, meetbot is sleeping :-)
23:16:58 <yamahata> It is possible for me to organize f2f meeting in Santa Clara on April 17 or 18.
23:17:07 <sweston> hehe, meetbot needs rest too
23:17:27 <s3wong> yamahata: f2f meeting in Santa Clara is fine with me
23:17:31 <yamahata> Do we want to have it? given it's only 1 month before the summit.
23:18:05 <sweston> the last one generated a good deal of interest ... I guess it depends on what would be discussed.
23:18:06 <yamahata> Maybe it can be done at the summit.
23:18:58 <s3wong> yamahata: this is not Icehouse feature, so having discussion at J-Summit would still be OK
23:19:36 <yamahata> s3wong: I've proposed the topic for J summit.
23:20:00 <sweston> I agree.  no reason to get everyone together if we're just all going to see each other in a month
23:20:10 <s3wong> +1
23:20:34 <yamahata> Then let's skip this time.
23:21:27 <yamahata> next thing is frequency.
23:22:08 <yamahata> I think the meeting will be held weekly at first. then we can switch to bi-weekly.
23:22:24 <s3wong> yamahata: OK
23:23:14 <yamahata> any other topic related to logistics?
23:23:24 <sweston> I don't have anyting
23:23:28 <sweston> anything
23:23:33 <s3wong> all good
23:23:49 <yamahata> #topic current-status
23:24:41 <yamahata> As agreed at I-summit, I'm working on servicevm for lbaas.
23:25:30 <yamahata> I've implemented API/DB model part, lbaas-driver(plugin-part), neutron-command, devstack.
23:25:51 <yamahata> and oslo.messaging
23:26:06 <yamahata> I'm working on lbaas-agent and VM image.
23:27:04 <yamahata> My estimation is 1 week or two to have working service VM that runs haproxy inside vm.
23:27:47 <yamahata> The blueprint for horizon GUI is proposed.
23:28:34 <sweston> okay ... is there anything that you need that anyone can help with, at this point?
23:28:49 <s3wong> yamahata: if I instantiate LBaaS, how can I specify if I am using the current container model vs VM based?
23:29:25 <yamahata> sweston: patch review and API review.
23:29:55 <yamahata> s3wong: Right now it is chosen by config file.
23:30:32 <yamahata> s3wong: In future, it could be chosen dynamically by service provider extension when lbaas supports it.
23:30:49 <sweston> okay, I can help with that ... do you have a list of reviews I can start on?
23:31:09 <yamahata> #link https://review.openstack.org/#/c/56892/
23:31:15 <yamahata> #link https://review.openstack.org/#/c/72068/
23:31:22 <yamahata> #link https://review.openstack.org/#/c/77862/
23:31:28 <yamahata> #link https://review.openstack.org/#/c/77863/
23:31:35 <yamahata> #link https://review.openstack.org/#/c/72070/
23:32:06 <s3wong> yamahata: could be part of the flavor framework in the future
23:32:56 <sweston> okay, I have them on my reading list now
23:32:58 <yamahata> s3wong: maybe yes when lbaas supports it.
23:34:50 <yamahata> the discussion for GUI has been started. There is mock image. would be interesting
23:35:39 <yamahata> #link https://blueprints.launchpad.net/horizon/+spec/neutron-adv-svc-vm
23:36:05 <yamahata> #link https://wiki.openstack.org/wiki/Horizon-NFV-configuration#NFV_instances
23:36:08 <s3wong> yamahata: yeah, there is a nova context in there too. Does the tenant get charged for one vm?
23:37:35 <yamahata> s3wong: it's open question for now. The current implementation doesn't, though.
23:38:30 <yamahata> It needs consideration. Do you have any idea?
23:39:24 <s3wong> yamahata: it is interesting, because now you are introducing "service VM" in nova also (thus it would know not to charge tenant)
23:39:42 <sweston> well, it's an api right?  so if there's expressed interest, we can add a multiplier .. but that might open up a can of worms
23:40:59 <yamahata> s3wong: VM is created with a dedicated user for now. not by the original user.
23:41:54 <yamahata> s3wong: there isurely s a requirement that tenants want to create its own servicevm and manage them themselves.
23:42:07 <s3wong> yamahata: OK. Good start
23:43:10 <yamahata> any other questions?
23:43:41 <sweston> not right now, not from me at least
23:43:53 <s3wong> good, will take a look at your code
23:44:31 <sweston> s3wong: agree
23:45:23 <yamahata> high level review of API will also help
23:45:55 <s3wong> yamahata: OK
23:46:05 <yamahata> #link https://docs.google.com/document/d/1ZWDDTjwhIUedyipkDztM0_nBYgfCEP9Q77hhn1ZduCA/edit#
23:46:07 <sweston> yamahata okay
23:46:19 <yamahata> # open topic
23:46:28 <yamahata> #topic open
23:46:38 <yamahata> Any open topic to discuss?
23:46:57 <sweston> I don't have anything ... s3wong?
23:47:11 <s3wong> Not for now
23:47:30 <yamahata> okay, thanks.
23:47:41 <yamahata> bye
23:47:44 <yamahata> #endmeeting