15:01:45 <ihrachys> #startmeeting neutron_upgrades
15:01:45 <openstack> Meeting started Mon Dec 14 15:01:45 2015 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:48 <openstack> The meeting name has been set to 'neutron_upgrades'
15:02:27 <ihrachys> hi all. I read the meeting notes from the previous week, seems like it was a quiet meeting ;) thanks sc68cal for handling it anyway.
15:03:00 <ihrachys> there are no announcements from my side. let's go straight to the matter.
15:03:14 <ihrachys> #topic Organisational matters
15:03:55 <ihrachys> one thing I wanted to ask you folks is whether we need a separate Launchpad tag for upgrade related issues. I think it could be useful once we get more stuff to care.
15:04:27 <rossella_s> let's wait then till we see the real need for it
15:04:42 <rossella_s> (sorry for being late)
15:04:46 <ihrachys> that's reasonable. then let's wait. :)
15:04:55 * ihrachys waves at rossella_s
15:04:57 <mhickey> agree
15:05:10 <akamyshnikova> agreed
15:05:11 <ihrachys> ok next thing is
15:05:11 <ihrachys> #topic Partial Multinode Grenade
15:05:27 <ihrachys> sc68cal: korzen: dare to update what's the job state and where we can help?
15:06:15 <korzen> I was not able to handle the grenade job lately
15:06:35 <ihrachys> korzen: pointers where to start for those who could have time to help?
15:06:38 <korzen> but the latest status is that we've got problem during resource creation phase
15:07:24 <korzen> yeap, anyone able to help is welcome
15:07:34 <korzen> the status is on mailing list
15:07:38 <korzen> let me search for it
15:07:44 <ihrachys> korzen: it's http://lists.openstack.org/pipermail/openstack-dev/2015-November/079344.html ?
15:07:51 <ihrachys> and below
15:08:16 <korzen> yes, this is the thread
15:08:25 * ihrachys should spare some cycles to look at what we have now
15:08:44 <ihrachys> I hope we have more eyes glaring this week.
15:08:50 <korzen> I hoped that sc68cal would take a look last week
15:09:17 <ihrachys> korzen: is there a way to trigger new runs? is it 'check experimental'?
15:09:28 <ihrachys> or 'recheck'?
15:09:35 <korzen> yes, it is the 'check experimental'
15:09:51 <korzen> is there a way to get the job stats?
15:09:55 <korzen> from jenkins?
15:10:15 <ihrachys> korzen: you mean, the number of failures vs. successes?
15:10:18 <korzen> yes
15:10:44 <ihrachys> korzen: I know little, but I have heard folks use graphite for that: http://graphite.openstack.org
15:11:44 <ihrachys> korzen: infra (sdague?) probably should have an answer. I know Sean actively monitors failures for some gate jobs.
15:12:05 <korzen> ihrachys, ok I will ask them
15:12:34 <ihrachys> ok, everyone welcome to look at latest results, and collect them.
15:12:36 <ihrachys> let's move on
15:12:44 <ihrachys> #topic Object implementation
15:12:50 <ihrachys> rossella_s: I believe it's your turn :)
15:13:03 <rossella_s> yay!
15:13:20 <rossella_s> so in case you didn't have a look, there's a WIP https://review.openstack.org/#/c/253641
15:13:30 <rossella_s> thanks ihrachys for the review
15:14:04 <rossella_s> I wanted to see if we can use the ObjectField to model extensions
15:14:07 <rossella_s> it seems to work
15:14:25 <ihrachys> rossella_s: that's a really good start, even though we need to iterate a bit on it.
15:14:28 <rossella_s> I didn't want to spend too much time on it, I wanted to receive feedback from people who worked with ovo before
15:14:35 <rossella_s> ihrachys, yes
15:14:38 <rossella_s> more than a bit
15:14:44 <ihrachys> rossella_s: :)
15:15:10 <rossella_s> just wanted to get some feeback before spending weeks on it :p
15:15:14 <korzen> I will post a WIP patch on network later this week
15:15:20 <korzen> network OVO
15:15:38 <rossella_s> korzen, great!
15:15:53 <ihrachys> I guess extensions, more test coverage could be the first steps. it would also be great to see whether it would be easy to plug the code into some existing code using dicts to see how it plays there. I think kevinbenton wanted to get it into notification layer, so that could be a good start.
15:15:59 <rossella_s> so my plan for next week it's to keep working on this patch, adding tests as a first step
15:16:02 <korzen> the network OVO has dependency on port, subnet and NetworkRBAC
15:16:22 <ihrachys> korzen: I am very glad to hear more good news!
15:16:34 <rossella_s> agreed ihrachys
15:16:57 <rossella_s> first let's add more tests, then let's try to introduce it in the code
15:17:14 <ihrachys> korzen: for rbac, we need to think how we integrate it into objects. AFAIK there is a patch by hdaniel that should come up with some general rbac solution, starting with qos policies.
15:17:32 <ihrachys> that one: https://review.openstack.org/250081
15:17:38 <ihrachys> so probably worth a look
15:17:40 <korzen> My current approach is to have Network OVO with custom JSON fields for port and subnet in it - this is the today's aproach, I'll see how it will work...
15:18:06 <rossella_s> korzen, please no custom JSON field
15:18:19 <ihrachys> rossella_s: I guess it's temp solution until port object is ready
15:18:30 <ihrachys> obviously not for merge
15:18:48 <rossella_s> ihrachys, ok then, let's put a big TODO there :)
15:18:58 <ihrachys> a huge one
15:19:00 <korzen> rossella_s, the problem is that subnet is introducing the 5 more OVO object to implement
15:19:39 <rossella_s> korzen, then I would say let's start with one of those object and leave network for later
15:19:44 <ihrachys> korzen: I am afrain that's something we'll be forced to unravel. :(
15:20:31 <ihrachys> yeah, I guess starting with leaves is the right approach. it's nevertheless good we started with network because now we should have better understanding of the tree.
15:20:43 <rossella_s> yeah
15:20:58 <korzen> I will try to post some patch with both aproaches
15:21:23 <ihrachys> korzen: cool!
15:21:29 <korzen> I'll see how it woudl work in the end...
15:21:45 <korzen> s/woudl/would
15:22:15 <ihrachys> on general object stuff side, I was reminded by nova folks we need some validation against unintended object schema changes in the gate. nova has something called object hasher that allows to hash on object schema definitions in the registry, I will need to look into adopting the approach.
15:22:36 <rossella_s> ihrachys, nice
15:22:43 <ihrachys> ok, so thanks everyone for working on the objects side, and looking forward for more ;)
15:22:48 <ihrachys> let's move on
15:22:51 <rossella_s> :)
15:22:53 <ihrachys> #topic Patches on review
15:23:06 <ihrachys> so rossella_s's patch https://review.openstack.org/#/c/253641/ was already discussed.
15:23:32 <ihrachys> another upgrades thing was devref update for upgrade strategy for RPC callbacks by ajo: https://review.openstack.org/241154 it's now merged. kudos to ajo!
15:23:47 <ihrachys> ajo: when do we expect to start nitpicking on code for the devref?
15:23:58 <mhickey> well done ajo; lot of hard PSes! :)
15:24:48 <ihrachys> ok, let's get back to ajo later, seems like he is deep into something right now :)
15:25:34 <ihrachys> I have one more patch for has_offline_migrations CLI for neutron-db-manage: https://review.openstack.org/248190 but it's still not really ready for merge, so let's not waste time on it
15:25:53 <ihrachys> any more patches for the team to look at?
15:26:20 <korzen> I have to drop the meeting, bye all!
15:26:26 <ihrachys> korzen: o/
15:26:55 <ihrachys> ok, I guess nothing else to review for now. which is fine, let's move on.
15:27:00 <ihrachys> #topic Open discussion
15:27:44 <ihrachys> I had one think in the agenda and was hoping to hear from rossella_s and akamyshnikova since you both know a great deal about OVS agent backend side
15:27:48 <ihrachys> specifically,
15:27:49 <ihrachys> #link http://lists.openstack.org/pipermail/openstack-dev/2015-December/081264.html
15:27:59 * rossella_s looking
15:28:12 <ihrachys> that's a proposal to introduce some structure into how we manage flows for features
15:28:45 <ihrachys> I suspect it may impact rolling upgrades (in terms of data plane disruption), so it would be great to hear what you think.
15:28:47 <rossella_s> I had read it briefly and was planning to comment on it
15:28:59 <rossella_s> ok, will answer later today
15:29:00 <ihrachys> same for overall proposal, since it honestly can make little sense.
15:29:13 <ihrachys> rossella_s: thanks!
15:29:23 <ihrachys> akamyshnikova: and thanks in advance your way ;)
15:30:00 <rossella_s> cool, anything else?
15:30:02 <ihrachys> one more thing that was raised by mhickey is we probably have little stuff to tackle for those who would like to get more involved.
15:30:19 <rossella_s> ihrachys, we can find something
15:30:36 <ihrachys> so I was wondering whether folks see where we can spin off some tasks for those who have time?
15:30:44 <mhickey> I am willing! :)
15:31:00 <rossella_s> I will try to do that, once I get the ovo port in a better shape
15:31:02 * ihrachys now wonders whether the objects hasher thing can be a great candidate for exact that goal
15:31:10 <rossella_s> ihrachys, good point
15:31:42 <rossella_s> maybe we should have an action for next meeting to fill a list of tasks that can be given to people willing to join
15:32:05 <ihrachys> mhickey: ok, let's discuss then in neutron channel what's that about and how you can help once you feel less burdened by other stuff you handle.
15:32:09 <ihrachys> rossella_s: that's a great idea!
15:32:34 <ihrachys> #action ihrachys to start a detailed list of tasks to do for folks with free time
15:32:36 <mhickey> ihrachys: sure; might be able to get something rolling before the holidays.
15:32:56 <ihrachys> rossella_s: is it ok to maintain it on wiki? or should it be etherpad?
15:33:11 <rossella_s> ihrachys, I think for now the wiki is ok...I don't expect a long list
15:33:22 <ihrachys> rossella_s: ok. thanks for the suggestion.
15:33:25 <ski1> ihrachys: i have 2 developers dedicated to this effort to attack those details
15:33:52 <rossella_s> ihrachys, thank you actually :)
15:33:52 <ihrachys> ski1: oh that's nice to hear. let's discuss details off the meeting!
15:34:04 <ski1> ihrachys: sounds good
15:34:19 <ihrachys> anyone else for the open discussion?
15:35:01 <ihrachys> #action rossella_s to reply on ovs agent flow maintenance email thread
15:35:08 <ihrachys> ok, I guess that's it, we call a day.
15:35:11 <rossella_s> ihrachys, thanks
15:35:24 <ihrachys> thanks everyone for joining!
15:35:24 <ihrachys> #endmeeting