15:01:45 <ihrachys> #startmeeting neutron_upgrades
15:01:46 <openstack> Meeting started Mon Apr 11 15:01:45 2016 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:48 <ihrachys> hi everyone!
15:01:50 <sayalilunkad> hello
15:01:50 <openstack> The meeting name has been set to 'neutron_upgrades'
15:01:53 <saisriki> hi
15:01:58 <electrocucaracha> hey there
15:02:12 <jlibosva> hi
15:02:22 <pmath> mornin
15:02:29 <ihrachys> #link https://wiki.openstack.org/wiki/Meetings/Neutron-Upgrades-Subteam Agenda
15:02:37 <ihrachys> hi pmath! hi everyone.
15:02:43 <ihrachys> let's get to the matter
15:02:47 <ihrachys> #topic Announcements
15:02:49 <rossella_s1> Hi
15:02:57 <korzen> hello
15:03:05 <tonytan4ever> morning
15:03:13 <ihrachys> as you probably know, Mitaka was released this week. but Newton was open for a while already. so nothing changes for us really.
15:03:33 <ihrachys> #topic Summit planning
15:03:49 <ihrachys> as you probably know, there will be a bunch of design summit sessions for neutron
15:04:23 <ihrachys> the etherpad where we collect ideas:
15:04:25 <ihrachys> #link https://etherpad.openstack.org/p/newton-neutron-summit-ideas
15:04:45 <ihrachys> note that the number of sessions is limited, so we won't have a huge slot where we could raise upgrade matters
15:04:56 <korzen> do we know if upgrades was accepted?
15:05:26 <ihrachys> that said, there will be a session on 'neutron architecture'
15:05:41 <ihrachys> which will be led by rossella_s1 and yours truly
15:05:47 <ihrachys> note that a slot is 40 mins
15:06:15 <ihrachys> I guess we will discuss some upgrade matters during that session
15:06:19 <korzen> ihrachys is there a schedule already?
15:06:20 <ihrachys> the etherpad for the session:
15:06:21 <ihrachys> #link https://etherpad.openstack.org/p/newton-neutron-future-neutron-architecture
15:06:31 <ihrachys> korzen: yes, a sec, I will post a link
15:07:15 <ihrachys> #link https://www.openstack.org/summit/austin-2016/summit-schedule/global-search?t=Neutron%3A
15:07:48 <ihrachys> the session in question is on Wed starting at 5:20
15:08:16 <korzen> Future of * is main topic I see
15:08:19 <korzen> ;)
15:08:30 <rossella_s> :D
15:08:37 <ihrachys> rossella_s1 and I will work on the agenda of the session in next days.
15:08:57 <rossella_s> ihrachys, I have already a first draft on the etherpad
15:09:06 <ihrachys> it's all about future! stadium, robots, time machine, Skynet, all taht
15:09:23 <ihrachys> rossella_s: cool! I will take a look till tomorrow
15:10:03 <rossella_s> ihrachys, thanks, I've just gathered the topics suggested on the general etherpad that could fit the neutron architecture umbrella
15:10:25 <ihrachys> for others, I will also note that korzen, rossella_s and I prepare a talk for the summit on upgrades that will take place on Mon:
15:10:26 <ihrachys> #link https://www.openstack.org/summit/austin-2016/summit-schedule/events/7536?goback=1
15:10:41 <ihrachys> ok, let's move on to current affairs.
15:10:58 <ihrachys> #topic Partial Multinode Grenade
15:11:21 <ihrachys> I don't think there was a huge progress on that one, we are mostly on hold while gate and stadium issues are in limbo
15:11:29 <ihrachys> but, things to note are:
15:11:55 <ihrachys> 1. armax has a patch to add rolling tag to neutron: https://review.openstack.org/286817
15:12:38 <ihrachys> it was WIP for a while, but now back to life, and I expect the discussion on the summit around what stadium and the future of *aas is to influence the patch
15:13:14 <ihrachys> to recollect, the patch was blocked while it's not clear whether work is needed in *aas repos before claiming a tag for the whole neutron project
15:13:27 <rossella_s> ihrachys, thanks for the nice summary
15:13:28 <ihrachys> another relevant patch is:
15:13:30 <ihrachys> #link https://review.openstack.org/299843
15:14:13 <ihrachys> ^ that one is intended to make the job we have voting
15:14:50 <ihrachys> ok, that's all I have for the job
15:15:00 <ihrachys> #topic Object implementation
15:15:08 <ihrachys> for objects, there was some progress made
15:15:40 <ihrachys> specifically, jlibosva got to completion the standard attributes patches: https://review.openstack.org/292829
15:15:43 <ihrachys> it's now merged
15:15:52 <ihrachys> so in theory we have no blockers to adopt subnetpool in the code
15:16:03 <electrocucaracha> \o/
15:16:08 <korzen> I have rebased the subnet OVO patch, and consider it ready for review, please do: https://review.openstack.org/#/c/264273/
15:16:10 <rossella_s> yay!
15:16:14 <ihrachys> need to respin https://review.openstack.org/300056 for that
15:17:28 <ihrachys> korzen: I hear you. I haven't checked those patches since they are probably huge :)
15:17:37 <ihrachys> but I should stop slacking
15:18:02 <ihrachys> also, we are currently landing the patch that integrates dhcp extra opt object:
15:18:02 <korzen> ihrachys I have split them if the one is too big
15:18:03 <ihrachys> #link https://review.openstack.org/285397
15:18:18 <ihrachys> that will be the first end-to-end integration of an object into existing db code ;)
15:18:21 <sayalilunkad> korzen: your patch still shows conflict
15:18:37 <ihrachys> sayalilunkad: that is probably because of std attr patch just landed
15:18:52 <sayalilunkad> ihrachys: ah ok
15:18:54 <rossella_s> ihrachys, great
15:19:07 <ihrachys> so overall, the progress happens
15:19:17 <rossella_s> ihrachys, I was to slow reviewing the extra dhcp opt patch
15:19:18 <ihrachys> thanks a lot everyone working on all those patches, it's great stuff :)
15:19:28 <ihrachys> rossella_s: amotoki got to help :)
15:19:43 <amotoki> hi
15:19:53 <rossella_s> thanks amotoki !
15:19:55 <ski2> ihrachys: any additional objects we can work on, that aren't taken or haven't been worked on?
15:20:01 <ihrachys> amotoki: hi. thanks for +A the extra dhcp opt patch :)
15:20:17 <ihrachys> ski2: let me check the list for port object.
15:20:52 <ihrachys> anyone looking at dns object?
15:20:58 <ihrachys> line 75 https://etherpad.openstack.org/p/code-sprint-neutron-objects-brno
15:21:08 <jlibosva> I can take something
15:21:19 <tonytan4ever> Me too
15:21:35 <tonytan4ever> I want to take an object as well
15:21:35 <saisriki> I believe korzen is working on the DNS object
15:21:40 <pmath> same
15:21:48 <korzen> I have DNS Name Server OVO
15:22:00 <korzen> not sure if it is the same as Port DNS extension
15:22:03 <jlibosva> maybe we can mark with name objects that are WIP
15:22:10 <ihrachys> jlibosva: can you maybe play with the WIP I have for subnetpool integration? it should require just standard attr integration and I believe you are in good position to carry that
15:22:11 <jlibosva> on that etherpad
15:22:19 <jlibosva> ihrachys: ack
15:22:27 <ihrachys> wow so many volunteers! :)
15:22:44 <korzen> router is free
15:22:51 <rossella_s> amazing
15:22:54 <korzen> fip is free
15:22:59 <amotoki> btw, I noticed too many reviews are linked to a single bug and i see a lot of assignee changes :-(
15:23:01 <ihrachys> it looks like we should indeed start with new resources
15:23:15 <ihrachys> amotoki: yeah. but having a bug per patch would also not scale
15:23:21 <amotoki> isn't it better to have a blueprint to gather the effort?
15:23:37 <ihrachys> korzen: rossella_s: what about network object?
15:23:52 <rossella_s> korzen, is working on it I think
15:23:52 <korzen> ihrachys I'm working on it
15:24:05 <ihrachys> amotoki: initially we were told we don't need bp and RFE is enough. but we can discuss it with armax to switch to bp. I will do it
15:24:07 <electrocucaracha> I noticed that it has subnet dependenci
15:24:16 <electrocucaracha> dependency*
15:24:18 <ihrachys> #action ihrachys to talk to armax about bp for ovo work
15:24:35 <korzen> electrocucaracha, yes, the network is dependent on subnet and port
15:24:42 <amotoki> ihrachys: thanks. I believe it is the case where a blueprint fits :)
15:25:08 <ihrachys> tonytan4ever: pmath: ski2: if you can care the burden, it would be great to start biting router object starting from leaves
15:25:18 <ihrachys> that's line 97+ https://etherpad.openstack.org/p/code-sprint-neutron-objects-brno
15:25:29 <tonytan4ever> Okay
15:25:35 <ski2> ihrachys: sounds like a plan!
15:25:39 <pmath> okay
15:25:44 <ihrachys> are you all in sync, or I need to split it more for you?
15:25:51 <tonytan4ever> How about I start with router0 object ?
15:26:29 <ihrachys> tonytan4ever: you can start with router. but I think first you will need to tackle the leaves (line 98+) before you are able to cover the whole router object.
15:26:30 <ski2> tonytan4ever: we'll take that offline
15:26:41 <ihrachys> tonytan4ever: see how we started for port - from extensions to the core resources
15:26:47 <tonytan4ever> I see.
15:26:54 <tonytan4ever> ski2: Cool
15:27:10 <ihrachys> ski2: pmath: are you from the same team? or you want me to help you sync?
15:27:11 <rossella_s> ihrachys, talking about port...I'd like to get that in this week
15:27:14 <pmath> yes
15:27:19 <pmath> we'll sync up
15:27:30 <ihrachys> rossella_s: wow. I did not expect it's in that great shape to consider it!
15:28:07 <ihrachys> pmath: thanks!
15:28:08 <rossella_s> ihrachys, :D , let's be ambitious...it still needs some respin but I want to focus on getting it done this week
15:28:10 <ski2> ihrachys: yeah we are all on same team, osic development rackspace/intel partnership for openstack
15:28:29 <ihrachys> rossella_s: ok I will try not to drag it. :)
15:28:40 <rossella_s> ihrachys, no worries, I will bother you when needed
15:29:10 <ihrachys> ski2: great. thanks for joining, really appreciate.
15:29:12 <electrocucaracha> oisc -> tonytan4ever, pmath, ski2, saisriki and me
15:29:26 <electrocucaracha> s/oisc/osic
15:30:02 <ihrachys> great!
15:30:12 <amotoki> what's osic?
15:30:30 <rossella_s> thanks for joining! don't forget to keep us (the bigger team) involved :)
15:30:35 <electrocucaracha> OpenStack Innovation Center
15:30:45 <amotoki> electrocucaracha: got it
15:31:01 <amotoki> there are many abbrev in openstack world :)
15:31:25 <ihrachys> #topic Other patches
15:31:46 <electrocucaracha> ihrachys: Address Scope and Agent OVO seem to be leaves
15:32:15 <ihrachys> one thing to note for 'other' stuff is that alembic testing framework landed recently in the tree. so we can now add functional tests for alembic specifically.
15:32:27 <rossella_s> ihrachys, wow
15:32:51 * ihrachys searches for the link..
15:32:54 <korzen> I need to drop, bye
15:33:00 <ihrachys> korzen: o/
15:33:19 <rossella_s> ihrachys, that's also a nice task to start...I mean I'd avoid to port more objects if we can write tests
15:33:43 <ihrachys> ok, that's the patch:
15:33:44 <ihrachys> #link https://review.openstack.org/#/c/124946/
15:34:14 <ihrachys> rossella_s: what do you mean?
15:34:24 <ski2> there were two patches that might fit in the other, leaf objects: https://review.openstack.org/#/c/297887/ https://review.openstack.org/#/c/297821/
15:34:28 <ski2> ready for review
15:34:45 <ihrachys> ski2: ack. we'll get to objects on review
15:35:02 <ihrachys> rossella_s: ?
15:35:21 <ski2> ihrachys: k
15:35:56 <amotoki> rossella_s: same question too as ihar
15:36:15 <rossella_s> ihrachys, I mean for people who wants to start working on the ovo stuff, some task like writing a test is also nice. I don't want to start porting all possible objects
15:36:37 <rossella_s> ihrachys, amotoki does it make sense?
15:36:48 <ihrachys> rossella_s: I am not sure I follow. why do you want to avoid porting everything to objects?
15:37:03 <amotoki> rossella_s: what kind of tests in your mind?
15:37:35 <amotoki> I thought our functional and dsvm testing cover most.
15:37:46 <ihrachys> I was talking more about this kinds of tests:
15:37:47 <ihrachys> #link https://review.openstack.org/#/c/294183/9/neutron/tests/functional/db/test_migrations.py
15:37:48 <rossella_s> ihrachys, I don't want to avoid that...that should be the end goal. I just want to avoid that we start working on some other object without finishing what we currently have in progress...or without adding enough tests
15:38:00 <ihrachys> where you populate db with data, then execute alembic on the data
15:38:33 <rossella_s> so if we have more people willing to work on this, I'd also put some test related tasks, not only new objects, I can take care of adding a list
15:38:51 <rossella_s> I am just afraid we end up with lots of object in the tree that are not fully integrated.
15:38:57 <electrocucaracha> +1
15:38:58 <ihrachys> rossella_s: I agree we should probably consolidate efforts, so let's stop at routers and not take more resources until we integrate existing bits for ports
15:39:11 <rossella_s> porting an object is kind of easy now but integrating is going to be painful
15:39:22 <rossella_s> ihrachys, +1
15:39:32 <ihrachys> rossella_s: would a list of objects to pending integration help?
15:40:26 <rossella_s> ihrachys, yes and I will also try to add missing test...the functional one for alembic is a good candidate for example
15:41:16 <ihrachys> rossella_s: ok. testing for alembic is a worthy effort, it's just a bit parallel to ovo work. but I get your point, we may pursue other topics apart from ovo while we work on integration.
15:41:54 <rossella_s> ihrachys, right...tasks that will make us find bugs that might cause us pain in the future
15:42:12 <ihrachys> ok, so back to the testing framework for alembic. it allows to add validation for new alembic scripts.
15:42:17 <amotoki> agree to some extent as we need to cover combos of db migration versions and object versions.
15:42:42 <ihrachys> since the framework is in the tree, I was thinking that maybe we should be aggressive at requiring tests for new scripts
15:42:49 <ihrachys> so I posted a patch to do just that
15:42:51 <ihrachys> #link https://review.openstack.org/#/c/302813/
15:43:09 <ihrachys> HenryG told me we'll need some tests in tree before considering the enforcement. which I agree.
15:43:49 <ihrachys> anyhow, I was thinking that unless we enforce, people will skip the framework. so something to consider in the future.
15:44:21 <ihrachys> ok any more patches to discuss?
15:44:21 <amotoki> agree
15:45:28 <ihrachys> #topic Open discussion
15:45:42 <ihrachys> anyone have anything apart from patches to discuss?
15:46:07 <ihrachys> do we want small upgrades meetup on Fri during the summit?
15:46:38 <ihrachys> just to gather and talk and plan. I think it could be worth to have a quick sync IRL.
15:46:42 <electrocucaracha> I can't, I will be only mon-wed
15:47:11 <amotoki> at least I think we need some wrap-up session/gathering of the main session.
15:47:31 <ihrachys> amotoki: main session? what do you refer?
15:47:44 <ihrachys> oh you mean the architecture one?
15:47:53 <amotoki> ihrachys: i am talking about the arch one
15:48:17 <ihrachys> I see. yeah, we could do it on Fri. I think we won't have time for that on Wed, sadly.
15:48:40 <ihrachys> so let's just think about it, and we'll see where it gets us. :)
15:49:20 <ihrachys> ok I will end the meeting. thanks everyone for joining!
15:49:27 <ihrachys> #endmeeting