15:01:34 <ihrachys> #startmeeting neutron_upgrades
15:01:35 <openstack> Meeting started Mon May 23 15:01:34 2016 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:38 <openstack> The meeting name has been set to 'neutron_upgrades'
15:01:40 <ihrachys> hello all
15:01:44 <korzen> hi
15:02:04 <ihrachys> rossella_s feels sick today, she won't join us
15:02:43 <ihrachys> we don't have any action items from the last meeting.
15:03:03 <ihrachys> #topic Partial Multinode Grenade
15:03:36 <ihrachys> I am not aware of any progress made on that one, except the fact that we got rolling upgrades tag merged
15:03:38 <ihrachys> #link https://review.openstack.org/#/c/286817/
15:04:00 <sayalilunkad> hello
15:04:06 <ihrachys> generally, the next steps are documented in:
15:04:07 <ihrachys> #link https://etherpad.openstack.org/p/neutron-multinode-jobs-newton
15:04:38 <korzen> hmm I was thinking that rolling upgrades requires no downtime acenario
15:04:40 <korzen> scenario*
15:04:54 <ihrachys> korzen: no, it requires 'some form' of per-component upgrades
15:05:10 <ihrachys> since we can upgrade agents independently of neutron-servers, it's enough
15:05:18 <ihrachys> we just needed to prove that with gate jobs.
15:05:42 <ihrachys> I believe if we need a tag for no-downtime, we would need to come up with a new one
15:05:59 <ihrachys> that would require rolling-upgrades one but would add more requirements.
15:07:03 <ihrachys> sc68cal: any progress around multinode grenade that I am not aware the last week?
15:07:09 <korzen> ihrachys, have someone tried to introduce any breaking changes and run the grenade to see if it catch the bug?
15:07:43 <ihrachys> korzen: nope. do I hear a suggestion to add an action item to your plate? ;)
15:08:15 <korzen> ihrachys, I would be my pleasure
15:08:26 <korzen> :)
15:08:44 <ihrachys> #action korzen to send a breaking patch to validate multinode grenade job catches rolling breakages
15:08:48 <ihrachys> thanks korzen! :)
15:09:03 <ihrachys> #topic Object implementation
15:09:33 <ihrachys> ok, on objects front, we are near merging allowed address pairs patch: https://review.openstack.org/#/c/287756/
15:09:48 <ihrachys> we also merged subnet object:
15:09:50 <ihrachys> #link https://review.openstack.org/#/c/264273/
15:10:05 <ihrachys> we need to proceed with its adoption in the db code.
15:10:15 <ihrachys> korzen: will you have time for that latter part?
15:10:33 <ihrachys> obviously, I don't expect it to work on the first iteration due to missing sorting/pagination support in base object class
15:10:34 <korzen> ihrachys, I'm already have some code
15:10:45 <ihrachys> but it would be great to start digging to see what we miss
15:10:48 <ihrachys> korzen: great!
15:11:07 <korzen> I should have something to discuss bu the next meeting
15:11:11 <ihrachys> for sorting/pagination support, we need:
15:11:22 <ihrachys> 1. expanded api test coverage for those features. first bit: https://review.openstack.org/#/c/306272/
15:11:55 <ihrachys> 2. support for that in get_objects: https://review.openstack.org/#/c/300055/13
15:12:18 * ihrachys notes that the former has +2 but failed in gate, will investigate right after the meeting.
15:12:55 <ihrachys> also, for all who help with the effort, pretty please, we need volunteers to cover more resources with sorting/pagination api tests
15:13:16 <ihrachys> there is not much reason to spin on more new objects right now before we get this set in place
15:13:22 <korzen> what should be the resources?
15:13:32 <korzen> like subnet and port?
15:13:33 <ihrachys> korzen: subnet, subnetpool, for one thing.
15:13:56 <ihrachys> korzen: yes. any 1st class resource that can currently recieve sorting/pagination criteria
15:14:20 <ihrachys> which is anything that is not a resource extension (like address pairs that are embedded into ports and hence are not fetched on their own)
15:14:36 <ihrachys> (that's why we can move forward with address pairs but not e.g. subnets or subnetpools)
15:14:43 <korzen> It seems like we are the only ones in the meeting right now ;)
15:15:03 <ihrachys> korzen: that's what we have, sadly.
15:15:15 <ihrachys> so I will just run it thru really quick.
15:15:37 <ihrachys> ok, that was it for objects and generally on how to contribute to the effort in a more effective way.
15:15:47 <ihrachys> #topic Open discussion
15:15:59 <ihrachys> now it's time to raise patches/concerns.
15:16:38 <korzen> I had some question but forgot what it was, nothing important I guesss
15:16:41 <ihrachys> before someone asks to review a new object, please make sure you read above and understand it may not be the current burning thing and hence reviews can be delayed.
15:17:33 <ihrachys> ok, I guess nothing burning apart from what was already covered.
15:17:55 <ihrachys> we will shut it down shortly and give ourselves 40 mins to do some progress in code and reviews.
15:18:01 <ihrachys> thanks korzen for joining
15:18:03 <ihrachys> #endmeeting