15:01:01 <ihrachys> #startmeeting neutron_upgrades
15:01:02 <openstack> Meeting started Mon May 30 15:01:01 2016 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:04 <ihrachys> hello my friends
15:01:05 <openstack> The meeting name has been set to 'neutron_upgrades'
15:01:05 <jlibosva> o/
15:01:09 <korzen> helo
15:01:19 <ihrachys> rossella_s: are you back with us?
15:01:44 <rossella_s> ihrachys, yeah
15:02:13 <ihrachys> great
15:02:23 <ihrachys> ok I guess it's mostly it, and we can start
15:02:39 <ihrachys> #topic Actions from the last meeting
15:02:50 <ihrachys> just one
15:02:51 <ihrachys> "korzen to send a breaking patch to validate multinode grenade job catches rolling breakages"
15:02:57 <ihrachys> korzen: have you got a chance?
15:03:02 <korzen> yeah...
15:03:06 <korzen> nope
15:03:28 <ihrachys> ok, then let's make sure it happens till next time :)
15:03:32 <korzen> sorry but I forgot about 2 days off I've taken
15:03:37 <ihrachys> #action korzen to send a breaking patch to validate multinode grenade job catches rolling breakages
15:03:53 <korzen> last week
15:04:02 <korzen> ok, I will prepare for the next meeting
15:04:06 <ihrachys> that's ok. as long as it eventually happens :)
15:04:21 <ihrachys> #topic Review velocity
15:04:31 <ihrachys> one thing before we get into tech details is this ^
15:04:42 <ihrachys> I feel that we lack attention to our patches somewhat
15:04:49 <ihrachys> especially from cores
15:04:59 <ihrachys> some reviewers use the review-day dashboard
15:05:18 * ihrachys dig for a link...
15:06:27 <ihrachys> ok, it's at...
15:06:28 <ihrachys> #link http://status.openstack.org/reviews/
15:06:36 <ihrachys> see the "Gerrit Dashboard links" above
15:06:43 <ihrachys> this dashboard is built from gerrit topics
15:06:59 <ihrachys> and it shows just bugs and bps that are targeted for Newton
15:07:06 <ihrachys> so far we used 'ovo' topic
15:07:14 <ihrachys> but it does not show up in the dashboad
15:07:35 <ihrachys> I experimented with switching some of my patches to using proper bug number mentioned in the topic
15:08:12 <ihrachys> it's hard to say whether it helped, but those landed
15:08:31 <ihrachys> so I wonder whether we may want to change our policy on topics in this regard
15:08:49 <rossella_s> ihrachys, let's do that
15:08:51 <jlibosva> I vote for change - we could have topic per rsource or something
15:08:56 <korzen> it can be helpful to show that our work is scoped for newton.,,
15:09:13 <rossella_s> ihrachys, one of the goal of the review dashboard is to make it easier for cores to find important patches
15:09:29 <ihrachys> ok, let's try that.
15:09:32 <korzen> so what should be the topic then?
15:09:33 <rossella_s> ihrachys, so let's change, there's agreement :)
15:09:45 <ihrachys> korzen: it should be bug/XXXX
15:09:55 <ihrachys> where XXXX is a bug that is targeted
15:09:59 <ihrachys> or it's bp/...
15:10:02 <ihrachys> again, targeted bp
15:10:12 <ihrachys> I think for general stuff, we should use bp
15:10:15 * ihrachys digs for an example
15:10:51 <ihrachys> #link https://review.openstack.org/#/q/topic:bp/adopt-oslo-versioned-objects-for-db
15:11:13 <ihrachys> for some related patches with a proper bug report we can also use bug/...
15:11:51 <ihrachys> f.e. I have that sorting/pagination bug that blocks some ovo patches, so I use:
15:11:52 <ihrachys> #link https://review.openstack.org/#/q/status:merged+project:openstack/neutron+branch:master+topic:bug/1566514
15:12:12 <ihrachys> any other ideas on how to get more attention to the effort?
15:12:18 <korzen> ihrachys, ok thx
15:12:34 <korzen> ihrachys, maybe ML?
15:12:34 <ihrachys> apart from personal pings that may or may not work depending on the position of Venus
15:13:12 <ihrachys> korzen: like... a status update f.e. bi-weekly with links to patches and overall description of the progress?
15:13:15 <korzen> I can prepare some ML mail with sumamry of our wokr
15:13:38 <ihrachys> that may be a good thing indeed if we stay focused there
15:13:40 <korzen> yes
15:13:47 <ihrachys> anyone else to comment on that one?
15:14:22 <ihrachys> rossella_s: jlibosva: ?
15:14:26 <jlibosva> maybe putting it on open agenda for weeklies
15:14:48 <jlibosva> just a small update with polite request for core reviews :)
15:14:51 <rossella_s> jlibosva, +1
15:15:12 <ihrachys> ok cool, let's use that opportunity too
15:15:17 <ihrachys> I will update for the next one
15:15:56 <ihrachys> ok, let's change topics, prepare a status update, and shout out on the next meeting. we'll see whether it brings more traction. :)
15:16:05 <korzen> jlibosva, good point, I can prepare e-mail with summary and we can walk it through on the netutron team meeting
15:16:19 <ihrachys> #action korzen to prepare first bi-weekly status update for ML
15:16:33 <ihrachys> #action ihrachys to update neutron meeting open agenda with ovo status update
15:17:04 <ihrachys> #action everyone to switch from 'ovo' topic to bug/XXXX or bp/XXXX where XXXX is targeted for Newton
15:17:14 <ihrachys> sounds fair?
15:17:19 <rossella_s> ihrachys, yes
15:17:26 <jlibosva> question
15:17:35 <ihrachys> jlibosva: shoot
15:17:39 <rossella_s> we could also try to volunteer some other core...if we get 3 cores no one can stop us :D
15:17:39 <jlibosva> should we open bugs for ongoing work so we can have better granularity?
15:18:22 <rossella_s> I think we can find some core that could do reviews at least...don't you think ihrachys ?
15:18:27 <ihrachys> jlibosva: what would be a topic of such a bug?
15:18:45 <jlibosva> e.g. we have bug per resource and bug is done once we have the object in db
15:18:48 <ihrachys> rossella_s: we can. I tried to pull ajo_ and kevinbenton but it did not work.
15:18:56 <jlibosva> in db plugin I mean or db layer or how is it called
15:19:00 <ihrachys> rossella_s: HenryG was more involved in some related patches
15:19:02 <rossella_s> maybe HenryG ?
15:19:42 <ihrachys> rossella_s: fyi I have a sit-down with HenryG tomorrow to walk him thru ovo implementation.
15:20:00 <rossella_s> ihrachys, great!
15:20:15 <ihrachys> jlibosva: I would be fine with it if we don't go too deep and if it's really a one person granular effort
15:20:16 * HenryG reads backscroll...
15:20:26 <ihrachys> otherwise bug reassignments in LP become bothersome
15:20:44 <ihrachys> HenryG: we are looking into expanding the core pool for ovo patches to get more velocity
15:21:08 <ihrachys> HenryG: currently we have two, and both produce patches, meaning it's always an effort to get a second vote
15:21:18 <HenryG> OK
15:21:45 <HenryG> pecan had/has a similar problem
15:22:12 <ihrachys> HenryG: have they solved it? or they just struggle?
15:22:20 <HenryG> the latter
15:22:50 <ihrachys> sounds promising!
15:22:51 <ihrachys> sigh
15:23:04 <rossella_s> we can do an agreement...we review pecan if they review ovo :D
15:23:14 <korzen> :)
15:23:18 <ihrachys> ok, let's proceed on action items we already identified, and sync next week on more improvements.
15:24:16 <ihrachys> jlibosva: so to follow up on your question, I think no one will be particularly against it, but note that those bugs are really of RFE type, which would trigger neutron drivers needlessly. something to consider.
15:24:48 <ihrachys> ok, let's digest that for the next week. let's move on to tech stuff.
15:24:49 <ihrachys> #topic Partial Multinode Grenade
15:24:58 <ihrachys> I am not aware of any progress. korzen, are you?
15:25:13 <korzen> nope
15:25:19 <ihrachys> ok, then let's skip that one
15:25:28 <ihrachys> #topic Object implementation
15:26:05 <ihrachys> afaiu we have some bare patches with objects but few of them have code that adopts them in any db modules.
15:26:19 <korzen> I have started the Subnet OVO integration patch: https://review.openstack.org/#/c/321001/
15:26:35 <jlibosva> wait
15:26:39 <korzen> it is just a bunch of TODOs
15:26:41 <jlibosva> I was working on that one too
15:26:53 <jlibosva> sorry, it's subnetpool
15:26:55 <jlibosva> ignore me :)
15:27:16 <ihrachys> jlibosva: you work on subnetpool? I assume you reuse what I already had?
15:27:31 <ihrachys> korzen: cool, at least there is something to start expanding on
15:27:32 <jlibosva> ihrachys: sure, we agreed on that couple of meetings back
15:27:44 <ihrachys> jlibosva: ok great, just wanted to make sure :)
15:27:55 <korzen> in my subnet ovo patch I have identified the use cases and tried to mimic the extention mechanism for ML2 plugin
15:28:43 <korzen> the extension mechanism will be useful for network more than for subnet but the port object can benefit as well
15:28:49 <ihrachys> korzen: I think we don't need to fix all those TODOs in one go
15:28:58 <ihrachys> we should be able to pick one module and switch it
15:29:02 <ihrachys> then take the next one
15:29:10 <korzen> ihrachys, yes, I'm planning to split
15:29:34 <ihrachys> ok, thanks for starting chewing it
15:30:18 <rossella_s> I have update the port ovo patch
15:30:19 <korzen> I have identified that the segment_id has been added to subnet
15:30:44 <ihrachys> korzen: yes, it landed very lately
15:30:52 <korzen> so the segment_id as AuthenticBase is rework needed for Subnet OVO patch
15:30:58 <korzen> and*
15:31:04 <ihrachys> rossella_s: do you plan to take on adopting it in the code in the near future?
15:31:35 <rossella_s> ihrachys, yes but the missing extensions need to be finished
15:31:42 <ihrachys> korzen: haven't we landed Authentic?
15:31:42 <rossella_s> sayalilunkad, how about sec group?
15:32:22 <ihrachys> korzen: ok, checked, it's in the tree now
15:32:23 <sayalilunkad> rossella_s: I haven't had time to work on it these weeks but I should be able to start with it again by next week
15:33:11 <korzen> ihrachys, your suggestion in Subnet OVO patch to move the IPNetwork to AuthenticBase, yes?
15:33:12 <ihrachys> ok, one more thing that we lack is lack of support for sorting/pagination in objects
15:33:31 <ihrachys> first patch for that is: https://review.openstack.org/#/c/300055/ (I need to get back to comments from jlibosva there)
15:33:58 <ihrachys> korzen: depends on how API currently behaves. the main point is that we should not break any tests.
15:34:07 <ihrachys> korzen: but I suspect that yes, it will be needed there.
15:34:43 <ihrachys> I am also slowly covering resources with sorting/pagination api tests.
15:34:51 <ihrachys> we merged networks, now ports are also merged: https://review.openstack.org/#/c/320980/
15:35:11 <korzen> super :)
15:35:43 <ihrachys> there is also a bug revealed by that work in page_reverse, that should be covered by https://review.openstack.org/#/c/318270/ (that lacks some api tests for a arcane api feature though)
15:36:04 <ihrachys> overall, I would love to see some volunteers to cover more of existing resources with sorting/pagination tests.
15:36:23 <ihrachys> I already talked to tony4... prev week on that one, and he said he will start looking into it
15:36:33 <ihrachys> but more people would be of great value there
15:36:50 <ihrachys> patches are not too involving, and I am glad to help
15:38:06 <rossella_s> great job ihrachys about pagination and sorting !
15:38:53 <korzen> anyone has took a look into network object?
15:39:30 <korzen> #link https://review.openstack.org/#/c/269658
15:39:46 <ihrachys> it's in conflict
15:39:56 <ihrachys> also no attempt to adopt.
15:40:16 <ihrachys> I am keen to stop merging more objects before we see at least some instances where they are attempted to be used
15:40:24 <korzen> ihrachys, ok I will try to elaborate more on it for the next meeting
15:41:36 <ihrachys> maybe short sightedly, I try to accommodate for getting subnets into shape since we have kevinbenton depending on that implementation for his rpc refactoring
15:42:23 <ihrachys> ok, let's proceed on specific patches on OVO
15:42:27 <ihrachys> #topic Open Discussion
15:42:33 <ihrachys> anything more to cover?
15:42:43 <korzen> I've seen midcycle sprint announcement
15:43:00 <korzen> anyone traveling there
15:43:00 <ihrachys> right. anyone coming?
15:43:01 <korzen> ?
15:43:19 <ihrachys> I am not sure, haven't talked to my manager in private yet. I would need a visa and all.
15:43:23 <korzen> I can go if the upgrades will be on the agenda
15:43:32 <jlibosva> do you plan to put objects as a topic?
15:43:59 <ihrachys> we could, assuming we have enough interested people
15:44:24 <korzen> I guess that we should have smth solid to discuss to have it on agenda
15:44:25 <rossella_s> I am not going
15:44:40 <rossella_s> I'd prefer to have a sprint focused on ovo as last time
15:44:44 <jlibosva> rossella_s: not even if the dates are going to change?
15:44:56 <rossella_s> jlibosva, are they going to change?
15:44:58 <ihrachys> jlibosva: would they?
15:45:20 <jlibosva> dunno, but there were complains it's during holiday period which is also related to flight tickets prices
15:45:26 <jlibosva> I don't want to spread rumors :)
15:45:42 <jlibosva> it's not even a rumor but just saying people weren't happy about the dates
15:45:51 <korzen> from my point of view, unless there is something bloking us, we can skip the midcycle
15:45:57 <rossella_s> jlibosva, I wrote one of those complaints anyway I did't have the impression that dates could change
15:46:04 <jlibosva> ok
15:46:32 <ihrachys> there was a thread on concurrency issues around rpc callbacks mechanism
15:46:33 <ihrachys> #link http://lists.openstack.org/pipermail/openstack-dev/2016-May/094862.html
15:46:36 <rossella_s> it's just a bit unfortunate that the first european midcycle is during a week that it's holidays for most european countries
15:46:40 <ihrachys> I honestly haven't found time to digest that.
15:46:46 <ihrachys> but I saw korzen was there to reply.
15:47:04 <ihrachys> korzen: could you give a brief overview of what's the result of discussion?
15:47:32 <rossella_s> ihrachys, we are not supposed to handle concurrency at object level
15:47:40 <rossella_s> ihrachys, the caller of the object should take care of that
15:47:44 <korzen> so the outcome was that OVO is not going to solve the concurency issues
15:48:12 <ihrachys> not by itself, sure
15:48:20 <rossella_s> see https://review.openstack.org/#/c/315705/
15:49:00 <korzen> I guess that Ilya idea was covered by kevinbenton spec with push notification and resource state version in DB
15:49:21 <ihrachys> that's CAS approach that he mentioned right?
15:49:42 <ihrachys> "Lock-free CAS based on object version counter"
15:49:48 <korzen> yes
15:50:14 <ihrachys> ok, then it's not anything new that he raised. we are well aware of that issue.
15:50:20 <ihrachys> thanks for updating me folks!
15:50:28 <ihrachys> anything more to discuss?
15:51:16 <ihrachys> I guess no and we have 9 minutes till a next meeting! enjoy!
15:51:18 <ihrachys> #endmeeting