15:01:12 <ihrachys> #startmeeting neutron_upgrades
15:01:12 <openstack> Meeting started Mon Jun  6 15:01:12 2016 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:16 <openstack> The meeting name has been set to 'neutron_upgrades'
15:01:48 <jaypipes> bauzas, dansmith: honestly, this is what I feel like doing: let me rebase cdent's patches for the object work and put them in a state I'm happy with. Let cdent be able to focus on the REST API changes that will be needed after the amendment to the generic-resource-pools spec, and let us not try to boil the ocean too much this week and just try to get agreement on the definition of the
15:01:54 <jaypipes> InventoryList and AllocationList objects.
15:02:01 <ihrachys> hi upgrades folks!
15:02:37 <john-davidge_> o/
15:03:16 <dasm> upgrade-o-nauts
15:03:26 <dasm> or upgrade-o-nuts
15:03:33 <ihrachys> meh :)
15:03:36 <ihrachys> john-davidge_: howdy!
15:03:42 <ihrachys> korzen: hello
15:04:02 <korzen> ihrachys, hello
15:04:08 <korzen> I've just joined
15:04:19 * ihrachys waves at rossella_s
15:04:25 <rossella_s> hello sorry for being late
15:04:53 <ihrachys> np, we are starting late :)
15:05:02 <ihrachys> ok, let's get it rolling
15:05:05 <rossella_s> I am a lucky girl
15:05:06 <ihrachys> #topic Actions from the last meeting
15:05:16 <ihrachys> "korzen to send a breaking patch to validate multinode grenade job catches rolling breakages"
15:05:21 <ihrachys> korzen: did it happen?
15:05:48 <korzen> ihrachys, sadly not yet but I have a patch ready for push
15:06:01 <korzen> I will push it and write the report on ML
15:06:20 <ihrachys> nice
15:06:27 <ihrachys> "korzen to prepare first bi-weekly status update for ML"
15:06:30 <ihrachys> that actually happened!
15:06:45 <dasm> i can confirm. good job korzen! :)
15:06:45 <korzen> general idea is to modify the RPC method interface for neutron server and agent communication in incompatible way...
15:06:48 <ihrachys> #link http://lists.openstack.org/pipermail/openstack-dev/2016-June/096512.html
15:07:06 <ihrachys> korzen: yeah, like drop an attribute from notification payload
15:07:17 <ihrachys> "ihrachys to update neutron meeting open agenda with ovo status update"
15:07:26 <ihrachys> that did *not* happen, but I have time till tomorrow ;)
15:07:41 <ihrachys> I will refer to korzen's report for the most part
15:07:48 <ihrachys> "everyone to switch from 'ovo' topic to bug/XXXX or bp/XXXX where XXXX is targeted for Newton"
15:07:59 * ihrachys looks at gerrit
15:08:01 <ihrachys> #link https://review.openstack.org/#/q/topic:ovo+status:open
15:08:19 <ihrachys> I see some stuff that is relevant to the effort but has wrong topics.
15:08:37 <ihrachys> I guess I need to walk through the list and make sure topics are correct
15:08:47 <rossella_s> ihrachys, I should update my patches...but not sure if it's worth reviewing them, they are still kind of WIP
15:08:59 <ihrachys> rossella_s: if it's WIP, it's ok to keep it as-is for now
15:09:10 <ihrachys> the main point of changing is getting attention from reviewers
15:09:19 <rossella_s> ihrachys, that's what I thought
15:09:21 <korzen> I am about to split my Subnet OVO eval patch and submit it with proper bp
15:09:23 <ihrachys> if we don't want that for a patch, it may be better to keep it under radar
15:09:58 <ihrachys> #action ihrachys to walk thru topic:ovo and change topics where applicable
15:10:18 <ihrachys> #topic Partial Multinode Grenade
15:10:51 <ihrachys> I haven't heard any progress on that one. sc68cal, did you have a change to look at expanding the testing to DVR and other stuff from that etherpad?
15:10:57 <ihrachys> *chance
15:11:18 <sc68cal> sorry, haven't
15:11:36 <ihrachys> np, let's just move on
15:11:42 <ihrachys> #topic Object implementation
15:12:09 <ihrachys> ok, I was looking at the blocker from API layer where I thought page_reverse is broken
15:12:19 <ihrachys> it could not be less trues
15:12:19 <ihrachys> *true
15:12:49 <ihrachys> turned out it's my brain having a bug, and I just incorrectly interpreted a goal of page_reverse
15:13:00 <ihrachys> so long story short, no bug and we just need some api test coverage
15:13:05 <ihrachys> #link https://review.openstack.org/318270 some tests
15:13:24 <ihrachys> and with that, I assume api test coverage is enough for us to start switching core resources to objects
15:13:48 <ihrachys> we just need to cover them with existing tests, which is a matter of inheritance.
15:14:21 <ihrachys> and btw, we landed sorting/pagination support in objects!
15:14:22 <ihrachys> #link https://review.openstack.org/300055
15:14:29 <korzen> ihrachys, cool
15:14:30 <korzen> !
15:14:32 <ihrachys> so from that perspective, we should be good to proceed
15:14:56 <ihrachys> now the focus probably moves to patches that adopt existing resources in db code
15:15:04 <rossella_s> ihrachys, I will catch up with the reviews
15:15:04 * ihrachys will get back to those patches this week.
15:15:17 <ihrachys> rossella_s: thanks, I would really love to get those api tests in
15:15:35 <rossella_s> ihrachys, will do later tonight
15:16:00 <ihrachys> any interesting patches to discuss in this regard? do we have mergeable pieces in review that adopt objects?
15:17:01 <rossella_s> ihrachys, no news on my side unfortunately...we should get the sec group patch in
15:17:30 <ihrachys> rossella_s: does it have db side? or just object definitions/
15:17:32 <rossella_s> I will synch with sayali and see if she can work on it or if we should find volunteers
15:17:54 <ihrachys> rossella_s: thanks for handling that! we should make sure no piece is stuck to deliver as planned.
15:18:06 <rossella_s> ihrachys, it's just the ovo introduction
15:18:51 <ihrachys> rossella_s: it's my thinking that we should focus on object adoption, would be great to see objects used in code and not just hanging out there.
15:19:12 <rossella_s> ihrachys, I totally agree, I commented that on some ovo patches
15:19:15 <ihrachys> without adoption, we risk to chase new features.
15:19:21 <rossella_s> agreed
15:19:22 <ihrachys> ok, good to be on same side
15:19:34 <korzen> I will publish some Subnet usage this week
15:19:43 <rossella_s> korzen, great
15:20:19 <ihrachys> I know that jlibosva was looking at refactoring resource hooks our of common_db_mixin but I don't see anything in review queue so far
15:20:49 <ihrachys> I heard that he may need to sync with korzen on that one.
15:20:54 <korzen> ihrachys, I've seen that it was added to subnetpool
15:21:20 <ihrachys> oh right.
15:21:22 <ihrachys> #link https://review.openstack.org/#/c/300056/4/neutron/objects/base.py
15:21:49 <ihrachys> something we may consider moving out of this patch since it seems like a separate piece of code
15:21:49 <korzen> yes
15:22:00 <rossella_s> for people who want to help I'd like to ask for help for the port extensions and the port object...instead of adding new ovo I think it's more productive to finish what we have
15:22:26 <ihrachys> rossella_s: absolutely. what's the base link to port object?
15:22:46 <rossella_s> #link https://review.openstack.org/253641
15:23:08 <ihrachys> ok, do we have a list of todos in this regard?
15:23:13 <rossella_s> we still need some work for the binding object...
15:23:19 <rossella_s> ihrachys, good idea I can update the team page
15:23:27 <ihrachys> maybe even putting it in commit message could help to understand the scope
15:24:01 <rossella_s> ihrachys, another good point, will do
15:24:30 <ihrachys> rossella_s: or this way. not sure about others, but I don't see the whole picture for the object as you probably do, so documenting your vision would be the 1st thing to do
15:24:54 <ihrachys> #action rossella_s to come up with specific list of TODOs for port object
15:25:02 <rossella_s> ihrachys, right, I will do that because I realized that I want to work on that but I keep postponing
15:25:12 <rossella_s> ihrachys, thanks for the TODO
15:25:48 <ihrachys> any more specific stuff for objects that would require team attention?
15:26:27 <ihrachys> ok, let's move on
15:26:32 <ihrachys> #topic Open Discussion
15:26:48 <ihrachys> one thing to note, seems like mid-cycle date is moved
15:26:55 <ihrachys> rossella_s: does it cover your concern with the original date?
15:27:22 <rossella_s> ihrachys, yes the email was clear
15:27:34 <rossella_s> ihrachys, still don't know if I will be able to attend, you people?
15:27:58 <ihrachys> rossella_s: nope, I still did not get ack from my management, and I would need a visa for that. we'll see.
15:28:24 <korzen> i didn't ask for permission either
15:28:27 <ihrachys> I guess we may have some focused discussion there on objects if we'll have some and if people attend; otherwise, no big dea.
15:28:29 <ihrachys> *deal
15:28:56 <rossella_s> indeed, it would be useful to know who's attending to understand if we can have that discussion
15:29:07 <ihrachys> I assume HenryG will ;)
15:29:26 <ihrachys> ok folks, anything more to cover?
15:29:34 <ihrachys> or we cut it short :)
15:30:06 <ihrachys> the latter ;)
15:30:11 <ihrachys> thanks folks!
15:30:11 <ihrachys> #endmeeting