15:00:48 <ihrachys> #startmeeting neutron_upgrades
15:00:49 <openstack> Meeting started Mon Dec 19 15:00:48 2016 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:52 <openstack> The meeting name has been set to 'neutron_upgrades'
15:00:57 <dasm> o/
15:01:02 <electrocucaracha> hola
15:01:03 <ihrachys> hi everyone
15:01:06 <ihrachys> #link https://wiki.openstack.org/wiki/Meetings/Neutron-Upgrades-Subteam Agenda
15:01:24 <ihrachys> ^ I updated the page a bit to include some useful links tracking our initiatives
15:01:38 <ihrachys> #topic Announcements
15:02:07 <ihrachys> we are heading into Christmas time. We obviously won't have a meeting on Dec 26.
15:02:20 <ihrachys> and neither Jan 2 that is US holiday
15:02:24 <dolphm> \o
15:02:29 <ihrachys> meaning, next meeting is Jan 9
15:02:47 <ihrachys> I will send a corresponding email after the meeting
15:02:51 <ihrachys> any objections?
15:02:56 <ihrachys> hi dolphm!
15:03:04 <electrocucaracha> +1
15:03:11 <dolphm> ihrachys: hello!
15:03:25 <ihrachys> korzen: any comments from your tower? :)
15:04:29 <ihrachys> ok I guess Artur is busy with Christmas preparation :)
15:04:51 <electrocucaracha> he is on vacation, isn't it?
15:05:09 <ihrachys> I dunno
15:05:10 <ihrachys> in other news, we cut off Ocata-2 the prev week.
15:05:17 <ihrachys> Ocata-3 is late January
15:05:36 <ihrachys> so we have like 4 weeks of work before freezes start to kick in
15:05:50 <ihrachys> #topic Partial Multinode Grenade
15:06:24 <ihrachys> ok as some of you may know, we had linuxbridge multinode job failing for quite some time
15:06:36 <ihrachys> it seems like we have found and solved the last issue with it with a revert: https://review.openstack.org/#/c/345428/
15:06:41 <ihrachys> and it now passes
15:07:01 <ihrachys> so now it's a matter of making it into check queue, and voting
15:07:04 <ihrachys> the first step is https://review.openstack.org/#/q/topic:linuxbridge-multinode-grenade
15:07:21 <ihrachys> we will collect stats on how it works in check queue for a bit before making it voting
15:08:03 <ihrachys> armax also mentioned that he would be glad to see the job converted into HA one, as well as other linuxbridge jobs we have
15:08:13 <ihrachys> but that will happen on its own schedule
15:08:36 <ihrachys> so with it, we have all basic setups covered for our loose definion of rolling upgrade
15:08:50 <ihrachys> now, for a more strict one (that implies no API downtime)
15:09:01 <ihrachys> the spec describing the approach landed: https://review.openstack.org/#/c/386685/
15:09:33 <ihrachys> also, korzen started investigation on getting a job that would indeed validate mixed neutron-server versions
15:09:47 <ihrachys> afaiu he should have talked to dolphm on the matter
15:10:08 <ihrachys> dolphm: since korzen is not here, maybe you can give a brief intro on where the infra stands on that matter
15:11:12 <dolphm> (sorry, i'm actually in another meeting as well!)
15:12:30 <ihrachys> dolphm: oh sorry, nevermind. we then collect the info async to the meeting. ;)
15:13:40 <ihrachys> ok so just to update others, I think infra and other folks are still working on foundation to be able to set such a job. I lack details though.
15:13:54 <ihrachys> #topic Object implementation
15:14:09 <ihrachys> the prev week, we landed some useful bits, specifically...
15:14:16 <ihrachys> (looking at https://review.openstack.org/#/q/status:merged+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db)
15:14:28 <ihrachys> validating UUIDField: https://review.openstack.org/393150
15:14:37 <ihrachys> ^ make sure all new patches use the new type!
15:14:42 <electrocucaracha> \o/
15:14:46 <manjeets> o/
15:14:50 <ihrachys> vlan allocation OVO: https://review.openstack.org/356660
15:15:13 <electrocucaracha> also delete_objects method, isn't it?
15:15:28 <ihrachys> ^ integration will need to wait I believe until https://review.openstack.org/#/c/398873/ lands.
15:15:40 <ihrachys> RouterRoute is integrated: https://review.openstack.org/367071
15:16:08 <ihrachys> Allocation and Endpoint also landed, will also need to wait for Ann's patch: https://review.openstack.org/396327
15:16:35 <ihrachys> electrocucaracha: yes, delete_objects landed too: https://review.openstack.org/403832 so make sure you consider it for new patches that integrate new objects
15:16:44 <dasanind> ihrachys: that's right
15:16:52 <ihrachys> also in test framework, we now have get_random_object_fields() method: https://review.openstack.org/407007
15:17:19 <ihrachys> there was also a non-deterministic failure in unit tests introduced by vxlan OVO fixed by https://review.openstack.org/#/c/411897/
15:17:39 <dasanind> I cherry picked my changes on Ann 's patch
15:18:28 <ihrachys> dasanind: yeah. I think Ann's patch is almost ready in general, but it needs some more safety tweaks to avoid more 3party breakages.
15:18:47 <ihrachys> I hope she will find time for respin this week
15:19:04 <dasanind> ihrachys: sounds good
15:19:09 <ihrachys> now to patches on review
15:19:11 <ihrachys> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
15:19:37 <ihrachys> one thing worth noting is korzen's patch adding new DictOfMiscValuesField type: https://review.openstack.org/411830
15:19:56 <ihrachys> this should hopefully solve issues with vif_details field in port, and configurations field in Agent
15:20:20 <ihrachys> turned out that oslo.versionedojbects DictOfStrings is not really suitable for our cases because our dicts have non-string values
15:20:38 <ihrachys> and the library itself does not ship a dict type that would map to our need
15:21:10 <ihrachys> we would need to have a patch on top of the one with the new type that would use it, to see that it indeed helps.
15:21:27 <ihrachys> is there any patch on top of it already? I think korzen was going to rebase on of them
15:22:22 <ihrachys> ok I think the patch that korzen was going to rebase is https://review.openstack.org/#/c/407868/
15:22:25 <ihrachys> and it's still not rebased
15:22:42 <ihrachys> maybe someone can take that rebase while korzen is off for vacation?
15:23:03 <dasanind> I can try to rebase that
15:23:09 <electrocucaracha> so, that means that ndahiwade should abandon the oslo patch?
15:23:12 <ihrachys> dasanind: cool, thanks
15:23:29 <ihrachys> electrocucaracha: I think the oslo patch is wrong, korzen also mentioned that does not make much sense
15:23:48 <ihrachys> electrocucaracha: I think it's more like oslo.versionedobjects type does not fit us, not that there is a bug there to be fixed
15:23:55 <electrocucaracha> korzen: submitted some changes in the morning
15:23:59 <ihrachys> electrocucaracha: so maybe also closing the reported bug as Invalid?
15:25:05 <electrocucaracha> Got it, I can do it
15:25:21 <ihrachys> electrocucaracha: cool!
15:25:37 <ihrachys> #action dasanind to rebase https://review.openstack.org/407868 on top of https://review.openstack.org/411830
15:25:58 <dasanind> ack
15:26:01 <ihrachys> #action electrocucaracha to abandon oslo.versionedobjects patch and bug modifying DictOfStringsField
15:26:58 <ihrachys> looking for patches ready to merge...
15:27:23 <ihrachys> electrocucaracha: I see https://review.openstack.org/#/c/306685/ has a tiny comment from rossella_s that blocks the merge for the patch. you think you can respin it?
15:28:03 <electrocucaracha> Sure
15:28:29 <sindhu> ihrachys: https://review.openstack.org/#/c/358845/ is ready, but it is dependent on Ann's patch
15:28:53 <ihrachys> sindhu: yeah. it will land once Ann's underlying patch does
15:29:00 <electrocucaracha> dasanind: it seems like kong_ consider agent in his patch https://review.openstack.org/#/c/411830/2/neutron/objects/agent.py
15:29:17 <ihrachys> electrocucaracha: mmm, nice.
15:29:24 <electrocucaracha> s/kong_/korzen
15:29:41 <ihrachys> electrocucaracha: but it does not show integration, so it's hard to say if it makes it better
15:30:37 <electrocucaracha> ihrachys: agree, definitely we'll need the dasanind  patch
15:30:56 <ihrachys> at this point, it would be worth checking the new type on one of integrated objects to see if it's of any help.
15:31:48 <ihrachys> ok cool, I think other patches are usual business, and a matter of reviews
15:32:09 <ihrachys> #topic Other patches on review
15:32:40 <ihrachys> one thing that I proposed lately is to use UpgradeImpact commit message tag more widely for any runtime dep changes
15:32:51 <ihrachys> see https://review.openstack.org/#/c/402004/
15:32:58 * manjeets is really happy with timely reviews on his tiny patches :)
15:33:07 <ihrachys> manjeets: my pleasure
15:33:16 <ihrachys> we will start to track all patches marked with the tag during the weeklies
15:33:24 <ihrachys> #link https://review.openstack.org/#/q/status:open+message:%22UpgradeImpact%22+project:openstack/neutron
15:33:54 <ihrachys> full disclosure: I haven't actually checked the list yet, so I have no specifics, but just a PSA we will pay attention to the list from now on :)
15:34:28 <ihrachys> we may also need to capture patches with release notes that contain 'upgrade' section, I will think about a gerrit query for that matter
15:34:44 <ihrachys> #action ihrachys to find a way to capture all patches on review with upgrade release notes
15:36:18 <ihrachys> of some relevance to upgrades, I will mention a patch I landed lately to update MTUs on neutron ports: https://review.openstack.org/405532 that will allow to change MTU configuration options and see update propagated to nodes with restarted agents without the need to rebind ports
15:36:31 <ihrachys> that is often useful on major system upgrade
15:36:57 <ihrachys> any other patches that you think can be interesting for the team?
15:37:00 <manjeets> ihrachys, is there any patch already with such kind of release notes ?
15:37:31 <ihrachys> manjeets: grep 'upgrade:' -r releasenotes/ shows 32 hits in the tree
15:38:00 <manjeets> okay thanks
15:38:06 <sshank> ihrachys: Regarding the segment_id in port binding level, we keep it for now right?
15:38:06 <ihrachys> example being https://review.openstack.org/#/c/329481/22/releasenotes/notes/enable-sorting-pagination-754390289d3311fa.yaml
15:38:30 <ihrachys> sshank: why? I was thinking we will explore fixing the Level object to store its synthetic field?
15:38:46 <manjeets> ihrachys, got it
15:38:47 <ihrachys> has the attempt failed?
15:41:01 <sshank> ihrachys: from what I observed, network segment has a foreign key which looks at segment_id in level object. And since, the segment_id is not present, level is not created.
15:42:05 <ihrachys> sshank: I think storing values is not implemented in base class, only loading, so if we need store to happen on parent object .create() as in this case, we need to implement the logic ourselves
15:42:26 <ihrachys> sshank: we should also fix the db test for the object that turned out is not triggered
15:43:32 <sshank> ihrachys: So we will have to override the create method in port binding level ovo class to take care of this?
15:44:08 <ihrachys> yes. I think we already do it in several other places too. it's a common pattern that we somehow missed during object review.
15:44:25 <ihrachys> in general, each synthetic field should support loading and storing
15:44:35 <ihrachys> loading is from base class and thru foreign keys
15:44:42 <ihrachys> but storing requires some code
15:44:57 <ihrachys> we could probably come up with some smart way to generalize it into base class layer
15:45:02 <ihrachys> so that it's automatic
15:45:10 <ihrachys> but that's another story
15:45:22 <ihrachys> we would need rossella_s to write some more magic for that ;)
15:45:47 <sshank> Okay.
15:45:50 <rossella_s> ihrachys, :p
15:46:41 <ihrachys> ok let's move on
15:46:42 <ihrachys> #topic Open discussion
15:46:59 <ihrachys> I see no topics in the wiki page so unless you are quick, we will call it a day in a minute :)
15:47:15 <ihrachys> to recap, we will meet again Jan 9th
15:47:32 <ihrachys> happy holidays to those who celebrate, and happy vacation for those who don't ;)
15:47:33 <manjeets> happy holidays sub neutrinos
15:47:56 <ihrachys> ok thanks everyone! keep it up!
15:48:00 <ihrachys> #endmeeting