15:01:12 <korzen> #startmeeting neutron_upgrades
15:01:13 <openstack> Meeting started Mon Jan  9 15:01:12 2017 UTC and is due to finish in 60 minutes.  The chair is korzen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:17 <openstack> The meeting name has been set to 'neutron_upgrades'
15:01:19 <korzen> hi all
15:01:28 <sshank> Hello
15:01:33 <asingh_> Hello
15:01:45 <korzen> hello in first team meeting in 2017
15:01:47 * dasm is sitting in corner, and watching at world in flames...
15:02:05 <ihrachys> o/
15:02:23 <korzen> hope you had a nice holidays and recharged your batteries
15:02:45 <korzen> taking a look at agenda
15:02:47 <korzen> #link https://wiki.openstack.org/wiki/Meetings/Neutron-Upgrades-Subteam Agenda
15:02:51 <dasanind> hi
15:02:59 <korzen> #topic Announcements
15:03:24 <korzen> we have 3 weeks left till ocata-3
15:03:32 <korzen> which is 25 Jan
15:04:04 <korzen> so we better settle down today what is important for this last weeks to complete in Ocata
15:04:27 <korzen> ihrachys, any other announcements?
15:04:45 <ihrachys> I will just update everyone that I am now in PCT (West Coast) time zone
15:05:00 <ihrachys> but I start early (6am early) so there is time to sync with Europe too
15:05:05 <ihrachys> nothing else
15:05:11 <dasm> ihrachys: welcome in "brave new world"!
15:05:19 <ihrachys> thanks
15:05:31 <korzen> good to hear for US folks, more time for us to sync with Ihar :)
15:05:39 <korzen> for US
15:06:03 <korzen> ok moving on
15:06:10 <korzen> #topic Partial Multinode Grenade
15:06:43 <korzen> linux gate is failing
15:06:56 <korzen> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=8&fullscreen
15:07:21 <korzen> if anyone is interested in debugging
15:08:00 <korzen> it would be nice to take a look
15:08:40 <ihrachys> I checked logs before, nothing obvious
15:08:46 <korzen> does anyone worked on testing mixed version of neutron server running?
15:08:59 <ihrachys> so maybe local reproduction could be of use, though multinode devstack setups are not easy
15:09:29 <sshank> korzen, I think manjeets was trying it out sometime back.
15:09:29 <ihrachys> re mixed versions, I haven't looked at it, but I believe that should be a priority for the remaining Ocata time
15:10:05 <ihrachys> ideally, we prove it works and then announce that as an experimental feature of the release
15:10:35 <korzen> it would be nice if someone could step up and test in manual way
15:11:05 <korzen> I have not synced with dolphm on that matter, how OSIC QA team is progressing on the gating
15:12:09 <korzen> manjeets, did you have any progress on the mixed version testing?
15:13:01 <korzen> I guess he is not around
15:13:08 <manjeets> o/ sorry for being late
15:13:19 <manjeets> korzen it did not try it yet
15:13:51 <manjeets> i setup env but was then got side tracked
15:13:59 <korzen> ok, so If noone has any input, I have work for it this week
15:14:22 <korzen> trying to setup the multinode devstack and try to perform some manual tests
15:14:38 <korzen> I can work for it*
15:14:48 <korzen> I will update you on the next meeting
15:14:54 <ihrachys> thanks korzen
15:15:21 <korzen> #action korzen to setup the mutlinode devstack env and try to test the mixed version of neutron server scenario
15:15:34 <korzen> ok, moving next
15:15:43 <korzen> #topic Object implementation
15:16:08 <korzen> #link https://review.openstack.org/#/q/status:merged+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
15:16:19 <korzen> what have merged since last meeting
15:16:47 <korzen> so we have FlatAllocation OVO and Port OVO in ml2/db
15:17:28 <korzen> there are many objects adoption in flight
15:17:50 <korzen> but the most important one is PortBinding
15:18:04 <korzen> #link https://review.openstack.org/#/c/407868/ Integration of (Distributed) Port Binding OVO
15:18:26 <ihrachys> I believe https://review.openstack.org/#/c/411830/10 is its dependency?
15:18:26 <korzen> not counting the merge conflict, the patch should be ready to review
15:18:36 <korzen> #link https://review.openstack.org/#/c/411830/ DictOfMiscValuesField
15:18:40 <korzen> yes,
15:18:52 <ihrachys> and we proved it fixes the issue we had?
15:19:13 <korzen> the new OVO field type for Port and Agent is handling full pythonic dict
15:19:43 <ihrachys> ok I see the port binding patch was blessed by Jenkins. I assume it means it indeed helped.
15:20:22 <korzen> ihrachys, yes, I have added agent and port binding test cases to 411830
15:20:45 <ihrachys> cool, I will bubble it up in my review queue for today.
15:21:05 <korzen> so, from now on, when some have to use JSON blob as field type, dictOfMiscValuesField should be used
15:21:48 <korzen> DictOfStringField had this limitation that the values can be only the string, or numbers/bools converted to string
15:22:18 <korzen> anyone has some important object patches to review?
15:22:41 <dasm> i would like to see someone looking at this: https://review.openstack.org/#/c/382659/
15:22:51 <dasm> it's layer between keystone v3 and ovo
15:22:59 <korzen> yes, that one
15:23:11 <manjeets> quotas ovo
15:23:27 <dasanind> RouterL3AgentBinding https://review.openstack.org/#/c/360908/
15:23:29 <manjeets> https://review.openstack.org/#/c/338625/
15:24:05 <manjeets> https://review.openstack.org/#/c/416352/ to break circular import issue for quotas
15:24:27 <manjeets> until lib release this patch https://review.openstack.org/#/c/416364/
15:24:57 <korzen> so as far as our goal for Ocata, unless some feature is not modifying the DB model, the OVO is not critical
15:25:36 <korzen> like for PortBinding, which will be adding new PK and 'status' field
15:26:01 <ihrachys> and I believe that's the only feature that could reasonably land in Ocata right?
15:26:20 <korzen> yes, I guess that is true
15:26:53 <korzen> the last thing that we are missing is online data migration framework
15:27:14 <korzen> but PortBinding for LM is not affected by not having the online data migration
15:27:28 * ihrachys leaves the audience early to attend another meeting, sorry
15:27:52 <korzen> since, we will add new field that is by default empty string does not have to be online migrated
15:28:24 <dasanind> korzen: and ihrachys : for LM data model changes I will need some review on this patch https://review.openstack.org/#/c/404293/
15:28:43 <korzen> this is what I have came up when thinking about data migration
15:29:25 <korzen> ok dasanind, I will take a look
15:29:37 <dasanind> korzen: thank you
15:29:58 <sshank> korzen, any ideas on the port binding level synthetic field issue I mentioned in the comments of that patch?
15:30:08 <korzen> dasanind, It would be nice to test your change in mixed version env
15:30:36 <korzen> sshank, which one?
15:30:38 <dasanind> korzen: yeah that's right
15:30:48 <sshank> korzen, https://review.openstack.org/#/c/382037/
15:31:31 <korzen> sshank, I did not have time to look at it
15:31:44 <korzen> Will take a look ASAP
15:31:58 <manjeets> korzen, for mixed versions test how many network nodes will be running
15:31:59 <sshank> korzen, Okay. Thanks.
15:32:02 <manjeets> 2 or 3 ?
15:32:21 <korzen> manjeets, network nodes should be 2
15:32:47 <korzen> but the neutron-server instances will be at least 2
15:33:05 <korzen> and the neutron-server is the most important here
15:33:41 <korzen> beacause we need to test the API nodes
15:33:47 <korzen> in mixed version
15:33:54 <manjeets> okay master and newton version of server
15:34:12 <korzen> the network node should be already tested in grenade multinode
15:34:36 <korzen> ok, moving next
15:34:44 <korzen> #topic Other patches on review
15:35:11 <korzen> since we already touched some of patches, port binding for LM
15:35:28 <manjeets> I sent some links earlier would be great if can get some reviews on those
15:35:35 <korzen> anyone has some interesting patches to share?
15:35:58 <korzen> manjeets, yes I will take them in my queue
15:36:16 <manjeets> thank you korzen
15:36:43 <korzen> I would like to remind you of
15:36:44 <korzen> #link https://review.openstack.org/336518 devref about OVO in neutron
15:37:09 <korzen> thanks for all of the reviews, I would need to ping ihrachys to review ^ :)
15:37:34 <ndahiwade> korzen: ihrachys : https://review.openstack.org/#/c/360799/
15:38:23 <ndahiwade> It's almost ready will fix the functional test today:)
15:38:41 <korzen> ndahiwade, good, added to the queue :)
15:39:17 <korzen> I wanted also to talk about methods in OVO classes
15:39:20 <ndahiwade> korzen, thanks:)
15:39:24 <korzen> Methods in OVO class returning non-OVO output
15:39:35 <korzen> like here: 		○ https://review.openstack.org/#/c/381209/17/neutron/objects/router.py@103
15:39:59 <korzen> My opinion is that classmethod in OVO class should return OVO
15:40:28 <korzen> do you have any drawbacks of that assumption?
15:41:05 <manjeets> korzen, i have one quotas
15:41:31 <sshank> korzen, In that example, I moved it inside the class because it had a complex join.
15:42:23 <korzen> sshank, yes, and moving it to OVO class is a good idea
15:42:29 <sshank> korzen, Right now it is returning a list of Router models but since router OVO is not ready yet, it is not returning OVOs
15:42:55 <korzen> sshank, ok
15:43:01 <manjeets> https://review.openstack.org/#/c/338625/23/neutron/objects/quota.py@94
15:43:24 <korzen> sshank, so the example is not so good :)
15:43:31 <korzen> but the main point stays the same
15:43:50 <korzen> manjeets, good one
15:44:16 <korzen> manjeets, I was thinking of returning reservation OVO
15:44:29 <sshank> korzen, I think this is returning non OVO: https://review.openstack.org/#/c/377074/35/neutron/objects/l3agent.py@42
15:44:42 <dasanind> korzen: my understanding is  if the class method needs to return OVO we need to translate the model returned by the query to object is that correct?
15:45:26 <korzen> sshank, yes, we can have some special methods returing ids
15:45:29 <korzen> sshank, it is fine
15:45:36 <manjeets> korzen, i would trying doing may be more refactoring of code if returns anything instead of dictionary
15:45:37 <korzen> it is named get_..._ids
15:46:28 <korzen> dasanind, yes, we need to evaluate query inside OVO classmethod and call load_object on the result
15:46:58 <korzen> my main point is to not to return query sqlalchemy object
15:47:16 <dasanind> korzen: do you have an example?
15:48:08 <korzen> dasanind, would need to look for, but it should be smth like: return [self.load_object(x) for x in query)]
15:49:00 <dasanind> korzen: thanks, will try that for https://review.openstack.org/#/c/377074/35/neutron/objects/l3agent.py@42
15:49:21 <korzen> dasanind, yes, thanks
15:49:53 <korzen> #topic Open discussion
15:50:07 <korzen> ok, do you have any more questions comments?
15:52:08 <korzen> ok, if not, then
15:52:11 <korzen> #endmeeting