15:01:02 <ihrachys> #startmeeting neutron_upgrades
15:01:03 <openstack> Meeting started Mon Mar 13 15:01:02 2017 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:06 <openstack> The meeting name has been set to 'neutron_upgrades'
15:01:38 <ihrachys> hi everyone
15:01:50 <manjeets> hi
15:02:22 <electrocucaracha> howdy
15:02:57 <dasanind> hi
15:03:26 <ihrachys> #link https://wiki.openstack.org/wiki/Meetings/Neutron-Upgrades-Subteam Agenda
15:03:50 <ihrachys> let's review action items from the last meeting
15:04:04 <ihrachys> that one will be embarrassing for me\
15:04:17 <ihrachys> "ihrachys to follow up with manjeets on next steps for linuxbridge multinode grenade"
15:04:20 <ihrachys> did I? no
15:04:40 <manjeets> we just concluded something messed up with data plane
15:05:00 <ihrachys> manjeets: yeah, I think external connectivity issue using floating IP?
15:05:05 <manjeets> yes
15:05:28 <manjeets> it is failing smoke tests some time where it tests vm connectivity
15:05:29 <ihrachys> manjeets: have you looked at the server/agent logs to see if anything there?
15:06:12 <manjeets> i looked server logs couldn't find anything i'll look at agent logs today
15:06:58 <ihrachys> it may help to try to trace messaging between them
15:07:08 <ihrachys> to see if agent actually processed FIP addition and such
15:07:30 <ihrachys> another thing to check would be the VM console log (I assume tempest tests already dump that in case of failure)
15:07:38 <ihrachys> there you may e.g. see DHCP lease not served
15:07:46 <ihrachys> or metadata access broken
15:08:08 <ihrachys> ok let's follow up on that and see if we can make progress till next week
15:08:32 <ihrachys> next was "everyone to review online data migration neutron-db-manage command: https://review.openstack.org/#/c/432494/"
15:08:48 <ihrachys> I see it didn't happen so we are all guilty
15:08:59 <ihrachys> let's repeat the action then
15:09:04 <ihrachys> #action everyone to review online data migration neutron-db-manage command: https://review.openstack.org/#/c/432494/
15:09:18 <ihrachys> next was "ihrachys to spec a mechanism to tackle differences in the list of extensions exposed by multiple mixed server nodes"
15:09:36 <ihrachys> didn't happen, will try to get to it this week :)
15:09:39 <ihrachys> #action ihrachys to spec a mechanism to tackle differences in the list of extensions exposed by multiple mixed server nodes
15:09:53 <ihrachys> next was "ihrachys to follow up on mixed server version gating"
15:09:57 <ihrachys> you know the pattern?
15:10:06 <ihrachys> didn't happen
15:10:39 <ihrachys> it's clear I am a slug
15:11:13 * electrocucaracha sometimes that happen
15:11:21 <ihrachys> anyone wants to take over that one from me? it's some talking to do with nova/infra/dolph
15:11:37 <ihrachys> that may raise the chance other stuff will happen
15:11:44 <electrocucaracha> ihrachys: maybe I can do it
15:11:53 <ihrachys> electrocucaracha: yeah you are in the same office
15:12:21 <ihrachys> electrocucaracha: so we just need to understand what's the progress to gate on mixed api versions for nova, and where we can plug ourselves into that for neutron
15:13:00 <electrocucaracha> ihrachys: got it, I can check with dolph
15:13:14 <ihrachys> #action electrocucaracha to explore status of mixed server version gating in nova/infra
15:13:17 <ihrachys> thanks a lot!
15:13:31 <ihrachys> next one was "manjeets to remove lock_for_update for quotas db code"
15:13:42 <manjeets> ihrachys, patch is up
15:13:53 <ihrachys> since manjeets is NOT a slug, he actually posted https://review.openstack.org/#/c/442181/
15:14:00 <manjeets> https://review.openstack.org/#/c/442181/
15:14:21 <manjeets> somehow i was for not being doing enough lb job
15:14:29 <ihrachys> gotta reach out to kevinbenton to make his judgement
15:14:47 <ihrachys> from my side it's good to go
15:15:00 <ihrachys> thanks manjeets for pulling that quick!
15:15:19 <ihrachys> ok no more actions to embarrass myself
15:16:09 <ihrachys> actually action items covered most topics in the agenda, so let's go straight to OVO
15:16:17 <ihrachys> #topic Object implementation
15:16:30 <ihrachys> some good news. we landed devref page, finally: https://review.openstack.org/#/c/336518/
15:16:43 <ihrachys> also pager docstring: https://review.openstack.org/#/c/441226
15:16:52 <manjeets> \o/
15:17:04 <ihrachys> we also landed lock_for_update removal for type driver allocations: https://review.openstack.org/#/c/438144/
15:17:14 <electrocucaracha> yeah thanks dasm for taking all the comments
15:17:34 <dasm> \o/
15:17:41 <ihrachys> I believe with quota lockless in, the code base should be free of lock_for_update
15:17:57 <ihrachys> yeah dasm was really helpful pushing the last mile of the patch
15:18:08 <ihrachys> also thanks to korzen for moving it along for so long
15:18:15 <electrocucaracha> +1
15:18:19 <manjeets> yes no blocker then except support of like i believe
15:18:40 <ihrachys> yeah, the LIKE patch: https://review.openstack.org/#/c/419152/
15:18:48 <ihrachys> it has some review comments to follow up on
15:18:58 <ihrachys> tonytan4ever: will you have time in next days to pull that?
15:20:38 <tonytan4ever> @ihrachys: yes
15:20:44 <tonytan4ever> I am working on it now actually
15:21:11 <ihrachys> tonytan4ever: oh cool, will wait for next PS
15:21:48 <ihrachys> ok next in the list from the agenda is tag OVO switch: https://review.openstack.org/#/c/356825/
15:21:55 <ihrachys> actually it seems like ready to go, so +W!
15:22:59 <ihrachys> next is quotas: https://review.openstack.org/#/c/338625/ manjeets is it already rebased on lockless? or we wait for it?
15:23:10 <manjeets> i'll rebase it today
15:23:20 <dasanind> ihrachys: need reviews on https://review.openstack.org/#/c/360908/. It's ready to go.
15:24:08 <ihrachys> dasanind: oh I see you removed the synthetic field
15:24:13 <ihrachys> will do, haven't noticed it before
15:24:26 <dasanind> ihrachys: thank you
15:25:50 <sshank> ihrachys, Regarding the portbinding level integration, we found out the cause. It is here: https://review.openstack.org/#/c/382037/42/neutron/plugins/ml2/plugin.py@1620 me and johndperkins have added comments to point where it fails. Error is when a model query is done right after the level OVO transaction. Can you please have a look into that?
15:27:40 <ihrachys> sshank: hm ok. I think kevinbenton also looked at something relevant here: https://review.openstack.org/#/c/441231/
15:28:36 <ihrachys> ok let's move to the next section which is
15:28:38 <ihrachys> #topic Other patches on review
15:28:49 <ihrachys> #link https://review.openstack.org/#/q/status:open+message:%22UpgradeImpact%22+project:openstack/neutron
15:28:55 <sshank> ihrachys, Thanks for the link.
15:29:16 <ihrachys> nothing huge in the list, just note ns-metadata-proxy is now switched to haproxy
15:29:32 <ihrachys> for what I understand it doesn't really affect users on upgrade
15:29:53 <ihrachys> it will merely replace implementation of the proxy on agent restart
15:30:05 <ihrachys> which may introduce a moment of metadata service not replying
15:30:31 <ihrachys> but metadata consumers should already be resilient against short downs
15:31:15 <electrocucaracha> I found useful this blog for understanding neutron metadata services https://vietstack.wordpress.com/2014/09/27/introduction-of-metadata-service-in-openstack/
15:31:49 <ihrachys> with the patch in, some of those bits will become irrelevant :)
15:32:00 <manjeets> electrocucaracha, ++
15:32:18 <ihrachys> ok other patches seem old and don't need discussion
15:32:30 <ihrachys> #topic Open discussion
15:32:44 <ihrachys> I think we talked about review prioritization before
15:33:13 <ihrachys> to mitigate some of the problems with my reviews, I created some calendar 'events' to review OVO patches specifically
15:33:28 <ihrachys> hopefully it will give me some motivation to walk thru them more often
15:33:54 <ihrachys> it would also help if folks raise patches they believe are ready to review in #openstack-neutron
15:34:05 <ihrachys> once in a while
15:34:33 <ihrachys> I think we started making some more progress lately, so that's good to see
15:34:58 <ihrachys> if you have more ideas how to keep reviewers more focused, I am all ears
15:35:18 <ihrachys> apart from that, I don't have anything to raise here, so unless you have something...
15:35:20 <electrocucaracha> ihrachys: quick question about that calendar
15:35:29 <electrocucaracha> ihrachys: is it public?
15:35:32 <ihrachys> nooo
15:35:38 <ihrachys> it's my private calendar;)
15:35:53 <ihrachys> I am just saying, that's what I try to do to fix my flow
15:35:57 <electrocucaracha> ihrachys: hehehe okas, that makes sense
15:36:44 <electrocucaracha> ihrachys: as long as we have some progress on that I'm ok
15:37:29 <electrocucaracha> ihrachys: at least there is an official document which explains how to contribute and review OVO
15:37:46 <ihrachys> indeed
15:37:58 <ihrachys> I wonder if it's consumable by anyone outside the group
15:38:16 <ihrachys> there may be a lot of assumed knowledge there
15:38:25 <ihrachys> but we will figure it out once people start reading it
15:38:44 <electrocucaracha> well, given the amount of review over that document I should expect that most of them were aware
15:38:59 <ihrachys> oh you think so!
15:39:01 <ihrachys> :)
15:39:10 <ihrachys> ok seems like we have plenty of time to spend for other means, like following up on things we said we will ;)
15:39:26 <electrocucaracha> yep :)
15:39:36 <ihrachys> thanks everyone for joining, take those 20 mins as a gift from yours truly
15:39:38 <ihrachys> ciao
15:39:41 <ihrachys> #endmeeting