15:01:37 <ihrachys> #startmeeting neutron_upgrades
15:01:38 <openstack> Meeting started Mon Apr 10 15:01:37 2017 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:42 <openstack> The meeting name has been set to 'neutron_upgrades'
15:01:42 <electrocucaracha> o/
15:02:34 <ihrachys> hi everyone
15:02:47 <ihrachys> let's start from reviewing priorities set in previous meeting
15:02:57 <ihrachys> #topic Review priorities from prev meeting
15:03:21 <ihrachys> first was the /extensions/ convergence spec: https://review.openstack.org/#/c/451993/
15:03:37 <ihrachys> thanks electrocucaracha and manjeets for having a first look
15:03:46 <electrocucaracha> :)
15:04:01 <electrocucaracha> the idea is great
15:04:16 <ihrachys> there was some discussion of that proposal on the last drivers meeting
15:04:39 <ihrachys> there are some concerns of complexity, but it was decided that drivers will have a look at the write-up
15:06:04 <ihrachys> so it's basically pending more discussion at this point
15:06:20 <ihrachys> next was migrate_data CLI command: https://review.openstack.org/#/c/432494/
15:06:27 <ihrachys> I see it's not respinned
15:06:56 <ihrachys> electrocucaracha, what's the status there?
15:08:04 <electrocucaracha> I have spent time in other things
15:08:13 <electrocucaracha> specially wsgi stuff
15:08:40 <electrocucaracha> so, it's still on my plate hopefully this weeks looks better
15:09:41 <ihrachys> yeah, I saw you respinning wsgi
15:09:51 <ihrachys> gotta get back to it
15:10:14 <ihrachys> ok I guess we will have something next week
15:10:16 <electrocucaracha> but at least there is some reviews there were I can address them
15:10:39 <ihrachys> next was LIKE support: https://review.openstack.org/#/c/419152/
15:10:48 <ihrachys> I just reviewed it and left some comments
15:11:17 <ihrachys> both test issues and something to tinker with the design/naming/...
15:11:29 <ihrachys> next was update_objects: https://review.openstack.org/452266
15:11:57 <ihrachys> asingh_, I see you respinned the patch.
15:12:50 <electrocucaracha> she still have a couple of things to do there
15:12:50 <asingh_> ihrachys i included few lines to code if updatable fields don't exist in a model then skip
15:13:09 <ihrachys> that makes sense. I still see "sqlalchemy.exc.InvalidRequestError: Could not evaluate current criteria in Python. Specify 'fetch' or False for the synchronize_session parameter."
15:13:50 <ihrachys> at least the skip brings failure toll lower :)
15:14:05 <asingh_> ihrachys this solved failing testcase in FlatAllocation. Also it seems that standard_attribute id is not being loaded and update_objects is trying to update the same and thus failing testcase
15:14:44 <ihrachys> you mean same revision?
15:15:26 <asingh_> yes , thats what i have observed
15:16:59 <ihrachys> oh ok. maybe the revision number bumping mechanism hasn't triggered because we do everything on server side
15:17:33 <ihrachys> in which case we may have to have two different update_objects implementations for revision-carrying and simple models.
15:17:51 <ihrachys> for the first type, we would go through full fetch/set/commit cycle
15:19:45 <ihrachys> ok I guess we have a way forward here
15:19:59 <ihrachys> next in line was https://review.openstack.org/367810 (endpoints OVO)
15:20:52 <ihrachys> this seems pending resolution of issues with update_objects?
15:21:03 <electrocucaracha> let me check with her
15:21:06 <ihrachys> then we could utilize that
15:21:50 <electrocucaracha> ihrachys: yes, that was she said
15:22:42 <ihrachys> ok
15:23:09 <ihrachys> asingh_, do you plan to work on update_objects? do you understand the idea with two implementations?
15:24:01 <asingh_> ihrachys at this point i don't understand the idea of two implementations
15:25:28 <ihrachys> ok, so the idea is that we may do filter_by().update() for models not having standard attrs; but for get_objects(): ...; obj.update() for the latter
15:25:54 <ihrachys> so that for those that have standard attributes, we fetch models, triggering the revision bump logic
15:26:18 <ihrachys> we can discuss that afterwards, or I can poke it
15:26:42 <asingh_> yes , that works
15:27:07 <electrocucaracha> I'd like to be involved in that discussion if I can
15:27:33 * electrocucaracha even when I have to complete the online migration
15:27:55 <ihrachys> sure, I guess I better post the suggestion in gerrit for everyone to see
15:28:25 <ihrachys> #action ihrachys to comment on the plan for update_objects for standard attrs aware objects
15:28:36 <ihrachys> next in line was router extra attrs: https://review.openstack.org/#/c/381209/
15:28:39 <ihrachys> I see it was respinned
15:29:46 <ihrachys> seems like now it's passing the gate
15:30:24 <ihrachys> I will have another look
15:31:05 <ihrachys> final in the list is HARouter: https://review.openstack.org/#/c/361443/
15:31:29 <ihrachys> it doesn't seem complete. I think it was brought up because of some issues that block the patch.
15:31:34 <ihrachys> I haven't had a look
15:31:54 <ihrachys> I see a bunch of comments there from others
15:32:06 <ihrachys> would it make sense to adopt those and refresh the patch to see where we stand?
15:32:15 <electrocucaracha> and a merge conflict
15:32:16 <ihrachys> even if it's not complete and there are outstanding issues
15:32:50 <ihrachys> then later this week we could have another look on what's going on there
15:34:15 <ihrachys> sindhu, what do you think
15:35:02 <sindhu> ihrachys: I am addressing the comments. I have changes locally
15:35:20 <sindhu> ihrachys: getting lot of errors due to the changes made
15:35:37 <sindhu> ihrachys: trying to figure out those
15:35:56 <sindhu> ihrachys: will push a patch soon
15:36:02 <ihrachys> nice
15:36:37 <ihrachys> now let's finally get to the agenda ;)
15:36:41 <ihrachys> #topic Linuxbridge multinode grenade job
15:36:44 <ihrachys> manjeets, any progress
15:37:15 <ihrachys> have you synced with kevinbenton on the matter
15:40:48 <ihrachys> ok seems like manjeets is out
15:41:01 <electrocucaracha> I can try to contact him later
15:41:09 <ihrachys> nah, we can revive next week
15:41:25 <ihrachys> at this point I feel we should not even bring it up until a progress is made
15:41:46 <electrocucaracha> make sense
15:42:24 * ihrachys quickly looked through the list of OVO patches and UpgradeImpact and doesn't see anything critical that was not discussed
15:42:33 <ihrachys> so I think we can go straight to open mic
15:42:38 <ihrachys> #topic Open discussion
15:42:46 <electrocucaracha> I was thinking about the Rodolfo's change
15:42:47 <electrocucaracha> https://review.openstack.org/#/c/361443/
15:43:06 <ihrachys> is it the right link?
15:43:36 <electrocucaracha> sorry ,https://review.openstack.org/#/c/454220/
15:45:34 <ihrachys> I am not sure I follow the reasoning of the bug report
15:46:00 <ihrachys> first, we can't use anything for micro-versioning in neutron because there is no micro-versioning in neutron :)
15:46:21 <electrocucaracha> me too, the reason that I took my attention was that it was related with OVO
15:46:38 <ihrachys> rodrigods, what's the reason behind the qos OVO rework?
15:49:35 <ihrachys> I guess we will need to chase the author in other means
15:49:41 <ihrachys> thanks for bringing it up electrocucaracha
15:50:42 <electrocucaracha> I'm sure that they have their reasons to modify it but I don't like the idea to change something for previous versions
15:50:48 <electrocucaracha> but let's see
15:51:48 <ihrachys> gotta understand the use case.
15:52:08 <ihrachys> the bug right now is worded in such a way that suggests it's some internal code improvement with no clear benefit.
15:53:51 <ihrachys> ok any more topics to discuss?
15:54:05 <electrocucaracha> none from me
15:54:36 <ihrachys> ok let's call it a day then
15:54:42 <ihrachys> thanks for joining
15:54:43 <electrocucaracha> thanks ihrachys
15:55:01 <ihrachys> btw the review priorities are probably same since we haven't landed much
15:55:03 <ihrachys> #endmeeting