15:04:28 <ihrachys> #startmeeting neutron_upgrades
15:04:29 <openstack> Meeting started Mon Apr 17 15:04:28 2017 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:33 <openstack> The meeting name has been set to 'neutron_upgrades'
15:04:36 <ihrachys> hi to those still alive
15:04:57 <ihrachys> FYI late OSIC layoff hit the team hard
15:05:04 <ihrachys> it's not clear who is still with us
15:05:07 <ihrachys> manjeets, you have an idea?
15:05:19 <manjeets> ihrachys, it will take some time I have not idea
15:05:21 <ihrachys> manjeets, I think it may have affected you too rihgt?
15:05:37 <manjeets> ihrachys, i talked my manager he said Im not impacted
15:05:46 <manjeets> i wasn't osic
15:05:52 <ihrachys> oh that's good to hear
15:06:06 <sshank> I am here to get updates.
15:06:18 <ihrachys> sshank, hi! you are not OSIC either?
15:06:25 <sshank> ihrachys, I am OSIC.
15:06:52 <ihrachys> sshank, and are you affected?
15:07:11 <sshank> ihrachys, Yes.
15:07:25 <sshank> ihrachys, I just wanna be in touch with the community irrespective.
15:07:36 <ihrachys> oh ok I see, nice to hear.
15:07:53 <ihrachys> so we will see how it goes.
15:08:11 <ihrachys> let's just look through our review queues to see what we can do with the situation
15:09:10 <ihrachys> btw we started landing some patches up for review that were from OSIC so that they are not bitrot before getting a chance for merge.
15:09:35 <ihrachys> we landed NetworkSegment switch which is a nice one, since it's probably one of those more complex objects that never happened
15:10:05 <ihrachys> ok let's get to a more formal business
15:10:15 <ihrachys> #topic Objects implementation
15:10:20 <ihrachys> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
15:11:20 <ihrachys> we are landing RouterExtAttrs: https://review.openstack.org/381209 and also Victor's UT refactoring: https://review.openstack.org/425800
15:11:54 <ihrachys> in the latter, we were hit by https://launchpad.net/bugs/1683369 but that doesn't seem like an issue of the patch in question
15:11:54 <openstack> Launchpad bug 1683369 in neutron "TagDbObjectTestCase.test_objects_exist_validate_filters_false may fail because of non-unique id for standardattributes" [High,Confirmed]
15:12:17 <ihrachys> oh and the patch is in merge conflict now, so I will rebase after the meeting
15:12:24 <ihrachys> #action ihrachys to rebase and push https://review.openstack.org/#/c/425800/
15:13:09 <ihrachys> we also tried to merge https://review.openstack.org/#/c/304873/ (dvr mac address object) yesterday but it seems to have an issue
15:13:13 <ihrachys> in functional tests
15:13:25 <ihrachys> the patch is on tonytan_brb
15:13:33 * ihrachys wonders if Tony was affected
15:13:56 <tonytan_brb> ihrachys: Yes, I am. but I will continue with the Patch.
15:14:25 <ihrachys> ok, thanks for following up on it
15:14:50 <ihrachys> tonytan_brb, you also have LIKE support: https://review.openstack.org/419152 will you follow up on that one too?
15:15:00 <tonytan_brb> Yes, I will
15:15:21 <ihrachys> ok thanks a bunch
15:16:04 <ihrachys> in other news, I updated update_objects patch: https://review.openstack.org/#/c/452266/ with the logic that I suggested (using the new update-in-place pattern only when there are no standard attributes)
15:16:37 <ihrachys> sshank, but it doesn't seem to solve the test failures that we see with "sqlalchemy.exc.InvalidRequestError: Could not evaluate current criteria in Python. Specify 'fetch' or False for the synchronize_session parameter."
15:16:47 <ihrachys> so it's probably a different thing
15:17:17 <ihrachys> sshank, do you plan to follow up on the patch, or I should take over?
15:17:53 <sshank> ihrachys, you can take over.
15:18:04 <ihrachys> ok, thanks for your work.
15:18:17 <ihrachys> #action ihrachys to take over update_objects
15:19:48 <sshank> ihrachys, One question regarding get_objects, does it not support None filter?
15:20:03 <ihrachys> sshank, what do you mean?
15:20:15 <ihrachys> sshank, if you don't want to filter, you don't pass kwargs
15:20:20 <ihrachys> then you get all objects
15:20:28 <ihrachys> or isn't it what you ask
15:21:00 <sshank> ihrachys, example: https://review.openstack.org/#/c/396351/16/neutron/db/l3_db.py@1401
15:21:47 <ihrachys> oh you mean passing a None value
15:22:03 <sshank> yes.
15:22:05 <ihrachys> do you have a traceback handy?
15:22:28 <sshank> No. It was while back, but just wanted to ask you when Kevin mentioned it there.
15:22:48 <ihrachys> I think we should make it work if it's not already
15:22:57 <ihrachys> so a bug/traceback would help to understand what happens
15:24:01 <ihrachys> sshank, are you going to report a bug for that?
15:24:23 <sshank> ihrachys, I can do it. But I need to test it again once.
15:24:48 <ihrachys> cool
15:25:05 <ihrachys> #action sshank to investigate why None filter don't work and/or report a bug
15:27:04 <ihrachys> in other news, we still need to revive neutron-db-manage data migration command: https://review.openstack.org/432494
15:27:16 <ihrachys> since Victor now left, someone needs to take it over
15:27:40 <ihrachys> I will probably take that one unless someone strongly feels like
15:28:19 <manjeets> ihrachys, I can take a look today and let you know by EOD ?
15:28:45 <ihrachys> manjeets, ok please do
15:28:58 <ihrachys> #action manjeets to take over new CLI command: https://review.openstack.org/432494
15:30:20 <ihrachys> #topic Other patches
15:30:27 <ihrachys> #link https://review.openstack.org/#/q/status:open+message:%22UpgradeImpact%22+project:openstack/neutron
15:30:43 <ihrachys> the only patch of interest is https://review.openstack.org/#/c/456419/ and it's already in gate
15:31:00 <ihrachys> it just tunes default oslo.db behaviour in neutron, nothing of major impact
15:31:14 <ihrachys> any other patches to raise?
15:31:39 <manjeets> not any from me atm
15:32:07 <ihrachys> ok
15:32:16 <ihrachys> #topic Open discussion
15:33:36 <ihrachys> I just want to say to all folks who are affected (or not) by recent events that I appreciate all the work already done and in the queue, and it is and was a pleasure to work with everyone. I am also happy to see people plan to stick with us even if obviously priorities may shift.
15:35:12 <ihrachys> ok that's all I have for now. we'll meet next week as usual. review priorities are still the same since we haven't made much progress lately (and I understand why)
15:35:17 <ihrachys> cu!
15:35:20 <ihrachys> #endmeeting