15:00:55 <ihrachys> #startmeeting neutron_upgrades
15:00:56 <openstack> Meeting started Mon Apr 24 15:00:55 2017 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <openstack> The meeting name has been set to 'neutron_upgrades'
15:01:00 <ihrachys> o/
15:01:27 <ihrachys> anyone else?
15:01:36 <manjeets> 0/
15:01:55 <ihrachys> ok we are two at least, let's run quick through what we have
15:02:20 <ihrachys> #topic Linuxbridge grenade
15:02:34 <ihrachys> I think kevinbenton had a reasonable lead as to why it may fail sometimes
15:02:38 * ihrachys searches for the bug number
15:02:52 <ihrachys> https://bugs.launchpad.net/neutron/+bug/1683256
15:02:54 <openstack> Launchpad bug 1683256 in neutron "linuxbridge multinode depending on multicast support of provider" [Critical,New]
15:03:11 <ihrachys> which may also explain why manjeets saw it on a particular cloud
15:03:40 <ihrachys> there is no patch up for review yet, but at least we know a possible culprit.
15:03:42 * manjeets looks at it
15:05:02 <ihrachys> we can discuss that later if needed
15:05:03 <ihrachys> #topic Mixed server versions
15:05:48 <ihrachys> due to recent changes in staffing, I decided I won't be able to make progress on /extensions convergence, so I abandoned https://review.openstack.org/#/c/451993/ and unassigned the RFE bug from myself
15:05:58 <ihrachys> I will instead spend time completing OVO transition
15:06:33 <ihrachys> later I may get back to it, but for now I will suggest we don't pursue this for Pike.
15:07:12 <manjeets> ok, we can also work on ovo patches already up to get going
15:07:12 <ihrachys> if someone would like to poke it though, you are welcome (but note we have plenty of work on OVO side and others, like neutron-db-manage CLI)
15:07:43 <ihrachys> right. there is little sense to start new endevours if we struggle to close those already running
15:08:07 <ihrachys> #topic Object implementation
15:08:20 <ihrachys> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
15:08:27 <ihrachys> I haven't checked those too much lately
15:08:49 <manjeets> may be we can track from Victor's spread sheet
15:09:17 <ihrachys> maybe, but let's have a look what's in the queue already that may be an easy target
15:09:25 <ihrachys> for one, metering should be close to completion: https://review.openstack.org/#/c/433125/
15:09:29 <ihrachys> needs a rebase/respin
15:09:38 <ihrachys> I will take care of that one
15:09:48 <ihrachys> #action ihrachys to respin metering OVO patch: https://review.openstack.org/#/c/433125/
15:10:06 <ihrachys> I also hear that router l3 agent binding should be ready: https://review.openstack.org/377074
15:10:19 <manjeets> Luijin luo was not osic is he gonna still keep up with his patches ?
15:11:04 <ihrachys> manjeets, may you ask him in gerrit? or do you have other means to contact him?
15:11:28 <manjeets> I don't have will comment on his patch to figure out
15:11:33 <ihrachys> ok thanks
15:12:17 <ihrachys> tonytan4ever, hi
15:12:23 <ihrachys> I see LIKE patch is stuck: https://review.openstack.org/#/c/419152/
15:12:57 <ihrachys> would be nice to see it moving forward. or if you don't have spare cycles, we can see who can pick it up for you.
15:13:14 <sshank> ihrachys: I tried the None filtering on object field. It works fine. I guess I was wrong.
15:13:46 <ihrachys> sshank, ok good to know. which patch was blocked due to that?
15:14:17 <sshank> I encountered that during floating ip ovo. But it is blocked by router ovo
15:14:29 <tonytan4ever> ihrachys: I will work on it this week
15:14:32 <sshank> Since the floating ip ovo depends on router ovo
15:14:44 <tonytan4ever> Last week is all sorta hectic finding new jobs.
15:15:42 <ihrachys> tonytan4ever, yeah that's understandable. I wish you all gl with the new endevours.
15:15:47 <ihrachys> tonytan4ever, thanks for taking care
15:15:59 <ihrachys> #action tonytan4ever to respin LIKE patches
15:17:05 <ihrachys> I haven't had a chance to work on update_objects so no progress there
15:17:55 <ihrachys> tonytan4ever, another patch that you have is the dvr mac address object: https://review.openstack.org/#/c/304873
15:18:09 <ihrachys> have you had a chance to look at the gate failure? seems related.
15:18:14 <tonytan4ever> Yes, I will take care of that too.
15:19:20 <ihrachys> ok cool
15:19:21 <tonytan4ever> I haven't looked at it for a while though, but I will pick it up later today.
15:19:39 <ihrachys> I think code wise it was ready but gate breaks because of it
15:19:55 <tonytan4ever> yeah
15:21:11 <ihrachys> I was looking through the Victor's documnet here: https://docs.google.com/spreadsheets/d/1FeeQlQITsZSj_wpOXiLbS36dirb_arX0XEWBdFVPMB8/edit#gid=1434170112
15:22:08 <ihrachys> seems like apart from things currently in progress, we lack several crucial bits. specifically, we haven't made much progress on Networks/Ports/Routers/SGs (basically, all huge objects) since we landed object definitions in tree.
15:22:51 <ihrachys> some of them had patches in the past (or even respinned and on review right now) but lacked attention from reviewers and authors lately
15:23:09 <ihrachys> we need to eventually shift the focus there
15:23:55 <ihrachys> I wanted to close the current smaller gaps before I get to the bigger pieces, but if folks have plans to take care of any of those, that's a good time to revisit the status of the patches and make them ready for reviews.
15:25:46 <ihrachys> next week we will revisit the document in some more detail
15:25:53 <ihrachys> #topic Other patches on review
15:26:23 <ihrachys> there is something that, I realized, breaks ml2 rolling upgrades for all agents not in tree: https://review.openstack.org/#/c/452009/
15:26:37 <ihrachys> thought it may be of interest to the group
15:26:58 <ihrachys> specifically, it breaks OVN rolling
15:28:25 <ihrachys> oh we should also discuss the new CLI command for neutron-db-manage
15:28:37 <ihrachys> https://review.openstack.org/#/c/432494/
15:28:43 <ihrachys> manjeets, I think you planned to have a look
15:29:07 <manjeets> ihrachys, sorry I was dragged into internal work last week
15:29:24 <manjeets> will review it in detail today
15:29:38 <ihrachys> ok
15:29:57 <ihrachys> #action manjeets to take over neutron-db-manage CLI command for data migration
15:30:18 <ihrachys> any other patches worth attention?
15:30:31 <manjeets> ovo for sg
15:30:50 <ihrachys> https://review.openstack.org/#/c/284738/ ?
15:31:12 <manjeets> https://review.openstack.org/#/c/284738/
15:31:14 <manjeets> yes
15:31:51 <ihrachys> ok, I see that Victor was the last touching it. I guess we need to get a new owner for the patch.
15:32:40 <manjeets> i guess need to address kevin's comment on that and then it will be good
15:32:47 <ihrachys> this is one of the larger objects that may need special attention. not as huge as ports though. I am actually a bit surprized integration patch is not too long.
15:33:00 <manjeets> i'll see if i get cycles
15:33:07 <ihrachys> ok thanks
15:33:20 <ihrachys> #action manjeets to try craft out cycles for SG adoption patch
15:34:38 <ihrachys> ok any other patches or topics to discuss?
15:34:41 <ihrachys> or I call it a day
15:35:02 <manjeets> mostly covered
15:35:26 <ihrachys> ok. we can discuss OVO adoption for larger objects in more details next week.
15:35:32 <ihrachys> thanks manjeets and others for joining
15:35:33 <manjeets> sure
15:35:36 <manjeets> thanks
15:35:39 <sshank> Thanks
15:35:56 <ihrachys> #endmeeting