15:01:23 <ihrachys> #startmeeting neutron_upgrades
15:01:24 <openstack> Meeting started Mon Jun  5 15:01:23 2017 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:28 <openstack> The meeting name has been set to 'neutron_upgrades'
15:01:28 <ihrachys> o/ everyone
15:01:49 <lujinluo> o/
15:02:00 <manjeets__> o/
15:02:27 <ihrachys> ok seems like we don't have any specific action items from the prev meeting
15:02:38 <ihrachys> so we can move straight into reviewing the list of OVO patches maybe
15:02:42 <ihrachys> #topic OVO
15:02:54 <ihrachys> https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
15:03:15 <ihrachys> for the record, we landed router-l3-agent-binding: https://review.openstack.org/377074
15:03:22 <ihrachys> also update_objects API: https://review.openstack.org/452266
15:03:39 <ihrachys> (^ which I think means tunnel endpoints patch can be revived)
15:04:16 <manjeets__> ihrachys: as you noticed gate was not so nice last week
15:04:32 <ihrachys> we aslo have security groups OVO adoption in the gate but failing over and over because of unrelated gate issues :https://review.openstack.org/284738
15:04:41 <ihrachys> yeah, gate is pretty bad
15:04:55 <ihrachys> I mostly work on getting it back to normal right now
15:05:55 <ihrachys> ok, now, starting from the top, lujinluo has two patches for router object: https://review.openstack.org/#/c/466237/ and https://review.openstack.org/#/c/307964/
15:06:05 <ihrachys> I presume that those two are the only bits needed?
15:07:13 <ihrachys> I see both having some issues passing the gate that seem legit
15:07:16 <lujinluo> i have not checked why the eager loading patch failed yet. will check after the meeting. as for the router ovo creation patch, i have a local patch which is not finished yet
15:07:59 <ihrachys> ok let's wait for the new version. for the relationship, functional test failure seems related, but worth a (re)check to be sure.
15:08:21 <lujinluo> yeah
15:08:31 <ihrachys> ok next we have network-dhcp-agent-binding: https://review.openstack.org/#/c/370452/
15:08:36 <ihrachys> this one has +2 from kevin, good
15:08:39 <ihrachys> and -1 from lujinluo
15:08:58 <lujinluo> yes, i pointed out we only need to make a slight change in test_base.py
15:09:03 <ihrachys> -1 seems to be a small test issue, correct?
15:09:05 <manjeets__> ihrachys: I just noticed i'll address lujinluo 's comments today
15:09:20 <lujinluo> ihrachys, yes, very small issue
15:09:31 <ihrachys> manjeets__, ++ I will have a look at it after the meeting to make sure we can get it in on the next PS
15:09:51 <manjeets__> ++
15:10:43 <ihrachys> ok next in the list is neutron-db-manage command for data migration: https://review.openstack.org/#/c/432494/
15:11:08 <ihrachys> I see there is some progress there, like stevedore alias added
15:11:26 <ihrachys> manjeets__, do you know the path forward, or we need to have another look at the latest?
15:11:36 <manjeets__> i've also added a functional test using existing framework
15:14:07 <ihrachys> manjeets__, so do you need us to eyeball the latest?
15:14:24 <manjeets___> sorry internet outage for a moment
15:15:08 <manjeets___> functional test passed locally but is failing over gate, need to debug it locally again
15:15:27 <ihrachys> manjeets___, do you need us to eyeball the latest?
15:15:38 <manjeets___> sure that will help
15:15:51 <manjeets___> if something is wrong with the approach i followed
15:16:41 <ihrachys> ok next in line is https://review.openstack.org/#/c/304873/ (dvr mac address OVO)
15:16:53 <ihrachys> it's on Tony, and I believe he is not available for the work
15:16:58 <ihrachys> we probably need to take it over
15:17:11 <ihrachys> thoughts? anyone heard from Tony lately?
15:17:30 <lujinluo> no, i do not
15:18:25 <ihrachys> ok, the patch doesn't seem huge
15:18:30 <ihrachys> anyone want to polish it?
15:18:56 <lujinluo> i can try, but i cannot promise i can do it this week
15:19:19 <ihrachys> ok I will take it myself, shouldn't take a lot of time
15:19:28 <lujinluo> ok
15:20:24 <ihrachys> next in the list is port binding: https://review.openstack.org/#/c/407868/
15:20:37 <ihrachys> this one is kinda important since we have port binding changes in the pipeline
15:20:51 <ihrachys> lujinluo, what's the status there? I see lots of red in gate.
15:21:42 <lujinluo> yeah, somehow i have a failed UT again besides functional test failures. have not figured out why
15:22:05 <lujinluo> i will priotirize this PS this week
15:22:09 <ihrachys> coool
15:22:35 <lujinluo> also, reviews would be aprreciated
15:22:47 <ihrachys> ok let me add it to my list
15:22:56 <manjeetsb> Sorry my home network is not good today
15:23:00 <lujinluo> it seems we have manjeetsb back now
15:23:04 <manjeetsb> Joined over phone now
15:23:49 <ihrachys> manjeetsb, ack
15:23:57 <manjeetsb> A review on dbmanage command will help ihrachys
15:24:09 <ihrachys> manjeetsb, + on my list now
15:24:18 <manjeetsb> Cool thanks
15:24:32 <manjeetsb> I'll checkout dvr ovo patch from Tony today
15:24:33 <ihrachys> next in queue are two qos related objects from Rodolfo: https://review.openstack.org/#/c/468406/ and https://review.openstack.org/#/c/468837/
15:24:50 <ihrachys> both seem green in gate and well isolated
15:25:04 <ihrachys> manjeetsb, I am taking it over, so no need.
15:25:12 <manjeetsb> Ok
15:25:29 <ihrachys> for qos, I will just put it in my list but it may take a while till I get there
15:26:56 <ihrachys> next in the list is port binding level OVO: https://review.openstack.org/#/c/382037/
15:27:11 <ihrachys> it was on shashank who I believe is no longer with openstack?
15:27:16 <ihrachys> manjeetsb, you should prolly know
15:27:28 <ihrachys> oh I see a respin on May 24
15:27:31 <manjeetsb> He switched job
15:27:52 <manjeetsb> He is no longer working on openstack now
15:28:19 <ihrachys> ok let's check in gerrit if he is going to complete it; if no response in a week, we can take it over then
15:28:47 <manjeetsb> Sure I'll ask him he is in same building as I am in
15:29:04 <ihrachys> cool
15:29:12 <ihrachys> I also posted a question on his plans in gerrit
15:29:26 <manjeetsb> Ohk
15:29:36 <ihrachys> #action manjeetsb to clarify if Shashank is going to complete port binding level OVO patch
15:30:07 <ihrachys> next in line are ip allocation OVOs: https://review.openstack.org/396718 and https://review.openstack.org/396711
15:30:25 <ihrachys> those were originally from Victor but I see lujinluo took over
15:30:36 <lujinluo> I respinned these two. Please help with the reviews ;)
15:30:48 <ihrachys> + will do, thanks for taking over
15:30:55 <ihrachys> they seem green, good progress
15:31:34 <ihrachys> ok next is LIKE filter support: https://review.openstack.org/#/c/419152/
15:31:36 <ihrachys> it's on Tony
15:31:40 <ihrachys> we should take it over
15:32:02 <ihrachys> I believe it's mostly small things left, like a test missing and such
15:32:11 <ihrachys> anyone willing to take it over and prepare for merge?
15:32:52 <manjeetsb> I'll review it today
15:33:13 <ihrachys> manjeetsb, review or take over/respin?
15:33:16 <manjeetsb> And see try respining if need really small changes
15:33:25 <ihrachys> ok, thanks
15:33:44 <ihrachys> #action manjeetsb to have a look at LIKE support patch and respin
15:34:29 <ihrachys> next in line is Anindita's endpoints OVO: https://review.openstack.org/#/c/367810/
15:34:37 <ihrachys> I think this was waiting for update_objects API to merge
15:34:44 <ihrachys> now that it's in, we should be able to revive it
15:34:56 <ihrachys> since Anindita is no longer with us, we will need to take it over
15:35:49 <ihrachys> I guess I can take it for respin
15:36:05 <ihrachys> #action ihrachys to respin endpoints OVO patch: https://review.openstack.org/#/c/367810
15:36:58 <ihrachys> ok, most other patches are in conflicts, and I think we have a lot on our hands for the week already, so I will skip those
15:37:12 <ihrachys> there is a small one for tests from manjeetsb : https://review.openstack.org/#/c/411981/
15:37:43 <ihrachys> it's nothing major, but seems like there is an issue with a test
15:37:51 <ihrachys> manjeetsb, what's your plan for the patch?
15:38:29 <manjeetsb> I'll revisit it this week and try to address it
15:38:57 <ihrachys> ok. no rush, it's definitely not top priority
15:39:26 <manjeetsb> Ok
15:40:11 <ihrachys> ok let's move to the next topic
15:40:23 <ihrachys> #topic Linuxbridge multinode grenade job
15:40:54 <ihrachys> the job is in check queue, not voting, and failing *sometimes* depending on the cloud
15:41:03 <ihrachys> we have this bug reported with proposed solution: https://bugs.launchpad.net/neutron/+bug/1683256
15:41:04 <openstack> Launchpad bug 1683256 in neutron "linuxbridge multinode depending on multicast support of provider" [High,Confirmed]
15:41:17 <ihrachys> I initially thought that Kevin will handle it himself, but now I am not sure
15:41:30 <ihrachys> maybe worth checking with him if he plans the implementation
15:42:02 <manjeetsb> May be we can nudge him and ask ??
15:42:07 <ihrachys> sounds like a devstack-gate/project-config job
15:42:20 <ihrachys> kevinbenton, what's your plan for https://bugs.launchpad.net/neutron/+bug/1683256 ?
15:42:21 <openstack> Launchpad bug 1683256 in neutron "linuxbridge multinode depending on multicast support of provider" [High,Confirmed]
15:42:34 <ihrachys> do you plan to tackle it, or we should find someone to take it over?
15:43:21 <ihrachys> it's prolly quite early for kevinbenton :)
15:43:29 <ihrachys> ok let's figure it out off band
15:43:32 <ihrachys> I will talk to him
15:43:44 <ihrachys> #action ihrachys to talk to Kevin about his plans for grenade linuxbridge multinode job setup
15:44:44 <ihrachys> #topic Open discussion
15:44:48 <ihrachys> anyone has anything to discuss?
15:45:17 <lujinluo> none from me
15:45:26 <manjeetsb> None from me as well
15:46:27 <ihrachys> ok then let's wrap it up
15:46:50 <ihrachys> overall I think we do good progress lately
15:46:59 <ihrachys> let's complete this OVO saga this cycle ;)
15:47:03 <ihrachys> thanks everyone
15:47:05 <ihrachys> #endmeeting