15:01:01 <ihrachys> #startmeeting neutron_upgrades
15:01:02 <openstack> Meeting started Mon Jun 12 15:01:01 2017 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:05 <openstack> The meeting name has been set to 'neutron_upgrades'
15:01:43 <ihrachys> o/
15:01:58 <lujinluo> o/
15:02:05 <ihrachys> let's start from reviewing action items from the previous week
15:02:11 <ihrachys> #topic Action items from prev week
15:02:18 <ihrachys> first is "manjeetsb to clarify if Shashank is going to complete port binding level OVO patch"
15:02:24 <ihrachys> this is regarding https://review.openstack.org/#/c/382037
15:02:30 <ihrachys> I see Shashank respinned
15:02:34 <ihrachys> though it's all red in gate
15:03:10 <lujinluo> but he did not say if he will continue it
15:03:25 <ihrachys> seems like this is the culprit: http://logs.openstack.org/37/382037/52/check/gate-grenade-dsvm-neutron-ubuntu-xenial/a4b33fa/logs/new/screen-q-agt.txt.gz?level=TRACE
15:03:44 <ihrachys> manjeets__, is Shashank going to drive it to completion?
15:06:33 <ihrachys> manjeets__, are you around?
15:06:42 <ihrachys> doesn't seem like it
15:06:49 <lujinluo> :(
15:07:11 <ihrachys> ok let's restate the AIs that are on him for the next week and move on
15:07:17 <ihrachys> #action manjeetsb to clarify if Shashank is going to complete port binding level OVO patch
15:07:22 <ihrachys> #action manjeetsb to have a look at LIKE support patch and respin
15:07:44 <ihrachys> next was one me
15:07:47 <ihrachys> "ihrachys to respin endpoints OVO patch: https://review.openstack.org/#/c/367810"
15:07:48 <manjeets__> ihrachys, I asked him and he respin
15:08:00 <manjeets__> he said whenever he have cycles he'll be able to do it
15:08:07 <ihrachys> manjeets__, oh good, you are here :)
15:08:40 <ihrachys> re endpoints patch, I haven't really had time to respin it, but it's still on me. I should have more time this week.
15:08:51 <ihrachys> #action ihrachys to respin endpoints OVO patch: https://review.openstack.org/#/c/367810
15:09:02 <ihrachys> next was "ihrachys to talk to Kevin about his plans for grenade linuxbridge multinode job setup"
15:09:32 <ihrachys> I did talk to him on the matter; it's on Kevin's plate, he is aware of it, just hasn't prioritized it yet.
15:10:03 <manjeets> ihrachys, I spent time last debugging other issues, I'll work on like patch this week
15:10:09 <manjeets> last week**
15:10:15 <ihrachys> I think it's ok to give it more time to bubble up Kevin's todo list
15:10:23 <ihrachys> manjeets, thanks for the update
15:11:17 <ihrachys> these were all the items we had from the last meeting. as you can see, we haven't pulled much, hopefully we will make more progress this week.
15:11:23 <ihrachys> next topic is
15:11:23 <ihrachys> #topic OVO
15:12:12 <ihrachys> of all, we were able to merge the ip allocation pool adoption: https://review.openstack.org/#/c/396711/
15:12:38 <ihrachys> let's review those open for review
15:12:40 <ihrachys> v
15:12:42 <ihrachys> https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
15:12:55 <ihrachys> first is ip allocation adoption: https://review.openstack.org/#/c/396718/
15:13:09 <ihrachys> it needs some more work; and it's in merge conflict right now
15:13:13 <lujinluo> i will adress the comments tomorrow in ip allocation
15:13:25 <ihrachys> cool
15:13:26 <lujinluo> address*
15:13:49 <ihrachys> next are qos binding patches: https://review.openstack.org/#/c/468837/ and https://review.openstack.org/#/c/468406/
15:13:56 <ihrachys> I reviewed them, had some comments
15:14:00 <ihrachys> but I see they are now respinned
15:14:06 <ihrachys> so probably should be good to go now
15:14:14 <ihrachys> I will get back to them after the meeting
15:14:56 <ihrachys> next is security groups adoption: https://review.openstack.org/#/c/284738/
15:15:02 <ihrachys> it was already in gate several times
15:15:09 <ihrachys> but failed to merge due to gate instability
15:15:30 <ihrachys> I think gate issues are fixed now
15:15:38 <manjeets> I just rebased it now
15:16:00 <ihrachys> yeah, I see. we'll wait for CI results and push in gate if it passes
15:16:20 <ihrachys> I hope we can get it in this week. there is nothing that could block it except gate.
15:16:49 <ihrachys> next is https://review.openstack.org/#/c/466237/ adding port relationship to routers
15:17:06 <ihrachys> apparently needed for router OVO: https://review.openstack.org/307964
15:17:13 <ihrachys> I haven't got time to get to it :(
15:17:16 <ihrachys> so can't comment
15:17:21 <lujinluo> yeah, the eager loading patch has an unstable UT failure
15:17:22 <ihrachys> manjeets, have you had a look?
15:17:35 <lujinluo> i debugged it last week, seems to be some unclosed session issue
15:17:40 <ihrachys> lujinluo, is it related to the patch?
15:17:48 <lujinluo> but i have not figured out how to resolve it
15:17:57 <lujinluo> yes ihrachys
15:18:15 <ihrachys> do you have an example of the failure?
15:18:17 <manjeets> ihrachys, not, I was onto networking-odl reviews and a gate job last week, I'll try to have a look today
15:19:19 <lujinluo> it is the routerport.port.fixed_ips update problem as I see it. The ipallocations are stored in db, but not properly in port.fixed_ips
15:19:52 <lujinluo> sometimes the ipallocation got updated correctly in port.fixed_ips and sometimes not
15:20:51 <ihrachys> lujinluo, it may be because you don't update ipallocations via port model, so sqlalchemy misses to update the cached port model in session.
15:21:10 <ihrachys> if so, I think a refresh(port_db) in the right place could help
15:22:11 <ihrachys> ok next in line is port binding: https://review.openstack.org/#/c/407868/
15:22:24 <ihrachys> sadly I haven't had a chance to look either :-x
15:23:18 <lujinluo> i have not paid much attention on this patch either. The tempest failures are SSH to instances timeout, which I have solved yet
15:23:39 <ihrachys> ack
15:23:41 <ihrachys> next is network dhcp agent binding: https://review.openstack.org/#/c/370452
15:23:45 <ihrachys> this has one +2 from Kevin
15:23:58 <ihrachys> but lujinluo has a comment on test case
15:24:08 <ihrachys> I see manjeets was the last one who respinned the patch
15:24:22 <ihrachys> manjeets, are you going to address lujinluo's comment?
15:24:33 <manjeets> yes
15:25:08 <ihrachys> great
15:25:20 <ihrachys> #action manjeets to respin network dhcp agent binding patch: https://review.openstack.org/#/c/370452
15:25:29 <ihrachys> this is probably close, right?
15:25:35 <ihrachys> considering +2
15:26:51 <ihrachys> ok next is neutron-db-manage command: https://review.openstack.org/432494
15:27:02 <manjeets> yes, looks like it is
15:27:07 <ihrachys> I don't think we made any significant progress (at least review wise) there since the previous meeting
15:27:40 <ihrachys> I remember manjeets asked for feedback the previous meeting, so please let's try to get it this week at least :)
15:28:01 <ihrachys> afaiu it's not complete
15:28:12 <ihrachys> but will benefit from reviews either way
15:28:14 <lujinluo> i will try to help review the patch this week ;)
15:28:21 <ihrachys> lujinluo, ++
15:28:30 <ihrachys> next is dvr mac OVO: https://review.openstack.org/#/c/304873/
15:28:51 <ihrachys> seems mostly green, I just rechecked because of docs failure
15:29:14 <ihrachys> I will have a look after the meeting. the patch is very tiny.
15:29:50 <ihrachys> that's about it for the patches in the queue. we should be able to land a bunch this week. the major one is ofc security groups.
15:30:25 <lujinluo> ++
15:30:27 <ihrachys> any other OVO patches that maybe missed the topic?
15:30:59 <lujinluo> seems no
15:31:14 <ihrachys> ok
15:31:48 <ihrachys> no new UpgradeImpact patches it seems
15:31:53 <ihrachys> #topic Open discussion
15:32:21 <ihrachys> I have PTO the next week; then the week after I have an event I will need to attend during the time of the meeting.
15:32:34 <ihrachys> meaning I won't be able to chair either of next two meetings
15:32:49 <ihrachys> if you folks feel like sync during the time, you are free to
15:33:17 <lujinluo> got it
15:33:25 <ihrachys> if you don't feel like, I can also formally cancel them. up to you.
15:33:26 <manjeets> ok
15:33:58 <manjeets> I won't have much other than these patches to talk if needed we can chat over neutron channel or irc lujinluo
15:34:00 <manjeets> ??
15:34:19 <lujinluo> sure manjeets
15:34:25 <ihrachys> ok I will cancel next two
15:34:34 <lujinluo> and personally this meeting time is not convienent for me, haha
15:34:47 <ihrachys> lujinluo, which slot would be better for you?
15:35:01 <ihrachys> you are in Asia right?
15:35:03 <lujinluo> i am based in Japan.
15:35:06 <lujinluo> yeah
15:35:18 <ihrachys> yeah. sorry for the inconvenience.
15:35:24 <lujinluo> never mind
15:35:37 <ihrachys> manjeets, I could move 2h earlier. would it be fine with you?
15:35:58 <manjeets> that'll be like 6 am PST ?
15:36:00 <ihrachys> maybe not on Monday though, but some other day.
15:36:14 <ihrachys> manjeets, yeah. I am not sure which tz you are
15:36:21 <manjeets> we can try that up, I usually get up at 7ish
15:36:23 <manjeets> I am pst
15:36:27 <manjeets> same as ca
15:36:36 <ihrachys> well I start @6am :)
15:36:43 <lujinluo> if it is too troublesome, please do not bother
15:37:04 <ihrachys> or we can consider something later. checking a tz calculator for a sec.
15:38:06 <ihrachys> lujinluo, would 6-7am your time be better for you?
15:38:25 <lujinluo> ihrachys, yeah, i think i can do that
15:38:53 <manjeets> what it'll be pst ?
15:38:54 <ihrachys> ok let me spin up a doodle and send it to you two so that we can pick the best slot.
15:39:14 <ihrachys> manjeets, it's 2-3pm
15:39:30 <manjeets> okay with me
15:40:21 <ihrachys> ok. we will need to sync with internal calendars (I have quite some slots filled in), so doodle should help us to pick the right day. once we have it, we can discuss it in email and I can propose a patch moving the slot then.
15:40:42 <lujinluo> ihrachys, got it. thanks
15:40:54 <ihrachys> ok thanks everyone
15:41:01 <ihrachys> I won't take any more of your time :)
15:41:02 <manjeets> thanks
15:41:06 <ihrachys> ciao
15:41:08 <ihrachys> #endmeeting