14:00:23 <ihrachys> #startmeeting neutron_upgrades
14:00:29 <openstack> Meeting started Thu Jul  6 14:00:23 2017 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:34 <openstack> The meeting name has been set to 'neutron_upgrades'
14:01:16 <ihrachys> o/ lujinluo
14:01:27 <lujinluo> o/ ihrachys
14:01:57 <ihrachys> waiting for Manjeet
14:02:08 <lujinluo> sure
14:02:12 <ihrachys> he was going to join :)
14:03:40 <ihrachys> hmmm
14:03:58 <ihrachys> ok le'ts wait till :05:00 and then run it anyway.
14:04:05 <lujinluo> ok
14:05:29 <ihrachys> no luck it seems... ok, let's do one real quick
14:05:36 <ihrachys> #topic Actions from prev meeting
14:05:50 <ihrachys> manjeets_, o/
14:05:54 <manjeets_> Hi
14:05:55 <ihrachys> we just started
14:05:56 <lujinluo> manjeets_, o/
14:06:04 <ihrachys> we are going thru action items
14:06:07 <ihrachys> first is manjeetsb to clarify if Shashank is going to complete port binding level OVO patch
14:06:15 <ihrachys> that's re https://review.openstack.org/#/c/382037
14:06:38 <manjeets_> last time we talked he said he'll able to spend some time
14:06:45 <manjeets_> on it
14:06:53 <ihrachys> it's not in shape for a month, we should probably take it over
14:07:23 <manjeets_> ok
14:07:38 <manjeets_> last he did update on june5th
14:07:57 <ihrachys> I think I reviewed it in the past. I will take over, it shouldn't be far from completion.
14:08:09 <ihrachys> #action ihrachys to take over port binding level OVO
14:08:18 <ihrachys> next was manjeetsb to have a look at LIKE support patch and respin
14:08:44 <manjeets_> I did that, found a issue with current patch
14:08:44 <ihrachys> that's re https://review.openstack.org/#/c/419152/
14:10:04 <ihrachys> ok. I see some tiny comments from mlavalle there
14:10:31 <ihrachys> I assume you will respin
14:10:33 <manjeets_> yes I'll address those
14:10:42 <ihrachys> next was ihrachys to respin endpoints OVO patch: https://review.openstack.org/#/c/367810
14:10:46 <ihrachys> I did, and the patch is merged
14:10:54 <ihrachys> next was manjeets to respin network dhcp agent binding patch: https://review.openstack.org/#/c/370452
14:11:28 <ihrachys> there is a comment from Kevin about adding lazy load
14:11:33 <ihrachys> sounds legit
14:11:46 <manjeets_> i'll look into it
14:12:24 <ihrachys> ok those were all AIs we had
14:12:29 <ihrachys> #topic OVO patches
14:12:40 <ihrachys> https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
14:13:31 <ihrachys> first is port binding OVO: https://review.openstack.org/#/c/407868/55
14:13:49 <ihrachys> eh, the latest is this: https://review.openstack.org/#/c/407868/
14:14:33 <lujinluo> i fixed some dvr related failures, but still have some unfixed. will continue this week
14:14:51 <ihrachys> there is also some question from Rodolfo ther
14:14:56 <ihrachys> but I am not sure I get it
14:15:11 <lujinluo> yeah, i forgot to address some of her/his comments
14:15:24 <lujinluo> i will reply after i fix the rest of the dvr failures first
14:15:30 <ihrachys> ok
14:16:03 <ihrachys> next is router OVO: https://review.openstack.org/#/c/307964/
14:16:06 <ihrachys> Kevin asked to split
14:16:23 <lujinluo> yes, im splitting them into 3
14:16:28 <ihrachys> ++
14:16:36 <lujinluo> router, routerport and floatingip respectively
14:17:57 <lujinluo> should be able to push them before next weekly meeting
14:18:01 <ihrachys> there is also related patch for relationship loading at https://review.openstack.org/#/c/466237/
14:18:18 <ihrachys> I admit I don't fully grasp why we need all those refreshes :)
14:19:30 <ihrachys> is it so that router reflects the latest state when pushed into notifications?
14:20:22 <lujinluo> yes. otherwise router.router_port is not updated after modifications
14:20:46 <lujinluo> *router.attached_ports
14:21:33 <ihrachys> ok
14:21:40 <ihrachys> there is also a question from Kevin at https://review.openstack.org/#/c/466237/8/neutron/plugins/ml2/plugin.py
14:22:29 <ihrachys> would it make more sence to refresh port in a place where a new ip is added and not in binding code?
14:24:07 <lujinluo> i will look into that
14:25:24 <ihrachys> ok next in line is https://review.openstack.org/#/c/396718/ (ipallocation integration)
14:25:30 <ihrachys> and it has +2 from Kevin already
14:25:35 <ihrachys> time for me to chime in I guess
14:25:44 <ihrachys> #action ihrachys to review ipallocation patch: https://review.openstack.org/#/c/396718/
14:26:42 <ihrachys> next two are just qos todos tackled: https://review.openstack.org/#/c/468837/ and https://review.openstack.org/#/c/468406/
14:26:44 <ihrachys> both with +2s
14:26:52 <ihrachys> I will review them right after the meeting
14:27:06 <ihrachys> #action ihrachys to review qos binding OVO objects
14:27:56 <ihrachys> next is subnet: https://review.openstack.org/#/c/321001/
14:28:02 <ihrachys> and I see James started working on it, nice
14:28:16 <ihrachys> there are some issues it seems, but great we started making progress there
14:29:06 <ihrachys> next is dvr mac address: https://review.openstack.org/#/c/304873/
14:29:22 <ihrachys> we were trying to make it pass several times, there is some json encoding issue lingering
14:29:29 <ihrachys> I need to get back to it this week
14:29:43 <ihrachys> #action ihrachys to get back to dvr mac address OVO and fix the json failure
14:30:19 <ihrachys> next is manjeets_'s CLI for data migration: https://review.openstack.org/#/c/432494/
14:30:30 <ihrachys> I admit I haven't had a change to look at latest
14:30:42 <ihrachys> #action ihrachys to review CLI patch for data migration
14:31:06 <lujinluo> since we are on data migration patch, i want to bring this up again https://review.openstack.org/#/c/288271/
14:31:27 <lujinluo> it is related to data migration patch as we discussed last time
14:32:00 <ihrachys> oh right. It fell thru cracks.
14:33:12 <ihrachys> lujinluo, do you have in mind how it would work with data migration?
14:34:52 <lujinluo> honestly no, because I have not reviewed data migration patch closely. but in my understand data migration patch helps migrate data in the backend and this is what the patch requires
14:35:00 <ihrachys> I mean, assuming you run old code in cluster on some nodes, this old code won't fill in the indexes for us?
14:35:59 <ihrachys> oh it's autoincrement
14:36:12 <ihrachys> so for new records created by old code, those will still be filled in
14:36:29 <ihrachys> it's just for existing records that you need to  fill it in
14:37:33 <lujinluo> yes
14:37:38 <ihrachys> ofc there is no guarantee that no old node will create a binding while you number existing records
14:38:06 <ihrachys> but it should get a number then; though the picked number may be in conflict with what's in your migration code
14:38:18 <ihrachys> in which case, I believe, you will receive an error?
14:38:26 <lujinluo> yes, an exception
14:40:16 <ihrachys> ok I need to think about out of this venue. but I guess we should be able to deal with it, maybe even moving the numbering to expand phase.
14:40:48 <lujinluo> that would be better if we do not need to depend on data migratin patch
14:40:52 <ihrachys> autoincrement may give us the needed backwards compatibility for schema
14:41:35 <ihrachys> #action ihrachys to have a close look at how to implement binding_index for dhcp agent bindings without contract: https://review.openstack.org/#/c/288271
14:41:53 <lujinluo> thanks
14:41:56 <ihrachys> I am sorry I can't give immediate reply
14:42:07 <lujinluo> not a problem ;)
14:42:41 <ihrachys> ok. I look at other patches in the queue, and they are all in merge conflict. perhaps we have enough work to do already and we can revisit those next week.
14:43:23 <ihrachys> and it seems most of them are router/fip related anyway, and they will depend on the split lujinluo is going to do for the patch introducing the objects
14:43:51 <lujinluo> ack, will work harder next week, XD
14:43:59 <ihrachys> :)
14:44:02 <ihrachys> thanks!
14:44:42 <ihrachys> #topic Open discussion
14:44:58 <ihrachys> anything to discuss?
14:45:04 <lujinluo> none from me
14:45:08 <ihrachys> the new time is ok for you folks?
14:45:19 <lujinluo> yes! thanks for doing this!!
14:45:25 <ihrachys> ok cool.
14:45:26 <lujinluo> how about manjeets_ ?
14:45:28 <manjeets_> it is okay I will get habit of getting 1 hour early
14:45:36 <ihrachys> thanks manjeets_ for sacrifice ;)
14:45:41 <lujinluo> manjeets_, thank you!
14:45:55 <manjeets_> ihrachys, I wanted to do that but now I have some reason to do it so its good for me
14:46:10 <ihrachys> ok, if nothing else, let's close the meeting and make sure we land stuff ;)
14:46:17 <manjeets_> thanks !!
14:46:18 <ihrachys> #endmeeting