14:00:21 <ihrachys> #startmeeting neutron_upgrades
14:00:22 <openstack> Meeting started Thu Jul 13 14:00:21 2017 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:24 <ihrachys> hey all
14:00:26 <openstack> The meeting name has been set to 'neutron_upgrades'
14:00:26 <manjeets_> hi
14:00:40 <ihrachys> lujinluo, o/
14:00:52 <lujinluo> hi!
14:01:39 <ihrachys> first, let's review action items from prev week
14:01:48 <ihrachys> #topic Actions from prev meeting
14:01:56 <ihrachys> first was "ihrachys to take over port binding level OVO"
14:02:13 <ihrachys> I haven't made progress on that one, hopefully will have time for this till next meeting :-x
14:02:17 <ihrachys> #action ihrachys to take over port binding level OVO
14:02:27 <ihrachys> next was "ihrachys to review ipallocation patch: https://review.openstack.org/#/c/396718/"
14:02:33 <ihrachys> it's reviewed and merged now
14:02:39 <ihrachys> next was "ihrachys to review qos binding OVO objects"
14:02:43 <ihrachys> those are also reviewed and merged
14:02:50 <ihrachys> next was "ihrachys to get back to dvr mac address OVO and fix the json failure"
14:02:58 <ihrachys> it's about this patch: https://review.openstack.org/#/c/304873
14:03:15 <ihrachys> I respinned it, seems like latest version doesn't show json serialization errors as before
14:03:33 <lujinluo> it seems to be some gate issues
14:03:35 <ihrachys> the gate is not very stable lately, so Jenkins -1d
14:03:42 <ihrachys> yeah, cinder breaks the world
14:03:53 <ihrachys> they have some issues with eventlet and whatnot
14:04:02 <lujinluo> ah, i see
14:04:10 <ihrachys> they'll get through it, they are aware at this point
14:04:20 <ihrachys> next item was "ihrachys to review CLI patch for data migration"
14:04:26 <ihrachys> and it didn't happen either :-x
14:04:31 <ihrachys> #action ihrachys to review CLI patch for data migration
14:04:34 <ihrachys> manjeets_, sorry man
14:04:44 <manjeets_> np
14:05:00 <ihrachys> next - and last - was "ihrachys to have a close look at how to implement binding_index for dhcp agent bindings without contract: https://review.openstack.org/#/c/288271"
14:05:09 <ihrachys> I took a look and left some comments.
14:05:21 <ihrachys> lujinluo, you probably need to review them to keep me honest
14:05:39 <lujinluo> I have not had time to take close look at them but will do tmr
14:06:00 <ihrachys> the rolling upgrade scenario is tricky in this case, but I think we can accommodate to it assuming that we don't expect the bug to fully be fixed before all neutron-servers are upgraded
14:06:06 <ihrachys> lujinluo, cool
14:06:46 <lujinluo> ihrachys, i see. i think we can compromise to that
14:06:54 <ihrachys> now let's first touch on gate related bugs we induced.
14:06:58 <ihrachys> #topic Gate breakages
14:07:33 <ihrachys> first, i noticed late router_extra_attrs OVO switch triggered a traceback in l2pop driver. I have a patch here: https://review.openstack.org/483085
14:07:40 <ihrachys> and it has W+1 already, good
14:07:45 <ihrachys> just need to recheck :)
14:07:58 <ihrachys> there is also this bug I spotted in gate: https://bugs.launchpad.net/neutron/+bug/1704000
14:07:59 <openstack> Launchpad bug 1704000 in neutron "Sometimes OVO unit tests clash on non-unique attributes" [High,Confirmed]
14:08:27 <ihrachys> this is an issue with how update_fields that sets specific values for some fields interact with generator of fields in base class
14:08:35 <ihrachys> or better, they don't interact at all
14:08:40 <ihrachys> so generator is not aware of the change
14:10:17 <ihrachys> I may have a look at it later next week, but if someone is up to the task, it's yours
14:11:33 <ihrachys> ok let's move on
14:11:45 <ihrachys> #action ihrachys to take a look at https://bugs.launchpad.net/neutron/+bug/1704000
14:11:47 <openstack> Launchpad bug 1704000 in neutron "Sometimes OVO unit tests clash on non-unique attributes" [High,Confirmed]
14:11:52 <ihrachys> #topic OVO patches
14:12:02 <ihrachys> https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
14:12:23 <ihrachys> first in the top of the queue is https://review.openstack.org/482722
14:12:40 <ihrachys> this is a cleanup that Trevor started that is needed for his QinQ network type driver
14:13:11 <ihrachys> oh actually that's a tad different
14:13:29 <ihrachys> I was thinking about this one: https://review.openstack.org/#/c/483020/
14:13:40 <manjeets_> type_vlan cleanup ?
14:13:55 <manjeets_> ohk got it
14:14:00 <ihrachys> anyway, the type_vlan cleanup patch is a clear review oversight
14:14:43 <ihrachys> I asked if we can get a test for that since it seems like we don't really test vlan unused allocation removal
14:14:47 <ihrachys> otherwise we would spot
14:16:04 <ihrachys> next in line is https://review.openstack.org/#/c/424154/ for router port and I see lujinluo plans to respin that
14:16:24 <ihrachys> next is floatingip OVO: https://review.openstack.org/#/c/481972/
14:16:56 <ihrachys> lujinluo, I see your comment there
14:17:18 <ihrachys> lujinluo, doesn't self.update_obj_fields solve your issue?
14:17:34 <ihrachys> it will allow you to create those resources you need to point to for your model
14:18:15 <lujinluo> ah, sorry. I am a bit lost here. where shall i put self.update_obj_fields?
14:18:27 <ihrachys> lujinluo, it would go in your test class
14:18:32 <ihrachys> sec, I will give an example
14:18:53 <ihrachys> like http://git.openstack.org/cgit/openstack/neutron/tree/neutron/tests/unit/objects/test_router.py#n66
14:19:24 <lujinluo> oh, i see! check try that tmr
14:19:37 <lujinluo> *will try that tmr
14:19:55 <lujinluo> (no idea why i mis-spelled will to check..
14:20:23 <ihrachys> ok let's take the next one in line: https://review.openstack.org/#/c/466237/
14:20:32 <ihrachys> it's routerport-router relationship
14:20:55 <ihrachys> the code seemed fine to me but there is a test failure that is probably related
14:21:39 <lujinluo> yeah, need to find out a good place to refresh updated obj
14:22:08 <ihrachys> ok sounds like fun
14:22:54 <ihrachys> next is network-dhcp-agent-binding: https://review.openstack.org/#/c/370452/
14:23:19 <ihrachys> manjeets_, there were some comments there that may need to be addressed
14:23:45 <manjeets_> I worked on that yesterday but unit test broke locally, I am working on fixing tests
14:24:33 <ihrachys> cool
14:24:38 <ihrachys> next in line is port binding: https://review.openstack.org/#/c/407868/
14:24:52 <ihrachys> lujinluo, was respinning it lately. there seems to be some concern from Rodolfo there
14:25:21 <lujinluo> I did not spend time on it this week. maybe next week
14:25:24 <ihrachys> smth about splitting concerns for changes
14:25:37 <ihrachys> ok
14:26:30 <ihrachys> other patches it seems were either already discussed in some way, or are in bad shape and we will close the gaps we already identified
14:27:44 <ihrachys> #topic Other patches
14:27:51 <ihrachys> anything I missed that we could have a look?
14:28:30 <lujinluo> hmm, i did not see any
14:28:45 <ihrachys> ok
14:28:48 <ihrachys> then...
14:28:50 <manjeets_> i guess you covered the most
14:29:00 <ihrachys> I guess we can close the meeting early?
14:29:11 <lujinluo> sounds good ;)
14:29:15 <manjeets_> sounds good ti me
14:29:19 <manjeets_> to**
14:29:23 <ihrachys> ok great. let's push the stone further :)
14:29:25 <ihrachys> #endmeeting