14:00:26 <ihrachys> #startmeeting neutron_upgrades
14:00:27 <openstack> Meeting started Thu Nov  2 14:00:26 2017 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:30 <ihrachys> o/
14:00:31 <openstack> The meeting name has been set to 'neutron_upgrades'
14:00:38 <annp_> hi ihar
14:00:53 <annp_> hi ihrachys
14:00:53 <lujinluo> o/
14:00:57 <ihrachys> good evening folks from my good morning
14:01:09 <lujinluo> lol
14:01:14 <TuanVu> hi everybody
14:01:30 <ihrachys> for the record, we discussed moving the meeting to -1h but then figured there are schedule conflicts for some of us, so we leave the slot as-is
14:01:47 <TuanVu> thank you very much, Ihar
14:01:51 <lujinluo> ok
14:01:57 <ihrachys> though I believe some suggested that some other day could work
14:02:26 <TuanVu> yes, it could be a good idea
14:02:40 <ihrachys> do you want me to pursue that? I can check calendars if everyone is on boards and see what we can do.
14:03:19 <lujinluo> Hmm, personally I do not think it is necessary for me to move -1h. 11PM is totally fine by me
14:03:49 <TuanVu> I'm fine with current schedule, but maybe we could move -1h earlier for Luo
14:03:56 <TuanVu> oh, thank you, Luo
14:04:00 <TuanVu> it's very kind of you
14:04:03 <ihrachys> seems like lujinluo doesn't really need it :)
14:04:07 <ihrachys> ok we will leave as is
14:04:12 <TuanVu> ok
14:04:13 <lujinluo> yeah. I can deal with it
14:04:20 <ihrachys> but feel free to raise the topic again if something changes
14:04:28 <lujinluo> sure
14:04:33 <ihrachys> I don't want you to suffer from late meetings more than needed
14:04:35 <ihrachys> #topic OVO
14:04:40 <ihrachys> https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
14:05:23 <ihrachys> https://review.openstack.org/#/c/516961/ "Router to OVO"
14:05:31 <ihrachys> that's some new patch
14:06:03 <ihrachys> was it spinned off https://review.openstack.org/#/c/307964/ ?
14:06:17 <lujinluo> Yes, I think so.
14:07:11 <ihrachys> I see some code in https://review.openstack.org/#/c/307964/60/neutron/objects/router.py that is not present though
14:07:37 <ihrachys> f.e. the Router object in the new patch lacks extra_attributes field
14:07:54 <ihrachys> so it's probably a derivative but not exact copy
14:08:15 <lujinluo> Oh, yeah. Do we have Hung here today?
14:08:20 <ihrachys> I don't see him
14:08:43 <lujinluo> me neither. TuanVu and annp_ can you two pass the info to him tmr?
14:08:59 <TuanVu> sure
14:09:16 <TuanVu> I'll inform him about this
14:09:20 <ihrachys> I asked in gerrit what's the relation of those 2 patches
14:09:23 <ihrachys> thanks TuanVu
14:10:03 <ihrachys> next is https://review.openstack.org/#/c/495810/
14:10:07 <TuanVu> it's my pleasure :)
14:10:08 <ihrachys> "Use Agent OVO in agents_db and test_agents_db"
14:10:22 <ihrachys> it seems like it needs a respin for a git conflict
14:11:06 <ihrachys> there are several small comments there but nothing huge
14:11:06 <TuanVu> yes, I'll rebase the patch
14:11:18 <TuanVu> and also update it as suggestion from Slawek
14:11:26 <ihrachys> ok, and same goes for https://review.openstack.org/#/c/501925/12 "Use Agent OVO in l3_agentschedulers_db"
14:12:07 <TuanVu> yes, regarding to that one
14:12:10 <ihrachys> those also seem to depend on https://review.openstack.org/#/c/516511/ "Reorder checks in apply_filters in db/_model_query"
14:12:17 <TuanVu> we're waiting for the patch from Luo to be merged
14:12:39 <lujinluo> I am rechecking the patch now.
14:12:41 <ihrachys> right. that patch has +W, but failed in gate
14:13:02 <ihrachys> by the look of it, the error (u'Invalid instance image.') is not neutron specifc
14:13:12 <ihrachys> http://logs.openstack.org/11/516511/3/gate/legacy-tempest-dsvm-neutron-linuxbridge/150563f/logs/testr_results.html.gz
14:13:15 <lujinluo> zuul does not seem to be friendly recently
14:13:27 <ihrachys> don't get me started lol... :)
14:13:44 <lujinluo> lol. tons of complaints? haha
14:15:02 <ihrachys> TuanVu, when you say we are waiting, can't we make the patches based/depend on the other patch?
14:16:07 <TuanVu> sure
14:16:14 <TuanVu> I'll do it
14:16:44 <ihrachys> ok cool
14:16:50 <ihrachys> next is https://review.openstack.org/#/c/321001/ "objects: get, update and delete converted to Subnet OVO usage"
14:16:54 <ihrachys> and I already +2d it
14:16:59 <ihrachys> we are waiting for the second vote
14:17:12 <ihrachys> I believe mlavalle was going to have a look in next days
14:17:46 <TuanVu> cool
14:18:10 <lujinluo> cool.
14:18:25 <ihrachys> next is https://review.openstack.org/#/c/396351/ "Integration of Floating IP OVO"
14:18:30 <ihrachys> also has +2
14:18:47 <ihrachys> there is -1 from ZhaoBo but I believe it's not valid
14:20:06 <lujinluo> thanks for answering those 2 comments Ihar. I have not had time to check them
14:20:06 <ihrachys> I added Miguel to reviewers there too
14:20:31 <ihrachys> next is https://review.openstack.org/#/c/407868/ "Integration of (Distributed) Port Binding OVO"
14:21:08 <lujinluo> so I modified my devstack env, and was able to do some debugging (though no big progresses yet
14:22:09 <ihrachys> so you can reproduce it now?
14:22:33 <lujinluo> yes
14:22:49 <lujinluo> i am seeing many tempest failures now :(
14:23:22 <ihrachys> that's good in a twisted way
14:23:30 <ihrachys> now you can debug it
14:23:34 <lujinluo> yeah...
14:24:54 <ihrachys> next is https://review.openstack.org/507772 "Use Network OVO in db_base_plugin"
14:24:56 <ihrachys> it's WIP
14:25:07 <TuanVu> yes
14:25:22 <TuanVu> I'm still working on it
14:25:32 <ihrachys> I assume you will cover for Network?
14:25:38 <ihrachys> not just for this file?
14:25:51 <TuanVu> yes, not just for this file
14:26:10 <TuanVu> you're correct, Ihar
14:26:55 <ihrachys> ok, there are lots of other patches that are not in shape
14:27:05 <ihrachys> I want to look at https://review.openstack.org/307964 "Router, RouterPort and FloatingIP to OVO"
14:27:23 <ihrachys> I believe now that we have Router patch and FIP patch, and RouterPort already merged, we can abandon it?
14:27:39 <lujinluo> yes! let's abandon it
14:28:02 <ihrachys> ok done
14:28:35 <hungpv> Hi Ihar, for patchset https://review.openstack.org/#/c/516961/ for router ovo, pleas e help me for review
14:28:54 <ihrachys> hungpv, hey! yeah I will
14:29:16 <ihrachys> hungpv, we were wondering, what's the relation of this patch to the other patch we had: https://review.openstack.org/307964
14:31:46 <ihrachys> hungpv, ?
14:31:52 <hungpv> Hi, my patch is a break-down patch for Router OVO only. We have looked it for some reference
14:32:12 <ihrachys> oh ok, so it's not exact copy then
14:32:23 <ihrachys> I mean, for Router pieces of course
14:32:25 <hungpv> But built new patch from our own knowledge
14:32:33 <hungpv> Yes,
14:32:58 <ihrachys> makes sense. I will have a look.
14:33:18 <hungpv> Thank you very much
14:33:25 <ihrachys> the list of objects being worked seems to have shrinked lately
14:33:38 <ihrachys> I will do a revision of objects still needed till next meeting
14:33:48 <ihrachys> #action ihrachys to review objects still missing from the radar
14:34:15 <lujinluo> cool. thanks!
14:34:17 <ihrachys> #topic Open discussion
14:34:31 <ihrachys> more topics?
14:34:57 <lujinluo> ihrachys: are you traveling to Sydney?
14:35:10 <ihrachys> no I don't. too much of a hassle for me.
14:35:15 <ihrachys> do you?
14:35:27 <lujinluo> i do..
14:35:35 <lujinluo> seems you are only off for PTG now?
14:36:04 <ihrachys> well, it's not strict. it's just that going to Australia would trigger lots of bureaucracy for me both for US and AUS visa
14:36:23 <ihrachys> though I tend to skip summits since they split
14:36:42 <lujinluo> yeah, i recalled that you did not go to Boston either
14:36:43 <ihrachys> afaik we will have like 2-3 people from our redhat networking team there
14:36:52 <ihrachys> which is an all time low I believe
14:37:11 <ihrachys> the location and 4 events per year are tough asks
14:37:34 <lujinluo> yeah, I did not see many names in the etherpad that Miguel put either
14:37:46 <lujinluo> seems we won't have a lot of people this time
14:38:17 <ihrachys> have fun there. maybe take a safari or smth, they have weird animals there. :)
14:38:45 <lujinluo> well, anyway, I was hoping we can meet in person this time. hopefully some time in the near future then
14:39:00 <ihrachys> yeah. that's unfortunate we won't.
14:39:49 <ihrachys> I guess we can call it a day. we will still have a quick meeting next week to check status of patches and any questions.
14:40:17 <ihrachys> unless everyone feels like skipping
14:40:21 <ihrachys> tell me if you do
14:40:24 <ihrachys> #endmeeting