14:02:04 <ihrachys> #startmeeting neutron_upgrades
14:02:05 <openstack> Meeting started Thu Mar 15 14:02:04 2018 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:08 <openstack> The meeting name has been set to 'neutron_upgrades'
14:02:11 <ihrachys> heya!!
14:02:15 <lujinluo> o/
14:02:19 <ihrachys> no action items from the previous time woooot
14:02:23 <ihrachys> I am so excited!
14:02:29 <lujinluo> LOL
14:02:31 <ihrachys> not really but hey!
14:02:40 <ihrachys> :) sorry, I am in good mood this morning
14:02:53 <ihrachys> #topic OVO
14:02:53 <ihrachys> https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
14:03:44 <ihrachys> is there anything in this list that would benefit from discussion?
14:03:54 <lujinluo> i have one update
14:04:00 <ihrachys> lujinluo, shoot
14:04:03 <lujinluo> regarding the bug we discussed last week
14:04:04 <lujinluo> https://review.openstack.org/#/c/551192/
14:04:20 <lujinluo> i pushed a fix and it got merged before you got time to take a look
14:04:50 <ihrachys> that's great, I am ok sitting on sidelines :)
14:05:11 <lujinluo> but i still think it worth for you to take a look
14:05:22 <ihrachys> as for me, I was a slacker and didn't make it to look into facade autodetection
14:06:07 <lujinluo> hopefully you can find more time this week!
14:06:08 <ihrachys> lujinluo, brief look suggested the approach is right though I would add a test class with new_engine = True to validate it works as intended
14:06:22 <ihrachys> because afaiu currently no test code would catch the issue
14:06:55 <lujinluo> yeah, so to do so, i need to add another fake obj and inheritate Iface() to test it?
14:07:15 <lujinluo> another fake obj with new_face=True
14:07:27 <ihrachys> yeah I believe so
14:07:49 <lujinluo> ok, i will push a follow-up later
14:07:59 <ihrachys> thanks
14:08:17 <ihrachys> #action lujinluo to push follow up for new_facade = True unit test fix
14:08:47 <ihrachys> apart from this update, is there anything in the list of patches that we could make progress on?
14:09:06 <lujinluo> i respinned the portbinding patch
14:09:18 <ihrachys> that's https://review.openstack.org/#/c/544206/
14:09:29 <lujinluo> but i could not find the previous logs which indicated failures of postgresql
14:09:47 <lujinluo> they are gone..
14:10:06 <ihrachys> I don't think the -pg- job is triggered in check queue. we can try 'check experimental'
14:10:24 <lujinluo> thanks!! this is what i am going to ask
14:10:38 <lujinluo> i have no idea where to find those logs
14:10:39 <ihrachys> yeah I posted it
14:10:44 <ihrachys> and it started "legacy-tempest-dsvm-neutron-pg-fullqueued (non-voting)"
14:11:02 <ihrachys> once it's done, zuul will post results to gerrit
14:11:09 <lujinluo> thanks
14:11:32 <lujinluo> other than that, i do not have any more updates from the list of patches
14:11:43 <ihrachys> lujinluo, afaiu all new patches for OVOs are now blocked on my facade type autodetection, right?
14:12:09 <lujinluo> mine about port ovo is. not sure about router and network..
14:12:41 <lujinluo> Tuan and Hung are not here today..
14:12:53 <lujinluo> oh, just arrived? hungpv
14:13:07 <ihrachys> well they all are potentially affected by that. better to have this piece in before merging more patches that potentially mix things up
14:13:23 <lujinluo> makes sense
14:14:14 <hungpv> Hi, sorry I'm having some problems at my end
14:14:44 <hungpv> The network seems unstable
14:14:59 <lujinluo> hungpv: so do you have any updates of your patches? are they ready for review?
14:15:03 <ihrachys> hungpv, do you have anything specific to discuss? I was mulling having a short meeting.
14:15:16 <ihrachys> patches to help with / review?
14:15:45 <hungpv> Actually I'm here to see if there anything updated
14:16:12 <hungpv> At my end there's no new patches to review
14:16:39 <ihrachys> gotcha. ok I think we could have an extremely short meeting then.
14:16:48 <lujinluo> haha, yeah
14:16:49 <ihrachys> 44 minutes back, I am so generous today!!!
14:17:07 <lujinluo> yes!! i can sleep really early today, lol
14:17:09 <ihrachys> ok buds see you in a week then.
14:17:17 <lujinluo> see you next week!
14:17:18 <ihrachys> lujinluo, enjoy, you deserved it! :)
14:17:21 <ihrachys> #endmeeting