14:00:11 <lujinluo> #startmeeting neutron_upgrades
14:00:13 <openstack> Meeting started Thu Apr 26 14:00:11 2018 UTC and is due to finish in 60 minutes.  The chair is lujinluo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <openstack> The meeting name has been set to 'neutron_upgrades'
14:00:20 <mlavalle> o/
14:00:22 <lujinluo> o/
14:00:35 <ihar_> o/
14:00:40 <lujinluo> o/ ihar_
14:00:46 <ihar_> I am lurking in two meetings, may be slightly slow
14:01:00 <lujinluo> not a problem at all!
14:01:15 <mlavalle> lurking in two meetings besides attending this one?
14:01:23 <ihar> haha not THAT bad
14:01:35 <mlavalle> :-)
14:01:50 <lujinluo> Let's get started by reviewing action items from last meeting: mlavalle and I to add comments in https://review.openstack.org/#/c/556667/
14:02:14 <lujinluo> We did add comments and merged the patch. however, it got reverted when I woke up in the morning..
14:02:43 <lujinluo> the revert of revert is under review here https://review.openstack.org/#/c/563736/
14:03:30 <lujinluo> ihar: i think we are still monitoring how drivers are handling it, right?
14:04:35 <lujinluo> vmware: https://review.openstack.org/#/c/563923/ networking-odl: https://review.openstack.org/#/c/563786/ heat: https://review.openstack.org/564043
14:04:52 <ihar> yeah I think vmware was the blocker
14:05:01 <ihar> I didn't have a chance to check the latest state for them
14:05:16 <ihar> odl / lbaas / heat were all affected by the same issue in lbaas repo that is fixed
14:05:24 <lujinluo> it seems no updates from the past 24 hrs
14:05:25 <ihar> vmware probably has some more work to do
14:05:42 <ihar> I will check vmware state after the meeting(s) since I have time for openstack today
14:05:57 <lujinluo> \o/ couldn't ask for more
14:06:02 <lujinluo> thanks!
14:06:02 <ihar> sorry I didn't monitor it yesterday closely, was pulled to other stuff
14:06:23 <lujinluo> never mind :)
14:06:27 <mlavalle> is each project affected doing its own work related to this?
14:07:24 <ihar> mlavalle: I think not but I need to check how vmware is affected
14:07:33 <mlavalle> ok
14:07:40 <ihar> other failures were due to lbaas using some very weird links between tables
14:08:30 <mlavalle> yeah, we are bound to find all sort of things... LOL
14:08:57 <ihar> I will report if vmware exposes some issue with the original patch
14:09:06 <mlavalle> especially the old lbaas that was developed under very tight schedule
14:10:03 <mlavalle> at the same time it is good that we are uncovering all this
14:10:19 <mlavalle> still early in the cycle
14:10:26 <lujinluo> yeah, that's true..
14:10:43 <ihar> yes. to answer the question directly: yes, it's possible that some plugins may need changes (same thing as we did in the original patch). but ideally not or not a lot
14:11:40 <lujinluo> #action ihar to follow up how vmware / other plugins are affected by auto expiry of fk
14:12:58 <lujinluo> let's take a look at the OVO patches then, which i do not think we made much progress last week LOL
14:13:05 <lujinluo> #topic OVO
14:13:15 <lujinluo> https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
14:13:39 <lujinluo> https://review.openstack.org/#/c/559414/ segment db to ovo
14:13:54 <mlavalle> that one is approved, isn't it?
14:13:57 <lujinluo> it is waiting for auto expiry patch
14:14:00 <lujinluo> yes
14:15:02 <lujinluo> but it depends on auto detection of new engine, which depends on auto expiry
14:15:16 <lujinluo> so it still gets holding back
14:15:47 <mlavalle> yeap
14:16:19 <lujinluo> next one is https://review.openstack.org/#/c/553617/ , the auto detection patch
14:16:38 <lujinluo> waiting for auto expiry
14:16:55 <ihar> yeah I think it was +W at some point, just waits for expiry
14:16:59 <ihar> everything waits for it
14:17:06 <lujinluo> LOL
14:17:09 <lujinluo> basically
14:17:11 <mlavalle> and Mike was happy with it
14:17:18 <mlavalle> that is always a good thing
14:17:40 <ihar> well, he probably at this point has a low bar of expectation for neutron db layer :))
14:17:53 <ihar> every time I show him something from there, he gasps
14:18:00 <lujinluo> LOL...
14:18:04 <ihar> apparently it didn't happen this time!
14:18:23 <lujinluo> lucky us!
14:19:05 <lujinluo> https://review.openstack.org/#/c/544206/ next is port binding
14:19:42 <lujinluo> i rebase this one on mlavalle's patch (https://review.openstack.org/#/c/414251/) locally
14:19:56 <lujinluo> still testing UTs
14:20:40 <mlavalle> I need to address some comments that I thought were minor from ihar and slaweq. After that, I think it is good to merge, in my opinion
14:20:41 <lujinluo> then auto expiry got reverted and I was too sad to continue, LOL
14:21:21 <lujinluo> good. then maybe i should wait for it to get merged. since mine waits for auto expiry too
14:21:28 <mlavalle> In my testing, I am moving ports from one backend to another (OVS to LB) and back
14:21:48 <mlavalle> and it works great. After merging that patch I'll implement fullstack tests
14:22:02 <ihar> mlavalle: my main concern was api test coverage
14:22:08 <lujinluo> understood. i will watch it closely
14:22:25 <ihar> I guess fullstack could also do since it uses a client
14:22:40 <mlavalle> ihar: noted, I will also create a follow up with Tempest API tests
14:24:03 <mlavalle> I will probably do it in the reverse order then, api tests first and then fullstack
14:24:33 <ihar> api should be easier
14:24:40 <mlavalle> yeap
14:26:02 <lujinluo> ok, then next one https://review.openstack.org/#/c/549168/
14:26:20 <lujinluo> still pretty red
14:26:57 <lujinluo> and the following patches are not updated from last week
14:27:34 <lujinluo> #topic open discussion
14:28:18 <lujinluo> I have one thing. The whole next week would be public holidays here in Japan, so I won't be able to chair next meeting.
14:28:36 <lujinluo> shall we cancel it?
14:28:52 <mlavalle> I'd say so
14:29:16 <lujinluo> ok, i will send an email to the mailing list then
14:29:38 <mlavalle> I also have something to say
14:29:55 <lujinluo> please
14:30:32 <mlavalle> ihar was promoted to Principal Sofware Engineer by his employer. More than well deserved. Let's congratulate him
14:30:37 <mlavalle> clap clap clap
14:30:44 <lujinluo> clap clap clap!!
14:30:58 <lujinluo> wow!! principal software engineer!!
14:31:21 <ihar> eh, thanks. :) I also have a general PSA: as you've probably noticed, I started to delude my attention to neutron and cannot monitor my and others' patches as closely as before. if a patch on me blocks you feel free to take it over / reshape / fix if you think it will move things forward.
14:31:24 <lujinluo> Yeah, I think LinkedIn sent me an email asking me to say congratulations to ihar too, :))
14:31:54 <ihar> lujinluo: that pesky linkedin. I *love* those template congratulations in its inbox. :p
14:32:30 <lujinluo> noted. i will watch our patches more and more closely 0_0
14:33:03 <mlavalle> lujinluo: I am so jealous that you will have a week long Holiday. In this country, we never have that
14:33:20 <ihar> mlavalle: christmas perhaps?
14:33:28 <mlavalle> hardly
14:33:32 <ihar> we have a shutdown here in redhat for a week+
14:33:34 <lujinluo> Haha, this is called golden week here in Japan
14:33:37 <ihar> Dec 24 till Jan 2
14:33:45 <mlavalle> yeah, but that's a company thing
14:33:51 <ihar> and it doesn't even count for PTOs, so you don't waste your vacation slots
14:34:08 <ihar> oh yeah sure, that's not available for most people
14:34:08 <lujinluo> and we will have another one week off in July or Aug
14:34:11 * mlavalle is also jealous of ihar now
14:34:36 <lujinluo> and we have one week off for new year too
14:34:36 <ihar> haha, redhat is good at work / life you know :)
14:34:45 <lujinluo> i should probably stop now, haha
14:34:56 <ihar> I think we can agree mlavalle to be jealous of lujinluo though
14:35:07 <mlavalle> yeap
14:35:45 <ihar> lujinluo: which of new years? ;)
14:35:59 <lujinluo> ihar: haha, good question.
14:35:59 <ihar> narrator: "ALL OF THEM!"
14:36:17 <lujinluo> but the new new year though
14:36:26 <hungpv_> In Vietnam we have a week off for Lunar new year
14:36:36 <hungpv_> That's all we got
14:36:37 <mlavalle> yeah, Tet
14:36:45 <hungpv_> Yeah Tet
14:36:58 <hungpv_> You know about it?
14:37:03 <mlavalle> of course
14:37:16 <ihar> "of course" !!!
14:37:42 <lujinluo> wow, i did not know. just googled
14:37:44 <hungpv_> Oh, I always thought you guys only know Chinese one
14:37:54 <mlavalle> well, I'm of a certain age. I grew up in the 60's and have memories of the Tet offensive
14:38:37 <hungpv_> Wow, yeah Tet offensive was pretty infamous
14:38:49 <mlavalle> it was a momentous event in 1968
14:39:11 * ihar opens wikipedia
14:39:51 <lujinluo> i just did the same
14:40:09 <mlavalle> and also there are Vietnamese communities in all the towns I've lived in Texas (Houston, San Antonio and Austin)
14:40:35 <mlavalle> I always go to my favorite Vetnamese restaurant during Tet, to eat some Pho
14:40:51 <ihar> great. now I am hungry.
14:40:57 <lujinluo> Yeap, everybody loves Pho
14:41:02 <hungpv_> Yes, and I think Tet in USA maybe even more traditional than in VN
14:42:06 <ihar> more traditional? how is it even possible
14:42:33 <lujinluo> well, i think ihar and i just had a history lesson
14:42:58 <hungpv_> Because Viet people oversea trying to keep thing as before, they're conservative
14:43:03 <lujinluo> i think hungpv_ is suggesting that normally migrants keep traditions better
14:43:10 <mlavalle> yeap
14:43:23 <ihar> gotcha
14:43:49 <hungpv_> While Viets in motherland got influence from foreign country like US, Japan, Korea...
14:44:05 <ihar> "today I learned"
14:44:24 <hungpv_> There's even an argument about celebrate New Year like Japanese
14:44:40 <hungpv_> In January 1st, not Lunar Year
14:44:42 <lujinluo> recently?
14:45:16 <hungpv_> Yes, it's started few years ago
14:45:49 <lujinluo> i see.
14:45:52 <hungpv_> I think we're trying to copy Japan and think maybe we'll be better lol
14:46:51 <lujinluo> well, i think this is much beyond our open discussion coverage :))
14:46:58 <mlavalle> LOL
14:47:05 <mlavalle> it was nice, though
14:47:15 <lujinluo> does anyone have anything else they want to share?
14:47:33 <lujinluo> yeah, historial lesson learnt!
14:47:34 <ihar> no only that you are all amazing
14:47:57 <lujinluo> thanks ihar !
14:48:26 <lujinluo> then let's call it a day! thank you everyone for joining. we will see you in two weeks
14:48:39 <lujinluo> #endmeeting