14:00:05 <njohnston> #startmeeting neutron_upgrades
14:00:06 <openstack> Meeting started Thu Jun 14 14:00:05 2018 UTC and is due to finish in 60 minutes.  The chair is njohnston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'neutron_upgrades'
14:00:27 <TuanVu> Hi njohnston
14:00:37 <njohnston> Hello all.  I am taking over the chairing duties from lujinluo since he is on vacation this week and next.
14:00:48 <njohnston> Hi TuanVu
14:00:51 <TuanVu> *she
14:01:03 <njohnston> Ah, my apologies!  We have never met.
14:01:19 <TuanVu> thanks for being chair of this meeting, njohnston
14:01:23 <TuanVu> no problem :)
14:01:39 <njohnston> So I don't think there were any action items from last time
14:01:47 <njohnston> #info No action items from last time.
14:02:01 <TuanVu> yes
14:02:22 <njohnston> So let's get in to the OVO updates - there are a number
14:02:27 <njohnston> #topic OVO
14:02:34 <njohnston> #link https://review.openstack.org/#/q/topic:bp/adopt-oslo-versioned-objects-for-db+(status:open+) List of outstanding changes
14:02:46 <njohnston> First up is
14:02:48 <njohnston> #link https://review.openstack.org/#/c/549168/ Use Router OVO in l3_db.py - Van Hung Pham
14:02:55 <njohnston> This one looks like it is being actively worked on.
14:04:19 <njohnston> I am not sure the author's IRC handle, but I don't really have anything to add at this point.
14:05:09 <njohnston> OK moving on
14:05:20 <njohnston> #link https://review.openstack.org/#/c/570244/ Use OVO in ml2/test_db - Nate Johnston
14:05:38 <njohnston> This change looks ready to go, and is only blocked by gate instability.
14:05:45 <TuanVu> yeah
14:06:00 <TuanVu> hopefully it will be merged soon
14:06:02 <njohnston> The recent runs got a Zuul -2 because some jobs ended up in TIMED_OUT status
14:06:23 <TuanVu> we'll need another recheck
14:06:42 <njohnston> I have notced that most of my changes have needed numerous rechecks in the past day or so
14:07:20 <TuanVu> it's because of query_constant bug which Luo is still working on, right?
14:07:37 <njohnston> I am not sure; I haven't had time to dig into it.
14:07:53 <TuanVu> as the last time I checked, it is
14:08:07 <njohnston> Next up
14:08:10 <njohnston> #link https://review.openstack.org/#/c/507772/ Use Network OVO in db_base_plugin - Vu Cong Tuan
14:08:16 <njohnston> This one has a number of feedback items from boden - and it looks like there may be side-effects to other stadium projects.
14:08:38 <TuanVu> yes
14:08:55 <TuanVu> I'm still trying to find answers for concerns from Boden
14:08:59 <TuanVu> for example this one:
14:09:12 <TuanVu> in models a network has 'port_security', but appears to be called 'security' in OVO land
14:10:27 <njohnston> In neutron/objects/port/extensions/port_security.py there is a class PortSecurity
14:12:12 <njohnston> I will review it also, see if I can add anything extra
14:12:27 <TuanVu> thank you very much, Nate :)
14:12:35 <njohnston> #action njohnston review https://review.openstack.org/#/c/507772/
14:12:45 <njohnston> #link https://review.openstack.org/#/c/565358/ objects: don't refetch a non-list object field if it's None - Ihar Hrachyshka
14:12:59 <njohnston> Looks solid to me, just needs some additional reviews.
14:14:05 <njohnston> next up
14:14:08 <njohnston> #link https://review.openstack.org/#/c/574797/ Test: Use Network OVO in db_base_plugin - Boden Russell
14:14:23 <njohnston> This is actually in the vmware-nsx repository, not neutron.  Still a WIP, based on boden's workflow -1
14:14:40 <njohnston> So we will see how that evolves.
14:14:53 <TuanVu> it's because of my patch
14:15:16 <TuanVu> it's for showing the error in vmware after running on my patch
14:15:33 <njohnston> makes sense
14:15:52 <njohnston> #link https://review.openstack.org/#/c/544206/ Integration of (Distributed) Port Binding OVO - Lujin Luo
14:16:09 <njohnston> This has some feedback from manjeets that should be addressed.  Since lujinluo is on vacation, I assume this will wait for her return, unless someone wants to jump in and give an assist.
14:16:46 <TuanVu> ok
14:17:41 <njohnston> #link https://review.openstack.org/#/c/565773/ Use Tag OVO in neutron/db/tag_db.py - Lajos Katona
14:17:48 <njohnston> This looks like it is on hold for this month due to author unavailability.
14:18:40 <njohnston> Also look at the list - we have five changes that have not been changed in the past week - check those and let's see if we can keep them moving forward.  Thanks!
14:19:47 <njohnston> Next up is a topic I am adding to the agenda
14:19:57 <njohnston> #topic OVO Joins
14:20:19 <njohnston> Last week I posed the question about how to do joins, as the area of the spreadsheet I have taken ownership of has many of them.
14:20:28 <njohnston> I took one case and summarized it.
14:20:36 <njohnston> #link http://paste.openstack.org/show/723413/ "_get_active_network_ports()" join code and resultant SQL query
14:21:13 <njohnston> I posed that to the #openstack-oslo channel, to see if anyone had any experience with such a scenario.  I got a response from dansmith.
14:21:32 <njohnston> To summarize dansmith's feedback, he said: "our query methods take "expected_attrs=" and then we arrange the query method below that to return them joined so we can fill out nested objects in one go" using the approach that "some objects with objects in a field, which is kinda what you get from a join".
14:21:40 <njohnston> In response to my example he said, "so in your example, we'd create a ML2PortBinding or whatever and then set binding.agent = Agent() and fill that out too".
14:21:47 <njohnston> #link http://eavesdrop.openstack.org/irclogs/%23openstack-oslo/%23openstack-oslo.2018-06-13.log.html#t2018-06-13T20:49:15 Conversation on #openstack-oslo
14:21:54 <njohnston> I think this is a fruitful avenue to experiment with, but I wanted to bring it up for all to review.
14:22:31 <TuanVu> thanks for this info, Nate
14:23:23 <njohnston> How does this approach sound to you, TuanVu?
14:25:36 <TuanVu> It sounds great
14:25:53 <TuanVu> I'll try to follow this suggestion as well
14:25:56 <njohnston> Great!  I'll see if I can follow this thread.
14:26:11 <njohnston> #topic Open Discussion
14:26:34 <njohnston> I do think that the agenda page that is linked to from eavesdrop.openstack.org should be updated, just wanted to note that here because it still talks about "Pike release schedule".
14:26:40 <njohnston> #action Update meeting agenda https://wiki.openstack.org/wiki/Meetings/Neutron-Upgrades-Subteam
14:26:53 <njohnston> Anything else?
14:28:24 <TuanVu> I think that's all for today?
14:28:42 <hungpv_> Think so
14:28:42 <njohnston> I think so.  Thank you TuanVu!
14:28:50 <njohnston> Hello hungpv_
14:29:00 <njohnston> Enjoy your day!
14:29:03 <njohnston> #endmeeting