14:00:06 <njohnston> #startmeeting neutron_upgrades
14:00:07 <openstack> Meeting started Thu Jul 12 14:00:06 2018 UTC and is due to finish in 60 minutes.  The chair is njohnston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:10 <openstack> The meeting name has been set to 'neutron_upgrades'
14:01:09 <njohnston> Hello TuanVu
14:01:15 <TuanVu> Hi Nate
14:01:20 <TuanVu> have a great day :)
14:01:33 <njohnston> Yes and you too!
14:01:40 <TuanVu> thanks :)
14:01:59 <njohnston> I was hoping hungpv would be here as well but that username is not in my list of who is online
14:02:30 <njohnston> #topic Announcements
14:02:37 <njohnston> Some general announcements, relaying from the neutron team meeting if you did not know:
14:02:38 <TuanVu> yeah, I hope so
14:02:44 <njohnston> Rocky 3 is really just around the corner, July 23 - 27
14:02:51 <njohnston> The PTG will take place on September 10 - 14 in Denver
14:02:58 <njohnston> And finally, next Tuesday 17th is the last day to propose presentations for the Berlin Summit
14:03:07 <njohnston> Is anyone going to be coming to any of the above with a particular focus on Neutron Upgrades or OVO?
14:03:15 <TuanVu> yes, thanks for this information
14:03:43 <TuanVu> hmm, I'm not sure
14:03:52 <hungpv> I hope I can come
14:04:14 <hungpv> but that's up to myself :D
14:04:23 <hungpv> *not up to
14:04:34 <njohnston> hello hungpv
14:04:47 <hungpv> hi nate, nice to see you
14:04:59 <njohnston> #topic Tracking Progress
14:05:21 <njohnston> I wanted to just check in on the state of the tracking spreadsheet
14:05:32 <njohnston> The completion percentage has been sitting at 26% for some time now.
14:05:38 <njohnston> #link https://docs.google.com/spreadsheets/d/1Mz7V40GSdcUH_aBoNWjsFaNRp4wf-duz1GFWligiNXc/edit#gid=1051788848 Neutron Upgrades Tracking Spreadsheet
14:05:50 <njohnston> Also please note we still do not have an assignee for the RBAC and Security Groups sections.
14:05:52 <TuanVu> yes, that's number should be updated
14:06:11 <TuanVu> yeah
14:06:38 <TuanVu> At this moment, I and Hung are busy with other tasks with higher priority so we haven’t had time to work on OVO stuffs yet
14:07:03 <njohnston> I invented a new status called "Blocked" for a few of my tasks that have dependencies on other things FYI
14:07:10 <TuanVu> however, tomorrow I'll update the actual progress number (%)
14:07:11 <njohnston> just to call those out, I marked them yellow
14:07:30 <njohnston> hungpv: How do things look for the L3 section in the spreadsheet?  It is rather large, and I don't see any tracked progress in it.
14:07:34 <TuanVu> thanks for the notice, Nate
14:08:27 <hungpv> sorry, i havent had time to touch it
14:09:16 <njohnston> Hopefully we can get to all of these in Stein :-)
14:09:20 <hungpv> it's almost unit test as I can see
14:09:46 <njohnston> Hopefully that makes it simpler, the unit test ones tend to be a little less difficult
14:09:51 <hungpv> I hope so
14:10:03 <njohnston> #topic OVO
14:10:11 <njohnston> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
14:10:20 <njohnston> #link https://review.openstack.org/580721 "Adopt Port OVO for ipam pluggable backend"
14:10:27 <njohnston> This one is mine, it has a number of test failures I need to work on.
14:11:01 <njohnston> #link https://review.openstack.org/561834 "ipam_backend_mixin: Segments model to OVO"
14:11:07 <njohnston> This belongs to TuanVu, but I noted that I think unit tests are affected (or should be).
14:11:15 <njohnston> What are your thoughts on that, TuanVu?
14:11:30 <TuanVu> thanks for the comment, Nate
14:12:13 <TuanVu> as I mentioned above, I and Hung are busy with other tasks with higher priority so we haven’t had time to work on OVO stuffs yet
14:12:46 <TuanVu> however, I'll try to manage to have time to work on it maybe next week
14:12:56 <hungpv> yess, meee tooo
14:13:13 <hungpv> our work in company took so much time
14:13:32 <TuanVu> by the way, I will not be able to join the meeting next week
14:13:44 <TuanVu> because of some personal stuffs
14:14:04 <TuanVu> but if there's any update, I'll post it on gerrit to keep you up to date
14:14:12 <njohnston> Thanks!
14:14:42 <njohnston> Regarding change 581634, the more I think about it the more I think the change needs to be larger in scope
14:15:09 <njohnston> query_filter_by_segment_and_host is still taking a 'query' argument
14:15:34 <njohnston> which seems to be constructed by some other functions, in neutron/db/ipam_backend_mixin.py lines 685-686
14:16:16 <njohnston> _query_subnets_on_network() and _query_filter_service_subnets()
14:16:37 <njohnston> which makes me think that perhaps the entirety of find_candidate_subnets needs to be pulled into the OVO
14:17:06 <njohnston> my rule of thumb is that there should never be an argument with a SQL query getting passed around outside of the OVO
14:17:19 <TuanVu> yes, I totally agree
14:18:25 <njohnston> ok, if you think I have a good point then I will comment to that effect in gerrit :-)
14:18:38 <TuanVu> yes, please do so
14:18:59 <TuanVu> thank you very much, Nate :)
14:19:13 <njohnston> #action njohnston Comment in https://review.openstack.org/561834 that the scope should be expanded to all of find_candidate_subnets()
14:19:22 <njohnston> It is my pleasure, TuanVu
14:19:37 <njohnston> #link https://review.openstack.org/562489 "ipam_backend_mixin: Service Type model to OVO"
14:19:51 <njohnston> This one looks good to go, TuanVu.  It just needs some core reviews, yes?
14:20:08 <TuanVu> yes
14:20:28 <njohnston> excellent
14:20:42 <TuanVu> I've added Miguel, but it looks like he's busy
14:20:48 <TuanVu> and hasn't had time to check it yet
14:20:55 <njohnston> His pile is deep indeed :-)
14:21:02 <njohnston> but I am sure he will get to it
14:21:11 <njohnston> #link https://review.openstack.org/579682 "Use OVO for tests/unit/plugins/ml2/drivers/l2pop/test_db.py"
14:21:13 <TuanVu> it would be great if we have more core reviewer to check it
14:21:21 <njohnston> This one is mine, but I think it is in the same situation as the last one - good to go, just needs core reviews.
14:21:21 <TuanVu> i hope so
14:21:33 <TuanVu> that's awesome
14:22:17 <TuanVu> you're moving with a rapid pace, Nate
14:22:38 <njohnston> #topic Open Discussion
14:22:47 <TuanVu> I see you're also very active in reviewing patches
14:23:05 <njohnston> Yes, I try - I hope I am helping
14:23:28 <njohnston> Next week I believe our esteemed leader lujinluo is scheduled to return
14:23:30 <TuanVu> of course you are
14:23:41 <hungpv> hi Nate, if you have time, please have a look at my patchset
14:23:57 <hungpv> https://review.openstack.org/#/c/549168/
14:24:00 <njohnston> hungpv I would be happy to
14:24:01 <TuanVu> yes, I hope so
14:24:51 <hungpv> as I mention in previous meeting, I have some problem and couldn't figure it out yet
14:24:57 <hungpv> I 'll update on gerrit
14:25:06 <hungpv> Hope you can give it a glance
14:25:10 <njohnston> hungpv Thanks, I will take a look at it.
14:25:24 <hungpv> Thank you so much for your time
14:25:30 <njohnston> #action njohnston Look at problem with https://review.openstack.org/#/c/549168/
14:25:49 <njohnston> Anything else that anyone would like to add?
14:26:25 <TuanVu> I wish I had more time to work on OVO so we can discuss more. However, there's not much from me at this moment
14:26:43 <hungpv> Almost nothing from me now.
14:26:57 <hungpv> Are you coming to PTG Denver, Nate?
14:27:42 <njohnston> I hope so but my company is just now making it's decisions on that
14:28:16 <hungpv> oh, hope that we can have a chance to see you there
14:28:28 <njohnston> +100
14:30:27 <njohnston> Thank you both, and have a wonderful week!  TuanVu I hope your personal stuff next week goes very well!
14:30:55 <njohnston> #endmeeting