14:00:11 <lujinluo> #startmeeting neutron_upgrades
14:00:12 <openstack> Meeting started Thu Aug 16 14:00:11 2018 UTC and is due to finish in 60 minutes.  The chair is lujinluo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:15 <openstack> The meeting name has been set to 'neutron_upgrades'
14:00:20 <lujinluo> o/
14:00:58 <lujinluo> ok, I will wait for my friends
14:01:22 <njohnston> o/
14:01:26 <lujinluo> o/
14:01:50 <lujinluo> It seems it would be just the two of us today, haha
14:02:06 <lujinluo> #topic OVO
14:02:11 <njohnston> perhaps others will join in time :-)
14:02:30 <lujinluo> haha, then let's wait for another 3 mins
14:02:47 <lujinluo> after that, let's start ;)
14:02:54 <njohnston> seems to be a fair number of gate issues of late
14:03:03 <njohnston> many Zuul -1s
14:03:16 <lujinluo> yeah
14:03:38 <lujinluo> hopefully it won't affect releasing Rocky
14:03:55 <hungpv> yes, hope so
14:04:11 <lujinluo> oh, hey hungpv
14:04:22 <lujinluo> do you know if Tuan will come today? hungpv
14:04:43 <njohnston> sadly our Berlin talk proposal was not accepted FYI :-(
14:04:55 <hungpv> I think he will come late
14:05:00 <lujinluo> :-( so sorry to hear that
14:05:02 <hungpv> But I'm not suee
14:05:19 <lujinluo> I see. Then let's get started first
14:05:20 <hungpv> Yeah, what a loss for them :((
14:05:26 <lujinluo> #link https://review.openstack.org/#/q/topic:bp/adopt-oslo-versioned-objects-for-db+(status:open)
14:05:47 <lujinluo> #link https://review.openstack.org/#/c/382037/ PortBinding Level
14:06:12 <lujinluo> slaweq respinned it and it hit the Zuul failure
14:06:31 <lujinluo> I just rechecked it, and I think it is very close to merge
14:07:13 <lujinluo> #link https://review.openstack.org/#/c/544206/ PortBinding OVO
14:07:42 <lujinluo> I pushed a PS about one hour ago. It should pass, so welcome reviews!
14:07:53 <lujinluo> if zuul is happy ;)
14:08:17 <njohnston> :)
14:08:31 <lujinluo> #link https://review.openstack.org/#/c/549168/ Router OVO
14:08:46 <lujinluo> i guess you want to share something about this one? hungpv
14:08:55 <lujinluo> It is still pretty red
14:11:37 <lujinluo> a quick comment would be https://review.openstack.org/#/c/549168/21/neutron/db/l3_db.py@259
14:11:56 <lujinluo> not to change _update_router_db to _update_router_obj in one patch
14:12:36 <lujinluo> i think you may add _update_router_obj to handle methods using objects and leave other in db, cause router objects are used in too many places
14:12:48 <lujinluo> hungpv_: oh did you lose connection?
14:13:05 <hungpv_> Yes, thanks for suggestions
14:13:24 <hungpv_> My network acting weird recently
14:13:50 <hungpv_> Last week I tried to sign in but got baned for spam
14:14:12 <njohnston> I think your suggestion is a good one lujinluo, looking at errors like this it looks like router objects are getting misallocated somehow:
14:14:13 <njohnston> ERROR [neutron.db._utils] Cannot clean up created object 2a337710-5021-49fa-b1b7-7170d1bc2c49. Exception: Class 'neutron.objects.router.Router' is not mapped"
14:14:36 <lujinluo> yes, I had same issued with Port object
14:14:43 <lujinluo> they are too many in codes
14:14:59 <lujinluo> we have to eat them bite by bite ;)
14:15:06 <njohnston> +1
14:15:23 <hungpv_> +1
14:15:36 <hungpv_> I will think about it tomorrow
14:15:56 <lujinluo> hopefully this can at least take us one step further
14:16:28 <lujinluo> #link https://review.openstack.org/#/c/579053/ OVO in subnet_alloc.py
14:16:42 <lujinluo> I checked this one njohnston
14:16:52 <lujinluo> But I am not sure if you have tried what I tried
14:17:29 <njohnston> Yes, and your comment is a good one; I will respin once my slew of meetings is done in 2h or so :-)
14:17:41 <njohnston> I have not tried that.
14:17:46 <lujinluo> great!
14:18:27 <lujinluo> #link https://review.openstack.org/#/c/580721/ Port OVO in ipam pluggable backend
14:18:50 <lujinluo> I did not have enough time for it yet, but I saw Hongbin reviewed it
14:19:04 <hongbin> o/
14:19:11 <lujinluo> I think it is related although I have not tested it yet
14:19:16 <lujinluo> hello hongbin!
14:19:22 <hongbin> lujinluo: hi
14:20:05 <hongbin> yes, i left 2 comments in that patch
14:20:20 <hongbin> one of them might relate to the test failure
14:20:45 <njohnston> Yes.  One of hongbin's comments was that to iterate through all ports to ensure they are not owned by a set of administrative users is suboptimal in situations with large numbers of ports.  This is a valid point, so I will look at ways to offload that into the OVO so it can be taken care of in SQL.
14:21:10 <lujinluo> +1
14:21:20 <hongbin> cool
14:21:41 <lujinluo> Great!
14:22:06 <lujinluo> #link https://review.openstack.org/#/c/565773/ Tag OVO
14:22:48 <njohnston> I don't see lajoskatona on, but this is a good forum to talk about one thing
14:22:59 <lujinluo> https://review.openstack.org/#/c/565773/5/neutron/services/tag/tag_plugin.py@70 this one?
14:23:00 <njohnston> line 70 here: https://review.openstack.org/#/c/565773/5/neutron/services/tag/tag_plugin.py@70
14:23:51 <lujinluo> Do you mean you'd prefer that we move db_api.retry_if_session_inactive() to OVO as well?
14:24:02 <njohnston> It is my understanding that a full cutover to OVO would hide the details of the database interaction from the rest of the neutron code, as a side effect of upgrade compatibility
14:24:30 <njohnston> Yes, that is what I was thinking, but I am wondering if I am being excessively object oriented in my thinking on this
14:25:07 <lujinluo> Well, I actually think this is a very good point
14:25:19 <lujinluo> So far, we have not had time to consider these decorators
14:25:38 <lujinluo> but indeed they are dealing with db sessions
14:26:04 <lujinluo> I would be in favor of considering moving them into OVO objects
14:26:10 <njohnston> it seems at least that a decorator like that should be as close as possible to the code that actually interacts with the database
14:26:24 <lujinluo> agree
14:26:56 <njohnston> ok, I will come up with a specific recommendation for where it should be relocated to and comment on the change
14:27:16 <lujinluo> I will check the Google sheet Tuan created long ago and add these decorators, to keep us reminded
14:27:23 <njohnston> #action njohnston Comment on https://review.openstack.org/#/c/565773/5/neutron/services/tag/tag_plugin.py@70 with location for decorator relocation
14:27:49 <njohnston> #action lujinluo Add decorators to google tracking spreadsheet
14:27:51 <njohnston> :-)
14:28:01 <njohnston> otherwise I will forget :-)
14:28:04 <lujinluo> njohnston: thanks ;)
14:28:50 <lujinluo> #link https://review.openstack.org/#/c/561834/ segmenta model to OVO
14:29:11 <lujinluo> this one is ready to go as Stein opens
14:29:17 <njohnston> indeed
14:29:51 <njohnston> just added a couple of extra cores for review
14:30:15 <lujinluo> thanks! i had a network interruption here i believe, suddenly could not open that page :(
14:30:46 <lujinluo> well, thankfully that's all the active patches we have now
14:30:55 <lujinluo> #topic open discussion
14:31:14 <lujinluo> #link Stein Neutron etherpad https://etherpad.openstack.org/p/neutron-stein-ptg
14:31:31 <lujinluo> just a FYI of the PTG etherpad
14:32:01 <lujinluo> As far as I could see, we do not have any topics related to OVO/upgrades yet
14:32:24 <lujinluo> Does anyone have anything else he/she wants to share?
14:32:34 <njohnston> I will try to drum up some help for OVO/upgrades through informal discussions, but I don't have any topics for it
14:34:06 <lujinluo> I see. Then just write Help wanted? ;)
14:34:56 <lujinluo> well, let's try to gather some thoughts in our next meeting
14:34:59 <njohnston> something like that ;)
14:35:17 <lujinluo> One week for us to spot unseen things
14:35:45 <njohnston> thanks everyone
14:35:54 <lujinluo> if no one has anything else
14:35:58 <lujinluo> let's call it a day
14:36:07 <lujinluo> have a good day/night my friends
14:36:12 <njohnston> you too@
14:36:12 <lujinluo> #endmeeting