14:00:07 <lujinluo> #startmeeting neutron_upgrades
14:00:07 <openstack> Meeting started Thu Aug 23 14:00:07 2018 UTC and is due to finish in 60 minutes.  The chair is lujinluo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:10 <openstack> The meeting name has been set to 'neutron_upgrades'
14:00:11 <njohnston> o/
14:00:14 <lujinluo> o/
14:00:27 <lujinluo> just the two of us? let's give others some time
14:00:38 <njohnston> +1
14:02:19 <mlavalle> o/
14:02:38 <lujinluo> o/
14:03:56 <lujinluo> ok, let's get started first. If Tuan and Hung come, they can join right away
14:04:25 <njohnston> sounds good
14:04:33 <lujinluo> We have 2 AIs from last week
14:04:40 <lujinluo> 1. njohnston Comment on https://review.openstack.org/#/c/565773/5/neutron/services/tag/tag_plugin.py@70 with location for decorator relocation
14:04:48 <njohnston> Yes, I did that :-)
14:04:57 <lujinluo> yeah, thanks
14:05:17 <lujinluo> I also commented on that. Since we have a lot of places using that decorator
14:05:47 <lujinluo> I wonder if we should move it to objects/db/api.py instead of moving to each specific objects, i.e. objects/tag.py
14:06:09 <njohnston> yeah.  So I have an action item on my side to talk with zzzeek about the engine facade pattern, to see how we should approach things while not breaking that
14:06:24 <njohnston> Perhaps he can give a recommendation on this
14:06:57 <lujinluo> i see. let me add a quick AI of this week then
14:07:16 <lujinluo> #action njohnston to talk to zzzeek of decorators in engine facade pattern
14:07:41 <njohnston> thanks!
14:08:03 <slaweq> hi
14:08:08 <lujinluo> The second AI we have is me to add decorators to the googl spread sheet
14:08:12 <lujinluo> slaweq: hi!
14:08:30 <lujinluo> The Google spread sheet is here https://docs.google.com/spreadsheets/d/1Mz7V40GSdcUH_aBoNWjsFaNRp4wf-duz1GFWligiNXc/edit#gid=1051788848
14:08:43 <lujinluo> but I have not added it yet, so sorry!
14:08:56 <lujinluo> Will move this AI to my this week's AI
14:09:18 <lujinluo> #action lujinluo Add decorators to google tracking spreadsheet
14:09:48 <lujinluo> Then let's move to the patches
14:09:53 <lujinluo> #topic OVO
14:10:00 <lujinluo> #link https://review.openstack.org/#/q/topic:bp/adopt-oslo-versioned-objects-for-db+(status:open)
14:10:22 <lujinluo> #link https://review.openstack.org/565773 Tag OVO
14:10:36 <lujinluo> this is the one where we had the decorators discussion
14:11:05 <njohnston> I'm inclined to say let's exclude the decorator from scope for now, and handle decorators separately once that picture becomes clearer
14:11:12 <lujinluo> besides the decorator comment and commit msg comment left by slaweq, i am fine with the change
14:11:15 <lujinluo> +1
14:12:00 <lujinluo> let me add a quick comment to Lajos then
14:12:41 <njohnston> Sorry, I just commented :-)
14:12:51 <lujinluo> haha, no worries and thanks!
14:13:56 <lujinluo> #link https://review.openstack.org/#/c/544206/ Port Binding OVO
14:14:30 <lujinluo> I worked on this patch this week and addressed Manjeet's comments from long time ago.
14:14:33 <njohnston> I think the zuul failure is a transient
14:14:51 <lujinluo> But I saw neutron-tempest-plugin-scenario-linuxbridge failed in the recent two patches
14:15:18 <njohnston> I have seen that issue in other changes as well though
14:15:39 <njohnston> not to say they are definitely not related to the change, but there is a strong chance it is unrelated
14:16:08 <lujinluo> i see. then i will recheck tmr, and see how Zuul reacts
14:16:34 <lujinluo> #action lujinluo to see if neutron-tempest-plugin-scenario-linuxbridge failure is transient in https://review.openstack.org/#/c/544206/
14:17:05 <lujinluo> #link https://review.openstack.org/#/c/561834/ Segment OVO
14:17:14 <lujinluo> this one has received a +2 from slaweq
14:17:28 <lujinluo> mlavalle: could you please take a look if it is ready?
14:17:43 <mlavalle> lujinluo: sure, will look today
14:17:48 <lujinluo> thanks
14:17:50 <mlavalle> in my pile
14:18:19 <lujinluo> #link https://review.openstack.org/#/c/579053/ Use OVO in neutron/ipam/subnet_alloc.py
14:18:31 <mlavalle> in fact, he pinged me a little more than a week ago, but with my trip to China, I didn't have time
14:19:01 <mlavalle> I meant 561834
14:19:28 <lujinluo> Haha, I see. stein just opened, so we still have a lot of time
14:20:00 <lujinluo> For 579053, njohnston, i am sorry I made a mistake last week
14:20:22 <lujinluo> update() always return None.. thus regressions occur
14:20:40 <njohnston> I see
14:21:03 <njohnston> So I should undo the change you suggested in your comment on PS3
14:21:10 <lujinluo> thus regardless of update() succeeds or not, RetryRequest is triggered
14:21:18 <lujinluo> yes
14:21:35 <njohnston> OK, I will do that, and then try and figure out what is going wrong with the UTs
14:21:53 <lujinluo> thanks. i will also follow it :)
14:22:44 <lujinluo> #link https://review.openstack.org/#/c/382037/ Port Binding Level OVO
14:23:40 <njohnston> this one gets a +1 from me
14:23:47 <lujinluo> I reviewed it last week, and it seems the latest patch addressed hongbin's comments about comments
14:24:04 <hongbin> o/
14:24:12 <slaweq> yes, and release note
14:24:31 <slaweq> I would be very happy if that could be merged finally :)
14:24:43 <hongbin> the patch looks very good now
14:24:56 <mlavalle> I'll get back to it today, then
14:25:02 <lujinluo> i see. i am fine with it then, just +1ed
14:25:04 <mlavalle> added to today's pile
14:25:13 <lujinluo> thanks mlavalle!
14:25:41 <slaweq> thx mlavalle :)
14:25:50 <mlavalle> I made my first comment to that patch almost two years ago.... LOL
14:26:07 <lujinluo> how time flies LOL
14:26:37 <lujinluo> #link https://review.openstack.org/#/c/549168/ Router OVO
14:27:19 <lujinluo> The author, Hung, is not here today, aslo no updates from last week either..
14:27:26 <njohnston> hungpv is online
14:27:41 <lujinluo> oh, let me try ping him
14:27:44 <lujinluo> hungpv: hi
14:28:31 <njohnston> hmm perhaps he is not at his computer
14:28:33 <hungpv> Hi guys. Sorry, i been  busy with internal task this week
14:28:39 <njohnston> hi!
14:28:49 <lujinluo> hi!
14:29:07 <hungpv> Haven't got time to update this yet
14:29:31 <lujinluo> ok, anyway i will leave the comment we gave at our last meeting to the patch. hopefully you will have more time for it this week :)
14:30:02 <lujinluo> That's all the patches we have for now.
14:30:08 <lujinluo> #topic open discussion
14:30:21 <lujinluo> #link https://releases.openstack.org/rocky/schedule.html
14:30:34 <njohnston> I just wanted to say, we only have 9 patches in the topic, 2 of which I could see getting merged in the next few days
14:30:39 <lujinluo> A gentle reminder that we are at the final RC week of Rocky now
14:31:04 <mlavalle> yes, we will cut a rc-2 later today
14:31:14 <mlavalle> and that is going to be the end of Rocky
14:31:25 <lujinluo> njohnston: yes
14:31:38 <njohnston> I plan on creating a few more changes, and I also hope to drum up some help at the PTG, so hopefully things look more lively in terms of our activity :-)
14:31:55 <lujinluo> njohnston: thank you!!
14:32:18 <lujinluo> Just in case you may find the tracking spread sheet helpful, the link is here
14:32:21 <lujinluo> #link https://docs.google.com/spreadsheets/d/1Mz7V40GSdcUH_aBoNWjsFaNRp4wf-duz1GFWligiNXc/edit#gid=1051788848
14:33:03 <mlavalle> one thing that I wanted to raise is the convergence of the OVO effort with the new engine facade adoption
14:33:12 <mlavalle> possible convergence I meant
14:33:41 <mlavalle> with the adoption of OVO, it seems to me we are reducing our dependence in the old engina facade
14:33:47 <mlavalle> is that impression correct?
14:33:52 <lujinluo> yes
14:34:18 <mlavalle> on the other hand the new engine facade adoption effort is really stalled on its own
14:34:41 <mlavalle> so since this team is combing the DB layer access anyway, amybe we should merge the efforts
14:34:49 <mlavalle> maybe^^^^
14:35:03 <mlavalle> would that make sense?
14:35:04 <njohnston> mlavalle: Where is the engine facade work tracked?
14:35:21 * njohnston thinks it is a great idea
14:35:22 <mlavalle> njohnston: that's the problem, nobody is really tracking it anymore
14:35:37 <lujinluo> agree
14:35:59 <lujinluo> #link https://blueprints.launchpad.net/neutron/+spec/enginefacade-switch BP of new engine facade
14:36:05 <njohnston> well this team is very good at tracking!
14:36:39 <mlavalle> I made an effort early in Rocky. I can resucitate a patch I pushed at that time
14:36:50 <lujinluo> yeah, it seems it has been stalled for a while
14:36:51 <mlavalle> not necessarily because the patch is mergable
14:37:13 <mlavalle> but is was sort of an inverntory of wehere we still have old engine facade stuff
14:37:28 <mlavalle> we can start from there
14:37:36 <njohnston> sounds great!
14:37:41 <mlavalle> I can work on it this coming weekend
14:37:42 <lujinluo> it is a good idea
14:38:03 <mlavalle> refresh it and I'll show it to this team during the next meeting
14:38:18 <lujinluo> we can track its status in this meeting in the future
14:38:26 <mlavalle> great
14:38:35 <mlavalle> I'll take the first step then this weekend
14:38:43 <lujinluo> thanks! mlavalle
14:39:06 <mlavalle> bases on what we discover, it might become a topic in the PTG
14:39:11 <mlavalle> based^^^
14:39:39 <lujinluo> yes! that's what I was thinking
14:39:42 <lujinluo> #Link https://etherpad.openstack.org/p/neutron-stein-ptg
14:39:43 <mlavalle> That's all I had
14:41:46 <lujinluo> So at the PTG, what's from upgrades subteam is 1) more help wanted; 2) convergence of the efforts of new engine facade
14:41:46 <mlavalle> nice!
14:41:46 <njohnston> yes
14:41:46 <lujinluo> So I will add these two points to the etherpad, but feel free to edit njohnston mlavalle :)
14:41:46 <njohnston> and if the topic of using the SQLAlchemy "baked queries" functionality comes up for speeding up sql query construction, I will argue that it naturally belongs in the OVO objects
14:41:46 <mlavalle> ok
14:41:46 <lujinluo> njohnston: great
14:43:44 <njohnston> nothing else from me :-)
14:43:46 <mlavalle> I lied....
14:44:00 <mlavalle> I have one final question
14:44:30 <mlavalle> I've been creating our Stein-1 dashboard: https://launchpad.net/neutron/+milestone/stein-1
14:45:00 <mlavalle> and the OVO blueprint is listed with Slow progress
14:45:10 <mlavalle> but it seems to me we have good progress
14:45:21 <mlavalle> are you guys ok if I change the status?
14:45:59 <lujinluo> yes, please
14:46:04 <mlavalle> cool
14:46:12 <lujinluo> we have covered most of the objects by now
14:46:26 <njohnston> we should update the completion percentage
14:46:36 <mlavalle> now it's I am telling the truth.... I don't have anything else for today's meeting ;-)
14:46:36 <njohnston> I hope that 26% complete is an understatement
14:50:38 <lujinluo> hmm, this 26% bothers me now.
14:51:11 <lujinluo> But from the objects part, we have covered most of them. The rest is mainly joins that we intentionally put away.
14:51:41 <njohnston> I assume the 26% is manually computed since it has been constant despite the changes I have introduced
14:51:53 <njohnston> and it just has not been updated
14:52:01 <njohnston> did we decide to defer action on the RBAC objects?
14:52:09 <njohnston> that probably predates me
14:52:56 <lujinluo> No, we did not decide to defer it. Just no one has enough bandwidth for it
14:53:34 <njohnston> OK so if I get a volunteer in Denver I can give it to them :-)
14:53:50 <lujinluo> exactly
14:54:27 <lujinluo> ok, does anyone have anything else?
14:54:43 <lujinluo> if not, we can call it a day
14:54:54 <njohnston> nothing here, thanks for a productive meeting
14:55:12 <lujinluo> thanks for being here njohnston :)
14:55:29 <lujinluo> have a good day/night my friends
14:55:34 <lujinluo> see you all next week
14:55:48 <lujinluo> #endmeeting