14:00:15 <lujinluo> #startmeeting neutron_upgrades
14:00:18 <openstack> Meeting started Thu Sep 20 14:00:15 2018 UTC and is due to finish in 60 minutes.  The chair is lujinluo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:21 <openstack> The meeting name has been set to 'neutron_upgrades'
14:00:28 <lujinluo> o/
14:00:38 <TuanVu> hi Luo-san :D
14:00:43 <lujinluo> hi TuanVu!
14:00:53 <TuanVu> long time no see :D
14:01:01 <lujinluo> yeah, haha, long time no see.
14:01:09 <hungpv> Hi guys
14:01:15 <TuanVu> Hi Hung-san
14:01:16 <lujinluo> hungpv: hi!
14:01:43 <lujinluo> let me ask if Nate would be able to join today.
14:01:55 <lujinluo> njohnston: hey, will you be able to join the meeting today?
14:01:55 <TuanVu> ok
14:01:56 <njohnston> o/
14:02:04 <lujinluo> o/ njohnston
14:02:04 <TuanVu> Hi Nate :D
14:02:07 <TuanVu> nice to see you
14:02:09 * njohnston is triple-tasking :-)
14:02:15 <njohnston> Nice to see you both!
14:02:31 <njohnston> s/both/all/ didn't see you there hungpv :-)
14:02:38 <lujinluo> haha, first thing first. how's the PTG :) njohnston
14:02:58 <hungpv> Nice to see u Nate!
14:03:36 <njohnston> So at the PTG there were a few interesting things
14:05:02 <njohnston> I spent all day attending the Upgrades SIG.  Most of this was consumed talking about the placement service - a really considerable change to the architecture of Nova specifically, and OpenStack in general.  It also means that there is no gentle rolling upgrade for the Rocky release, since many of the Nova tables are now to be relocated to the Placement database.
14:06:13 <njohnston> I also reported on the progress of this team; people were interested in the level of effort we are giving to it.  By that point operators from the Ops Meetup had joined the Upgrades meeting, and there was feedback from one or two that they are actually doing rolling upgrades now and they have been working, i.e. Pike to Queens
14:06:54 <lujinluo> Very happy to know ops are actually trying it out!!
14:07:05 <hungpv> That's great
14:07:15 <njohnston> Here's the etherpad for the Upgrades SIG: https://etherpad.openstack.org/p/upgrade-sig-ptg-stein
14:07:35 <TuanVu> thanks for the info, Nate
14:07:45 <njohnston> Then Wednesday through Friday was all Neutron meetings.  Etherpad: https://etherpad.openstack.org/p/neutron-stein-ptg
14:09:07 <njohnston> There was a specific topic for OVO/Upgrades late in the day on Thuesday.  I showed the spreadsheet and there was interest from some contributors, although one or two people looked at some unowned changes and said they had already been fixed (example: haleyb).
14:10:05 <njohnston> There was also discussion of the engine facade switch; there was a divide between those who remembered it from before, and others who are newer who were like "what?"
14:10:30 <lujinluo> LOL
14:10:32 <njohnston> but there was a lot of support from the community and some interest in helping
14:11:11 <lujinluo> Sounds like a very productive week!
14:12:00 <lujinluo> Was there anyone from Fenix team explaining more details about how they are doing rolling upgrades? I just happen to see this page #link https://wiki.openstack.org/wiki/Fenix
14:12:45 <njohnston> Yes there was someone there, and he spent perhaps 20 minutes talking about it, in the upgrades SIG
14:14:02 <lujinluo> This project is really interesting to me.
14:14:18 <lujinluo> Thank you so much for the updates you brought back to the team njohnston!
14:14:38 <njohnston> It seemed like an interesting project, but it was unclear how broad the base of support for it is
14:14:59 <njohnston> You are welcome, lujinluo!  I was happy and proud to represent the subteam and all the work we have accomplished.
14:16:58 <lujinluo> So based on what njohnston brought back, we have one clear action item, which is to update the spread sheet..
14:17:33 <lujinluo> Does anyone have the bandwidth to cover it recently?
14:18:03 <njohnston> I did do one thing on my own recognizance, which is: in places where there was an assignee but no work was registered to have taken place, I set it to unowned, to try and attract new developers.
14:18:05 <TuanVu> I'll do it
14:18:29 <hungpv> Before moving on to other topics, I want to announce something. I'll be leaving Fujitsu and Openstack world soon. So my works will be continued by announce and TuanVu
14:18:31 <TuanVu> that's a great idea, Nate
14:19:02 <lujinluo> hungpv: ah, so sad you are leaving us
14:19:07 <njohnston> hungpv: Best of luck on your next adventure!
14:19:22 <TuanVu> yeah, good luck, Hung-san
14:19:22 <hungpv> I'll miss you guys and our meeting
14:19:23 <lujinluo> hungpv: yeah, all the best!
14:19:59 <lujinluo> #action TuanVu to update the tracking spread sheet #link https://docs.google.com/spreadsheets/d/1Mz7V40GSdcUH_aBoNWjsFaNRp4wf-duz1GFWligiNXc/edit#gid=1051788848
14:20:47 <lujinluo> OK, now let's move to our OVO patches.
14:20:52 <hungpv> Thank you so much. Hopefully we can work together someday somewhere
14:20:52 <lujinluo> #topic OVO
14:21:01 <lujinluo> https://review.openstack.org/#/q/topic:bp/adopt-oslo-versioned-objects-for-db+(status:open)
14:21:53 <lujinluo> #link https://review.openstack.org/#/c/544206/ Port Binding OVO
14:23:03 <lujinluo> In last PS, I addressed njohnston's comments about wrong version bump. And I mistakenly deleted a few lines which then caused some regression.. the latest patch is going on reviewed by Zuul, but i think it should be fine
14:23:14 <njohnston> +1
14:23:33 <lujinluo> when it passed Zuul, please take a look :-)
14:24:20 <lujinluo> #link https://review.openstack.org/#/c/602362/ retry_session
14:25:38 <njohnston> yeah I have taken a few looks at that
14:25:46 <lujinluo> A new comment from hongbin reminding us that we need to sync-up with neutron-lib, which I overlooked..
14:29:37 <lujinluo> Apparently neutron-lib did not move retry_if_session_inactive() but made a duplicate function
14:29:37 <njohnston> ok
14:29:47 <hongbin> o/
14:29:48 <lujinluo> #link http://codesearch.openstack.org/?q=def%20retry_if_session_inactive&i=nope&files=&repos=
14:30:02 <lujinluo> hongbin: o/
14:30:17 <hongbin> lujinluo: :)
14:30:42 <TuanVu> hi hongbin
14:30:49 <hongbin> TuanVu: hi
14:32:34 <lujinluo> yeah, then we just need another patch to address that.
14:33:20 <hongbin> i left another comment on that patch, which is a minor issue, see if you guys think it makes sense
14:37:01 <lujinluo> yeah, i would prefer your change
14:38:40 <njohnston> +1
14:39:02 <lujinluo> i will adjust my comment soon after this meeting
14:39:53 <lujinluo> next #link https://review.openstack.org/#/c/602497/ use ovo for L3HARouterAgentPortBinding in l3_hamode.
14:40:22 <lujinluo> i believe manjeet is still working on it.
14:41:35 <lujinluo> the changes he made would propagate more changed to other places
14:41:52 <lujinluo> let's move to next one
14:41:59 <lujinluo> #link https://review.openstack.org/#/c/507772/ network ovo
14:42:11 <TuanVu> I’ve already provided answer for Nate’s concern and waiting for his feedback
14:42:28 <njohnston> I'll take a look today TuanVu
14:42:36 <TuanVu> thank you, Nate :)
14:42:36 <lujinluo> ack. I will review it today too
14:42:46 <TuanVu> thank you in advance, Luo :)
14:43:02 <lujinluo> next one is Router OVO #link https://review.openstack.org/#/c/549168/
14:43:08 <annp_> hi
14:43:16 <TuanVu> Hi An-san
14:43:20 <lujinluo> so the responsibility of this patch will go to TuanVu?
14:43:26 <lujinluo> hi annp_!
14:43:40 <annp_> lujinluo, Can I take over this patch?
14:43:48 <lujinluo> yeah, of course!
14:43:58 <lujinluo> you are more than welcome to do so :-)
14:43:58 <TuanVu> thanks a lot! An-san
14:44:04 <annp_> thanks. Hope I can update this soon.
14:44:14 <TuanVu> I really appreciate your help
14:44:28 <annp_> TuanVu: you're welcome :-)
14:44:30 <lujinluo> thanks! annp_
14:44:41 <TuanVu> I believe with your technical ability, this patch will be moved forward very quickly :D
14:45:18 <annp_> TuanVu: Let's see :-)
14:45:24 <lujinluo> next Port OVO in external_net_db.py #link https://review.openstack.org/#/c/537320/
14:45:45 <lujinluo> This is on me. I will respin it today to address slawek's comment
14:47:05 <lujinluo> That's all the OVO patches we have now
14:47:23 <njohnston> did we talk about the ipam change?
14:47:30 <njohnston> https://review.openstack.org/579053
14:47:50 <njohnston> that one is mine; I will try to address tidwellr's comment today or tomorrow
14:47:52 <lujinluo> oops, i somehow overlooked it
14:47:58 <lujinluo> thanks!
14:48:30 <njohnston> Nice to see tidwellr back!
14:49:01 <lujinluo> so for the patches, i am thinking we should start to track the engine facade patches now - and then we can gradually pick them up
14:49:04 <lujinluo> #link https://review.openstack.org/#/q/topic:bp/enginefacade-switch+(status:open)
14:49:20 <lujinluo> haha, yeah, always nice to see people coming back!
14:49:32 <lujinluo> #topic engine facade
14:49:38 <lujinluo> #link https://review.openstack.org/#/q/topic:bp/enginefacade-switch+(status:open)
14:50:22 <lujinluo> i know we have not picked up any patches yet, but it is always good to be reminded we also take it discussed here
14:50:56 <lujinluo> #topic open discussion
14:51:14 <lujinluo> Does anyone have anything else to share?
14:51:23 <njohnston> Regarding engine facade, I wanted to see how unit tests would respond if we enabled the new engine facade so I tried it: https://review.openstack.org/#/c/602035/
14:51:42 <njohnston> just FYI for those looking at it
14:52:20 <lujinluo> ack. impressed by the red-ness
14:52:29 <lujinluo> LOL
14:53:01 <njohnston> yes but only 23 unit tests failed: http://logs.openstack.org/35/602035/1/check/openstack-tox-py36/bad207a/testr_results.html.gz
14:53:17 <njohnston> so those 23 may need some special attention; not sure if they have or have not been converted
14:53:59 <lujinluo> understood
14:54:44 <lujinluo> So if no one else has anything to share, we would call it a day here.
14:54:54 <njohnston> That's all I have.  Thanks everyone!
14:55:14 <lujinluo> again thank you hungpv for your hard work until now. and all the best to your next adventure!
14:55:15 <TuanVu> thanks everyone :)
14:55:54 <lujinluo> thank you the rest of the team, and see you all next week
14:56:06 <lujinluo> #endmeeting