14:00:21 <lujinluo> #startmeeting neutron_upgrades
14:00:22 <openstack> Meeting started Thu Oct 11 14:00:21 2018 UTC and is due to finish in 60 minutes.  The chair is lujinluo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:26 <openstack> The meeting name has been set to 'neutron_upgrades'
14:00:31 <lujinluo> o/
14:00:35 <ralonsoh> hi
14:00:57 <lujinluo> hi ralonsoh!
14:01:13 <njohnston> o/
14:01:21 <lujinluo> o/ njohnston
14:01:35 <lujinluo> ok, let's get started
14:01:40 <lujinluo> #topic OVO
14:01:48 <lujinluo> #link https://review.openstack.org/#/q/topic:bp/adopt-oslo-versioned-objects-for-db+status:open
14:02:22 <lujinluo> #link https://review.openstack.org/#/c/608198/ NetworkRBAC in neutron/db/db_base_plugin_v2.py
14:03:00 <ralonsoh> I replied to njohnston
14:03:12 <ralonsoh> IMO, is almost almost ready
14:03:28 <ralonsoh> It will depends on https://review.openstack.org/#/c/609691/
14:03:33 <ralonsoh> the functional tests
14:04:13 <njohnston> just added +1
14:04:21 <ralonsoh> njohnston thanks!!
14:04:31 <lujinluo> ack. i will review it today
14:05:31 <lujinluo> #link https://review.openstack.org/#/c/608628/ Use NetworkRBAC OVO in neutron/db/external_net_db.py
14:05:59 <ralonsoh> functional tests in https://review.openstack.org/#/c/609692/
14:06:18 <ralonsoh> addressed all comments in last commit
14:07:58 <njohnston> Sorry I have not been active on that review; I'll try to take a pass later
14:08:05 <lujinluo> awesome. by taking a quick look at the codes, i think they are generally fine. i will review it today as well.
14:08:29 <lujinluo> (me neither. will try to get back on track this week, sorry :(
14:09:15 <lujinluo> next two are functional tests of the previous two patches
14:09:36 <lujinluo> #link https://review.openstack.org/#/c/609691/ functional tests of #link https://review.openstack.org/#/c/608198/
14:10:00 <lujinluo> #link https://review.openstack.org/#/c/609692/ functional tests of #link https://review.openstack.org/#/c/608628/
14:10:32 <lujinluo> I will review the four of them within this week!
14:10:38 <ralonsoh> thanks! no rush
14:10:55 <lujinluo> thanks for the great work ralonsoh!
14:11:14 <ralonsoh> lujinluo: no problem, that was a suggestion made by njohnston
14:11:45 <lujinluo> thank you! njohnston
14:11:47 * njohnston is very appreciative of ralonsoh's great work
14:11:59 <lujinluo> next is port binding #link https://review.openstack.org/#/c/544206/
14:12:38 <lujinluo> i addressed most of the comments from hongbin and manjeet, except for 2 left, which i do not think i will revise the codes, but i need to run some local tests to justify the changes
14:13:07 <lujinluo> i will finish it this week too. then reviews are welcome :)
14:13:56 <njohnston> I do have one question
14:14:11 <njohnston> You turn on new engine facade in this change
14:14:16 <lujinluo> yes
14:15:09 <njohnston> This is pre-empting the engine-facade section in the agenda I realize, but I wonder if that should be a separate change?  Or does it positively affect the functioning of what you're changing here?
14:16:29 <lujinluo> yes, the changes made in that patch requires using new engine facade. let me find an example here
14:18:02 <lujinluo> https://review.openstack.org/#/c/544206/24/neutron/plugins/ml2/plugin.py@399
14:19:34 <njohnston> ok
14:19:40 <lujinluo> this update() inside _process_port_binding() then __create_port_db() is inside a writer transaction
14:20:01 <njohnston> yep, that makes sense
14:20:16 <njohnston> ok, cool, I am good to move on :-)
14:20:16 <lujinluo> good!
14:20:46 <lujinluo> let's move to the next one
14:21:31 <lujinluo> #link https://review.openstack.org/#/c/608638/
14:21:35 <lujinluo> Use NetworkRBAC OVO in tests/unit/db/test_db_base_plugin_v2.py
14:21:58 <ralonsoh> last comment already addressed
14:23:58 <lujinluo> good job! and i will review it right after the meeting
14:24:09 <lujinluo> thank you so much for your work ralonsoh!!
14:24:57 <lujinluo> next is the retry decorator changes in neutron-lib #link https://review.openstack.org/#/c/605365/
14:25:20 <lujinluo> i replied to michel's concern but he has not replied yet
14:26:01 <njohnston> He's right about it, but it is a transitional accomodation
14:26:09 <njohnston> with a finite lifetime
14:26:16 <lujinluo> yeah
14:27:14 <lujinluo> will wait for a while before approaching him on irc
14:27:47 <lujinluo> #link https://review.openstack.org/#/c/602497/ use ovo for L3HARouterAgentPortBinding in l3_hamode
14:28:13 <lujinluo> for this patch, does zuul hang somewhere? or did i miss anything
14:29:39 <njohnston> hmm
14:30:12 <lujinluo> let me try if recheck would help or not
14:30:24 <njohnston> it's parent has not merged https://review.openstack.org/#/c/607076/
14:30:41 <njohnston> so that is to be expected
14:31:06 <lujinluo> oh, got it
14:31:26 <lujinluo> thanks for the recheck
14:31:57 <njohnston> :-)
14:32:05 <lujinluo> #link https://review.openstack.org/#/c/507772/ network OVO
14:32:31 <lujinluo> TuanVu: since you are here today, do you happen to have any updates on it?
14:33:38 <njohnston> last time I looked at it I came away with the same questions you had posted lujinluo so I maintained my -1
14:33:55 <TuanVu> Hi Luo and Nate
14:34:01 <njohnston> Hi TuanVu!
14:34:05 <lujinluo> hi TuanVu!
14:34:21 <TuanVu> I intended to update it this week but couldn't manage to have enough time
14:34:26 <TuanVu> I will try to update it soon
14:34:34 <TuanVu> thanks a lot for your kind help
14:35:12 <lujinluo> ack!
14:35:30 <njohnston> thanks
14:35:56 <lujinluo> the rest of the patches are not updated since previous meeting. and let's give them some time
14:36:02 <lujinluo> #topic engine facade
14:36:12 <lujinluo> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/enginefacade-switch
14:36:36 <lujinluo> last week, i said i have a local patch working on, but sadly i have not finished it :(
14:36:49 <lujinluo> i will try to finish it this week and push for review
14:37:24 <lujinluo> #topic open discussion
14:37:31 <njohnston> Are there any other objects that we think we can switch to the new facade, on a per-object basis?
14:38:37 <njohnston> the Agent object, for example?
14:38:48 <lujinluo> i have not gone through the codes so i cannot tell for sure, but theoretically speaking for the objects that we have already converted, should be fine to switch on new facade
14:38:52 <njohnston> according to the tracking spreadsheet, work on that jas completed
14:39:20 <njohnston> I think I'll push up something to enable the new facade on that, and let's see how well it works
14:39:32 <lujinluo> great
14:40:11 <njohnston> if that works OK then we can move on Network and Router as next steps
14:40:36 <lujinluo> yep!
14:40:59 <njohnston> #action njohnston to push change that enables new engine facade for Agent object
14:41:26 <lujinluo> thanks!
14:41:43 <lujinluo> does anyone have anything else?
14:42:31 <lujinluo> if not, i have one small favor i would like to ask
14:42:39 <ralonsoh> sure
14:42:56 <njohnston> ok
14:42:58 <lujinluo> first i am sorry i was not active enough to track the changes last week, and i saw people actually added me as reviewers to those new patches
14:43:13 <lujinluo> but that one goes to my previous company email, which i did not have access to..
14:43:23 <lujinluo> i mean i dont have access anymore
14:43:40 <lujinluo> so if possible.. please add the account with my gmail address, :)
14:43:44 <njohnston> ok
14:43:47 <ralonsoh> ok
14:44:10 <lujinluo> i will also contact the admin ppl to see if they can remove the old account for good
14:44:17 <lujinluo> thanks! njohnston ralonsoh
14:44:27 <ralonsoh> thanks!
14:44:32 <njohnston> np
14:44:46 <lujinluo> ok, if that's it. let's call it a day :-)
14:44:53 <njohnston> I have one other thing
14:44:59 <lujinluo> sure
14:45:14 <njohnston> I am starting to play around with how best to implement baked qieries
14:45:30 <njohnston> I have a very WIP change here: https://review.openstack.org/609715
14:45:38 <lujinluo> is it the one we may need for all the joins?
14:47:04 <njohnston> it speeds up operations.  Basically it short cuts the process of constructing the text of the SQL query.  Especially for frequently invoked queries that never change it will be a significant speed boost.
14:47:44 <lujinluo> sounds very impressive
14:48:18 <njohnston> it was already implemented in ODL; check out https://review.openstack.org/#/c/591363/ for comparison
14:49:36 <lujinluo> got it. will check on both patches. this will be a big performance gain in large scale systems
14:50:40 <njohnston> absolutely
14:52:41 <lujinluo> yeah, would be very interested to see how it works!
14:52:49 <njohnston> that is all for me
14:53:04 <lujinluo> ok if nothing else, let's call it a day!
14:53:10 <lujinluo> thanks everyone for joining
14:53:15 <lujinluo> have a good day/night
14:53:22 <ralonsoh> bye
14:53:26 <lujinluo> and hope to see you all next week!
14:53:44 <lujinluo> #endmeeting