14:00:06 <lujinluo> #startmeeting neutron_upgrades
14:00:07 <openstack> Meeting started Thu Oct 18 14:00:06 2018 UTC and is due to finish in 60 minutes.  The chair is lujinluo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:11 <openstack> The meeting name has been set to 'neutron_upgrades'
14:00:16 <lujinluo> o/
14:01:53 <njohnston> o/
14:02:12 <ralonsoh> o/
14:02:24 <slaweq> hi
14:02:36 <lujinluo> hi njohnston ralonsoh slaweq !
14:02:43 <lujinluo> then let's get started
14:03:04 <lujinluo> last week we have one action item: njohnston to enabl new_face in Agent OVO
14:03:13 <lujinluo> #link https://review.openstack.org/#/c/609749/
14:03:19 <njohnston> Yes, I tried that, and it had some issues
14:03:22 <lujinluo> *new_facade
14:03:31 <njohnston> not as straightforward as I would have hoped
14:03:42 <njohnston> given that the agent part of the spreadsheet was completed
14:04:28 <lujinluo> yeah, I downloaded the patch locally and tried to test it. I think we still miss something
14:05:05 <njohnston> I worry that it is some of the "common" code that we can't convert until all of the code has been changed to OVO
14:05:12 <njohnston> i.e. the stuff marked as "blocked
14:05:21 <njohnston> " on the OVO tracking spreadsheet
14:07:03 <lujinluo> i see.
14:07:26 <njohnston> the failures in unit tests: http://logs.openstack.org/49/609749/1/check/openstack-tox-py36/a962088/testr_results.html.gz
14:07:32 <njohnston> and in functional: http://logs.openstack.org/49/609749/1/check/neutron-functional/d69aeae/job-output.txt.gz#_2018-10-11_19_14_37_954448
14:07:51 <njohnston> that "common" thing is just a hypothesis, I have no data to back it up yet
14:08:16 <lujinluo> the failures are most related to router and l3 agent though
14:08:39 <lujinluo> it could be router OVO that is blocking
14:08:49 <njohnston> so my thought was to pick a specific test and step through with pdb and see if I can track the problem
14:09:54 <lujinluo> i think that is what we should try at least
14:10:48 <lujinluo> i will continue testing that patch on my side as well. i will ping you if i find anything interesting njohnston
14:11:03 <njohnston> #action njohnston pick tests from https://review.openstack.org/609749 and step through with pdb to detect failure
14:11:24 <njohnston> will do, thanks very much for your help lujinluo!
14:11:38 <lujinluo> no problem!
14:11:47 <lujinluo> then let's move to OVO patches
14:11:50 <lujinluo> #topic OVO
14:12:02 <lujinluo> #link https://review.openstack.org/#/q/status:open+topic:bp/adopt-oslo-versioned-objects-for-db
14:12:29 <lujinluo> #link https://review.openstack.org/#/c/608198/
14:12:39 <lujinluo> Use NetworkRBAC OVO in neutron/db/db_base_plugin_v2.py
14:13:40 <lujinluo> i just have one small question in https://review.openstack.org/#/c/608198/7/neutron/db/db_base_plugin_v2.py@437
14:13:51 <lujinluo> other changes look good to me
14:14:22 <ralonsoh> lujinluo: I'll answer this question today
14:14:55 <lujinluo> thanks! ralonsoh
14:15:31 <lujinluo> next #link https://review.openstack.org/#/c/608638/
14:15:40 <lujinluo> Use NetworkRBAC OVO in tests/unit/db/test_db_base_plugin_v2.py
14:16:01 <lujinluo> it has got 3 +1
14:16:14 <lujinluo> slaweq: could you please take a look at it when you are available?
14:16:24 <lujinluo> it is changes to a test file
14:16:29 <slaweq> lujinluo: sure
14:16:33 <slaweq> I will review it today
14:16:43 <lujinluo> thank you slaweq !
14:17:23 <lujinluo> #link https://review.openstack.org/#/c/611461/
14:17:36 <lujinluo> WIP: Fix port status for router ha_migration
14:17:41 <lujinluo> it is still a WIP
14:20:17 <lujinluo> it is not a OVO transition but related to it, so i guess we can wait until CI is cool with it before we review
14:20:28 <njohnston> +1
14:20:59 <lujinluo> #link https://review.openstack.org/#/c/610280/
14:21:10 <lujinluo> Use RBACBaseObject OVO in neutron/db/rbac_db_mixin.py
14:21:39 <ralonsoh> I still need to fix the UTs
14:21:47 <ralonsoh> I need more time
14:21:59 <lujinluo> got it. yeah, take your time :)
14:22:46 <lujinluo> #link https://review.openstack.org/#/c/608628/
14:22:56 <lujinluo> Use NetworkRBAC OVO in neutron/db/external_net_db.py
14:23:40 <lujinluo> slawek suggeted that we wait for #link https://review.openstack.org/#/c/609692/ to be merged first
14:23:50 <lujinluo> but the changes look good to most of us :)
14:24:56 <lujinluo> #link https://review.openstack.org/#/c/544206/
14:25:05 <lujinluo> Integration of (Distributed) Port Binding OVO
14:26:10 <lujinluo> last week, i said that i was trying to justify the code change mentioned by hongbin, but it turns that the change was not necessary, so i pushed a new patch set
14:26:48 <lujinluo> i still have one last comment related to load relationship that i have not tested yet.
14:27:33 <lujinluo> i will remove my -1 if i finished the testing, then reviews are much welcomed
14:28:32 <lujinluo> #link https://review.openstack.org/#/c/602497/
14:28:43 <lujinluo> use ovo for L3HARouterAgentPortBinding in l3_hamode.
14:29:23 <lujinluo> Zuul is still not happy about it
14:31:42 <hongbin> o/
14:31:47 <lujinluo> just rechecked and hope it will make it this time
14:31:50 <lujinluo> hi hongbin !
14:31:58 * hongbin is being pulled from fwaas meeting
14:32:05 <hongbin> lujinluo: hi
14:32:23 <lujinluo> aha, busy with fwaas these days? hongbin
14:32:40 <lujinluo> next ps is from hongbin #link https://review.openstack.org/#/c/610182/
14:32:46 <hongbin> lujinluo: a bit, but my topic is finished there now
14:32:54 <lujinluo> Support fetching specific db column in OVO
14:33:26 <hongbin> for this one, i am figuring out how to pass the unit tests
14:33:29 <lujinluo> this patch is -W by hongbin, so let's give him more time :)
14:33:45 <hongbin> yes, more time is always needed :)
14:34:32 <lujinluo> #link https://review.openstack.org/#/c/507772/ Use Network OVO in db_base_plugin
14:35:11 <lujinluo> Tuan did not update this patch since last week, and boden left a comment about the compatibility layer which we once discussed before
14:35:34 <lujinluo> I will try to catch Tuan this week to see if he has any updates on the comments
14:35:54 <lujinluo> #action lujin to keep an eye on Network OVO in db_base_plugin
14:36:32 <lujinluo> #link https://review.openstack.org/#/c/609847/ Support filter with "not in" criterion
14:37:00 <lujinluo> i think this patch would benefit us a lot, thanks hongbin!
14:37:04 <njohnston> +1
14:37:15 <hongbin> np
14:37:17 <ralonsoh> agree
14:37:28 <hongbin> will address the comments later, good comments though
14:37:46 <lujinluo> excellent!
14:38:28 <hongbin> and i expect there might be a bit more criterion to add (other than "not in")
14:39:53 <njohnston> yes, this builds a good base for those future operators to be developed on later
14:40:13 <lujinluo> +1
14:41:49 <lujinluo> The next two patches seem to be WIP #link https://review.openstack.org/#/c/610184/ and #link https://review.openstack.org/#/c/609848/
14:42:12 <lujinluo> Convert Subnet to OVO in ipam_pluggable_backend.py
14:42:21 <lujinluo> Convert Port to OVO in db/ipam_pluggable_backend.py
14:43:10 <hongbin> the first one is for testing the feature for fetching specific column
14:43:24 <hongbin> the second one is for testing the feature of "not in" filter
14:44:22 <hongbin> both are small patches, i will remove the WIP marker once the depending features are landed
14:44:34 <lujinluo> understood.
14:45:20 <lujinluo> the next one about retry decorator, which i want to discuss about
14:45:23 <lujinluo> #Link https://review.openstack.org/#/c/602362/
14:45:43 <lujinluo> and this one in neutron-lib #link https://review.openstack.org/#/c/605365/
14:46:14 <lujinluo> So michel would like us not to refactor old engine facade
14:46:45 <lujinluo> and suggested to "unpack the context and call a helper function"
14:47:30 <njohnston> yes, it seems like an interesting idea, although I have not given it enough thought to know how to go about it
14:47:40 <lujinluo> my concern is that, if we follow this way, do we need to do it in every methods that we use retry decorator
14:47:56 <lujinluo> Lajos said he/she would push a patch set to do it
14:48:13 <lujinluo> but only the Tag ovo
14:48:56 <lujinluo> ok, i think it is an interesting idea too. just want to bring it on the table to make us aware of its status :)
14:50:24 <lujinluo> we can continue the discussion in Gerrit after Lajos pushes another ps in #link https://review.openstack.org/#/c/602362/
14:50:54 <lujinluo> the rest of the ovo patches are not updated since last week
14:51:01 <lujinluo> #topic new engine facade
14:51:17 <lujinluo> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/enginefacade-switch
14:51:43 <lujinluo> interesting enough, i was trying to switch to new engine facade following #Link https://review.openstack.org/#/c/545501/
14:52:06 <lujinluo> so i pushed #link https://review.openstack.org/611462
14:52:42 <lujinluo> but it turns out it is some cleaning work of agent ovo
14:53:03 <lujinluo> "Remove context guard of Agent OVO"
14:54:02 <njohnston> I'll try rebasing my agent ovo engine facade adoption change on top of this
14:54:33 <lujinluo> yeah, that worth a try
14:54:45 <njohnston> done
14:55:06 <lujinluo> great!
14:55:19 <lujinluo> ok, that's all for the patches.
14:55:24 <lujinluo> #topic open discussion
14:55:38 <lujinluo> Does anyone have anything else wants to share?
14:56:40 <lujinluo> if not, let's call it a day
14:56:44 <njohnston> thanks all
14:56:51 <lujinluo> have a great day/night everyone
14:56:55 <ralonsoh> bye!
14:56:57 <lujinluo> see you all next week
14:57:10 <lujinluo> #endmeeting